[PATCH v4] staging: wfx: cleanup long lines in data_tx.c

2020-04-25 Thread Suraj Upadhyay
Break lines with length over 80 characters to conform to the linux coding style and refactor wherever necessary. Signed-off-by: Suraj Upadhyay --- Changes in v4: - Added a space after declaration in wfx_get_hw_rate(). - A checkpatch warning for this commit is retained at line 75

Re: [PATCH v4] staging: wfx: cleanup long lines in data_tx.c

2020-04-27 Thread Suraj Upadhyay
On Mon, Apr 27, 2020 at 11:50:23AM +, Jerome Pouiller wrote: > On Saturday 25 April 2020 13:32:34 CEST Suraj Upadhyay wrote: > > Break lines with length over 80 characters to > > conform to the linux coding style and refactor > > wherever necessary. > > > &

[PATCH v2] staging: wfx: cleanup long lines in data_tx.c

2020-04-24 Thread Suraj Upadhyay
Break lines with length over 80 characters to conform to the linux coding style and refactor wherever necessary. Signed-off-by: Suraj Upadhyay --- Changes in v2: - Introduced a temporary variable for the memzcmp statement. - Addressed the checkpatch problem with wfx_get_hw_rate

Re: [PATCH] staging: wfx: cleanup long lines in data_tx.c

2020-04-24 Thread Suraj Upadhyay
On Thu, Apr 23, 2020 at 09:29:28AM +, Jerome Pouiller wrote: > Hello Suraj, > > Thank you for your contribution. This would be my first patch to linux-kernel :) > On Wednesday 22 April 2020 17:39:00 CEST Suraj Upadhyay wrote: > > > > Break lines with length over

[PATCH v3] staging: wfx: cleanup long lines in data_tx.c

2020-04-24 Thread Suraj Upadhyay
Break lines with length over 80 characters to conform to the linux coding style and refactor wherever necessary. Signed-off-by: Suraj Upadhyay --- Changes in v3: - Changed the temporary variable name for the memzcmp statement to is_used. (as suggested). - Added

[PATCH] staging: wfx: cleanup long lines in data_tx.c

2020-04-22 Thread Suraj Upadhyay
Break lines with length over 80 characters to conform to the linux coding style. Issue found by checkpatch. Signed-off-by: Suraj Upadhyay --- drivers/staging/wfx/data_tx.c | 25 + 1 file changed, 17 insertions(+), 8 deletions(-) diff --git a/drivers/staging/wfx

Re: [PATCH v2] staging: rts5208: rtsx: Replace depracated MSI API

2020-07-18 Thread Suraj Upadhyay
On Sat, Jul 18, 2020 at 09:10:30PM +0530, Suraj Upadhyay wrote: > Replace depracated pci_enable_msi with pci_alloc_irq_vectors. > > Signed-off-by: Suraj Upadhyay > --- > drivers/staging/rts5208/rtsx.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > Hii, d

Re: [PATCH] staging: media: atomisp: Replace depracated MSI API.

2020-07-18 Thread Suraj Upadhyay
On Sat, Jul 18, 2020 at 06:56:32PM +0530, Suraj Upadhyay wrote: > Replace depracated pci_enable_msi with pci_alloc_irq_vectors. > And as a result modify how the returned value is handled. > > Signed-off-by: Suraj Upadhyay > --- > drivers/staging/media/atomisp/pci/atomisp_v4

Re: [PATCH v2] staging: kpc2000: Replace depracated MSI API.

2020-07-18 Thread Suraj Upadhyay
On Sat, Jul 18, 2020 at 09:19:51PM +0530, Suraj Upadhyay wrote: > Replace depracated pci_enable_msi with pci_alloc_irq_vectors. > And as a result modify how the returned value is handled. > > Signed-off-by: Suraj Upadhyay > --- > Changes: > v2: Removed t

[PATCH v2] staging: media: atomisp: Replace depracated MSI APIs

2020-07-19 Thread Suraj Upadhyay
Replace depracated MSI IRQ enabler and disabler with pci_alloc_irq_vectors and pci_free_irq_vectors respectively. And as a result handle the returned error as appropriate. Compile tested. Signed-off-by: Suraj Upadhyay --- Change: v2: Replace the MSI IRQ disabler too. --- drivers/staging

[PATCH v2] staging: rts5208: rtsx: Replace depracated MSI API

2020-07-19 Thread Suraj Upadhyay
Replace depracated MSI IRQ enablers and disablers with pci_alloc_irq_vectors and pci_free_irq_vectors respectively. Compile tested. Signed-off-by: Suraj Upadhyay --- Changes: v2: Replace MSI IRQ disablers too. --- drivers/staging/rts5208/rtsx.c | 12 ++-- 1 file changed, 6

[PATCH v3] staging: kpc2000: Replace depracated MSI APIs

2020-07-19 Thread Suraj Upadhyay
Replace depracated MSI IRQ enabler and disabler with pci_alloc_irq_vectors and pci_free_irq_vectors respectively. Compile tested. Signed-off-by: Suraj Upadhyay --- Changes: v3: Replaced the disabler for MSI IRQ too with pci_free_irq_vectors. v2: Fix the undefined

[PATCH v2] staging: comedi: s626: Remove pci-dma-compat wrapper APIs.

2020-07-13 Thread Suraj Upadhyay
_set_dma_mask(E1, E2) + dma_set_mask(>dev, E2) Signed-off-by: Suraj Upadhyay --- Changes: v2: Converted the GFP_ATOMIC flag to GFP_KERNEL to suit for the context. On reviewer's advise. drivers/staging/comedi/drivers/s626.c | 18 ++ 1 file changed, 10 insertions(

[PATCH 4/6] staging: qlge: qlge_main: Simplify while statements.

2020-07-13 Thread Suraj Upadhyay
Simplify while loops into more readable and simple for loops. Signed-off-by: Suraj Upadhyay --- drivers/staging/qlge/qlge_main.c | 49 ++-- 1 file changed, 22 insertions(+), 27 deletions(-) diff --git a/drivers/staging/qlge/qlge_main.c b/drivers/staging/qlge

[PATCH 5/6] staging: qlge: qlge_mpi: Simplify while statements.

2020-07-13 Thread Suraj Upadhyay
Simplify while loops into more readable and simple for loops. Signed-off-by: Suraj Upadhyay --- drivers/staging/qlge/qlge_mpi.c | 32 +++- 1 file changed, 15 insertions(+), 17 deletions(-) diff --git a/drivers/staging/qlge/qlge_mpi.c b/drivers/staging/qlge

[PATCH 0/6] staging: qlge: General cleanup and refactor.

2020-07-13 Thread Suraj Upadhyay
Hii, This patchest aims to remove several of the checkpatch.pl warnings and refactor some ugly while loops into for loops for better readability. Some of the issues are found with checkpatch and others were listed in qlge/TODO. Thanks, Suraj Upadhyay (6): staging: qlge: qlge.h

[PATCH 1/6] staging: qlge: qlge.h: Function definition arguments should have names.

2020-07-13 Thread Suraj Upadhyay
Issue found with checkpatch.pl Signed-off-by: Suraj Upadhyay --- drivers/staging/qlge/qlge.h | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/qlge/qlge.h b/drivers/staging/qlge/qlge.h index 05e4f47442a3..48bc494028ce 100644 --- a/drivers/staging/qlge

[PATCH 6/6] staging: qlge: qlge_ethtool: Remove one byte memset.

2020-07-13 Thread Suraj Upadhyay
Use direct assignment instead of using memset with just one byte as an argument. Issue found by checkpatch.pl. Signed-off-by: Suraj Upadhyay --- Hii Maintainers, Please correct me if I am wrong here. --- drivers/staging/qlge/qlge_ethtool.c | 4 ++-- 1 file changed, 2 insertions(+), 2

[PATCH 3/6] staging: qlge: qlge_dbg: Simplify while statements

2020-07-13 Thread Suraj Upadhyay
Simplify while loops into more readable and simple for loops. Signed-off-by: Suraj Upadhyay --- drivers/staging/qlge/qlge_dbg.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/staging/qlge/qlge_dbg.c b/drivers/staging/qlge/qlge_dbg.c index 32fbd30a6a2e

[PATCH 2/6] staging: qlge: qlge.h: Insert line after declaration.

2020-07-13 Thread Suraj Upadhyay
Issue found by checkpatch.pl Signed-off-by: Suraj Upadhyay --- drivers/staging/qlge/qlge.h | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/staging/qlge/qlge.h b/drivers/staging/qlge/qlge.h index 48bc494028ce..483ce04789ed 100644 --- a/drivers/staging/qlge/qlge.h +++ b/drivers

Re: [PATCH 6/6] staging: qlge: qlge_ethtool: Remove one byte memset.

2020-07-14 Thread Suraj Upadhyay
On Tue, Jul 14, 2020 at 11:57:23AM -0700, Joe Perches wrote: > On Mon, 2020-07-13 at 17:17 +0300, Dan Carpenter wrote: > > On Mon, Jul 13, 2020 at 05:52:22PM +0530, Suraj Upadhyay wrote: > > > Use direct assignment instead of using memset with just one byte as an > > >

Re: [PATCH 6/6] staging: qlge: qlge_ethtool: Remove one byte memset.

2020-07-14 Thread Suraj Upadhyay
On Tue, Jul 14, 2020 at 12:22:05PM -0700, Joe Perches wrote: > On Wed, 2020-07-15 at 00:36 +0530, Suraj Upadhyay wrote: > > On Tue, Jul 14, 2020 at 11:57:23AM -0700, Joe Perches wrote: > > > On Mon, 2020-07-13 at 17:17 +0300, Dan Carpenter wrote: > > > > On Mon, Ju

Re: [PATCH] staging: qlge: Remove pci-dma-compat wrapper APIs.

2020-07-12 Thread Suraj Upadhyay
On Mon, Jul 13, 2020 at 01:59:59PM +0900, Benjamin Poirier wrote: > On 2020-07-11 18:16 +0530, Suraj Upadhyay wrote: > > The legacy API wrappers in include/linux/pci-dma-compat.h > > should go away as it creates unnecessary midlayering > > for include/linux/dma-mapping.h

[PATCH] staging: qlge: qlge_ethtool.c: Proper indentation.

2020-07-02 Thread Suraj Upadhyay
Remove extra indentations from if-statement. Signed-off-by: Suraj Upadhyay --- drivers/staging/qlge/qlge_ethtool.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/qlge/qlge_ethtool.c b/drivers/staging/qlge/qlge_ethtool.c index 949abd53a7a9..16fcdefa9687

[PATCH] staging: rtl8192e: rtl8192E_dev: Remove pci-dma-compat wrapper APIs.

2020-07-11 Thread Suraj Upadhyay
_set_dma_mask(E1, E2) + dma_set_mask(>dev, E2) Signed-off-by: Suraj Upadhyay --- This change is proposed by Christoph Hellwig in the post https://marc.info/?l=kernel-janitors=158745678307186=4 on kernel-janitors Mailing List. drivers/staging/rtl8192e/rtl8192e/r8192E_dev.c

[PATCH] staging: rtl8192e: rtl_core: Remove pci-dma-compat wrapper APIs.

2020-07-11 Thread Suraj Upadhyay
erent_mask(>dev, E2) @@ expression E1, E2; @@ - pci_set_dma_mask(E1, E2) + dma_set_mask(>dev, E2) Signed-off-by: Suraj Upadhyay --- This change is proposed by Christoph Hellwig in the post https://marc.info/?l=kernel-janitors=158745678307186=4 on kernel-janitors Mailing List

[PATCH] staging: comedi: s626: Remove pci-dma-compat wrapper APIs.

2020-07-11 Thread Suraj Upadhyay
_set_dma_mask(E1, E2) + dma_set_mask(>dev, E2) Signed-off-by: Suraj Upadhyay --- This change is proposed by Christoph Hellwig in the post https://marc.info/?l=kernel-janitors=158745678307186=4 on kernel-janitors Mailing List. drivers/staging/comedi/drivers/s626.c | 18 +

[PATCH] staging: qlge: Remove pci-dma-compat wrapper APIs.

2020-07-11 Thread Suraj Upadhyay
_set_dma_mask(E1, E2) + dma_set_mask(>dev, E2) Signed-off-by: Suraj Upadhyay --- This change is proposed by Christoph Hellwig in the post https://marc.info/?l=kernel-janitors=158745678307186=4 on kernel-janitors Mailing List. drivers/staging/qlge/qlge_mpi.c | 9 +--

[PATCH] staging: qlge/qlge_main.c: Replace depracated MSI API.

2020-07-16 Thread Suraj Upadhyay
Replace the depracated MSI API pci_enable_msi() with pci_alloc_irq_vectors(). Signed-off-by: Suraj Upadhyay --- drivers/staging/qlge/qlge_main.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/qlge/qlge_main.c b/drivers/staging/qlge/qlge_main.c index

[PATCH] staging: media: atomisp: Replace depracated MSI API.

2020-07-18 Thread Suraj Upadhyay
Replace depracated pci_enable_msi with pci_alloc_irq_vectors. And as a result modify how the returned value is handled. Signed-off-by: Suraj Upadhyay --- drivers/staging/media/atomisp/pci/atomisp_v4l2.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging

[PATCH] staging: media: ipu3: Replace depracated MSI API.

2020-07-18 Thread Suraj Upadhyay
Replace depracated psi_enable_msi with pci_alloc_irq_vectors. And as a result modify how the returned value is handled. Signed-off-by: Suraj Upadhyay --- drivers/staging/media/ipu3/ipu3.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/media/ipu3/ipu3.c

[PATCH] staging: rts5208: rtsx: Replace depracated MSI API

2020-07-18 Thread Suraj Upadhyay
Replace depracated pci_enable_msi with pci_alloc_irq_vectors. Signed-off-by: Suraj Upadhyay --- drivers/staging/rts5208/rtsx.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rts5208/rtsx.c b/drivers/staging/rts5208/rtsx.c index e28e162d004e..adc80e766412

[PATCH] staging: kpc2000: Replace depracated MSI API.

2020-07-18 Thread Suraj Upadhyay
Replace depracated pci_enable_msi with pci_alloc_irq_vectors. Signed-off-by: Suraj Upadhyay --- drivers/staging/kpc2000/kpc2000/core.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/kpc2000/kpc2000/core.c b/drivers/staging/kpc2000/kpc2000/core.c index

[PATCH v2] staging: rts5208: rtsx: Replace depracated MSI API

2020-07-18 Thread Suraj Upadhyay
Replace depracated pci_enable_msi with pci_alloc_irq_vectors. Signed-off-by: Suraj Upadhyay --- drivers/staging/rts5208/rtsx.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rts5208/rtsx.c b/drivers/staging/rts5208/rtsx.c index e28e162d004e..b39d3f8b54df

[PATCH v2] staging: kpc2000: Replace depracated MSI API.

2020-07-18 Thread Suraj Upadhyay
Replace depracated pci_enable_msi with pci_alloc_irq_vectors. And as a result modify how the returned value is handled. Signed-off-by: Suraj Upadhyay --- Changes: v2: Removed the undefined variable. Reported by kernel-bot. drivers/staging/kpc2000/kpc2000/core.c | 2 +- 1

Re: [PATCH] staging: rts5208: rtsx: Replace depracated MSI API

2020-07-18 Thread Suraj Upadhyay
On Sat, Jul 18, 2020 at 06:48:56PM +0530, Suraj Upadhyay wrote: > Replace depracated pci_enable_msi with pci_alloc_irq_vectors. > > Signed-off-by: Suraj Upadhyay > --- > drivers/staging/rts5208/rtsx.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff