[easybuild] Installing software with different suffix

2016-08-22 Thread Exequiel SepĂșlveda
Hi there, Is there any option to use a existent configure file without writing a new one for this case? Package: MyAPP-foss-2016a-Python-2.7.11.eb Target: MyAPP-foss-2016a-Python-2.7.12.eb I have tried --try-software-version but it seems not working Cheers -- Exequiel Sepulveda

Re: [easybuild] Installing software with different suffix

2016-08-22 Thread Kenneth Hoste
Hi Exequiel, On 22/08/16 06:53, Exequiel SepĂșlveda wrote: Hi there, Is there any option to use a existent configure file without writing a new one for this case? Package: MyAPP-foss-2016a-Python-2.7.11.eb Target: MyAPP-foss-2016a-Python-2.7.12.eb I have tried --try-software-version but it

Re: [easybuild] numpy, scipy, mpi4py

2016-08-22 Thread Ward Poelmans
On 22-08-16 15:27, Joachim Hein wrote: > Hi, > > Looking into e.g. Python-2.7.12-intel-2016b.eb it seems this is building > stuff like scipy, numpy and mpi4py (sometimes old versions). Why are > the separate easyconfigs for those kind of packages as well? Are the > later obsolete? Someone

Re: [easybuild] numpy, scipy, mpi4py

2016-08-22 Thread Maxime Boissonneault
Don't Numpy and Scipy require MKL or some optimized BLAS version though (it should) ? Also, doesn't mpi4py require MPI ? How are these not "additional deps" ? For Python packages, R packages, Perl packages, Lua packages, etc., we usually instruct our users to either install them in their home

Re: [easybuild] numpy, scipy, mpi4py

2016-08-22 Thread Kenneth Hoste
On 22/08/16 15:45, Maxime Boissonneault wrote: Don't Numpy and Scipy require MKL or some optimized BLAS version though (it should) ? Also, doesn't mpi4py require MPI ? How are these not "additional deps" ? Because both MPI & BLAS are included in the toolchain already (at least the one

Re: [easybuild] numpy, scipy, mpi4py

2016-08-22 Thread Kenneth Hoste
On 22/08/16 15:53, Joachim Hein wrote: Hi Ward, Thanks for the swift reaction. So a scipy-0.17.1-intel-2016b-Python-2.7.12.eb should not be needed, since the Python module Python-2.7.12-intel-2016b.eb has scipy 0.17.1 in its extension list? Indeed. And when scipy 0.18.0 is released, we

Re: [easybuild] numpy, scipy, mpi4py

2016-08-22 Thread Joachim Hein
On 22 Aug 2016, at 15:58, Kenneth Hoste > wrote: On 22/08/16 15:53, Joachim Hein wrote: Hi Ward, Thanks for the swift reaction. So a scipy-0.17.1-intel-2016b-Python-2.7.12.eb should not be needed, since the Python module