Re: [edk2] EDK II Network Stack Issue

2019-01-23 Thread Karin Willers
On 1/22/19 6:34 PM, Laszlo Ersek wrote: Okay, summary: - forget the MdePkg and StdLib DSC files, build only AppPkg (or whatever platform DSC it is that produces your UEFI application) - make sure PcdDebugPropertyMask has bitmask 0x06 set when you build AppPkg (or the appropriate platform

Re: [edk2] EDK II Network Stack Issue

2019-01-22 Thread Laszlo Ersek
Adding the list back in -- I can't really justify spending an hour or more on emails like this if I don't send them to the list. More importantly, I could be wrong about some details, and keeping the discussion on-list gives others a chance to correct me. Comments below: On 01/22/19 09:56, Karin

Re: [edk2] EDK II Network Stack Issue

2019-01-16 Thread Laszlo Ersek
On 01/16/19 13:57, Karin Willers wrote: > On 2019-01-10 13:40, Karin Willers wrote: >> On 2019-01-07 20:27, Laszlo Ersek wrote: >>> On 01/04/19 15:02, Karin Willers wrote: G'Day! I'm trying to get networking under edk2 up and running. I tried

Re: [edk2] EDK II Network Stack Issue

2019-01-16 Thread Karin Willers
On 2019-01-10 13:40, Karin Willers wrote: On 2019-01-07 20:27, Laszlo Ersek wrote: On 01/04/19 15:02, Karin Willers wrote: G'Day! I'm trying to get networking under edk2 up and running. I tried AppPkg/Applications/Sockets/RawIp4Tx under OVMF. The raw packet is sent out on the network, but the

Re: [edk2] EDK II Network Stack Issue

2019-01-10 Thread Karin Willers
On 2019-01-07 20:27, Laszlo Ersek wrote: On 01/04/19 15:02, Karin Willers wrote: G'Day! I'm trying to get networking under edk2 up and running. I tried AppPkg/Applications/Sockets/RawIp4Tx under OVMF. The raw packet is sent out on the network, but the application never returns from the socket

Re: [edk2] EDK II Network Stack Issue

2019-01-07 Thread Laszlo Ersek
On 01/04/19 15:02, Karin Willers wrote: > G'Day! > > I'm trying to get networking under edk2 up and running. I tried > AppPkg/Applications/Sockets/RawIp4Tx > under OVMF. The raw packet is sent out on the network, but the > application never returns from the > socket close routine. > > I'm

[edk2] EDK II Network Stack Issue

2019-01-04 Thread Karin Willers
G'Day! I'm trying to get networking under edk2 up and running. I tried AppPkg/Applications/Sockets/RawIp4Tx under OVMF. The raw packet is sent out on the network, but the application never returns from the socket close routine. I'm currently using UDK2017 with the latest security patches