[O] Bug: %?%i in org-capture-templates

2011-11-12 Thread XeCycle
Hello. I have an template entry in org-capture-templates like this: (s Software usage notes entry (file ~/workspace/notes/software.org) * %^{Title} %^g\n\n %?%i) When the active region is more than one line, the %i is indented on every line by literal %?, which is not desired, I'm afraid.

Re: [O] [PATCH] Create visibility overlays properly

2011-11-12 Thread Milan Zamazal
Any chance to get this patch applied? Or is there anything wrong with it? * org.el (org-set-outline-overlay-data): Use outline-flag-region to make a region invisible. This ensures all necessary actions, especially adding isearch-open-invisible property, are applied. --- lisp/org.el |3 +--

Re: [O] [PATCH] Create visibility overlays properly

2011-11-12 Thread Bastien
Hi Milan, Milan Zamazal p...@zamazal.org writes: Any chance to get this patch applied? Or is there anything wrong with it? I looked at it and it looks good. I just wanted to take the time to carefully test the consequences of using `outline-flag-region'. The code behind is okay, but

[O] Bug in latex export

2011-11-12 Thread Markus Grebenstein
Dear list, I found a problem with the latex exporter when exporting bold font: *this is a text* is exported as \textbf{this is a text\} with an extra \ which disables the }after it and causes a latex error. I use org-mode 7.7 from githhub updated on tuesday or wednesday using org-tracks.

[O] Mouse clicking on headings

2011-11-12 Thread Leo
Hi there, I occasionally use mouse on org mode files; I have the module org-mouse loaded. However only recently I noticed mouse clicking on the heading stars no longer toggles the visibility of the heading. I am annoyed by this change. Could someone enlighten me on this? Leo

Re: [O] Mouse clicking on headings

2011-11-12 Thread Nicolas Goaziou
Hello, Leo sdl@gmail.com writes: However only recently I noticed mouse clicking on the heading stars no longer toggles the visibility of the heading. I cannot reproduce this on the latest version. Could you upgrade Org and tell me if the bug is still there? Thanks, -- Nicolas Goaziou

Re: [O] Mouse clicking on headings

2011-11-12 Thread Leo
On 2011-11-12 21:18 +0800, Nicolas Goaziou wrote: I cannot reproduce this on the latest version. Could you upgrade Org and tell me if the bug is still there? Seems to be fine in the latest version. I thought my org-mode version was fairly recent. Leo

Re: [O] Bug: cdlatex-tab in math-env isn't considered when inside of a list item. [7.7 (release_7.7.513.g2a5877)]

2011-11-12 Thread Nicolas Goaziou
Hello, Maik Beckmann beckmann.m...@googlemail.com writes: The attached patch what works for me. Your patch prevents cdlatex expansion for LaTeX environments, since point must be in a LaTeX fragment to trigger `cdlatex-tab'. I've slightly modified your patch to repair that. Could you test it

Re: [O] zotero plain, org-odt, and citations in general

2011-11-12 Thread Matt Price
On Sat, Nov 12, 2011 at 2:21 AM, Christian Moe m...@christianmoe.comwrote: On 11/11/11 10:13 PM, Jambunathan K wrote: I wonder whether the issue is related to we - Matt(?), Christian(?) and I - using Windows. not me either -- ubuntu for me.

Re: [O] [bug] regression tests broken

2011-11-12 Thread Martyn Jago
Hi Eric Eric Schulte schulte.e...@gmail.com writes: Hi Martyn, I have all tests passing in a branch in the Org-mode git repo (which I plan to merge into master soon). Could you try a run of this on the standard-code-block-syntax branch? I've added the standard-code-block-syntax branch to

[O] [ODT] [BUG?] Custom links are formatted as for html

2011-11-12 Thread Christian Moe
Hi, Jambunathan, When I try to define a custom link type with special formatting for ODT export, the exporter behaves as if the backend is html. I'll exemplify with a tweaked version of org-bbdb-export, since that's the textbook example of a custom link. I've rewritten it below so that if

[O] funny problem for table of contents when publishing org-latex with #+INCLUDE other.org

2011-11-12 Thread jack song
Hi, All I got a funny (or strange) problem when I published to latex with #+INCLUDE other org file problem: if there is no any * first line in the index.org file before the #+INCLUDE otherfile.org, there will be no table of contents. Other wise it works. For example, there are one index file

Re: [O] [ODT] [BUG?] Custom links are formatted as for html

2011-11-12 Thread Jambunathan K
Hello Christian Christian Moe m...@christianmoe.com writes: Hi, Jambunathan, When I try to define a custom link type with special formatting for ODT export, the exporter behaves as if the backend is html. I have pushed a fix for this. Note that I haven't modified org-bbdb yet. ps: If I

Re: [O] [ODT] [BUG?] Custom links are formatted as for html

2011-11-12 Thread Christian Moe
On 11/12/11 10:24 PM, Jambunathan K wrote: When I try to define a custom link type with special formatting for ODT export, the exporter behaves as if the backend is html. I have pushed a fix for this. Note that I haven't modified org-bbdb yet. Hi, I confirm that it's fixed. Thanks! Just to

Re: [O] enhancements for org-agenda-to-appt

2011-11-12 Thread Peter M√ľnster
On Tue, Nov 08 2011, Daniel Clemente wrote: 1.) Warning period should be taken from timestamp That means, that the warntime must be passed to appt-add. 2.) Warning period in hours and minutes -3h for 3 hours or -10M for 10 minutes should be possible. Do you really need to

Re: [O] zotero plain, org-odt, and citations in general

2011-11-12 Thread Christian Moe
On 11/11/11 5:12 PM, Erik Hetzner wrote: At Fri, 11 Nov 2011 10:51:22 -0500, Matt Price wrote: Wouldn't the rigt target be, not the sqlite db, but the Zoteor*service* that runs on port 50001 when Zotero is running? Aren't there some higher-level tools for working through that interface

Re: [O] zotero plain, org-odt, and citations in general

2011-11-12 Thread Christian Moe
On 11/13/11 12:45 AM, Christian Moe wrote: A good while back -- before zotero-plain -- I spent some late nights Sorry about the noise: I didn't mean to send this fragment. Please ignore. Christian

Re: [O] Getting rid of split frame with org-capture

2011-11-12 Thread Gregor Zattler
Hi Thomas, org-mode community, * Thomas Lockney tho...@lockney.net [10. Nov. 2011]: I'm attempting to get some code working that should create a new frame with *just* org-capture, this is something I also tried hard to achive. but when I run it, I keep getting a split despite various

Re: [O] Getting rid of split frame with org-capture

2011-11-12 Thread Nick Dokos
Gregor Zattler telegr...@gmx.net wrote: Hi Thomas, org-mode community, * Thomas Lockney tho...@lockney.net [10. Nov. 2011]: I'm attempting to get some code working that should create a new frame with *just* org-capture, this is something I also tried hard to achive. but when I run

Re: [O] Bug: cdlatex-tab in math-env isn't considered when inside of a list item. [7.7 (release_7.7.513.g2a5877)]

2011-11-12 Thread Maik Beckmann
2011/11/12 Nicolas Goaziou n.goaz...@gmail.com: Your patch prevents cdlatex expansion for LaTeX environments, since point must be in a LaTeX fragment to trigger `cdlatex-tab'. That actually bit me yesterday :P I've slightly modified your patch to repair that. Could you test it and report