Re: Bug: First file opened does not colorize (tested with 9.3.7 and 9.4.5)

2021-04-30 Thread Dominick Samperi
Changing the suffix to .org does not help. Still the first file opened
does not colorize.
I first observed this problem about six months ago (and have been
using a function
key to fix with 'org-mode-restart).

The problem does not appear on a new desktop, running
the same version of Emacs, same version of org-mode, and same .emacs.d.

The only notable difference between the new machine and the older machines
where the problem occurs is that the newer machine has an solid state drive,
whereas the other machines have conventional hard drives.

On Fri, Apr 30, 2021 at 8:51 PM Samuel Wales  wrote:
>
> what if .org?
>
> On 4/30/21, Dominick Samperi  wrote:
> > The first org mode file opened (.txt suffix) is not colorized. To force
> > colorize I use 'org-mode-restart. Subsequently opened txt files are
> > properly colorized. This happens under Windows 10 using Emacs 27.1 and
> > 27.2, and org-mode 9.3.7 and 9.4.5. There are no problems under Ubuntu
> > Linux.
> >
> > Oddly, the problem does not appear on my new desktop (Lenovo). It
> > happens on my ASUS laptop. I'm using the same version of org-mode and
> > Emacs on both machines.
> >
> > I copied .emacs.d from the desktop to the laptop
> > to be sure the environments are the same, and I installed Emacs 27.1
> > and 27.2 on the laptop. The colorize problem occurs on the laptop no
> > matter the environment. It also occurred with my old desktop.
> >
> >
>
>
> --
> The Kafka Pandemic
>
> Please learn what misopathy is.
> https://thekafkapandemic.blogspot.com/2013/10/why-some-diseases-are-wronged.html



Bug: First file opened does not colorize (tested with 9.3.7 and 9.4.5)

2021-04-30 Thread Dominick Samperi
The first org mode file opened (.txt suffix) is not colorized. To force
colorize I use 'org-mode-restart. Subsequently opened txt files are
properly colorized. This happens under Windows 10 using Emacs 27.1 and
27.2, and org-mode 9.3.7 and 9.4.5. There are no problems under Ubuntu Linux.

Oddly, the problem does not appear on my new desktop (Lenovo). It
happens on my ASUS laptop. I'm using the same version of org-mode and
Emacs on both machines.

I copied .emacs.d from the desktop to the laptop
to be sure the environments are the same, and I installed Emacs 27.1
and 27.2 on the laptop. The colorize problem occurs on the laptop no
matter the environment. It also occurred with my old desktop.



Re: Bug: No colors in first file opened [9.3.7 (9.3.7-dist @ c:/w/.emacs.d/org-9.3.7/lisp/)]

2020-09-03 Thread Dominick Samperi
Hello Bastien,

My current work-around is to map F12 to (org-mode-restart).

After installing a fresh version of Emacs 27.1 using the Windows
installer, and copying
org-9.3.7 to ~/.emacs.d, the first file I open is not colorized until
I use F12. My init.el contains:
(add-to-list 'load-path "~/.emacs.d/org-9.3.7/lisp")
(setq auto-mode-alist (cons '("\\.s?txt?\\'" . org-mode) auto-mode-alist))
(require 'org)

This happens when the first file I open has name foo.org, or bar.txt.
There are no problems when I continue to open files.

On Thu, Sep 3, 2020 at 6:09 AM Bastien  wrote:
>
> Hi Dominick,
>
> Dominick Samperi  writes:
>
> > No colors appear in first file opened. Must use (org-mode-restart)
> > to enable colors after opening first file.
>
> Can you provide a reproducible recipe?
>
> --
>  Bastien



Bug: No colors in first file opened [9.3.7 (9.3.7-dist @ c:/w/.emacs.d/org-9.3.7/lisp/)]

2020-09-02 Thread Dominick Samperi
No colors appear in first file opened. Must use (org-mode-restart) to
enable colors after
opening first file.