[O] Bug: horizontal line incorrectly drawn when numbers are prefixed with plus sign [8.2.5h (8.2.5h-6-g8e1386-elpa @ /Users/jason/.emacs.d/elpa/org-20140203/)]

2014-02-23 Thread Jason Lewis
Hi,

If you enter a table like this in org, the +4 will get a strike-through
line through it
incorrectly.

I expect it should not happen and only the hline below should appear as
a solid line.

| 1 | +4 |
|---+|
|   ||


you can see a screenshot of what happens here:

http://monosnap.com/image/Sudbx4RL5T9KaLBYZHYo4e1GtssQbT



Emacs  : GNU Emacs 24.3.50.1 (x86_64-apple-darwin13.0.0, NS
apple-appkit-1265.00)
 of 2014-01-24 on tolkien.lan
Package: Org-mode version 8.2.5h (8.2.5h-6-g8e1386-elpa @
/Users/jason/.emacs.d/elpa/org-20140203/)

current state:
==
(setq
 org-tab-first-hook '(org-hide-block-toggle-maybe
org-src-native-tab-command-maybe org-babel-hide-result-toggle-maybe
org-babel-header-arg-expand)
 outline-minor-mode-hook '(mediawiki-outline-magic-keys)
 org-speed-command-hook '(org-speed-command-default-hook
org-babel-speed-command-hook)
 org-occur-hook '(org-first-headline-recenter)
 org-metaup-hook '(org-babel-load-in-session-maybe)
 org-html-format-drawer-function '(lambda (name contents) contents)
 org-latex-format-inlinetask-function 'ignore
 org-confirm-shell-link-function 'yes-or-no-p
 org-ascii-format-inlinetask-function 'org-ascii-format-inlinetask-default
 org-latex-format-headline-function
'org-latex-format-headline-default-function
 org-default-notes-file ~/Dropbox/org/todo.org
 org-after-todo-state-change-hook '(org-clock-out-if-current)
 org-latex-format-drawer-function '(lambda (name contents) contents)
 org-from-is-user-regexp \\Jason Lewis\\
 org-src-mode-hook '(org-src-babel-configure-edit-buffer
org-src-mode-configure-edit-buffer)
 org-agenda-before-write-hook '(org-agenda-add-entry-text)
 org-babel-pre-tangle-hook '(save-buffer)
 org-mode-hook '((lambda nil (flyspell-mode -1))
 #[nil \300\301\302\303\304$\207 [org-add-hook
change-major-mode-hook org-show-block-all append local] 5]
 #[nil \300\301\302\303\304$\207 [org-add-hook
change-major-mode-hook org-babel-show-result-all append local] 5]
 org-babel-result-hide-spec org-babel-hide-all-hashes)
 org-refile-targets '((nil :maxlevel . 9) (org-agenda-files :maxlevel . 9))
 org-ascii-format-drawer-function '(lambda (name contents width) contents)
 org-ctrl-c-ctrl-c-hook '(org-babel-hash-at-point
org-babel-execute-safely-maybe)
 org-directory ~/Dropbox/org
 org-cycle-hook '(org-cycle-hide-archived-subtrees
org-cycle-hide-drawers org-cycle-hide-inline-tasks
org-cycle-show-empty-lines
  org-optimize-window-after-visibility-change)
 org-M-RET-may-split-line '((default))
 org-blank-before-new-entry nil
 org-confirm-elisp-link-function 'yes-or-no-p
 org-metadown-hook '(org-babel-pop-to-session-maybe)
 org-html-format-headline-function 'ignore
 org-html-format-inlinetask-function 'ignore
 org-agenda-files '(~/Dropbox/org/todo.org ~/Dropbox/org
~/Dropbox/org/todo.org)
 org-clock-out-hook '(org-clock-remove-empty-clock-drawer)
 )

-- 
Jason Lewis
http://emacstragic.net




signature.asc
Description: OpenPGP digital signature


[O] Bug: shift-enter in org tables leaves cursor in wrong position [8.2.5h (8.2.5h-6-g8e1386-elpa @ /cygdrive/c/Users/jason/.emacs.d/elpa/org-20140203/)]

2014-02-05 Thread Jason Lewis
Hi,

when using the Shift-enter feature in a table to copy values down, it
fails to place the cursor where you expect it to if the previous column
has a fixed width and the contents of the cell is truncated.

Steps to reproduce:

enter the following org table:

|   | 7 |   |
|---+-+---|
| 4 | podsdfsfsadastatoes | 1 |
| 5 | podsdfsfsadastatoes | 2 |
| 6 | |   |

press C-c C-c to ensure the second column is showing abbreviated.

place cursor on the number 1,
Shift-enter copies values to the next line but leaves the cursor in
the wrong position, at the end of the string in the row that starts with 5

if you remove the 7 and repeat the experiment, the cursor moves down
the third column as you expect it to.

I expect it should work the same whether or not the previous column has
truncated contents.

Emacs  : GNU Emacs 24.3.50.2 (i686-pc-cygwin)
 of 2014-01-15 on jade
Package: Org-mode version 8.2.5h (8.2.5h-6-g8e1386-elpa @
/cygdrive/c/Users/jason/.emacs.d/elpa/org-20140203/)

current state:
==
(setq
 org-ctrl-c-ctrl-c-hook '(org-babel-hash-at-point
org-babel-execute-safely-maybe)
 org-latex-format-headline-function
'org-latex-format-headline-default-function
 org-html-format-inlinetask-function 'ignore
 outline-minor-mode-hook '(mediawiki-outline-magic-keys)
 org-tab-first-hook '(org-hide-block-toggle-maybe
org-src-native-tab-command-maybe
  org-babel-hide-result-toggle-maybe
org-babel-header-arg-expand)
 org-refile-targets '((nil :maxlevel . 9) (org-agenda-files :maxlevel . 9))
 org-cycle-hook '(org-cycle-hide-archived-subtrees org-cycle-hide-drawers
  org-cycle-hide-inline-tasks org-cycle-show-empty-lines
  org-optimize-window-after-visibility-change)
 org-agenda-before-write-hook '(org-agenda-add-entry-text)
 org-speed-command-hook '(org-speed-command-default-hook
org-babel-speed-command-hook)
 org-ascii-format-inlinetask-function 'org-ascii-format-inlinetask-default
 org-babel-pre-tangle-hook '(save-buffer)
 org-occur-hook '(org-first-headline-recenter)
 org-html-format-headline-function 'ignore
 org-metaup-hook '(org-babel-load-in-session-maybe)
 org-confirm-elisp-link-function 'yes-or-no-p
 org-default-notes-file ~/Dropbox/org/todo.org
 org-latex-format-drawer-function '(lambda (name contents) contents)
 org-blank-before-new-entry nil
 org-clock-out-hook '(org-clock-remove-empty-clock-drawer)
 org-mode-hook '(#[nil \300\301\302\303\304$\207
   [org-add-hook change-major-mode-hook
org-show-block-all append local]
   5]
 #[nil \300\301\302\303\304$\207
   [org-add-hook change-major-mode-hook
org-babel-show-result-all append
local]
   5]
 org-babel-result-hide-spec org-babel-hide-all-hashes
 (lambda nil (flyspell-mode -1)))
 org-ascii-format-drawer-function '(lambda (name contents width) contents)
 org-directory ~/Dropbox/org
 org-from-is-user-regexp \\jason\\
 org-html-format-drawer-function '(lambda (name contents) contents)
 org-metadown-hook '(org-babel-pop-to-session-maybe)
 org-agenda-files '(~/Dropbox/org/todo.org ~/Dropbox/org
~/Dropbox/org/todo.org)
 org-src-mode-hook '(org-src-babel-configure-edit-buffer
 org-src-mode-configure-edit-buffer)
 org-after-todo-state-change-hook '(org-clock-out-if-current)
 org-latex-format-inlinetask-function 'ignore
 org-M-RET-may-split-line '((default))
 org-confirm-shell-link-function 'yes-or-no-p
 )




signature.asc
Description: OpenPGP digital signature


Re: [O] LaTeX export with documentclass ltugboat

2013-11-29 Thread Jason Lewis
On 29/11/2013 5:53 pm, Thomas S. Dye wrote:
 Jason Lewis ja...@dickson.st writes:

 (require 'org-latex)
 (unless (boundp 'org-export-latex-classes)
 (add-to-list 'org-export-latex-classes
  '(ltugboat
\\documentclass{ltugboat}
(\\section{%s} . \\section*{%s})
(\\subsection{%s} . \\subsection*{%s})
(\\subsubsection{%s} . \\subsubsection*{%s})
(\\paragraph{%s} . \\paragraph*{%s})
(\\subparagraph{%s} . \\subparagraph*{%s})))
 It looks like you are using  8.0 functions.

 Try something like this:

 (require 'ox-latex)
 (add-to-list 'org-latex-classes
   '(ltugboat
 \\documentclass{ltugboat}
 (\\section{%s} . \\section*{%s})
 (\\subsection{%s} . \\subsection*{%s})
 (\\subsubsection{%s} . \\subsubsection*{%s})
 (\\paragraph{%s} . \\paragraph*{%s})
 (\\subparagraph{%s} . \\subparagraph*{%s})))

 Note: org-latex - ox-latex
   org-export-latex-classes - org-latex-classes

 hth,
 Tom

Thanks Tom, that works perfectly.

Jason

-- 
Jason Lewis
http://emacstragic.net




signature.asc
Description: OpenPGP digital signature


[O] LaTeX export with documentclass ltugboat

2013-11-28 Thread Jason Lewis
Hi,

How can I export an org file to LaTeX with a document class of ltugboat?

I've seen the example linked below but it doesn't appear to work in
8.2.1 and in fact states its for org  8.0.
http://orgmode.org/worg/org-tutorials/org-latex-export.html

Is this documented somewhere for versions  8.0?

Any pointers would be appreciated.

Thanks,

Jason

-- 
Jason Lewis
http://emacstragic.net




signature.asc
Description: OpenPGP digital signature


Re: [O] LaTeX export with documentclass ltugboat

2013-11-28 Thread Jason Lewis
Hi Charles,

Thanks for your suggestion. I've tried it out it doesn't work for me.


I ran this elisp to add the export class

(require 'org-latex)
(unless (boundp 'org-export-latex-classes)
(add-to-list 'org-export-latex-classes
 '(ltugboat
   \\documentclass{ltugboat}
   (\\section{%s} . \\section*{%s})
   (\\subsection{%s} . \\subsection*{%s})
   (\\subsubsection{%s} . \\subsubsection*{%s})
   (\\paragraph{%s} . \\paragraph*{%s})
   (\\subparagraph{%s} . \\subparagraph*{%s})))

made an org file:

#+LaTeX_CLASS: ltugboat
TEST


but when I export it gives an error:

user-error: Unknown LaTeX class `ltugboat'

Thanks,

Jason



Charles Millar wrote, On 28/11/2013 11:37 PM:
 Jason,
 
 On 11/28/2013 7:02 AM, Jason Lewis wrote:
 Hi,

 How can I export an org file to LaTeX with a document class of ltugboat?

 I've seen the example linked below but it doesn't appear to work in
 8.2.1 and in fact states its for org  8.0.
 http://orgmode.org/worg/org-tutorials/org-latex-export.html

 Is this documented somewhere for versions  8.0?

 Any pointers would be appreciated.

 Thanks,

 Jason

 
 I just started LaTeX export recently and referred to that page.
 
 I added (require 'ox-latex) to my .emacs and the custom classes example
 (as modified for my purposes) worked fine.
 
 Charlie Millar
 
 ---
 This email is free from viruses and malware because avast! Antivirus
 protection is active.
 http://www.avast.com
 
 


-- 
Jason Lewis
http://emacstragic.net





signature.asc
Description: OpenPGP digital signature


Re: [O] error exporting latex src block

2013-10-17 Thread Jason Lewis
Hi Eric,

On 17/10/13 2:59 PM, Eric Schulte wrote:
 Jason Lewis jasonble...@gmail.com writes:

 Your example exports w/o problem for me with Org-mode version Org-mode
 version 8.2.1.  I believe the problem on your system lies in the latex
 fontification on your system.  Org-mode uses htmlize to export fontified
 code to html, so you could try running htmlize-buffer from a latex-mode
 buffer with \\.

Thanks for the pointer.

You were correct, the test resulted in the same error.

I'm at a loss as to how I might resolve it. emacs doesn't seem to
produce any useful error, and toggle-debug-on-error doesn't seem to trap
when the error happens either.

Any ideas?

Thanks,

Jason





[O] conditionally includes or file options

2013-10-17 Thread Jason Lewis
Hi,

I have an org file stored on a Dropbox drive. I need some file options
in it for exporting to reveal.js using ox-reveal. eg:

on my mac:
#+REVEAL_EXTRA_CSS:
file:///Users/jason/source/reveal.js-fullscreen-img/fullscreen-img.css

on my windows computer:
#+REVEAL_EXTRA_CSS:
file:///C:\Users\jason\source\reveal.js-fullscreen-img\fullscreen-img.css


I'm alternating between a Windows computer and a mac for writing this
document, and so the path is different.

Is there some way I can conditionally set the path based on the computer
I'm exporting it on?

Thanks,

Jason

-- 
Jason Lewis
http://emacstragic.net




[O] error exporting latex src block

2013-10-16 Thread Jason Lewis

-BEGIN PGP SIGNED MESSAGE-
Hash: SHA256

Hi,

If I try and export:

#+BEGIN_SRC latex
\\
#+END_SRC

as html from org-mode, it gives me the following error:

face-attribute: Invalid face: font-lock-warning

and fails to export anything.

Is this a bug or a feature?

Is there any way I can include a double \\ in a latex SRC block?

I'm using Org-mode version 8.2.1 (8.2.1-3-g35e5e5-elpa @
/Users/jason/.emacs.d/elpa/org-20131007/)

Thanks,

Jason
-BEGIN PGP SIGNATURE-
Version: GnuPG v1.4.13 (Darwin)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJSXzvCAAoJEPpXHsdQXnZOdE8QAJRAK6guJS9c/qGVfwK4FSQx
ridM3+JiScSWKPy3dzxy14EC++r5kCqU5zt4/mn7QTWI6/skdUZSfAB9rJ4AJ1jm
gV8lnqtA8XzYW9judrxK57QnU2Xlz9oz+CCdGDTpX4xW/Ek3Wc1wWZB2f8AAtiEZ
e2LGqxZDIgJYew1aSR/+xMb+g3RVq0XUaXwmuu25AfryXIyYyCZzkdkl5JY/IJGT
HV1nrgP/SBOR4KUr0xexRXC8pk9DyVuA7JwEGuoRIfJOPyvktQkTwNsqUX50kA85
1cQ7UPA+aUV2Zsx5Qhry65URHoxw6LBkG0xSpOZZ8GJtnyx14XbJzSPFX4/yqqaK
NQWWaXaY9B/WInFXsOFWOzs18zhaqWX31vfx836dTwEL+I+JhmnPOxZa8qmElQSA
QHzbwoZnKbqnpY9zocwmBtIfdgAfM02HguI+msLjNEEfiY6vOE0aYB8ZB6SHlluz
Iui+sSUV1W9F6U6IFHBVp+ooufT4efkzZ6w50Omky0zL6L5ao3fPwi+TGf0/9Bii
jtqUdyRjnF5rWkPwuCNBZDU0u6eZhllJxT3mVLOSEZ/6715SA7J7RzQeWyXVRnXL
XkU29m048tPEw1pJNU9n+G6D59Mk6RhTX+ujDP6j7OfCW4mfoNLxOI6/sYRkNRok
+bjYFwYu40hpTZREVxEW
=nX9v
-END PGP SIGNATURE-




Re: [O] error exporting latex src block

2013-10-16 Thread Jason Lewis
On 17/10/13 12:22 PM, Jason Lewis wrote:

 Hi,

 If I try and export:

 #+BEGIN_SRC latex
 \\
 #+END_SRC

I also get the same error with

#+BEGIN_SRC latex
\newline
#+END_SRC

I'm exporting with C-c C-e hH





Re: [O] error exporting latex src block

2013-10-16 Thread Jason Lewis
On 17/10/13 12:30 PM, Jason Lewis wrote:
 On 17/10/13 12:22 PM, Jason Lewis wrote:
 
 Hi,

 If I try and export:

 #+BEGIN_SRC latex
 \\
 #+END_SRC

 I also get the same error with

 #+BEGIN_SRC latex
 \newline
 #+END_SRC

 I'm exporting with C-c C-e hH



I see the same error with:

#+BEGIN_SRC latex
\titleformat{\chapter}
#+END_SRC

am I doing something wrong?




[O] Bug: #+SETUPFILE breaks org buffers syntax highlighting [8.2.1 (8.2.1-3-g35e5e5-elpa @ /cygdrive/c/Users/jason/.emacs.d/elpa/org-20131007/)]

2013-10-14 Thread Jason Lewis
--text follows this line--

Remember to cover the basics, that is, what you expected to happen and
what in fact did happen.  You don't know how to make a good report?  See

 http://orgmode.org/manual/Feedback.html#Feedback

Your bug report will be posted to the Org-mode mailing list.


Inserting a #+SETUPFILE line in an org buffer and causing the settings
to be re-read causes all font highlighting in the buffer to disappear.

Steps to reproduce:

Creat an or buffer with a line or two
insert at the top of the org file:
#+SETUPFILE: somfile.org

Press C-c C-c on that line.

observe font highlighting disappears.

Seems to happen whether or not somefile.org exists or no, and whether it
contains anything or not.

Also if you open an org-file with a SETUPFILE line in it, it also fails
to render the colours.

I expect highlighting should stay the same when a setupfile is inserted.

Emacs  : GNU Emacs 24.3.50.3 (i686-pc-cygwin)
 of 2013-02-26 on jade
Package: Org-mode version 8.2.1 (8.2.1-3-g35e5e5-elpa @
/cygdrive/c/Users/jason/.emacs.d/elpa/org-20131007/)

current state:
==
(setq
 org-ctrl-c-ctrl-c-hook '(org-babel-hash-at-point
org-babel-execute-safely-maybe)
 org-latex-format-headline-function
'org-latex-format-headline-default-function
 outline-minor-mode-hook '(mediawiki-outline-magic-keys)
 org-tab-first-hook '(org-hide-block-toggle-maybe
org-src-native-tab-command-maybe org-babel-hide-result-toggle-maybe
org-babel-header-arg-expand)
 org-refile-targets '((nil :maxlevel . 9) (org-agenda-files :maxlevel . 9))
 org-cycle-hook '(org-cycle-hide-archived-subtrees
org-cycle-hide-drawers org-cycle-hide-inline-tasks
org-cycle-show-empty-lines
  org-optimize-window-after-visibility-change)
 org-agenda-before-write-hook '(org-agenda-add-entry-text)
 org-speed-command-hook '(org-speed-command-default-hook
org-babel-speed-command-hook)
 org-babel-pre-tangle-hook '(save-buffer)
 org-occur-hook '(org-first-headline-recenter)
 org-metaup-hook '(org-babel-load-in-session-maybe)
 org-confirm-elisp-link-function 'yes-or-no-p
 org-default-notes-file ~/Dropbox/org/todo.org
 org-latex-classes '((beamer
\\documentclass[presentation]{beamer}\n[DEFAULT-PACKAGES]\n[PACKAGES]\n[EXTRA]
(\\section{%s} . \\section*{%s})
  (\\subsection{%s} . \\subsection*{%s})
(\\subsubsection{%s} . \\subsubsection*{%s}))
 (article \\documentclass[11pt]{article}
(\\section{%s} . \\section*{%s}) (\\subsection{%s} .
\\subsection*{%s})
  (\\subsubsection{%s} . \\subsubsection*{%s})
(\\paragraph{%s} . \\paragraph*{%s})
  (\\subparagraph{%s} . \\subparagraph*{%s}))
 (report \\documentclass[11pt]{report}
(\\part{%s} . \\part*{%s}) (\\chapter{%s} . \\chapter*{%s})
  (\\section{%s} . \\section*{%s})
(\\subsection{%s} . \\subsection*{%s}) (\\subsubsection{%s} .
\\subsubsection*{%s}))
 (book \\documentclass[11pt]{book} (\\part{%s}
. \\part*{%s}) (\\chapter{%s} . \\chapter*{%s})
  (\\section{%s} . \\section*{%s})
(\\subsection{%s} . \\subsection*{%s}) (\\subsubsection{%s} .
\\subsubsection*{%s}))
 )
 org-blank-before-new-entry nil
 org-clock-out-hook '(org-clock-remove-empty-clock-drawer)
 org-mode-hook '(#[nil \300\301\302\303\304$\207 [org-add-hook
change-major-mode-hook org-show-block-all append local] 5]
 #[nil \300\301\302\303\304$\207 [org-add-hook
change-major-mode-hook org-babel-show-result-all append local] 5]
 org-babel-result-hide-spec org-babel-hide-all-hashes
(lambda nil (flyspell-mode -1)))
 org-directory ~/Dropbox/org
 org-metadown-hook '(org-babel-pop-to-session-maybe)
 org-agenda-files '(~/Dropbox/org/todo.org ~/Dropbox/org
~/Dropbox/org/todo.org)
 org-src-mode-hook '(org-src-babel-configure-edit-buffer
org-src-mode-configure-edit-buffer)
 org-after-todo-state-change-hook '(org-clock-out-if-current)
 org-M-RET-may-split-line '((default))
 org-confirm-shell-link-function 'yes-or-no-p
 )

 
Jason Lewis http://emacstragic.net



[O] bug report: org-beamer-select-environment popup window not displaying nicely

2013-10-13 Thread Jason Lewis
--text follows this line--

Remember to cover the basics, that is, what you expected to happen and
what in fact did happen.  You don't know how to make a good report?  See

 http://orgmode.org/manual/Feedback.html#Feedback

Your bug report will be posted to the Org-mode mailing list.


Hi,

org-beamer-select-environment (C-c C-b) does not popup its selection
buffer nicely if the emacs frame is very wide.

Steps to reproduce:

1. make a narrow frame, make sure only 1 window is open.
2. create an org buffer and enable org-beamer-mode
3. on a heading, press C-c C-b
  - the popup window is nicely formatted

screenshot: http://take.ms/E389Mv

4. make the frame very wide, make sure only 1 window is visible.
5. on a heading, press C-c C-b
  - 2 new windows are created, one a copy of the original buffer, but
the formatting of the *Org tags* buffer

screenshot: http://take.ms/V3ZPkL

I expect org-beamer-select-environment should display the *Org Tags* the
same no matter the frame width.

Emacs  : GNU Emacs 24.3.50.3 (i686-pc-cygwin)
 of 2013-02-26 on jade
Package: Org-mode version 8.2.1 (8.2.1-3-g35e5e5-elpa @
/cygdrive/c/Users/jason/.emacs.d/elpa/org-20131007/)

current state:
==
(setq
 org-ctrl-c-ctrl-c-hook '(org-babel-hash-at-point
org-babel-execute-safely-maybe)
 org-latex-format-headline-function
'org-latex-format-headline-default-function
 outline-minor-mode-hook '(mediawiki-outline-magic-keys)
 org-tab-first-hook '(org-hide-block-toggle-maybe
org-src-native-tab-command-maybe
  org-babel-hide-result-toggle-maybe
org-babel-header-arg-expand)
 org-refile-targets '((nil :maxlevel . 9) (org-agenda-files :maxlevel . 9))
 org-cycle-hook '(org-cycle-hide-archived-subtrees org-cycle-hide-drawers
  org-cycle-hide-inline-tasks org-cycle-show-empty-lines
  org-optimize-window-after-visibility-change)
 org-agenda-before-write-hook '(org-agenda-add-entry-text)
 org-speed-command-hook '(org-speed-command-default-hook
org-babel-speed-command-hook)
 org-babel-pre-tangle-hook '(save-buffer)
 org-occur-hook '(org-first-headline-recenter)
 org-metaup-hook '(org-babel-load-in-session-maybe)
 org-confirm-elisp-link-function 'yes-or-no-p
 org-default-notes-file ~/Dropbox/org/todo.org
 org-latex-classes '((beamer

\\documentclass[presentation]{beamer}\n[DEFAULT-PACKAGES]\n[PACKAGES]\n[EXTRA]
  (\\section{%s} . \\section*{%s})
  (\\subsection{%s} . \\subsection*{%s})
  (\\subsubsection{%s} . \\subsubsection*{%s}))
 (article \\documentclass[11pt]{article}
  (\\section{%s} . \\section*{%s})
  (\\subsection{%s} . \\subsection*{%s})
  (\\subsubsection{%s} . \\subsubsection*{%s})
  (\\paragraph{%s} . \\paragraph*{%s})
  (\\subparagraph{%s} . \\subparagraph*{%s}))
 (report \\documentclass[11pt]{report}
  (\\part{%s} . \\part*{%s}) (\\chapter{%s} .
\\chapter*{%s})
  (\\section{%s} . \\section*{%s})
  (\\subsection{%s} . \\subsection*{%s})
  (\\subsubsection{%s} . \\subsubsection*{%s}))
 (book \\documentclass[11pt]{book} (\\part{%s}
. \\part*{%s})
  (\\chapter{%s} . \\chapter*{%s})
  (\\section{%s} . \\section*{%s})
  (\\subsection{%s} . \\subsection*{%s})
  (\\subsubsection{%s} . \\subsubsection*{%s}))
 )
 org-blank-before-new-entry nil
 org-clock-out-hook '(org-clock-remove-empty-clock-drawer)
 org-mode-hook '(#[nil \300\301\302\303\304$\207
   [org-add-hook change-major-mode-hook
org-show-block-all append local] 5]
 #[nil \300\301\302\303\304$\207
   [org-add-hook change-major-mode-hook
org-babel-show-result-all append
local]
   5]
 org-babel-result-hide-spec org-babel-hide-all-hashes
 (lambda nil (flyspell-mode -1)))
 org-directory ~/Dropbox/org
 org-metadown-hook '(org-babel-pop-to-session-maybe)
 org-agenda-files '(~/Dropbox/org/todo.org ~/Dropbox/org
~/Dropbox/org/todo.org)
 org-src-mode-hook '(org-src-babel-configure-edit-buffer
org-src-mode-configure-edit-buffer)
 org-after-todo-state-change-hook '(org-clock-out-if-current)
 org-M-RET-may-split-line '((default))
 org-confirm-shell-link-function 'yes-or-no-p
 )



Jason

 
Jason Lewis http://emacstragic.net



[O] how to provide feedback to the org documentation on the website?

2013-09-27 Thread Jason Lewis
Hi,

I noticed a word that is probably wrong in the org doco online. What's
the general procedure for providing feedback? It's not editable like a
wiki is it?

Specifically on the page http://orgmode.org/manual/Beamer-export.html

 Eventually, every plain list has support should read Finally, every
plain list has support

Jason

-- 
Jason Lewis
http://emacstragic.net



signature.asc
Description: OpenPGP digital signature


Re: [O] Bug: Wrong type argument: arrayp, nil when exporting to beamer [8.2 (8.2-elpa @ /Users/jason/.emacs.d/elpa/org-20130919/)]

2013-09-22 Thread Jason Lewis
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA256

Nicolas Goaziou wrote, On 23/09/2013 7:56 AM:
 Hello,
 
 Jason Lewis ja...@dickson.st writes:
 
 When I try and export the following code to beamer, using the C-c
 C-e l b, it gives the error:
 
 setq: Wrong type argument: arrayp, nil
 
 example file that causes the error:
 
 #+STARTUP: beamer * Introduction
  :B_frame: :PROPERTIES: :BEAMER_env: frame :END: ** Tools I
 looked at :B_frame: :PROPERTIES: :BEAMER_env: frame :END: + test
 
 The syntax is wrong: you cannot have two frames within the same
 tree.
 
 
 Regards,
 


Hi Nocolas,

Thanks. The error message is not very clear and this is an easy
mistake for a beginner to make.

Thanks,

Jason


- -- 
Jason Lewis
http://emacstragic.net
-BEGIN PGP SIGNATURE-
Version: GnuPG v2.0.19 (MingW32)

iQIcBAEBCAAGBQJSP3QdAAoJEPpXHsdQXnZO7FYP/jB4wOL8UzV6SCh1ZKI7siwa
Yd9WnMVCNM3pmwfOAO+WAgWrnIA8lfE4sIt6S7T2BkUsvvNAsVt/DorooKX/6Bwh
naIWRJd3qOqA3v5TpN8I+Y8jDjGTr8ZuXfV9OGuxrWgs/Z9vk4MMRSepyYT5wdyA
QUoV/yfgppPKrq9lqSf9OwXQ+sZ1Q62aZ5tTSWvVo5gKH9Po0pSJ8mAnQwoOPZiK
xkk8L26Ex2ffYkVtLl1FQMQM+YCUU4Pga9YE0//q6KIF+EbC73L03BIWvVVUVNQd
/KK3IyvqKuASR45mv5L3zsk8I27iBv7Sowxhel+JqDz14PaOqPCWC7CjAQ/AU9Bj
u44DxOP/pY7B2VVi7SbYcXMgOCDcoog37AyPjHLSnRATqI7cC/jXPlgrzpS+pbRt
FkAcajAQdp1dQ9G7ba3JVm7sy1SeBzxzYbDBv4waL1/4GGEJ7UWtl++8SeKBYyUs
+wjVSs7OKkphVErL3a0r1oYN6FjSnRSagR0lmCFz2bk1rktRE/As07kt7M4OJBlp
xzkIN6Jy9atk0CGTUNGt8RcJztpiRSmrvMhiUOlv9u3tM/J6SpH3oyhTjVSgAOXd
df33T81ieMuB6Ek4a7Glq/WDUZWkE/iNO6s4phrtib7oaFhzVzO6S2HkMmUqatSD
Kwv3FCcyGBCzmuGc0oLO
=rpK3
-END PGP SIGNATURE-