(setq org-hide-emphasis-markers t) + markup + lists + Visible only = blank list items

2020-01-10 Thread Michael Dixon
I’m running Org 9.3.1 and Emacs 27.0.60, which I compile myself.

I discovered that if I have (setq org-hide-emphasis-markers t) in my config, 
and I create an ordered or unordered list where there are list items only 
containing marked up text, and then I export Visible only (C-v), those list 
items export as blank lines (other than the bullet or number).

For example, if I have an org file with the following:

* Heading
This is some text. And following is a list.
  1. ~with code~
  2. some text ~with code~
  3. some text

And back to a new paragraph

It will export to LaTeX/PDF as:
Heading
This is some text. And following is a list.

some text with code
some text
And back to a new paragraph
If I look at the LaTeX source that was exported for the list, this is what it 
looks like:
\begin{enumerate}
\item 
\item some text \texttt{with code}
\item some text
\end{enumerate}
I can reproduce this with an init.el file containing only these 2 lines:
(require 'org)
(setq org-hide-emphasis-markers t)
If I comment out the second line, the list exports correctly.

[Orgmode] Upgrading org-mode--Windows

2007-10-23 Thread Michael Dixon
I apologize in advance if this question is off-topic/inappropriate, but 
the version of org-mode packaged with emacs 22.1 for Windows is 4.67, 
while the latest current version is 5.13. I can't seem to figure out how 
to update the org-mode package in Windows. Any help?



___
Emacs-orgmode mailing list
Remember: use `Reply All' to send replies to the list.
Emacs-orgmode@gnu.org
http://lists.gnu.org/mailman/listinfo/emacs-orgmode