[O] Two questions about org-export-insert-default-template in new org-exporter

2013-06-04 Thread Robert Goldman
1. The original org-insert-export-options-template always inserted the template at the top of the file. The new one inserts at point. Since the options need to be at the top of the file, would there be any objection to making the new template inserter behave the same way? 2. Users can

Re: [O] {New exporter] What happened to the export template

2013-05-31 Thread Robert Goldman
A very late follow-up: I note that the Worg instructions for HTML export still cite org-insert-export-options-template: http://orgmode.org/worg/org-tutorials/org-publish-html-tutorial.html

[O] Minor bug in org export to latex

2013-05-31 Thread Robert Goldman
I find that a mathmode environment, bounded by $..$, that breaks across line boundaries, is not typeset correctly. I am attaching a minimal example org-file. Best, r #+TITLE: Latex Export bug on line boundaries #+AUTHOR: Robert P. Goldman #+DATE: 2013-05-31 Fri #+EMAIL: rpgold...@sift.info

[O] Question about org-agenda-goto-today (bug?)

2013-04-26 Thread Robert Goldman
I am finding that when I use this command (bound to . in the org agenda), I often do NOT go to today. Looking at the code, it seems like org-mode may be guessing today based on text markup: (let ((tdpos (text-property-any (point-min) (point-max) 'org-today t))) We jump to this position, instead

Re: [O] Fix for bug in org-capture

2013-04-16 Thread Robert Goldman
Bastien wrote: Hi Robert, Robert Goldman rpgold...@sift.info writes: I tried to make two submenus to my org-capture templates: a prefix key t (for TODO) and a prefix key T (for today's TODO). When I tried to use them, the T key did not appear and was not accepted. Looking more deeply

[O] Fix for bug in org-capture

2013-04-15 Thread Robert Goldman
I tried to make two submenus to my org-capture templates: a prefix key t (for TODO) and a prefix key T (for today's TODO). When I tried to use them, the T key did not appear and was not accepted. Looking more deeply, it appears that it was filtered out by a mistakenly case-folding (or at least

Re: [O] phone links...

2013-04-09 Thread Robert Goldman
Michael Strey wrote: Robert, On Mo, Apr 08, 2013 at 09:44:12 -0500, Robert Goldman wrote: Michael Strey wrote: Currently org-phone.el as well as my org-dial.el are incompatible with org-contacts. The only idea behind my proposal was to make the contributors of both packages aware of each

Re: [O] phone links...

2013-04-08 Thread Robert Goldman
Michael Strey wrote: Robert, On Do, Apr 04, 2013 at 09:38:48 -0500, Robert P. Goldman wrote: [...] I will be happy to include this into contrib (and do the relevant assignment) at any time when people think that it is sufficiently ready to go. I have been testing it in contrib/ in a

Re: [O] phone links...

2013-04-08 Thread Robert Goldman
Michael Strey wrote: Currently org-phone.el as well as my org-dial.el are incompatible with org-contacts. The only idea behind my proposal was to make the contributors of both packages aware of each other. Can you explain what makes org-phone incompatible with org-contacts? Maybe my naming of

Re: [O] phone links...

2013-04-03 Thread Robert Goldman
On 4/3/13 Apr 3 -9:52 AM, Michael Strey wrote: This gives me the opportunitie to publish my own attempt to implement telephone functionality into org. I'm using Linphone (http://www.linphone.org/) instead of Skype. Thanks! I am folding the linphone code in to make org-phone more generic.

Re: [O] phone links...

2013-04-01 Thread Robert Goldman
On 3/29/13 Mar 29 -6:23 PM, Robert Goldman wrote: Since I keep my todo tasks in my org files, and some of them involve phone calls, I made a rudimentary handler for phone: links that I would like to contribute. It features a link declaration (in org-phone.el) and an ancillary script

[O] phone links...

2013-03-29 Thread Robert Goldman
Since I keep my todo tasks in my org files, and some of them involve phone calls, I made a rudimentary handler for phone: links that I would like to contribute. It features a link declaration (in org-phone.el) and an ancillary script (currently only working on Mac OS X, but should be translatable

Re: [O] A mail client that is org-mode compatible

2013-01-03 Thread Robert Goldman
On 1/3/13 Jan 3 -4:17 AM, Daniel Clemente wrote: El Wed, 02 Jan 2013 13:07:20 -0600 Robert Goldman va escriure: Thunderbird, which I have been using, doesn't support links to messages. OTOH, it has the best IMAP client I have found, so I keep coming back to it. Gnus: I regret to say

Re: [O] A mail client that is org-mode compatible

2013-01-02 Thread Robert Goldman
I have a closely related question: I use multiple devices, so I need to have an IMAP server that really is an IMAP server, instead of something the just serves up messages to be downloaded. I have multiple folders, and I read messages from different clients. I haven't been able to figure out an

Re: [O] Org agenda and recent files list....

2012-08-10 Thread Robert Goldman
On 8/10/12 Aug 10 -2:21 AM, Bastien wrote: Robert Goldman rpgold...@sift.info writes: ;;;--- ;;; Agenda files shouldn't get entries in the recentf-list

[O] Org agenda and recent files list....

2012-08-09 Thread Robert Goldman
I was finding that the use of org-agenda made my recent files list less than useful, by filling up the list with files that I rarely opened by hand with find-file. The following snippet, added to my org-config file, seems to have fixed things.

Re: [O] centering blocks cause latex export to crash

2011-12-24 Thread Robert Goldman
On 12/23/11 Dec 23 -12:41 PM, Nick Dokos wrote: Bastien b...@altern.org wrote: Hi Robert, Robert Goldman rpgold...@sift.info writes: The attached org-mode file causes latex export to crash with an error of unbalanced begin/end center blocks with This should work as expected now

[O] centering blocks cause latex export to crash

2011-12-14 Thread Robert Goldman
I am using the latest org from git. The attached org-mode file causes latex export to crash with an error of unbalanced begin/end center blocks with This did work, as recently as a month ago, so something relatively recent has broken it. best, r #+TITLE: center-export-bug.org #+AUTHOR:

Re: [O] centering blocks cause latex export to crash

2011-12-14 Thread Robert Goldman
On 12/14/11 Dec 14 -3:06 PM, Robert Goldman wrote: I am using the latest org from git. The attached org-mode file causes latex export to crash with an error of unbalanced begin/end center blocks with This did work, as recently as a month ago, so something relatively recent has broken

Re: [O] centering blocks cause latex export to crash

2011-12-14 Thread Robert Goldman
On 12/14/11 Dec 14 -3:13 PM, Nick Dokos wrote: Robert Goldman rpgold...@sift.info wrote: I am using the latest org from git. The attached org-mode file causes latex export to crash with an error of unbalanced begin/end center blocks with This did work, as recently as a month ago, so

Re: [O] OPatches for org-generic-export

2011-10-24 Thread Robert Goldman
On 10/24/11 Oct 24 -9:44 AM, Wes Hardaker wrote: On Fri, 21 Oct 2011 19:23:04 +0200, Bastien b...@altern.org said: Glad to see someone tinkering with it! yay! B Could you test Robert's patches against latest Org and report B any problem? As the author of the generic exporter, you might

Re: [O] OPatches for org-generic-export

2011-10-21 Thread Robert Goldman
On 10/21/11 Oct 21 -12:06 PM, Wes Hardaker wrote: On Fri, 21 Oct 2011 11:13:24 -0500, Robert P. Goldman rpgold...@real-time.com said: RPG Attached is a set of patches to the org-generic-exporter. They fix RPG a change in the org-preprocess process that means that all uses of RPG the

[O] Bug? in latex export of cross-references in footnotes

2011-09-26 Thread Robert Goldman
Here is a simple footnote in a test file: Footnotes: [1] The footnote contains a cross-reference to [[Heading]]. When I export this using org-export-as-pdf, the cross-reference to Heading doesn't get exported properly. In particular, what I see in the emitted latex file is: Inside the text

Re: [O] Bug? in latex export of cross-references in footnotes

2011-09-26 Thread Robert Goldman
On 9/26/11 Sep 26 -2:26 PM, Robert Goldman wrote: Here is a simple footnote in a test file: Footnotes: [1] The footnote contains a cross-reference to [[Heading]]. When I export this using org-export-as-pdf, the cross-reference to Heading doesn't get exported properly. In particular

Re: [O] Question about org-mode compilation

2011-09-11 Thread Robert Goldman
On 9/11/11 Sep 11 -12:52 AM, David Maus wrote: At Sat, 10 Sep 2011 12:08:45 -0500, Robert Goldman wrote: Today I was trying to push to mobile org after an update from git, and got an invalid function error on org-eval-in-environment. This macro is defined in org-macs.el and is used in org

[O] Question about org-mode compilation

2011-09-10 Thread Robert Goldman
Today I was trying to push to mobile org after an update from git, and got an invalid function error on org-eval-in-environment. This macro is defined in org-macs.el and is used in org-agenda.el. I note that the makefile has org-agenda depending on org.el, but /not/ on org-macs.el. Is that an

Re: [O] Google Tasks integration

2011-09-06 Thread Robert Goldman
On 9/3/11 Sep 3 -12:44 PM, Sven Bretfeld wrote: Hi Brad I don't know anything about your question proper, but ... Brad Collette shopinthewo...@gmail.com writes: I've also been using mobileorg to get my stuff on my iphone. However, I'm less satisfied with that. Having to both push

Re: [O] HTML5 presentations

2011-06-16 Thread Robert Goldman
On 6/7/11 Jun 7 -3:01 PM, Tassilo Horn wrote: Vinh Nguyen vinhdi...@gmail.com writes: After the recent org-mode to S5 discussion, I stumbled onto [these](https://gist.github.com/509761) code. It offers a way to export org files to HTML5 presentations. I think it looks quite nice. I see

Re: [O] HTML5 presentations

2011-06-16 Thread Robert Goldman
On 6/16/11 Jun 16 -2:29 PM, Eric Schulte wrote: Robert Goldman rpgold...@sift.info writes: On 6/7/11 Jun 7 -3:01 PM, Tassilo Horn wrote: Vinh Nguyen vinhdi...@gmail.com writes: After the recent org-mode to S5 discussion, I stumbled onto [these](https://gist.github.com/509761) code

Re: [O] HTML5 presentations

2011-06-16 Thread Robert Goldman
On 6/16/11 Jun 16 -3:36 PM, Jambunathan K wrote: Eric Schulte schulte.e...@gmail.com writes: Robert Goldman rpgold...@sift.info writes: On 6/7/11 Jun 7 -3:01 PM, Tassilo Horn wrote: Vinh Nguyen vinhdi...@gmail.com writes: I have tried the version here: https://github.com/twada/org

[O] Bug in latex description list export

2011-05-30 Thread Robert Goldman
I stumbled across a /very/ weird bug in latex export. The bug arises when there is 1. A footnote in a description list 2. The word description appears in the footnote and 3. The word description is flush to the left margin. See the attached .org file * Header + item 1 ::

[O] Problem with latex export of anchors

2011-05-30 Thread Robert Goldman
The latex exporter mistakenly leaves the text of anchors in the exported text. I have reported this before --- see http://thread.gmane.org/gmane.emacs.orgmode/41414 I am attaching an org-mode file that shows a minimal test case, and the corresponding exported latex My earlier posting

Re: [O] Org babel does not work properly with included files

2011-05-11 Thread Robert Goldman
I would say we can close this bug report as INVALID. AFAICT, the actual problem was happening simply because of the incorrect treatment of missing links during export, which is now fixed. When that got fixed, my issue went away. best, r

Re: [O] Bug in latex export tutorial on worg ?

2011-05-10 Thread Robert Goldman
On 5/10/11 May 10 -12:25 AM, Thomas S. Dye wrote: Robert Goldman rpgold...@sift.info writes: On 5/9/11 May 9 -11:22 PM, Nick Dokos wrote: Robert Goldman rpgold...@sift.info wrote: On 5/9/11 May 9 -9:54 PM, Nick Dokos wrote: Robert Goldman rpgold...@sift.info wrote: There is the following

Re: [O] mobileorg android refuses to syn with mydisk.se

2011-05-10 Thread Robert Goldman
On 5/10/11 May 10 -12:34 PM, Matthew Jones wrote: Hi Robert... I'm the developer for MobileOrg on Android, we have a known issue with self-signed certificates. What version of MobileOrg are you using? If you visit the site in the Android browser do you get a certificate notification also?

[O] Bug in latex export tutorial on worg ?

2011-05-09 Thread Robert Goldman
There is the following code block there: #+begin_src emacs-lisp :results silent (add-to-list 'org-export-latex-classes '(per-file-class \\documentclass{scrartcl} [NO-DEFAULT-PACKAGES] [EXTRA] (\\section{%s} . \\section*{%s})

Re: [O] Bug in latex export tutorial on worg ?

2011-05-09 Thread Robert Goldman
On 5/9/11 May 9 -11:22 PM, Nick Dokos wrote: Robert Goldman rpgold...@sift.info wrote: On 5/9/11 May 9 -9:54 PM, Nick Dokos wrote: Robert Goldman rpgold...@sift.info wrote: There is the following code block there: #+begin_src emacs-lisp :results silent (add-to-list 'org-export-latex

Re: [O] Org babel does not work properly with included files

2011-05-05 Thread Robert Goldman
On 5/5/11 May 5 -11:56 AM, Eric Schulte wrote: Robert Goldman rpgold...@sift.info writes: Looking over this some more, I see that the challenge is to: 1. read the file parameters (whatever they are) from the original file (hence opening the file from the link) and 2. read the header

Re: [O] Org babel does not work properly with included files

2011-05-05 Thread Robert Goldman
On 5/5/11 May 5 -4:27 PM, Eric Schulte wrote: I'm not sure that the current behavior is a bug. Is it reasonable to place code block parameters into an included file? These parameters would not be successfully found during interactive evaluation, and could only plausibly be used during

[O] Bug in :minlevel for INCLUDE

2011-05-05 Thread Robert Goldman
AFAICT there is an off-by-one-error here. I.e., if I tell it that the :minlevel is 2, then my included level one headers get level 3, and if I tell it that the :minlevel is 1, then they get level 2. So it seems like :minlevel is actually being interpreted as a level *increment*, rather than a

[O] footnotes header not handled properly by INCLUDE files?

2011-05-05 Thread Robert Goldman
I just included a file that had a footnotes header, and the footnotes header appeared in the main text as a separate region, rather than correctly being interpreted as footnotes. I guess I'm not /terribly/ surprised this fails, but it does suggest the need for some link rewriting on import, or

Re: [O] Bug in :minlevel for INCLUDE

2011-05-05 Thread Robert Goldman
On 5/5/11 May 5 -6:03 PM, Nick Dokos wrote: Robert Goldman rpgold...@sift.info wrote: AFAICT there is an off-by-one-error here. I.e., if I tell it that the :minlevel is 2, then my included level one headers get level 3, and if I tell it that the :minlevel is 1, then they get level 2. I

[O] Request for suggestions including source code

2011-05-04 Thread Robert Goldman
I have a document that has big chunks of included source code. Unfortunately, when this is typeset in LaTeX, it typically blows past the right margin. I find it quite difficult to determine how many characters I get in a monospace line in LaTeX, and it seems like LaTeX won't give me enough to fit

Re: [O] Request for suggestions including source code

2011-05-04 Thread Robert Goldman
On 5/4/11 May 4 -4:13 PM, Thomas S. Dye wrote: Aloha Robert, Have a look at the listings and minted packages. You can specify font size on a per-document or per-language basis. I believe listings has an option to wrap long lines (don't remember this for minted, though). The

Re: [O] Request for suggestions including source code

2011-05-04 Thread Robert Goldman
On 5/4/11 May 4 -4:44 PM, Nick Dokos wrote: Tom provides the practical answers, I go for the frivolous ones :-) : the following latex program will give you the text width of the page: --8---cut here---start-8--- \documentclass{article}

Re: [O] Request for suggestions including source code

2011-05-04 Thread Robert Goldman
On 5/4/11 May 4 -5:23 PM, Thomas S. Dye wrote: On May 4, 2011, at 11:59 AM, Robert Goldman wrote: On 5/4/11 May 4 -4:13 PM, Thomas S. Dye wrote: Aloha Robert, Have a look at the listings and minted packages. You can specify font size on a per-document or per-language basis. I believe

Re: [O] [Accepted] Make the latex export preprocessor rewrite #+INDEX to \index.

2011-05-04 Thread Robert Goldman
On 5/4/11 May 4 -5:36 PM, Carsten Dominik wrote: On 4.5.2011, at 17:08, Robert Goldman wrote: On 5/4/11 May 4 -2:59 AM, Carsten Dominik wrote: Patch 767 (http://patchwork.newartisans.com/patch/767/) is now Accepted. Maintainer comment: Pushed with modifications. Some optimization

Re: [O] Request for suggestions including source code

2011-05-04 Thread Robert Goldman
On 5/4/11 May 4 -6:10 PM, Nick Dokos wrote: Robert Goldman rpgold...@sift.info wrote: On 5/4/11 May 4 -4:44 PM, Nick Dokos wrote: So what I need now is some way to fix the verbatim environments that are produced by org-mode to use a smaller font. I.e., instead of trying to fix

[O] Collaboration and settings --- was Re: bug in latex export tutorial?

2011-05-01 Thread Robert Goldman
On 4/30/11 Apr 30 -5:14 PM, Eric S Fraga wrote: Robert Goldman rpgold...@sift.info writes: On 4/29/11 Apr 29 -1:21 PM, Nick Dokos wrote: [...] amsmath conflicts with wasysym (redefines \iint), so you have to redefine your headers to omit wasysym or include amsmath *first*: for some

Re: [O] Bug in latex export of links

2011-05-01 Thread Robert Goldman
On 4/29/11 Apr 29 -4:07 PM, Robert Goldman wrote: I have this header in my org-mode file: Documentation documentationPseudoProp it gets translated into the following, which formats poorly: \item Documentation \label{documentationPseudoProp}documentationPseudoProp\\ Any idea why

Re: [O] Images in included files

2011-05-01 Thread Robert Goldman
I'm having exactly this same problem. I have a file, suggestions.org, in directory ~/x/y/z/top/child/ that contains many images. These are included by means of links such as [[./foo.pdf]] Now, I have a parent file in top/, manual.org, and I want to #+include child/suggestions.org

[O] Org babel does not work properly with included files

2011-05-01 Thread Robert Goldman
Here's the problem: when org-babel goes to look for parameters when executing a source block, it looks for them in the parent source file, and not in the parent source file with the included materials. Here is the function that goes awry: (defmacro org-babel-exp-in-export-file (lang rest

Re: [O] Org babel does not work properly with included files

2011-05-01 Thread Robert Goldman
Looking over this some more, I see that the challenge is to: 1. read the file parameters (whatever they are) from the original file (hence opening the file from the link) and 2. read the header parameters from the export buffer, since the header may not actually be contained in the original

[O] bug in latex export tutorial?

2011-04-29 Thread Robert Goldman
The document http://orgmode.org/worg/org-tutorials/org-latex-export.html claims The Org-mode LaTeX exporter uses several packages to support special characters used by org-entities. One of these, amsmath, conflicts with several LaTeX fonts. If you want finer control over which packages are

Re: [O] bug in latex export tutorial?

2011-04-29 Thread Robert Goldman
configure a file so that it *can* use amsmath? 2. What happens to the parallel HTML export if we use amsmath constructs in an org file? thanks! r Thanks for pointing this out. All the best, Tom On Apr 29, 2011, at 6:26 AM, Robert Goldman wrote: The document http://orgmode.org/worg/org

Re: [O] bug in latex export tutorial?

2011-04-29 Thread Robert Goldman
On 4/29/11 Apr 29 -1:21 PM, Nick Dokos wrote: Robert Goldman rpgold...@sift.info wrote: On 4/29/11 Apr 29 -11:44 AM, Thomas S. Dye wrote: Aloha Robert, Yep. It should be One of these, amssymb, requires amsmath, which conflicts with several LaTeX fonts. I don't /believe/ amssymb requires

[O] Bug Re: [PATCH] Make the latex export preprocessor rewrite #+INDEX to \index.

2011-04-29 Thread Robert Goldman
Drat. This patch isn't quite right; it mis-handles typeface specifications. E.g. #+index: =Class= generates an index entry for =Class= instead of an entry for Class set in monospace font. Maybe someone who understands the intricacies of exporting can figure out a fix. The problem is likely

[O] Bug in latex export of links

2011-04-29 Thread Robert Goldman
I have this header in my org-mode file: Documentation documentationPseudoProp it gets translated into the following, which formats poorly: \item Documentation \label{documentationPseudoProp}documentationPseudoProp\\ Any idea why this would happen? Seems like a bona fide bug, but perhaps

Re: [O] Making an index in latex export --- surprisingly difficult

2011-04-28 Thread Robert Goldman
On 4/28/11 Apr 28 -4:28 AM, Eric S Fraga wrote: Robert Goldman rpgold...@sift.info writes: [...] I looked at that thread and unfortunately it petered out (partly because it went off into a different direction to solve an easier problem with conflicting style files). The last message

Re: [O] [PATCH] Make the latex export preprocessor rewrite #+INDEX to \index.

2011-04-28 Thread Robert Goldman
On 4/28/11 Apr 28 -7:33 AM, Nick Dokos wrote: rpgold...@sift.info wrote: From: Robert P. Goldman rpgold...@real-time.com --- lisp/org-latex.el | 13 + 1 files changed, 13 insertions(+), 0 deletions(-) ... Very nice! Did a small test and it works as advertised.

Re: [O] [PATCH] Make the latex export preprocessor rewrite #+INDEX to \index.

2011-04-28 Thread Robert Goldman
My mistake -- I made the template wrong; it wasn't a case-fold issue, after all. I have a patch that will do this now. Will post it soon. Cheers, r

Re: [O] Patch --- adding an easy template for #+index

2011-04-28 Thread Robert Goldman
On 4/28/11 Apr 28 -2:11 PM, Bernt Hansen wrote: rpgold...@sift.info writes: The next message will contain a patch that provides a new easy template for adding index entries, per Nick Dokos's suggestion. Hi Robert, Just a FYI: you can include the above information right in your patch

Re: [O] Making an index in latex export --- surprisingly difficult

2011-04-26 Thread Robert Goldman
On 4/26/11 Apr 26 -4:52 PM, Nick Dokos wrote: Robert Goldman rpgold...@sift.info wrote: I was trying to make an index in latex export and found that it was very difficult to make it work. I wonder if this could be simplified. Here's what I had to do: 2. put in \index commands (I

Re: [O] Making an index in latex export --- surprisingly difficult

2011-04-26 Thread Robert Goldman
On 4/26/11 Apr 26 -6:14 PM, Nick Dokos wrote: Robert Goldman rpgold...@sift.info wrote: 2. put in \index commands (I don't /believe/ #+INDEX works, but I could be wrong) Am I right about #+INDEX not being translated in the latex back end (it seems not to work, but it's hard to verify

Re: [O] include an .org file and lower the level of all its headers

2011-04-20 Thread Robert Goldman
This is a feature that I was just looking for, and I'm pretty excited about it. However, I find that providing this new facility leads me to look for another one: relativizing links. It seems like when I include another file, the links in that other file get messed up. In particular, I have

[O] Illiterate programming question

2011-03-30 Thread Robert Goldman
I would like to do the opposite of literate programming (hence the subject line!): I would like to pull into my org file snippets from a code file. I know that org-mode will let me import /entire/ source code files. Is there some way to say Import the region of this file between these two

Re: [O] Illiterate programming question

2011-03-30 Thread Robert Goldman
On 3/30/11 Mar 30 -4:33 PM, Nick Dokos wrote: Robert Goldman rpgold...@sift.info wrote: I would like to do the opposite of literate programming (hence the subject line!): I would like to pull into my org file snippets from a code file. I know that org-mode will let me import /entire

Re: [O] Having problem with latex export of image file

2011-03-19 Thread Robert Goldman
On 3/17/11 Mar 17 -4:35 AM, Bastien wrote: Hi Nick, Nick Dokos nicholas.do...@hp.com writes: I didn't look very hard, but I didn't find documentation on these. If Robert or you can provide a documentation patch for this, it would be nice. It's not (only) laziness from me: since you

Re: [O] Having problem with latex export of image file

2011-03-15 Thread Robert Goldman
X-TagToolbar-Keys: D20110315084847273 Content-Type: text/plain; charset=ISO-8859-1 Content-Transfer-Encoding: 7bit On 3/15/11 Mar 15 -12:04 AM, Nick Dokos wrote: Robert Goldman rpgold...@sift.info wrote: I have the following in my org file: #+CAPTION: Sample (partial) plan graph. #+LABEL

[O] Having problem with latex export of image file

2011-03-14 Thread Robert Goldman
I have the following in my org file: #+CAPTION: Sample (partial) plan graph. #+LABEL: fig:sampleGraph #+ATTR_LaTeX: width=.9\textwidth [[plan-with-tc-start.pdf]] which I believe should give me a figure. However, when I run this through the latex export I get the following instead:

[Orgmode] Re: convert orgmode to docx --- using odt export

2011-02-27 Thread Robert Goldman
Question: is this only usable in a stand-alone emacs, or can we load the exporter into our normal orgmode configuration? I suspect from reading that a merge will be difficult that we must use this outside our standard environment, but just wanted to be sure Thanks, r

[Orgmode] OrgCamp in Minneapolis/St. Paul

2011-01-23 Thread Robert Goldman
There's a lisp users group here in the Twin Cities (Twin Cities Lispers --- tclispers.org). I think that would be a good venue to have an OrgCamp, if there is sufficient interest. Feel free to contact me off line if this sounds interesting. best, r

[Orgmode] Re: EmacsForMacOSX - copy paste in orgmode

2011-01-13 Thread Robert Goldman
On 8/18/10 Aug 18 -5:01 AM, Erwin Panen wrote: Hi Juan, I hope you don't mind me mailing you directly. I copied orgmode list in cc. Do you have a way to copy / paste between say Firefox and Emacs / orgmode? It doesn't seem to work, and I've found some posts googling, but no apparent

Re: [Orgmode] Quick note about subtree copy and paste

2011-01-11 Thread Robert Goldman
On 1/11/11 Jan 11 -8:03 AM, Giovanni Ridolfi wrote: Robert Goldman rpgold...@sift.info writes: I just did a copy and paste and noticed that when I did so the copied properties included the ID which, after being copied, meant that the unique identifier became a non-unique identifier. Well

[Orgmode] Quick note about subtree copy and paste

2011-01-06 Thread Robert Goldman
I just did a copy and paste and noticed that when I did so the copied properties included the ID which, after being copied, meant that the unique identifier became a non-unique identifier. Is it work tweaking the org-paste-special command to rip out ID properties? cheers, r

[Orgmode] Re: Request for suggestions: multiple revision control systems/repositories + org

2010-12-20 Thread Robert Goldman
On 12/20/10 Dec 20 -1:03 AM, RĂ©mi Vanicat wrote: Robert P. Goldman rpgold...@sift.info writes: That is what I had done originally, but I thought mobile org required that all the org files be in the same directory. Was I wrong about that? I've org files in several directories, and in

[Orgmode] Request for suggestions: multiple revision control systems/repositories + org

2010-12-19 Thread Robert Goldman
I am looking for hints. I have a number of org files, typically one for each major project plus two or three for my personal life. These must often live in different revision control systems: my work projects, in particular, have different repositories; I have a main set of org files for work in

[Orgmode] bug in docstring for org-emphasis-regexp-components (org.el)

2010-11-12 Thread Robert Goldman
The docstring says: ...This is a list with 6 entries pre Chars allowed as prematch. Beginning of line will be allowed too. post Chars allowed as postmatch. End of line will be allowed too. border The chars *forbidden* as border characters. body-regexp A regexp

[Orgmode] Re: Having problems with faces in org agenda

2010-11-11 Thread Robert Goldman
On 9/30/10 Sep 30 -2:34 PM, Robert Goldman wrote: My org agendas for day and week are showing DONE items with the DONE in red, and not dulled out. This makes the agenda less useful than it might be for at-a-glance planning. This (bright red DONEs) does not happen when I am looking at an org

[Orgmode] Re: Meetup/conference

2010-10-28 Thread Robert Goldman
Since we're talking about meet-ups, I'd like to say it would be great to see an informal org-mode meet-up attached to other conferences one might attend. Not as an alternative to the Hawaii proposal, but as an also. cheers, r ___ Emacs-orgmode mailing

[Orgmode] quotes inside code markup: bug?

2010-10-25 Thread Robert Goldman
I'm finding that, when I export as Latex or html, quoted strings don't get translated properly. I.e., a bit of text like =foo= will be translated literally, instead of turning into a code marked-up string. I am attaching a simple document of this type, and the results of export to latex. Export

[Orgmode] Minor docstring bug: org-footnote-goto-previous-reference

2010-10-23 Thread Robert Goldman
The docstring for the command org-footnote-goto-previous-reference is Find the next previous of the footnote with label LABEL. ...which I can't actually parse. Find the (immediately) previous reference to the footnote with label LABEL. Is that better? Cheers, r

Re: [Orgmode] Re: Bug (?) in org-capture

2010-10-15 Thread Robert Goldman
On 10/15/10 Oct 15 -1:48 AM, Carsten Dominik wrote: Hi Robert, I cannot reproduce this error. If I set my default notes file to ~/org//notes.org things seem to work just fine. I will see if I can figure out why this happened for me. I may not be able to do so, though --- it occurred when

[Orgmode] Bug (?) in org-capture

2010-10-14 Thread Robert Goldman
I was trying to experiment for the first time using org-capture together with w3m today, and I get an error. I invoke org-capture, and was pleased to find that it built me a buffer just fine, and made an org link for the URL of the w3m buffer. So far, so good. Unfortunately, when I try to save

[Orgmode] Re: Bug (?) in org-capture

2010-10-14 Thread Robert Goldman
On 10/14/10 Oct 14 -9:40 AM, Robert Goldman wrote: I was trying to experiment for the first time using org-capture together with w3m today, and I get an error. I invoke org-capture, and was pleased to find that it built me a buffer just fine, and made an org link for the URL of the w3m

Re: [Orgmode] Any other Aquamacs + org-mode users?

2010-10-13 Thread Robert Goldman
On 10/12/10 Oct 12 -10:50 PM, Nick Dokos wrote: Robert Goldman rpgold...@sift.info wrote: If so, are any of you having trouble with the faces in agenda buffers? I'm finding that I get all of the todo keywords in what looks like the warning face --- bright red. It's a problem because

[Orgmode] Any other Aquamacs + org-mode users?

2010-10-12 Thread Robert Goldman
If so, are any of you having trouble with the faces in agenda buffers? I'm finding that I get all of the todo keywords in what looks like the warning face --- bright red. It's a problem because it looks like the display is shouting at me about tasks that are DONE, not just ones that are still

[Orgmode] Worg buglet

2010-10-11 Thread Robert Goldman
The link to the sample presentation, from http://orgmode.org/worg/org-tutorials/org-beamer/tutorial.php to http://orgmode.org/worg/org-tutorials/org-beamer/presentation.org is broken. Sorry if this is the wrong place to report this. best, r ___

[Orgmode] buglet in org-toggle-checkbox

2010-09-30 Thread Robert Goldman
Not a big bug... When I invoke org-toggle-checkbox with ^U in order to add a checkbox to a list item that doesn't have one, I get this message in the minibuffer: Invalid search bound (wrong side of point) although the command seems to work correctly. When I turn on debug-on-error, I get the

[Orgmode] Having problems with faces in org agenda

2010-09-30 Thread Robert Goldman
My org agendas for day and week are showing DONE items with the DONE in red, and not dulled out. This makes the agenda less useful than it might be for at-a-glance planning. This (bright red DONEs) does not happen when I am looking at an org file, where the TODO keyword is red and the DONE

Re: [Orgmode] Re: Request for suggestions about best practices: tracking responses

2010-09-23 Thread Robert Goldman
On 9/23/10 Sep 23 -1:44 PM, David Maus wrote: Robert P. Goldman wrote: I know how to make a custom agenda for this; the problem is more how to have that custom agenda always open for me to glance at. I don't want to have to call up this agenda every time I get an email or a phone call to

[Orgmode] Request for suggestions about best practices: tracking responses

2010-09-22 Thread Robert Goldman
Often now I have org-mode tasks that I move to WAIT status when I send someone an email to get some next step done. The problem is that I have a hard time getting back to those tasks when I get a response email (or phone call). There is nothing salient about these that means that when I get a

Re: [Orgmode] Re: bug with link following --- a (partial) solution

2010-09-22 Thread Robert Goldman
On 9/22/10 Sep 22 -1:11 PM, David Maus wrote: David Maus wrote: Ah, now I see the problem: For some reason `org-store-link' removes the colon at the end of the headline. I reopended the issue as a bug; setting the aforementioned variable to nil might be considered a temporary work-around.

Re: [Orgmode] Re: bug with link following --- a (partial) solution

2010-09-22 Thread Robert Goldman
On 9/22/10 Sep 22 -1:36 PM, Robert Goldman wrote: On 9/22/10 Sep 22 -1:11 PM, David Maus wrote: David Maus wrote: Ah, now I see the problem: For some reason `org-store-link' removes the colon at the end of the headline. I reopended the issue as a bug; setting the aforementioned variable

[Orgmode] Problems with capture on Mobile Org for Android

2010-09-19 Thread Robert Goldman
I have just had a problem twice with loss of data using Mobile org for android (flagged as version 40 in Application Info). Here's what you need to do to lose data: 1. enter foobar into the capture window 2. synchronize 3. enter baz into the capture window 4. synchronize 5. org-mobile

[Orgmode] Re: inline images in org-mode

2010-09-16 Thread Robert Goldman
On 9/16/10 Sep 16 -7:11 AM, Dan Davison wrote: Robert Goldman rpgold...@sift.info writes: I was looking for a way to put illustrations in my org-mode files so that I could actually look at them while editing the org stuff. I found a post a while ago suggesting using iimage mode (which

Re: [Orgmode] inline images in org-mode

2010-09-16 Thread Robert Goldman
On 9/16/10 Sep 16 -7:32 AM, Sebastian Rose wrote: Robert Goldman rpgold...@sift.info writes: I was looking for a way to put illustrations in my org-mode files so that I could actually look at them while editing the org stuff. I found a post a while ago suggesting using iimage mode (which

Re: [Orgmode] inline images in org-mode

2010-09-16 Thread Robert Goldman
On 9/16/10 Sep 16 -8:46 AM, Sebastian Rose wrote: Robert Goldman rpgold...@sift.info writes: ... Is there some magic I can put in the Local Variables block that will cause the images to be displayed on startup? # org-display-inline-images: t # Local Variables: # mode: Org # eval

[Orgmode] Question about local variables block

2010-09-15 Thread Robert Goldman
I've been putting local variables blocks at the bottom of some of my org-mode files (in particular, those files that I share with others). The problem is that having a local variables block at the bottom of the file, at least if it uses # as a virtual comment character, doesn't dovetail nicely

Re: [Orgmode] Question about local variables block

2010-09-15 Thread Robert Goldman
On 9/15/10 Sep 15 -12:06 PM, Sebastian Rose wrote: Robert Goldman rpgold...@sift.info writes: I've been putting local variables blocks at the bottom of some of my org-mode files (in particular, those files that I share with others). The problem is that having a local variables block

  1   2   3   >