Re: [O] CDlatex

2015-12-19 Thread marvin doyley
Hi Nick, You are correct it is still there, but I can’t start cdlatex-mode via the org-mode-hook (i.e., include add-hook 'org-mode-hook 'turn-on-org-cdlatex in my .emacs file). It only works when it type M-x cdlatex-mode in the buffer. Maybe it is clashing with something. Best wishes, M

[O] CDlatex

2015-12-18 Thread Doyley, Marvin M.
Hi there, I just upgrade my org-mode, and it seems that the function turn-on-org-cdlatex is no longer available, or maybe I am messing something. M ---

Re: [O] CDlatex

2015-12-18 Thread Nick Dokos
"Doyley, Marvin M." writes: > I just upgrade my org-mode, and it seems that the function > turn-on-org-cdlatex is no longer available, or maybe I am messing > something. It's still there in org.el, line 18812 or thereabouts. -- Nick

[O] cdlatex and indentation

2014-07-10 Thread Federico Beffa
Hi, when I insert a LaTeX environment with the cdlatex keybinding C-{, the environment is not properly indented as the rest of the text and the TAB key is bound to the cdlatex functions. Is there a way to get it properly aligned directly, without having to select the region and press TAB? I

[O] Cdlatex and ELPA

2013-12-09 Thread Rasmus
Hi, Since I use multiple computers I'd like to cdlatex in GNU ELPA. An outdated version is currently on Marmelade, but I think that version doesn't work with current Org (v4.0 vs. v4.6). Also, cdlatex deserves to be in GNU ELPA IMO. There's this snip in cdlatex.el: ;; CDLaTeX requires

Re: [O] Cdlatex and ELPA

2013-12-09 Thread Rasmus
Rasmus ras...@gmx.us writes: Perhaps AUCTeX is a too heavy dependency which might 'talk' in favor of distributing textmathp.el separately. However, I'm not sure if package.el supports some kind of either (i) an or statement in 'Package-Requires' or (ii) a 'Package-Provides' for people who

Re: [O] Cdlatex and ELPA

2013-12-09 Thread Achim Gratz
Rasmus writes: Since I use multiple computers I'd like to cdlatex in GNU ELPA. An outdated version is currently on Marmelade, but I think that version doesn't work with current Org (v4.0 vs. v4.6). Also, cdlatex deserves to be in GNU ELPA IMO. Don't you think that emacs-devel would be a

Re: [O] CDLaTeX in Org document

2013-10-27 Thread Carsten Dominik
On 26.10.2013, at 08:47, Vladimir Lomov lomov...@gmail.com wrote: Hello, I'm using CDLaTeX with Org documents and with LaTeX ones (AUCTeX major mode). I configured cdlatex to insert closing brackets and dollar ( '$({[' ) and this works fine in AUCTeX major mode. Is it possible to use

[O] CDLaTeX in Org document

2013-10-26 Thread Vladimir Lomov
Hello, I'm using CDLaTeX with Org documents and with LaTeX ones (AUCTeX major mode). I configured cdlatex to insert closing brackets and dollar ( '$({[' ) and this works fine in AUCTeX major mode. Is it possible to use similar feature in combination Org+cdlatex? I tested with following settings

Re: [O] CDLaTeX (4.0) not working in Org mode (8.0.3)?

2013-08-31 Thread Carsten Dominik
On 20.5.2013, at 10:59, Omid omidl...@gmail.com wrote: Thanks. I confirm that this in fact solves the problem. This is also fixed in CDLaTeX 4.6 at http://staff.science.uva.nl/~dominik/Tools/cdlatex - Carsten On Mon, May 20, 2013 at 3:57 AM, Longmin WANG longminw...@gmail.com wrote:

Re: [O] CDLaTeX (4.0) not working in Org mode (8.0.3)?

2013-05-20 Thread Longmin WANG
On Mon, May 20, 2013 at 11:14 AM, Omid omidl...@gmail.com wrote: I see the following strange behavior from Org-CDLaTeX (OCDL). Outside a * heading it works. Inside a * heading (or anything under that) it does NOT work. What can be causing this? Here is a minimal example: # Org CDLaTeX

Re: [O] CDLaTeX (4.0) not working in Org mode (8.0.3)?

2013-05-20 Thread Omid
Thanks. I confirm that this in fact solves the problem. On Mon, May 20, 2013 at 3:57 AM, Longmin WANG longminw...@gmail.com wrote: On Mon, May 20, 2013 at 11:14 AM, Omid omidl...@gmail.com wrote: I see the following strange behavior from Org-CDLaTeX (OCDL). Outside a * heading it works.

[O] CDLaTeX (4.0) not working in Org mode (8.0.3)?

2013-05-19 Thread Omid
I see the following strange behavior from Org-CDLaTeX (OCDL). Outside a * heading it works. Inside a * heading (or anything under that) it does NOT work. What can be causing this? Here is a minimal example: # Org CDLaTeX (OCDL) works here (at least does not issue an error) \[ x^2 \] * heading

Re: [O] Cdlatex questions

2011-10-19 Thread Carsten Dominik
On 17.10.2011, at 21:55, Rasmus wrote: Hi, I would like to add to cdlatex. However, it does not seem to work. This is probably the best place to ask. First, I want to add \mathbb{·} to cdlatex-math-modify-alist. Second, I want to change \mathbf{·} to \boldsymbol{·}, which is nicer

Re: [O] Cdlatex questions

2011-10-19 Thread Rasmus Pank Roulund
Carsten Dominik carsten.domi...@gmail.com writes: Hi Rasmus, you need to set these variables before cdlatex.el has been loaded, or you need run (cdlatex-reset-mode) after you have changed them. THis is not documented well, unfortunately. Thanks Carsten. For the reference I use the

[O] Cdlatex questions

2011-10-17 Thread Rasmus
Hi, I would like to add to cdlatex. However, it does not seem to work. This is probably the best place to ask. First, I want to add \mathbb{·} to cdlatex-math-modify-alist. Second, I want to change \mathbf{·} to \boldsymbol{·}, which is nicer and works with greek letters. I have tried to