Re: [O] org-open-at-point fails on internal links

2017-10-10 Thread Scott Otterson
This morning, I updated my packages (Options -> Manage Emacs Packages -> U ->X) and now, internal links work perfectly. For the record, the updated packages were: dash-20171009.105 flycheck-20171009-1145 helm-20171009.221 kaolin-theme-20171009.1130 org-20171009 org-plus-contrib-20171009

Re: [O] org-open-at-point fails on internal links

2017-10-09 Thread Scott Otterson
> Scott Otterson writes: > >> When I click on an internal link to an anchor, I get the error message: >> >> "Wrong type argument: number-or-marker-p" The problem has something do do with org-mouse.el -- if I go to Emacs customize "Org Modules" and uncheck: "mouse:

Re: [O] org-open-at-point fails on internal links

2017-10-07 Thread Nicolas Goaziou
Hello, Kyle Meyer writes: > Hello, > > Scott Otterson writes: > >> When I click on an internal link to an anchor, I get the error message: >> >> "Wrong type argument: number-or-marker-p" >> >> The same happens if I type C-c C-o on the link. This is

Re: [O] org-open-at-point fails on internal links

2017-10-07 Thread Kyle Meyer
Hello, Scott Otterson writes: > When I click on an internal link to an anchor, I get the error message: > > "Wrong type argument: number-or-marker-p" > > The same happens if I type C-c C-o on the link. This is mapped > to org-open-at-point, which should handle internal

[O] org-open-at-point fails on internal links

2017-10-07 Thread Scott Otterson
When I click on an internal link to an anchor, I get the error message: "Wrong type argument: number-or-marker-p" The same happens if I type C-c C-o on the link. This is mapped to org-open-at-point, which should handle internal links. However, if I type C-c o on the link, then the cursor goes