[O] Strings converted to numbers in Org table?

2017-02-23 Thread Vicente Vera
Hello. I'm trying to get an Org table from an R data frame but data is lost in the process. Here is a MWE. Note that: - In R every value is a string. "var2" contains no numbers (is a character vector). - Upon conversion to a table Org removes the zero from "var2" last value.

Re: [O] Logbook not working?

2017-02-23 Thread Lawrence Bottorff
Aaaag! I have every confidence that someday I'll stop making a fool of myself to you good people. . . . On Thu, Feb 23, 2017 at 2:55 PM, Nicolas Goaziou wrote: > Hello, > > Lawrence Bottorff writes: > > > I set `debug-on-error` to `t` and went through

Re: [O] Problem with noweb-ref property [9.0.5 (9.0.5-elpaplus @ /home/rainer/.emacs.d/elpa/org-plus-contrib-20170210/)]

2017-02-23 Thread Nicolas Goaziou
Rainer Hansen writes: > However, I have still problems. I have adapted the example, > http://orgmode.org/manual/noweb_002dref.html#noweb_002dref, I fixed it. > in the > Orgmode handbook to the changed Babel header properties. However, the > generated file contained only

Re: [O] Logbook not working?

2017-02-23 Thread Lawrence Bottorff
I set `debug-on-error` to `t` and went through creating a log entry: Debugger entered--Lisp error: (error "Before first headline at position 1151 in buffer test3.org") signal(error ("Before first headline at position 1151 in buffer test3.org ")) error("Before first headline at position %d in

Re: [O] Logbook not working?

2017-02-23 Thread Nicolas Goaziou
Hello, Lawrence Bottorff writes: > I set `debug-on-error` to `t` and went through creating a log entry: > > Debugger entered--Lisp error: (error "Before first headline at position > 1151 in buffer test3.org") > signal(error ("Before first headline at position 1151 in buffer

Re: [O] avoiding "First item of list cannot move without its subtree"

2017-02-23 Thread Nicolas Goaziou
Hello, "Max Rydahl Andersen" writes: > Here is a screencast of me trying before and after evaluating buffer > with the function in it. > > https://v.usetapes.com/COVDzfByN0 Odd. I definitely see TRT in my case. What is the value of `org-shiftmetaleft-hook' ? Could you

Re: [O] avoiding "First item of list cannot move without its subtree"

2017-02-23 Thread Nicolas Goaziou
Hello, "Max Rydahl Andersen" writes: > Fixed the typo - but still nothing happens :/ "Nothing happens" is a bit vague. M-S-Left should demote an item. When it reaches top-level, it should be turned into a headline. What happens instead? Regards, -- Nicolas Goaziou

Re: [O] [PATCH 1/1] org.el: Make faces org-quote and org-verse be appended

2017-02-23 Thread Nicolas Goaziou
Hello, Anders Johansson writes: > This means fontification of emphasis, links etc. is kept in quote and > verse blocks even with org-fontify-quote-and-verse-blocks non-nil. Applied. Thank you. Regards, -- Nicolas Goaziou

Re: [O] org.texi edits, patch attached

2017-02-23 Thread Nicolas Goaziou
Nicolas Goaziou writes: > Lambda Coder writes: > >> See attached patch for Exporting chapter against maint. > > Thank you. > > Unfortunately, I cannot apply it. Could you send create it with > format-patch against maint's tip, without gzipping it?

Re: [O] inheritance of mutually exclusive tags

2017-02-23 Thread Nicolas Goaziou
Hello, yanmcbe writes: > Org-mode allows marking a set of tags as mutually exclusive. It also allows > the inheritance of tags. > > (from now on I am talking only about these mutually exclusive tags) > > When a tag is set in a parent, but also in a child, what I expect to

Re: [O] Bug: Agenda clockcheck: org-duration-to-minutes: Wrong type argument: stringp [9.0.5 (release_9.0.5-318-gb1353c @ /tmp/emacs/org-mode/lisp\ /)]

2017-02-23 Thread Nicolas Goaziou
Hello, Dale writes: > Hi! I think org-mode from master currently has a bug in agenda's > clockcheck mode. Steps to reproduce: > > 1. Start emacs -Q and load org-mode master (b1353cb6f83) > > 2. Open a empty org-mode buffer, e.g.: C-x C-f test.org RET > > 3. M-x org-agenda RET

[O] Problem with noweb-ref property [9.0.5 (9.0.5-elpaplus @ /home/rainer/.emacs.d/elpa/org-plus-contrib-20170210/)]

2017-02-23 Thread Rainer Hansen
Hi, I have tried the following example of using noweb-ref: --8<---cut here---start->8--- #+BEGIN_SRC sh :tangle yes :noweb yes :shebang #!/bin/sh <> #+END_SRC * the mount point of the fullest disk ** query all mounted disks #+HEADER: :noweb-ref fullest-disk

Re: [O] Problem with noweb-ref property [9.0.5 (9.0.5-elpaplus @ /home/rainer/.emacs.d/elpa/org-plus-contrib-20170210/)]

2017-02-23 Thread Nicolas Goaziou
Hello, Rainer Hansen writes: > I have tried the following example of using noweb-ref: > > #+BEGIN_SRC sh :tangle yes :noweb yes :shebang #!/bin/sh > <> > #+END_SRC > > * the mount point of the fullest disk > > ** query all mounted disks > > #+HEADER: :noweb-ref

Re: [O] avoiding "First item of list cannot move without its subtree"

2017-02-23 Thread Max Rydahl Andersen
On 23 Feb 2017, at 12:41, Nicolas Goaziou wrote: Hello, "Max Rydahl Andersen" writes: Fixed the typo - but still nothing happens :/ "Nothing happens" is a bit vague. M-S-Left should demote an item. When it reaches top-level, it should be turned into a headline. What

Re: [O] Problem with noweb-ref property [9.0.5 (9.0.5-elpaplus @ /home/rainer/.emacs.d/elpa/org-plus-contrib-20170210/)]

2017-02-23 Thread Rainer Hansen
Hi Nicolas, Nicolas Goaziou writes: > Hello, > > Rainer Hansen writes: > >> I have tried the following example of using noweb-ref: >> >> #+BEGIN_SRC sh :tangle yes :noweb yes :shebang #!/bin/sh >> <> >> #+END_SRC >> >> * the mount point of the

[O] Logbook not working?

2017-02-23 Thread Lawrence Bottorff
I'm trying to create Logbook entries with C-c C-z -- which has worked fine in the past. But now whenever I try I get org-back-to-heading: Before first headline at position 1151 in buffer current.org . . . i.e., my entry doesn't show up anywhere. What have I inadvertently messed up? LB

Re: [O] Logbook not working?

2017-02-23 Thread Nicolas Goaziou
Hello, Lawrence Bottorff writes: > I'm trying to create Logbook entries with C-c C-z -- which has worked fine > in the past. But now whenever I try I get > > org-back-to-heading: Before first headline at position 1151 in buffer > current.org > > . . . i.e., my entry doesn't