Re: [Emc-users] LCNC won't run VFD

2019-04-13 Thread Gene Heskett
On Saturday 13 April 2019 04:31:26 Lester Caine wrote: > On 13/04/2019 01:51, Gene Heskett wrote: > > Ideas folks? I seem to be fresh out. The other VFD I put on the > > Sheldon worked OOTB once the registers were set for external > > control. > > Gene ... I use the ACS150 inverter with a 3

Re: [Emc-users] Hardware emcmot?

2019-04-13 Thread Nicklas SB Karlsson
> But any OS needs to disable interrupts to access shared memmory or maybe > for some IO drivers. I use to get by without disabling interrupts. Then exchanging data most usually the methodI use is to write data in shared memory and use a variable written to zero or one to indicate new data is

[Emc-users] buildbot for pi is on the fritz, yet

2019-04-13 Thread Gene Heskett
Any chance of applying the jump-start paddles it it again? Cheers, Gene Heskett -- "There are four boxes to be used in defense of liberty: soap, ballot, jury, and ammo. Please use in that order." -Ed Howdershelt (Author) Genes Web page

Re: [Emc-users] Hardware emcmot? Real time delay

2019-04-13 Thread Danny Miller
On 4/13/2019 3:46 PM, Nicklas SB Karlsson wrote: Even th D-525-MW motherboard? I can latency-test for an hour or 2 on this machine I'm building up right now, and not show any worse than 5.1 microseconds for base thread latency, and If I run without that thread, which I don't use anyway, and

Re: [Emc-users] Hardware emcmot? Real time delay

2019-04-13 Thread Chris Albertson
> > On an STM32 it will probably be less than 4850ns on the highest priority > interrupt. Others however depends on threads with higher priority. Ideally > all threads should be known and have an upper bound on execution time then > it might under correct conditions be possible to calculate

Re: [Emc-users] Hardware emcmot? Real time delay

2019-04-13 Thread Nicklas SB Karlsson
> Even th D-525-MW motherboard? I can latency-test for an hour or 2 on this > machine I'm building up right now, and not show any worse than 5.1 > microseconds for base thread latency, and If I run without that thread, > which I don't use anyway, and the worst case latency is 4850ns. Thats >

Re: [Emc-users] Hardware emcmot? Real time delay

2019-04-13 Thread bari
Please don't paint yourself into a corner like GRBL and the *duino crowd with not being able to support closed loop for servos, rigid tapping, 4+ axis, >30fps HD GUI's, etc etc. On 4/13/19 5:04 PM, Danny Miller wrote: > > On 4/13/2019 3:46 PM, Nicklas SB Karlsson wrote: >>> Even th D-525-MW

Re: [Emc-users] LCNC won't run VFD

2019-04-13 Thread Gene Heskett
On Saturday 13 April 2019 08:38:53 Gene Heskett wrote: [...] I've done some more checking by putting it into a config where LCNC can at least start it, and I've apparently verified it needs a full time signal to run as it stops if I disconnect the FWD wire. It doesn't run for both FWD and

Re: [Emc-users] LCNC won't run VFD

2019-04-13 Thread Gene Heskett
On Saturday 13 April 2019 10:31:30 Lester Caine wrote: > On 13/04/2019 13:38, Gene Heskett wrote: > > That is an obviously more complex and probably more costly drive > > than this one is as this one was $118 handed to me by the mailman. > > Hookup is considerably different too. > > It's not too

Re: [Emc-users] Encoder down

2019-04-13 Thread a k
Finally https://www.youtube.com/watch?v=gwYzcD33VXk https://www.youtube.com/watch?v=e1Edx5CPNYE https://www.youtube.com/watch?v=EJwBP4ajHqU hi this is some video after i made my motor work again this video can help to everyone to see how to fix ac servomotor thanks aram On Mon, Mar 4, 2019 at

Re: [Emc-users] LCNC won't run VFD

2019-04-13 Thread Lester Caine
On 13/04/2019 13:38, Gene Heskett wrote: That is an obviously more complex and probably more costly drive than this one is as this one was $118 handed to me by the mailman. Hookup is considerably different too. It's not too bad a price ... £110 ... $140 at current exchange rate, but the price

Re: [Emc-users] LCNC won't run VFD

2019-04-13 Thread Lester Caine
On 13/04/2019 01:51, Gene Heskett wrote: Ideas folks? I seem to be fresh out. The other VFD I put on the Sheldon worked OOTB once the registers were set for external control. Gene ... I use the ACS150 inverter with a 3 phase motor on the Taig conversions. This is nice because it has the