This is an automated email from the git hooks/post-receive script.

stefan pushed a change to annotated tag v1.23.0
in repository core/efl.

        at  cb7b23c978 (tag)
   tagging  cd9ef487fec80e7af47e98a8f766c63d869b14df (commit)
  replaces  v1.23.0-beta3
 tagged by  Stefan Schmidt
        on  Tue Oct 1 12:36:19 2019 +0200

- Log -----------------------------------------------------------------
v1.23.0

Bruno da Silva Belo (6):
      eolian_cxx: Possible infinite loop, if called.
      efl_ui_suite: Some pointers were being delete.
      Updating README for clang requirements.
      mono-docs:  adding and updating docs for eina_array.
      mono_docs:adding and updating eina_binbuf.cs.
      csharp: add since 1.23 to eina_accessor.

Carsten Haitzler (1):
      evas - gl_drm - handle modifiers for drm formats

Cedric BAIL (18):
      elementary: add support for default property on item being created by 
Efl.Ui.Widget_Factory.
      elementary: return an error when unimplemented function on 
Efl.Ui.Widget_Factory.
      elementary: properly mark iterator usage in Efl.Ui.Factory.
      efl: improve error message to be really useful.
      elementary: stabilize Efl.Ui.Widget_Factory.
      efl: stabilize Efl.Ui.Factory.
      efl: stabilize Efl.Ui.Property_Bind
      efl: stabilize Efl.Ui.Factory_Bind
      efl: stabilize Efl.Model
      elementary: stabilize Efl.Ui.View_Model
      ecore: stabilize Efl.Composite_Model.
      ecore: stabilize Efl.Loop_Model
      elementary: stabilize Efl.Ui.Collection_View.
      elementary: rename Efl.Ui.Collection_Event to Efl.Ui.Item_Clickable
      elementary: temporary workaround include issue that prevent acces to 
Evas_Eo.h
      elementary: forward Efl.Input.Clickable event to Efl.Ui.Collection* event.
      elementary: stabilize Efl.Ui.Item_Clickable.
      evas: fix memory leak with Efl.Canvas.Vg

Daniel Kolesa (11):
      eolian: expose most API as stable
      eolian: stricter checks for const() validity
      eolian: move EOLIAN_TYPE_BUILTIN_HASH into beta section
      eolian: rename event_prefix to event_c_prefix for consistency
      eolian: loosen the requirements on API (don't return stringshare)
      eolian: rename param direction enum and fields for consistency
      efl_mono: remove spurious const
      eolian: better error message for const on strings
      eolian: fix potential ABI violation in expr serialization
      eolian: disallow missing docs for stable API where necessary
      efl: add code to enforce presence of @since tags

Davide Andreoli (2):
      Pyolian: reformat code to make pycharm happy
      Pyolian: implemented eolian Error object

Felipe Magno de Almeida (1):
      csharp: Load library in permanent way for static members and not rely on 
leaks

Hermet Park (1):
      evas map: diable high quality texture mapping feature.

Jaehyun Cho (5):
      theme: remove efl.track.slider and efl.track2.slider from efl_ui_slider
      theme: replace hbar and vbar to horizontal_bar and vertical_bar
      eolian_mono: support beta for enum if mono-beta is enabled
      theme: port to efl.ui.clickable and use macro for anchor style
      theme: remove duplicated version 119

Lauro Moura (8):
      elm: Avoid maybe unitialized variable accesses
      bindings: Fix disposal of eolian state
      eolian-cxx: Release iterators
      csharp: Add since to Eina.Promise
      csharp: Document Eina.Log
      csharp: Allow improved cbs in eina comparators
      csharp: Document Eina.List
      csharp: Add missing since docs to a bunch of classes.

Marcel Hollerbach (10):
      elm: add basics test to create a destroy *every* widget with errors
      Revert "elm: add basics test to create a destroy *every* widget with 
errors"
      efl_ui_*selectable: unify these APIs with the same c_prefix
      efl: mark selectable stable
      elm_*: make scrolling correct again
      test_code: do not create a background by hand
      elm_code_widget: initialize these vars correctly
      elm_code_widget: when the position is updated, set new geom to cursor
      efl_canvas_animation_player: improve docs
      docs: do not crash gengrid widget preview

Mike Blumenkrantz (58):
      efl/arrangement: mark content_padding beta
      api: mark Efl.Ui.Box_Stack stable
      api: mark Efl.Ui.Spin_Button stable
      api: mark Efl.Ui.Scrollable stable
      efl_ui/layout: improve docs
      efl_ui/layout: add explicit error case when theme version > efl version
      efl_ui/image: fix playback_speed timer calcs
      theme: /efl,orient,(horizontal|vertical)/efl,state,(horizontal|vertical)/
      api: move eo-based radio and check widgets to use selectable signal names
      efl_ui/layout: add mechanism for deferring versioned theme signals
      theme: efl,state,(content|text),(set|unset) -> 
efl,(content|text),(set|unset)
      theme: use 'visible' style signals for spin_button button/entry visibility
      theme: use more explicit signal names for C -> theme scrollbar signals
      theme: efl,action,clicked -> efl,action,click
      theme: use more explicit signal names for C <- theme scrollbar signals
      theme: remove unused scroller group
      api: efl,state,busy,(start|stop) -> efl,state,busy,(started|stopped)
      theme: efl,state,anim,stop -> efl,state,animating,stopped
      theme: migrate all efl,anim,activate (and similar) signals to 
efl,state,animation,activated
      api: mark efl.gfx.image and related types stable
      api: mark Efl.Gfx.Image_Load_Controller stable
      api: mark Efl.Ui.Image_Zoomable stable
      efl_ui/item_clickable: fix event info for press events
      ecore-x: fix null derefs in window prop code
      ecore-evas/x: detect and track wm existence, apply visibility correctly
      ecore-x: track whether ecore-x is internally "managing" the root window
      ecore-x: add internal function for selecting just properties of root 
window
      ecore-x: protect against accidentally "un-managing" the root window
      efl_ui/layout: use better check for determining whether to defer signals
      efl_ui/layout: fix shadow warning
      efl_ui/layout: improve error message when theme version parsing fails
      tests/check: add port of check widget mouse testing for efl_ui_check
      theme: remove efl_ui_slider "disabled" styles
      theme: add spec documentation for all stabilized theme groups in 1.23
      efl_ui/item_clickable: mark beta again
      epp: remove extra variable passed in format specifier
      tests/strbuf: call va_end for varargs
      eina/list: move dead code inside corresponding #ifdef
      tests/eina: outdent code
      ecore_evas/convert: fix div by zero
      efl_ui/table: handle case where table has no items
      efl_ui/scroll_manager: fix null derefs
      efl_ui/image fix null derefs
      eio/dir: fix null deref
      evas/object; fix null deref
      elm_test: undef logging macros before redefining them in header
      efl/canvas: add Efl_Canvas.h
      edje: rename edje_types.eot to efl_canvas_types.eot and move include
      edje: add Efl_Layout.h for eo-based layout headers
      elm_test/radio: use eo type here
      efl_ui: explicitly include eo headers for a couple types
      tests/spec: use eo types here since this isn't supposed to use legacy
      tests/spin_button: include Elementary.h since this uses legacy api
      benchmark/collection: add Elementary.h
      efl_ui: remove efl_ui_text headers from Efl_Ui.h for now
      efl_ui: remove legacy component includes, include Efl_Layout.h and 
Efl_Canvas.h
      Revert "eo beta - mark task, io classes as beta because they are..."
      tests/position_manager: initialize variable in declaration

SangHyeon Jade Lee (4):
      efl_ui : change selected_items_get to selected_iterator_new.
      efl_ui : add document comment on efl_ui_item_clickable event data
      efl_ui : stablized Efl.Ui.View
      efl_core : stabilized Efl.Generic_Model

Shinwoo Kim (2):
      evas_callbacks: check if obj is NULL before using it
      evas filter: Implement grayscale filter in pure GL

Stefan Schmidt (1):
      release: Update NEWS and bump version for 1.23.0 release

WooHyun Jung (4):
      efl_ui_spin_button: mark "direct_text_input" property @beta
      efl_ui_win: add validation check to return legacy default value
      edje_legacy: add validation check to return legacy default value
      efl_ui_image: fix a wrong return value of legacy API

Xavi Artigas (5):
      docs: formatting nitpick in Efl.Player.eo
      themes: Rename "dragable" to "draggable"
      mono-docs: Add some missing docs for workaround.cs
      mono-docs: Formatting of @since tags
      Revert "eolian: disallow missing docs for stable API where necessary"

Yeongjong Lee (2):
      efl_ui_layout: fix null pointer dereferences
      eolian_mono: Respect beta for enum

-----------------------------------------------------------------------

No new revisions were added by this update.

-- 


Reply via email to