Re: [e-users] Problem with kodi multimedia player

2019-03-23 Thread The Rasterman
On Wed, 20 Mar 2019 17:50:20 -0700 Eric  said:

> 
> 
> On 2/9/19 10:00 PM, eric wrote:
> > On 2/8/19 1:53 AM, Carsten Haitzler (The Rasterman) wrote:
> >> On Tue, 5 Feb 2019 08:28:20 -0800 Eric  said:
> >>
> >>>
> >>>
> >>> On 2/5/19 8:04 AM, Mick wrote:
>  On Tuesday, 5 February 2019 13:12:38 GMT Eric wrote:
> > Hello,
> >
> > I have had a problem with kodi on the enlightenment desktop for quite
> > some time and have had no luck trying to resolve it.
> >
> > The problem is that kodi only shows a black window when it is in
> > windowed mode.  It works fine in full screen mode. It has been like 
> > this
> > since about the time xbmc became kodi.
> >
> > This occurs with Ubuntu, Arch and openSuse with Intel and Nvidia video
> > cards.
> >
> > Has anyone used kodi on their enlightenment desktop in windowed mode
> > with success?
> >
> > I have not had any luck searching for solutions on the internet.
> >
> > I like to use kodi in windowed mode so I can keep an eye on other 
> > things
> > going on such as temperature when using it as a media player without
> > having to close the app or switch to a different terminal.
> >
> > Regards,
> >
> > Eric
> 
>  I've had a similar experience with various apps using hardware 
>  acceleration,
>  so I blamed Radeon for it.
> 
>  The workaround for me has been to press Ctrl+Alt+End which restarts the
>  compositor and the app window is rendered properly thereafter.
> 
>  HTH in your case.
> 
> >>>
> >>> Thank you for responding but unfortunately no luck with the 
> >>> Ctrl+Alt+End.
> >>>
> >>> I have seen that there are similar problems when using the Cinnamon
> >>> desktop that has something to do with the rendering of kodi.
> >>>
> >>> I was hoping someone had it working from the list and could tell me
> >>> their secret.  :-)
> >>
> >> http://www.enlightenment.org/ss/e-5c5d426e1f3f71.90449760.jpg
> >>
> >> :)
> >>
> >> out of the box (amdgpu driver). FYI I also have it working on an intel 
> >> gfx
> >> system too - no issues there. have had that one going for maybe 1.5 
> >> years? i
> >> have in the past had it work on nvidia drivers too. sorry that it's a 
> >> tale of
> >> "it just works" with no help there, but suffice to say it can and does 
> >> work for
> >> people, so maybe there is something more specific you are doing that 
> >> others are
> >> not that causes this?
> > 
> > Thank you for the information.  You and Daniel both give me hope that it 
> > can be done as it is being done.  It is more than likely something that 
> > I am doing or failing to do.
> > 
> > Ubuntu is the only distro I build enlightenment from source anymore and 
> > my Arch boxes are pretty sparse with what I install so I may be missing 
> > something.  Also these are all laptops with intel i5 or i7 with either 
> > intel or nvidia video which I should have mentioned in the beginning.
> > 
> 
> I just wanted to report that kodi 18.1 is working now in windowed mode 
> on my updated arch computer with enlightenment 22.4 and efl 1.21.1-2 
> after updating this week.  I don't know what was causing the problem but 
> it works now.  Hooray.

yay! :)

-- 
- Codito, ergo sum - "I code, therefore I am" --
Carsten Haitzler - ras...@rasterman.com



___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] Problem with kodi multimedia player

2019-03-20 Thread Eric



On 2/9/19 10:00 PM, eric wrote:

On 2/8/19 1:53 AM, Carsten Haitzler (The Rasterman) wrote:

On Tue, 5 Feb 2019 08:28:20 -0800 Eric  said:




On 2/5/19 8:04 AM, Mick wrote:

On Tuesday, 5 February 2019 13:12:38 GMT Eric wrote:

Hello,

I have had a problem with kodi on the enlightenment desktop for quite
some time and have had no luck trying to resolve it.

The problem is that kodi only shows a black window when it is in
windowed mode.  It works fine in full screen mode. It has been like 
this

since about the time xbmc became kodi.

This occurs with Ubuntu, Arch and openSuse with Intel and Nvidia video
cards.

Has anyone used kodi on their enlightenment desktop in windowed mode
with success?

I have not had any luck searching for solutions on the internet.

I like to use kodi in windowed mode so I can keep an eye on other 
things

going on such as temperature when using it as a media player without
having to close the app or switch to a different terminal.

Regards,

Eric


I've had a similar experience with various apps using hardware 
acceleration,

so I blamed Radeon for it.

The workaround for me has been to press Ctrl+Alt+End which restarts the
compositor and the app window is rendered properly thereafter.

HTH in your case.



Thank you for responding but unfortunately no luck with the 
Ctrl+Alt+End.


I have seen that there are similar problems when using the Cinnamon
desktop that has something to do with the rendering of kodi.

I was hoping someone had it working from the list and could tell me
their secret.  :-)


http://www.enlightenment.org/ss/e-5c5d426e1f3f71.90449760.jpg

:)

out of the box (amdgpu driver). FYI I also have it working on an intel 
gfx
system too - no issues there. have had that one going for maybe 1.5 
years? i
have in the past had it work on nvidia drivers too. sorry that it's a 
tale of
"it just works" with no help there, but suffice to say it can and does 
work for
people, so maybe there is something more specific you are doing that 
others are

not that causes this?


Thank you for the information.  You and Daniel both give me hope that it 
can be done as it is being done.  It is more than likely something that 
I am doing or failing to do.


Ubuntu is the only distro I build enlightenment from source anymore and 
my Arch boxes are pretty sparse with what I install so I may be missing 
something.  Also these are all laptops with intel i5 or i7 with either 
intel or nvidia video which I should have mentioned in the beginning.




I just wanted to report that kodi 18.1 is working now in windowed mode 
on my updated arch computer with enlightenment 22.4 and efl 1.21.1-2 
after updating this week.  I don't know what was causing the problem but 
it works now.  Hooray.


Regards,

Eric


___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] Problem with kodi multimedia player

2019-02-09 Thread eric

On 2/8/19 1:53 AM, Carsten Haitzler (The Rasterman) wrote:

On Tue, 5 Feb 2019 08:28:20 -0800 Eric  said:




On 2/5/19 8:04 AM, Mick wrote:

On Tuesday, 5 February 2019 13:12:38 GMT Eric wrote:

Hello,

I have had a problem with kodi on the enlightenment desktop for quite
some time and have had no luck trying to resolve it.

The problem is that kodi only shows a black window when it is in
windowed mode.  It works fine in full screen mode. It has been like this
since about the time xbmc became kodi.

This occurs with Ubuntu, Arch and openSuse with Intel and Nvidia video
cards.

Has anyone used kodi on their enlightenment desktop in windowed mode
with success?

I have not had any luck searching for solutions on the internet.

I like to use kodi in windowed mode so I can keep an eye on other things
going on such as temperature when using it as a media player without
having to close the app or switch to a different terminal.

Regards,

Eric


I've had a similar experience with various apps using hardware acceleration,
so I blamed Radeon for it.

The workaround for me has been to press Ctrl+Alt+End which restarts the
compositor and the app window is rendered properly thereafter.

HTH in your case.



Thank you for responding but unfortunately no luck with the Ctrl+Alt+End.

I have seen that there are similar problems when using the Cinnamon
desktop that has something to do with the rendering of kodi.

I was hoping someone had it working from the list and could tell me
their secret.  :-)


http://www.enlightenment.org/ss/e-5c5d426e1f3f71.90449760.jpg

:)

out of the box (amdgpu driver). FYI I also have it working on an intel gfx
system too - no issues there. have had that one going for maybe 1.5 years? i
have in the past had it work on nvidia drivers too. sorry that it's a tale of
"it just works" with no help there, but suffice to say it can and does work for
people, so maybe there is something more specific you are doing that others are
not that causes this?


Thank you for the information.  You and Daniel both give me hope that it 
can be done as it is being done.  It is more than likely something that 
I am doing or failing to do.


Ubuntu is the only distro I build enlightenment from source anymore and 
my Arch boxes are pretty sparse with what I install so I may be missing 
something.  Also these are all laptops with intel i5 or i7 with either 
intel or nvidia video which I should have mentioned in the beginning.


Regards,

Eric


___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] Problem with kodi multimedia player

2019-02-08 Thread The Rasterman
On Tue, 5 Feb 2019 08:28:20 -0800 Eric  said:

> 
> 
> On 2/5/19 8:04 AM, Mick wrote:
> > On Tuesday, 5 February 2019 13:12:38 GMT Eric wrote:
> >> Hello,
> >>
> >> I have had a problem with kodi on the enlightenment desktop for quite
> >> some time and have had no luck trying to resolve it.
> >>
> >> The problem is that kodi only shows a black window when it is in
> >> windowed mode.  It works fine in full screen mode. It has been like this
> >> since about the time xbmc became kodi.
> >>
> >> This occurs with Ubuntu, Arch and openSuse with Intel and Nvidia video
> >> cards.
> >>
> >> Has anyone used kodi on their enlightenment desktop in windowed mode
> >> with success?
> >>
> >> I have not had any luck searching for solutions on the internet.
> >>
> >> I like to use kodi in windowed mode so I can keep an eye on other things
> >> going on such as temperature when using it as a media player without
> >> having to close the app or switch to a different terminal.
> >>
> >> Regards,
> >>
> >> Eric
> > 
> > I've had a similar experience with various apps using hardware acceleration,
> > so I blamed Radeon for it.
> > 
> > The workaround for me has been to press Ctrl+Alt+End which restarts the
> > compositor and the app window is rendered properly thereafter.
> > 
> > HTH in your case.
> > 
> 
> Thank you for responding but unfortunately no luck with the Ctrl+Alt+End.
> 
> I have seen that there are similar problems when using the Cinnamon 
> desktop that has something to do with the rendering of kodi.
> 
> I was hoping someone had it working from the list and could tell me 
> their secret.  :-)

http://www.enlightenment.org/ss/e-5c5d426e1f3f71.90449760.jpg

:)

out of the box (amdgpu driver). FYI I also have it working on an intel gfx
system too - no issues there. have had that one going for maybe 1.5 years? i
have in the past had it work on nvidia drivers too. sorry that it's a tale of
"it just works" with no help there, but suffice to say it can and does work for
people, so maybe there is something more specific you are doing that others are
not that causes this?

> Regards,
> 
> Eric
> 
> 
> ___
> enlightenment-users mailing list
> enlightenment-users@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/enlightenment-users
> 


-- 
- Codito, ergo sum - "I code, therefore I am" --
Carsten Haitzler - ras...@rasterman.com



___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] Problem with kodi multimedia player

2019-02-07 Thread Daniel Kasak
I've never had this kind of problem with Kodi, and I've been using both
Kodi and E for decades, mainly with Intel GPUs, but sometimes with ATI/AMD
ones, like now ( Vega 10 ). I've always built Kodi using Gentoo. Currently:

nanginator ~ # emerge -pv kodi

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R] media-tv/kodi-18.0::gentoo  USE="X alsa bluetooth css dbus
gles mysql opengl pulseaudio samba (system-ffmpeg) systemd udev xslt
zeroconf -airplay -bluray -caps -cec -debug -dvd -gbm -lcms -libressl
-libusb -lirc -mariadb -nfs -test -udisks -upnp -upower -vaapi -vdpau
-wayland -webserver" PYTHON_TARGETS="python2_7" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

nanginator ~ #

If you're able to run normally in fullscreen, but not windowed, I suspect
it might be a compositing manager thing, as they'll generally disable
compositing for fullscreen windows.

For Intel GPUs, I've always used 'bleeding edge' drivers ( ie mesa from git
) in the hope that later versions have less bugs, less lockups, etc. I also
switched to using Glamor with Intel early on, and this did actually fix
quite a few rendering issues. I think Intel drivers still default to UXA.
Don't use Intel GPUs unless you have to.

For nVidia - you're on your own there :)

Dan

On Wed, Feb 6, 2019 at 3:29 AM Eric  wrote:

>
>
> On 2/5/19 8:04 AM, Mick wrote:
> > On Tuesday, 5 February 2019 13:12:38 GMT Eric wrote:
> >> Hello,
> >>
> >> I have had a problem with kodi on the enlightenment desktop for quite
> >> some time and have had no luck trying to resolve it.
> >>
> >> The problem is that kodi only shows a black window when it is in
> >> windowed mode.  It works fine in full screen mode. It has been like this
> >> since about the time xbmc became kodi.
> >>
> >> This occurs with Ubuntu, Arch and openSuse with Intel and Nvidia video
> >> cards.
> >>
> >> Has anyone used kodi on their enlightenment desktop in windowed mode
> >> with success?
> >>
> >> I have not had any luck searching for solutions on the internet.
> >>
> >> I like to use kodi in windowed mode so I can keep an eye on other things
> >> going on such as temperature when using it as a media player without
> >> having to close the app or switch to a different terminal.
> >>
> >> Regards,
> >>
> >> Eric
> >
> > I've had a similar experience with various apps using hardware
> acceleration,
> > so I blamed Radeon for it.
> >
> > The workaround for me has been to press Ctrl+Alt+End which restarts the
> > compositor and the app window is rendered properly thereafter.
> >
> > HTH in your case.
> >
>
> Thank you for responding but unfortunately no luck with the Ctrl+Alt+End.
>
> I have seen that there are similar problems when using the Cinnamon
> desktop that has something to do with the rendering of kodi.
>
> I was hoping someone had it working from the list and could tell me
> their secret.  :-)
>
> Regards,
>
> Eric
>
>
> ___
> enlightenment-users mailing list
> enlightenment-users@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/enlightenment-users
>

___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] Problem with kodi multimedia player

2019-02-05 Thread Eric




On 2/5/19 8:04 AM, Mick wrote:

On Tuesday, 5 February 2019 13:12:38 GMT Eric wrote:

Hello,

I have had a problem with kodi on the enlightenment desktop for quite
some time and have had no luck trying to resolve it.

The problem is that kodi only shows a black window when it is in
windowed mode.  It works fine in full screen mode. It has been like this
since about the time xbmc became kodi.

This occurs with Ubuntu, Arch and openSuse with Intel and Nvidia video
cards.

Has anyone used kodi on their enlightenment desktop in windowed mode
with success?

I have not had any luck searching for solutions on the internet.

I like to use kodi in windowed mode so I can keep an eye on other things
going on such as temperature when using it as a media player without
having to close the app or switch to a different terminal.

Regards,

Eric


I've had a similar experience with various apps using hardware acceleration,
so I blamed Radeon for it.

The workaround for me has been to press Ctrl+Alt+End which restarts the
compositor and the app window is rendered properly thereafter.

HTH in your case.



Thank you for responding but unfortunately no luck with the Ctrl+Alt+End.

I have seen that there are similar problems when using the Cinnamon 
desktop that has something to do with the rendering of kodi.


I was hoping someone had it working from the list and could tell me 
their secret.  :-)


Regards,

Eric


___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] Problem with kodi multimedia player

2019-02-05 Thread Mick
On Tuesday, 5 February 2019 13:12:38 GMT Eric wrote:
> Hello,
> 
> I have had a problem with kodi on the enlightenment desktop for quite
> some time and have had no luck trying to resolve it.
> 
> The problem is that kodi only shows a black window when it is in
> windowed mode.  It works fine in full screen mode. It has been like this
> since about the time xbmc became kodi.
> 
> This occurs with Ubuntu, Arch and openSuse with Intel and Nvidia video
> cards.
> 
> Has anyone used kodi on their enlightenment desktop in windowed mode
> with success?
> 
> I have not had any luck searching for solutions on the internet.
> 
> I like to use kodi in windowed mode so I can keep an eye on other things
> going on such as temperature when using it as a media player without
> having to close the app or switch to a different terminal.
> 
> Regards,
> 
> Eric

I've had a similar experience with various apps using hardware acceleration, 
so I blamed Radeon for it.

The workaround for me has been to press Ctrl+Alt+End which restarts the 
compositor and the app window is rendered properly thereafter.

HTH in your case.
-- 
Regards,
Mick
___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users