Re: [e-users] System Tray

2018-09-15 Thread The Rasterman
On Fri, 14 Sep 2018 18:47:59 +0200 "Roy Reese"  said:

> > Enviar: sábado 8 de septiembre de 2018 a las 11:59
> > De: "Simon Lees" 
> > Para: enlightenment-users@lists.sourceforge.net
> > Asunto: Re: [e-users] System Tray
> >
> > > 
> > > 1) Does the E systray support appindicator notifications X?
> > > 
> > 
> > Yes, but you might need to enable the systray module and add the gadget
> > to your shelf.
> 
> Yes, that I have had.
> 
> > 
> > > 2) a. If so, what packages apart from application-specific indicators are
> > > needed to implement it properly?
> > > 
> > If your distro is set up correctly you shouldn't need anything it should
> > just work, last time I checked some distro's weren't carrying all the
> > patches required for at least Qt4 apps.
>  
> Thanks for the information on Qt, Simon. vlc has shown up in both mga6 and
> mga7. Qt apps are not the only ones affected, as I cannot get the Pidgin
> plugin working with the systray for some reason (will ask in the distro),
> along with a few other things. After looking around a bit just now it seems
> that things are still a mess, with some older apps having either no
> appindicator compatible solution or one designed for Ubuntu/Debian, e.g.,
> there is a PPA for parcellite with no source code.

well it's actually Ubuntu's Unity that pushed appindicator from memory... so a
solution for that would work fine I believe.

-- 
- Codito, ergo sum - "I code, therefore I am" --
Carsten Haitzler - ras...@rasterman.com



___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] System Tray

2018-09-14 Thread Roy Reese
> Enviar: sábado 8 de septiembre de 2018 a las 11:59
> De: "Simon Lees" 
> Para: enlightenment-users@lists.sourceforge.net
> Asunto: Re: [e-users] System Tray
>
> > 
> > 1) Does the E systray support appindicator notifications X?
> > 
> 
> Yes, but you might need to enable the systray module and add the gadget
> to your shelf.

Yes, that I have had.

> 
> > 2) a. If so, what packages apart from application-specific indicators are 
> > needed to implement it properly?
> > 
> If your distro is set up correctly you shouldn't need anything it should
> just work, last time I checked some distro's weren't carrying all the
> patches required for at least Qt4 apps.
 
Thanks for the information on Qt, Simon. vlc has shown up in both mga6 and 
mga7. Qt apps are not the only ones affected, as I cannot get the Pidgin plugin 
working with the systray for some reason (will ask in the distro), along with a 
few other things. After looking around a bit just now it seems that things are 
still a mess, with some older apps having either no appindicator compatible 
solution or one designed for Ubuntu/Debian, e.g., there is a PPA for parcellite 
with no source code.


___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] System Tray

2018-09-09 Thread The Rasterman
On Fri, 7 Sep 2018 18:22:56 +0200 "Roy Reese"  said:

> > Enviar: lunes 6 de agosto de 2018 a las 11:05
> > De: "yurwpjt via enlightenment-users"
> >  Para:
> > "enlightenment-users@lists.sourceforge.net"
> >  CC: yurwpjt
> >  Asunto: [e-users] System Tray
> >
> > Is there any way to use default enlightenment system tray? Or how can i use
> > stalonetray on enlightenment shelf?
> > 
> > 
> I am just catching up with mailing lists, but this is an unanswered question
> I have raised in the past given that E dropped support for Xembed back in
> E20. AFAIK there is no way to get stalonetray on a shelf. I have it running
> for a couple of applications in the upper left corner of the screen where it
> does not bother anything.
> 
> However, that solution does not solve the problem for applications which have
> shifted to appindicator notifications, such as the update notifications in my
> current distro (Mageia). So to rephrase the question for the list regarding
> the use of the E system tray in X, let me try with a two-part question:
> 
> 1) Does the E systray support appindicator notifications X?

yes. appindicator dbus protocol is supported. steam uses this and it works.

> 2) a. If so, what packages apart from application-specific indicators are
> needed to implement it properly?

it's up to toolkits/apps to support appindicator protocol. there was something
that converts some old xmbed tray usage to appindicator - maybe it was qt
something with "sni" in it... i don't know.  google for it. :)

>b. If not, what is needed to have systray notifications?
> 
> 
> ___
> enlightenment-users mailing list
> enlightenment-users@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/enlightenment-users
> 


-- 
- Codito, ergo sum - "I code, therefore I am" --
Carsten Haitzler - ras...@rasterman.com



___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] System Tray

2018-09-08 Thread Simon Lees



On 08/09/2018 01:52, Roy Reese wrote:
>> Enviar: lunes 6 de agosto de 2018 a las 11:05
>> De: "yurwpjt via enlightenment-users" 
>> 
>> Para: "enlightenment-users@lists.sourceforge.net" 
>> 
>> CC: yurwpjt 
>> Asunto: [e-users] System Tray
>>
>> Is there any way to use default enlightenment system tray? Or how can i use 
>> stalonetray on enlightenment shelf?
>>
>>
> I am just catching up with mailing lists, but this is an unanswered question 
> I have raised in the past given that E dropped support for Xembed back in 
> E20. AFAIK there is no way to get stalonetray on a shelf. I have it running 
> for a couple of applications in the upper left corner of the screen where it 
> does not bother anything.
> 
> However, that solution does not solve the problem for applications which have 
> shifted to appindicator notifications, such as the update notifications in my 
> current distro (Mageia). So to rephrase the question for the list regarding 
> the use of the E system tray in X, let me try with a two-part question:
> 
> 1) Does the E systray support appindicator notifications X?
> 

Yes, but you might need to enable the systray module and add the gadget
to your shelf.

> 2) a. If so, what packages apart from application-specific indicators are 
> needed to implement it properly?
> 
If your distro is set up correctly you shouldn't need anything it should
just work, last time I checked some distro's weren't carrying all the
patches required for atleast Qt4 apps.

-- 

Simon Lees (Simotek)http://simotek.net

Emergency Update Team   keybase.io/simotek
SUSE Linux   Adelaide Australia, UTC+10:30
GPG Fingerprint: 5B87 DB9D 88DC F606 E489 CEC5 0922 C246 02F0 014B


___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] System Tray

2018-09-07 Thread Roy Reese
> Enviar: lunes 6 de agosto de 2018 a las 11:05
> De: "yurwpjt via enlightenment-users" 
> 
> Para: "enlightenment-users@lists.sourceforge.net" 
> 
> CC: yurwpjt 
> Asunto: [e-users] System Tray
>
> Is there any way to use default enlightenment system tray? Or how can i use 
> stalonetray on enlightenment shelf?
> 
> 
I am just catching up with mailing lists, but this is an unanswered question I 
have raised in the past given that E dropped support for Xembed back in E20. 
AFAIK there is no way to get stalonetray on a shelf. I have it running for a 
couple of applications in the upper left corner of the screen where it does not 
bother anything.

However, that solution does not solve the problem for applications which have 
shifted to appindicator notifications, such as the update notifications in my 
current distro (Mageia). So to rephrase the question for the list regarding the 
use of the E system tray in X, let me try with a two-part question:

1) Does the E systray support appindicator notifications X?

2) a. If so, what packages apart from application-specific indicators are 
needed to implement it properly?

   b. If not, what is needed to have systray notifications?


___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] system tray problem

2013-12-19 Thread Stefan Schmidt
Hello.

On Thu, 2013-12-19 at 14:53, mh wrote:
 I seem to have a problem with the system tray in Enlightenment e18. I am 
 trying to use a program called Synergy, http://synergy-foss.org/, which 
 is a server/client program that lets me use one mouse and keyboard 
 across two or more computers. When you move the mouse off the current 
 (server) screen it will appear on the other (client) computer's display 
 and the mouse/keyboard work on the other computer. Move it to the side 
 on the second computer and it returns to the first. This works perfectly 
 using xfce 4.x.

And it works perfectly fine here for me with two machines and e18. I
run synergy client and server from the commandline without any UI
though. Which would explain why I'm not seeing your problem.

 When I try to start the Synergy server with E18 running I get an error 
 window that says System tray is unavailable, quitting. I enabled the 
 Systray module and Systray gadget in E18 but this has no effect and I 
 still get the same error message. Does the Systray module function 
 differently than the system tray in xfce? Is there something else I need 
 to enable in E18?

You added the gadget to a shelf? You might need to enable xmbed in the
systray settings. Besides that it should work.

regards
Stefan Schmidt

--
Rapidly troubleshoot problems before they affect your business. Most IT 
organizations don't have a clear picture of how application performance 
affects their revenue. With AppDynamics, you get 100% visibility into your 
Java,.NET,  PHP application. Start your 15-day FREE TRIAL of AppDynamics Pro!
http://pubads.g.doubleclick.net/gampad/clk?id=84349831iu=/4140/ostg.clktrk
___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] system tray problem

2013-12-19 Thread mh
On 12/19/2013 03:49 PM, Stefan Schmidt wrote:
 Hello.

 On Thu, 2013-12-19 at 14:53, mh wrote:
 I seem to have a problem with the system tray in Enlightenment e18. I am
 trying to use a program called Synergy, http://synergy-foss.org/, which
 is a server/client program that lets me use one mouse and keyboard
 across two or more computers. When you move the mouse off the current
 (server) screen it will appear on the other (client) computer's display
 and the mouse/keyboard work on the other computer. Move it to the side
 on the second computer and it returns to the first. This works perfectly
 using xfce 4.x.
 And it works perfectly fine here for me with two machines and e18. I
 run synergy client and server from the commandline without any UI
 though. Which would explain why I'm not seeing your problem.

 When I try to start the Synergy server with E18 running I get an error
 window that says System tray is unavailable, quitting. I enabled the
 Systray module and Systray gadget in E18 but this has no effect and I
 still get the same error message. Does the Systray module function
 differently than the system tray in xfce? Is there something else I need
 to enable in E18?
 You added the gadget to a shelf? You might need to enable xmbed in the
 systray settings. Besides that it should work.

 regards
 Stefan Schmidt
Once I enabled xmbed in the systray settings I had no problems, either 
starting synergy from command line, or from the UI menus. Thank you!

mike

--
Rapidly troubleshoot problems before they affect your business. Most IT 
organizations don't have a clear picture of how application performance 
affects their revenue. With AppDynamics, you get 100% visibility into your 
Java,.NET,  PHP application. Start your 15-day FREE TRIAL of AppDynamics Pro!
http://pubads.g.doubleclick.net/gampad/clk?id=84349831iu=/4140/ostg.clktrk
___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] system tray problem

2013-12-19 Thread Wido
Try what mh said. Right click in systray module - enable xembed.

It may do some funny things to other apps/icons, like dropbox
El 19/12/2013 18:24, mh mhe...@member.fsf.org escribió:

 On 12/19/2013 03:49 PM, Stefan Schmidt wrote:
  Hello.
 
  On Thu, 2013-12-19 at 14:53, mh wrote:
  I seem to have a problem with the system tray in Enlightenment e18. I am
  trying to use a program called Synergy, http://synergy-foss.org/, which
  is a server/client program that lets me use one mouse and keyboard
  across two or more computers. When you move the mouse off the current
  (server) screen it will appear on the other (client) computer's display
  and the mouse/keyboard work on the other computer. Move it to the side
  on the second computer and it returns to the first. This works perfectly
  using xfce 4.x.
  And it works perfectly fine here for me with two machines and e18. I
  run synergy client and server from the commandline without any UI
  though. Which would explain why I'm not seeing your problem.
 
  When I try to start the Synergy server with E18 running I get an error
  window that says System tray is unavailable, quitting. I enabled the
  Systray module and Systray gadget in E18 but this has no effect and I
  still get the same error message. Does the Systray module function
  differently than the system tray in xfce? Is there something else I need
  to enable in E18?
  You added the gadget to a shelf? You might need to enable xmbed in the
  systray settings. Besides that it should work.
 
  regards
  Stefan Schmidt
 Once I enabled xmbed in the systray settings I had no problems, either
 starting synergy from command line, or from the UI menus. Thank you!

 mike


 --
 Rapidly troubleshoot problems before they affect your business. Most IT
 organizations don't have a clear picture of how application performance
 affects their revenue. With AppDynamics, you get 100% visibility into your
 Java,.NET,  PHP application. Start your 15-day FREE TRIAL of AppDynamics
 Pro!
 http://pubads.g.doubleclick.net/gampad/clk?id=84349831iu=/4140/ostg.clktrk
 ___
 enlightenment-users mailing list
 enlightenment-users@lists.sourceforge.net
 https://lists.sourceforge.net/lists/listinfo/enlightenment-users

--
Rapidly troubleshoot problems before they affect your business. Most IT 
organizations don't have a clear picture of how application performance 
affects their revenue. With AppDynamics, you get 100% visibility into your 
Java,.NET,  PHP application. Start your 15-day FREE TRIAL of AppDynamics Pro!
http://pubads.g.doubleclick.net/gampad/clk?id=84349831iu=/4140/ostg.clktrk
___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] system tray nm-applet icon

2009-04-01 Thread Matthew Morgan
 On Mon, 30 Mar 2009 14:33:10 +0200, Matthew Morgan
 lytith...@gmail.com wrote:


 On Sat, Mar 28, 2009 at 6:55 AM, Kim Woelders k...@woelders.dk wrote:

  On Thu, 26 Mar 2009 18:11:11 +0100, Don Harrop d...@effx.us wrote:
 

  Quoting Kim Woelders k...@woelders.dk:
 

  On Tue, 24 Mar 2009 21:52:30 +0100, Jona Schuman
  jonaschuman+eus...@gmail.com wrote:
 

  Hello,
 
  I'm having an issue that I imagine concerns the system
 tray. Namely,
  the icon for the NetworkManger applet disappears. The
 applet itself
  works fine, it's just invisible unless I click on it to get
 its menu.
  All my other applets don't seem afflicted and nm-applet
 itself works
  fine when I run it in the Gnome panel.
 
  I'm running 0.16.8.15-1 and network-manager-gnome 0.6.6-4
 on Debian
  squeeze.
 
  Any suggestions would be greatly appreciated.
 

  Yeah, problems like that seem to come and go.
  Currently I see that problem with pidgin but not with NM
 (version
  0.7.0.99).
  I guess I should try to figure out if it can be fixed in e16
 or if
  the apps are just misbehaving.

 
  If you want more apps to poke at, I tend to see issues with
 Opera and
  occasionally the Screenlets icon not being visible in e16's
 systray.
 
  Icon drawing becomes problematic when changing icon sizes
 around a bit
  too,
  no matter what icons are in there..  Maybe the problem is related?
  Turning on base images aggravates the issue when changing the
 icon
  sizes too.
 

  My problems with pidgin seem go away when setting the systray
 icon size to e.g. 16 or 32 in stead of the default 24.
  This might also fix problems with nm-applet.


 Just thought I'd confirm that setting icon size to 16 appears to fix
 all strange behavior with nm-applet on my end. Thanks!
 How do you set the icon size for systray?  I can't seem to find it
 anywhere.

 Right click in some systray part, e.g. background or slider, and
 select Settings...
 If the systray background/slider/arrows are all hidden you'll have to
 use eesh ibox cfg _ST_.

 /Kim
When I right click in systray, nothing happens.  Also, I'm running e17,
so I don't have eesh.  Is there a way to run that command using
enlightenment_remote?  I tried reading the man page, but it has a LOT of
options, and I didn't see anything about calling up a configuration dialog.

--
___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] system tray nm-applet icon

2009-03-31 Thread Kim Woelders
On Mon, 30 Mar 2009 14:33:10 +0200, Matthew Morgan lytith...@gmail.com wrote:


 On Sat, Mar 28, 2009 at 6:55 AM, Kim Woelders k...@woelders.dk wrote:

  On Thu, 26 Mar 2009 18:11:11 +0100, Don Harrop d...@effx.us wrote:
 

  Quoting Kim Woelders k...@woelders.dk:
 

  On Tue, 24 Mar 2009 21:52:30 +0100, Jona Schuman
  jonaschuman+eus...@gmail.com wrote:
 

  Hello,
 
  I'm having an issue that I imagine concerns the system tray.  
 Namely,
  the icon for the NetworkManger applet disappears. The applet  
 itself
  works fine, it's just invisible unless I click on it to get  
 its menu.
  All my other applets don't seem afflicted and nm-applet itself  
 works
  fine when I run it in the Gnome panel.
 
  I'm running 0.16.8.15-1 and network-manager-gnome 0.6.6-4 on  
 Debian
  squeeze.
 
  Any suggestions would be greatly appreciated.
 

  Yeah, problems like that seem to come and go.
  Currently I see that problem with pidgin but not with NM (version
  0.7.0.99).
  I guess I should try to figure out if it can be fixed in e16 or  
 if
  the apps are just misbehaving.

 
  If you want more apps to poke at, I tend to see issues with Opera  
 and
  occasionally the Screenlets icon not being visible in e16's  
 systray.
 
  Icon drawing becomes problematic when changing icon sizes around a  
 bit
  too,
  no matter what icons are in there..  Maybe the problem is related?
  Turning on base images aggravates the issue when changing the  
 icon
  sizes too.
 

  My problems with pidgin seem go away when setting the systray icon  
 size to e.g. 16 or 32 in stead of the default 24.
  This might also fix problems with nm-applet.


 Just thought I'd confirm that setting icon size to 16 appears to fix
 all strange behavior with nm-applet on my end. Thanks!
 How do you set the icon size for systray?  I can't seem to find it  
 anywhere.

Right click in some systray part, e.g. background or slider, and select 
Settings...
If the systray background/slider/arrows are all hidden you'll have to use eesh 
ibox cfg _ST_.

/Kim
 

--
___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] system tray nm-applet icon

2009-03-30 Thread Matthew Morgan

 On Sat, Mar 28, 2009 at 6:55 AM, Kim Woelders k...@woelders.dk wrote:
   
  On Thu, 26 Mar 2009 18:11:11 +0100, Don Harrop d...@effx.us wrote:
 
 
  Quoting Kim Woelders k...@woelders.dk:
 
   
  On Tue, 24 Mar 2009 21:52:30 +0100, Jona Schuman
  jonaschuman+eus...@gmail.com wrote:
 
 
  Hello,
 
  I'm having an issue that I imagine concerns the system tray. Namely,
  the icon for the NetworkManger applet disappears. The applet itself
  works fine, it's just invisible unless I click on it to get its menu.
  All my other applets don't seem afflicted and nm-applet itself works
  fine when I run it in the Gnome panel.
 
  I'm running 0.16.8.15-1 and network-manager-gnome 0.6.6-4 on Debian
  squeeze.
 
  Any suggestions would be greatly appreciated.
 
   
  Yeah, problems like that seem to come and go.
  Currently I see that problem with pidgin but not with NM (version
  0.7.0.99).
  I guess I should try to figure out if it can be fixed in e16 or if
  the apps are just misbehaving.
 
 
  If you want more apps to poke at, I tend to see issues with Opera and
  occasionally the Screenlets icon not being visible in e16's systray.
 
  Icon drawing becomes problematic when changing icon sizes around a bit
  too,
  no matter what icons are in there..  Maybe the problem is related?
  Turning on base images aggravates the issue when changing the icon
  sizes too.
 
   
  My problems with pidgin seem go away when setting the systray icon size to 
  e.g. 16 or 32 in stead of the default 24.
  This might also fix problems with nm-applet.
 

 Just thought I'd confirm that setting icon size to 16 appears to fix
 all strange behavior with nm-applet on my end. Thanks!
How do you set the icon size for systray?  I can't seem to find it anywhere.

--
___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] system tray nm-applet icon

2009-03-29 Thread Jona Schuman
On Sat, Mar 28, 2009 at 6:55 AM, Kim Woelders k...@woelders.dk wrote:
 On Thu, 26 Mar 2009 18:11:11 +0100, Don Harrop d...@effx.us wrote:

 Quoting Kim Woelders k...@woelders.dk:

 On Tue, 24 Mar 2009 21:52:30 +0100, Jona Schuman
 jonaschuman+eus...@gmail.com wrote:

 Hello,

 I'm having an issue that I imagine concerns the system tray. Namely,
 the icon for the NetworkManger applet disappears. The applet itself
 works fine, it's just invisible unless I click on it to get its menu.
 All my other applets don't seem afflicted and nm-applet itself works
 fine when I run it in the Gnome panel.

 I'm running 0.16.8.15-1 and network-manager-gnome 0.6.6-4 on Debian
 squeeze.

 Any suggestions would be greatly appreciated.

 Yeah, problems like that seem to come and go.
 Currently I see that problem with pidgin but not with NM (version
 0.7.0.99).
 I guess I should try to figure out if it can be fixed in e16 or if
 the apps are just misbehaving.

 If you want more apps to poke at, I tend to see issues with Opera and
 occasionally the Screenlets icon not being visible in e16's systray.

 Icon drawing becomes problematic when changing icon sizes around a bit
 too,
 no matter what icons are in there..  Maybe the problem is related?
 Turning on base images aggravates the issue when changing the icon
 sizes too.

 My problems with pidgin seem go away when setting the systray icon size to 
 e.g. 16 or 32 in stead of the default 24.
 This might also fix problems with nm-applet.

Just thought I'd confirm that setting icon size to 16 appears to fix
all strange behavior with nm-applet on my end. Thanks!

--
___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] system tray nm-applet icon

2009-03-28 Thread Kim Woelders
On Thu, 26 Mar 2009 18:11:11 +0100, Don Harrop d...@effx.us wrote:

 Quoting Kim Woelders k...@woelders.dk:

 On Tue, 24 Mar 2009 21:52:30 +0100, Jona Schuman
 jonaschuman+eus...@gmail.com wrote:

 Hello,

 I'm having an issue that I imagine concerns the system tray. Namely,
 the icon for the NetworkManger applet disappears. The applet itself
 works fine, it's just invisible unless I click on it to get its menu.
 All my other applets don't seem afflicted and nm-applet itself works
 fine when I run it in the Gnome panel.

 I'm running 0.16.8.15-1 and network-manager-gnome 0.6.6-4 on Debian
 squeeze.

 Any suggestions would be greatly appreciated.

 Yeah, problems like that seem to come and go.
 Currently I see that problem with pidgin but not with NM (version  
 0.7.0.99).
 I guess I should try to figure out if it can be fixed in e16 or if
 the apps are just misbehaving.

 If you want more apps to poke at, I tend to see issues with Opera and
 occasionally the Screenlets icon not being visible in e16's systray.

 Icon drawing becomes problematic when changing icon sizes around a bit  
 too,
 no matter what icons are in there..  Maybe the problem is related?
 Turning on base images aggravates the issue when changing the icon
 sizes too.

My problems with pidgin seem go away when setting the systray icon size to e.g. 
16 or 32 in stead of the default 24.
This might also fix problems with nm-applet.

I also see some trouble with opera when changing the icon size. I have 
committed a fix that seems to cure some of this. There still are some issues 
when using a base image.

/Kim

--
___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] system tray nm-applet icon

2009-03-26 Thread Don Harrop
Quoting Kim Woelders k...@woelders.dk:

 On Tue, 24 Mar 2009 21:52:30 +0100, Jona Schuman   
 jonaschuman+eus...@gmail.com wrote:

 Hello,

 I'm having an issue that I imagine concerns the system tray. Namely,
 the icon for the NetworkManger applet disappears. The applet itself
 works fine, it's just invisible unless I click on it to get its menu.
 All my other applets don't seem afflicted and nm-applet itself works
 fine when I run it in the Gnome panel.

 I'm running 0.16.8.15-1 and network-manager-gnome 0.6.6-4 on Debian
 squeeze.

 Any suggestions would be greatly appreciated.

 Yeah, problems like that seem to come and go.
 Currently I see that problem with pidgin but not with NM (version 0.7.0.99).
 I guess I should try to figure out if it can be fixed in e16 or if   
 the apps are just misbehaving.

If you want more apps to poke at, I tend to see issues with Opera and
occasionally the Screenlets icon not being visible in e16's systray.

Icon drawing becomes problematic when changing icon sizes around a bit too,
no matter what icons are in there..  Maybe the problem is related?   
Turning on base images aggravates the issue when changing the icon  
sizes too.

- Don





--
___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] system tray nm-applet icon

2009-03-24 Thread Gustavo Sverzut Barbieri
On Tue, Mar 24, 2009 at 5:52 PM, Jona Schuman
jonaschuman+eus...@gmail.com wrote:
 Hello,

 I'm having an issue that I imagine concerns the system tray. Namely,
 the icon for the NetworkManger applet disappears. The applet itself
 works fine, it's just invisible unless I click on it to get its menu.
 All my other applets don't seem afflicted and nm-applet itself works
 fine when I run it in the Gnome panel.

 I'm running 0.16.8.15-1 and network-manager-gnome 0.6.6-4 on Debian squeeze.

 Any suggestions would be greatly appreciated.

no ideas on what can be the problem, since everything else works.

I don't use nm myself, but connman that I believe is a better
solution. We plan to add e-connman support soon, so you will be able
to interact with it even without systray since it will be a native e
gadget.

-- 
Gustavo Sverzut Barbieri
http://profusion.mobi embedded systems
--
MSN: barbi...@gmail.com
Skype: gsbarbieri
Mobile: +55 (19) 9225-2202

--
Apps built with the Adobe(R) Flex(R) framework and Flex Builder(TM) are
powering Web 2.0 with engaging, cross-platform capabilities. Quickly and
easily build your RIAs with Flex Builder, the Eclipse(TM)based development
software that enables intelligent coding and step-through debugging.
Download the free 60 day trial. http://p.sf.net/sfu/www-adobe-com
___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] system tray nm-applet icon

2009-03-24 Thread Viktor Kojouharov
On Tue, 2009-03-24 at 18:06 -0300, Gustavo Sverzut Barbieri wrote:
 On Tue, Mar 24, 2009 at 5:52 PM, Jona Schuman
 jonaschuman+eus...@gmail.com wrote:
  Hello,
 
  I'm having an issue that I imagine concerns the system tray. Namely,
  the icon for the NetworkManger applet disappears. The applet itself
  works fine, it's just invisible unless I click on it to get its menu.
  All my other applets don't seem afflicted and nm-applet itself works
  fine when I run it in the Gnome panel.
 
  I'm running 0.16.8.15-1 and network-manager-gnome 0.6.6-4 on Debian squeeze.
 
  Any suggestions would be greatly appreciated.
 
 no ideas on what can be the problem, since everything else works.
 
 I don't use nm myself, but connman that I believe is a better
 solution. We plan to add e-connman support soon, so you will be able
 to interact with it even without systray since it will be a native e
 gadget.
 

He's using E16 :)


--
Apps built with the Adobe(R) Flex(R) framework and Flex Builder(TM) are
powering Web 2.0 with engaging, cross-platform capabilities. Quickly and
easily build your RIAs with Flex Builder, the Eclipse(TM)based development
software that enables intelligent coding and step-through debugging.
Download the free 60 day trial. http://p.sf.net/sfu/www-adobe-com
___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] system tray nm-applet icon

2009-03-24 Thread Gustavo Sverzut Barbieri
On Tue, Mar 24, 2009 at 6:29 PM, Viktor Kojouharov
vkojouha...@gmail.com wrote:
 On Tue, 2009-03-24 at 18:06 -0300, Gustavo Sverzut Barbieri wrote:
 On Tue, Mar 24, 2009 at 5:52 PM, Jona Schuman
 jonaschuman+eus...@gmail.com wrote:
  Hello,
 
  I'm having an issue that I imagine concerns the system tray. Namely,
  the icon for the NetworkManger applet disappears. The applet itself
  works fine, it's just invisible unless I click on it to get its menu.
  All my other applets don't seem afflicted and nm-applet itself works
  fine when I run it in the Gnome panel.
 
  I'm running 0.16.8.15-1 and network-manager-gnome 0.6.6-4 on Debian 
  squeeze.
 
  Any suggestions would be greatly appreciated.

 no ideas on what can be the problem, since everything else works.

 I don't use nm myself, but connman that I believe is a better
 solution. We plan to add e-connman support soon, so you will be able
 to interact with it even without systray since it will be a native e
 gadget.


 He's using E16 :)

LOL, I'm freaking with som much things to do/reply/code that I'm not
even reading mails properly.


-- 
Gustavo Sverzut Barbieri
http://profusion.mobi embedded systems
--
MSN: barbi...@gmail.com
Skype: gsbarbieri
Mobile: +55 (19) 9225-2202

--
Apps built with the Adobe(R) Flex(R) framework and Flex Builder(TM) are
powering Web 2.0 with engaging, cross-platform capabilities. Quickly and
easily build your RIAs with Flex Builder, the Eclipse(TM)based development
software that enables intelligent coding and step-through debugging.
Download the free 60 day trial. http://p.sf.net/sfu/www-adobe-com
___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] System Tray

2007-05-23 Thread gimpel
On Di, 22.05.07 22:31 Mirek [EMAIL PROTECTED] wrote:

 Hi, I am using trayer:
 
 /usr/bin/trayer --widthtype request --heighttype pixel --height 24 
 --edge bottom --align right --alpha 100 --transparent true --margin 0 
 --distance 40 
 
 Mirek
 

Or take a look at stalonetray:
http://stalonetray.sourceforge.net

IMHO it works better than trayer, esp with kde stuff.

Best,
Tom

-
This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
http://sourceforge.net/powerbar/db2/
___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] System Tray

2007-05-22 Thread Mirek
Hi, I am using trayer:

/usr/bin/trayer --widthtype request --heighttype pixel --height 24 
--edge bottom --align right --alpha 100 --transparent true --margin 0 
--distance 40 

Mirek

Jackie C. Smith II napsal(a):
 Thank you for adding me to your mail list. I have looked at the FAQ and 
 unless I missed it, I did not see my situation there. That being said, I 
 installed e17 on my existing Linux Mint (using edgy 6.10). It works 
 wonderfully, however, I noticed that there is no system tray available. 
 There is no way to see my programs that are running in the background. 
 Such as, (any) messenger, Amarok. While with most programs, all I need 
 to do to activate the active program is to click on that programs 
 starter, programs like Skype will open a new window leaving no way to 
 access the already opened window.
 
 Thank you in advance for considering this situation.
 
 Clyde9
 
 -
 This SF.net email is sponsored by DB2 Express
 Download DB2 Express C - the FREE version of DB2 express and take
 control of your XML. No limits. Just data. Click to get it now.
 http://sourceforge.net/powerbar/db2/
 ___
 enlightenment-users mailing list
 enlightenment-users@lists.sourceforge.net
 https://lists.sourceforge.net/lists/listinfo/enlightenment-users
 

-
This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
http://sourceforge.net/powerbar/db2/
___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users


Re: [e-users] System Tray

2007-05-22 Thread The Rasterman
On Thu, 03 May 2007 12:19:22 -0600 Jackie C. Smith II
[EMAIL PROTECTED] babbled:


there is, and will be, no system tray support in e17. use something else like
trayer.

 Thank you for adding me to your mail list. I have looked at the FAQ and 
 unless I missed it, I did not see my situation there. That being said, I 
 installed e17 on my existing Linux Mint (using edgy 6.10). It works 
 wonderfully, however, I noticed that there is no system tray available. 
 There is no way to see my programs that are running in the background. 
 Such as, (any) messenger, Amarok. While with most programs, all I need 
 to do to activate the active program is to click on that programs 
 starter, programs like Skype will open a new window leaving no way to 
 access the already opened window.
 
 Thank you in advance for considering this situation.
 
 Clyde9
 
 -
 This SF.net email is sponsored by DB2 Express
 Download DB2 Express C - the FREE version of DB2 express and take
 control of your XML. No limits. Just data. Click to get it now.
 http://sourceforge.net/powerbar/db2/
 ___
 enlightenment-users mailing list
 enlightenment-users@lists.sourceforge.net
 https://lists.sourceforge.net/lists/listinfo/enlightenment-users
 


-- 
- Codito, ergo sum - I code, therefore I am --
The Rasterman (Carsten Haitzler)[EMAIL PROTECTED]
裸好多
Tokyo, Japan (東京 日本)

-
This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
http://sourceforge.net/powerbar/db2/
___
enlightenment-users mailing list
enlightenment-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-users