Re: [e-users] E 0.21.5 stuck at 100% CPU for days

2018-03-26 Thread Marc MERLIN
On Tue, Mar 27, 2018 at 02:39:14PM +0900, Carsten Haitzler wrote: > If E is hung solid then it'll help. But if it's working just consuming CPU, No, it's fully responsive, just taking 100% on one core and killing my battery if I'm off mains power. > it's not going to. It's likely something

Re: [e-users] E 0.21.5 stuck at 100% CPU for days

2018-03-26 Thread The Rasterman
On Mon, 26 Mar 2018 22:20:27 -0700 Marc MERLIN said: > On Tue, Mar 27, 2018 at 03:20:47PM +1030, Simon Lees wrote: > > > Howdy, > > > > > > This happens some time after I start, not right away. > > > Restarting E while my desktop is running does not seem to help > > >

Re: [e-users] E 0.21.5 stuck at 100% CPU for days

2018-03-26 Thread Simon Lees
On 27/03/18 01:43, Marc MERLIN wrote: > Howdy, > > This happens some time after I start, not right away. > Restarting E while my desktop is running does not seem to help significantly. > > What is my best way to find out what is keeping E in a busy loop like this? > if you kill the e process

Re: [e-users] multiple terminology windows

2018-03-26 Thread The Rasterman
On Mon, 26 Mar 2018 20:31:07 -0400 Conrad Knight said: > > -s should bypass this and force a new process. it sees multiple > > instances one process has become broken somehow. disabling that should > > get you back to normal. > > Hmm, using "terminology" or "terminology

Re: [e-users] multiple terminology windows

2018-03-26 Thread Conrad Knight
> -s should bypass this and force a new process. it sees multiple > instances one process has become broken somehow. disabling that should > get you back to normal. Hmm, using "terminology" or "terminology -s" from the command line both start a new process. But then again, starting it from the

Re: [e-users] E 0.21.5 stuck at 100% CPU for days

2018-03-26 Thread Marc MERLIN
On Tue, Mar 27, 2018 at 03:20:47PM +1030, Simon Lees wrote: > > Howdy, > > > > This happens some time after I start, not right away. > > Restarting E while my desktop is running does not seem to help > > significantly. > > > > What is my best way to find out what is keeping E in a busy loop

Re: [e-users] multiple terminology windows

2018-03-26 Thread The Rasterman
On Sun, 25 Mar 2018 13:54:23 -0400 Conrad Knight said: found it... it's an efl bug in ecore_ipc. and it's been there i think a long time. ever since efl.net came in. fixed in efl git master. > Hi, > > I've been having this issue for a while now. If i attempt to run >

Re: [e-users] multiple terminology windows

2018-03-26 Thread The Rasterman
On Sun, 25 Mar 2018 13:54:23 -0400 Conrad Knight said: > Hi, > > I've been having this issue for a while now. If i attempt to run > terminology from Enlightenment's applications menu, it does not open a > new terminal. Instead it will simply put the focus on an existing >

[e-users] E 0.21.5 stuck at 100% CPU for days

2018-03-26 Thread Marc MERLIN
Howdy, This happens some time after I start, not right away. Restarting E while my desktop is running does not seem to help significantly. What is my best way to find out what is keeping E in a busy loop like this? strace below if that helps. [pid 28024] 08:09:37.656879 writev(15, [{"+\1\1\0",