Re: New ES6 spec draft (Rev 22, Jan 20, 2014)

2014-01-23 Thread Jason Orendorff
On Mon, Jan 20, 2014 at 9:42 PM, Allen Wirfs-Brock al...@wirfs-brock.com wrote: The draft is available at http://wiki.ecmascript.org/doku.php?id=harmony:specification_drafts#january_20_2014_draft_rev_22 The HTML version is up at: http://people.mozilla.org/~jorendorff/es6-draft.html As

Re: New ES6 spec draft (Rev 22, Jan 20, 2014)

2014-01-23 Thread Allen Wirfs-Brock
big thanks, We there any new styling anomalies that your converter initially barfed on. I'm still battling (two steps forward, one back) intermittent broken multi-level list functionality, so anything that stands out might be a clue. Allen On Jan 23, 2014, at 4:57 PM, Jason Orendorff

Re: New ES6 spec draft (Rev 22, Jan 20, 2014)

2014-01-23 Thread Jason Orendorff
The script initially barfed on some list formatting, but it was clearly my fault, not the document's. I did file bug 2429 on some styling anomalies, not sure that'll help: https://bugs.ecmascript.org/show_bug.cgi?id=2429 On Thu, Jan 23, 2014 at 7:23 PM, Allen Wirfs-Brock al...@wirfs-brock.com

Re: New ES6 spec draft (Rev 22, Jan 20, 2014)

2014-01-21 Thread Tom Van Cutsem
I really like the way the ES6 spec is coming together. Generally the way in which abstract ops are used and internal methods are specified is much clearer and more uniform in ES6 than in ES5. Also, the table of contents is much better structured. I like your classification according to indexed

Re: New ES6 spec draft (Rev 22, Jan 20, 2014)

2014-01-21 Thread Kevin Smith
Couple of nits WRT modules: - The instantiationRequest interface is defined as having two properties: execute and deps. I believe deps should be spelled dependencies to match the naming conventions throughout the rest of the document. Besides that, there is no reason that I can see to optimize

Re: New ES6 spec draft (Rev 22, Jan 20, 2014)

2014-01-21 Thread Sam Tobin-Hochstadt
On Tue, Jan 21, 2014 at 9:29 AM, Kevin Smith zenpars...@gmail.com wrote: 2) The current loader is an instance of the Loader type. It is incongruent to name an instance with a capitalized identifier. I believe it would be more appropriate to provide access to the current loader via a

Re: New ES6 spec draft (Rev 22, Jan 20, 2014)

2014-01-21 Thread John Barton
On Mon, Jan 20, 2014 at 7:42 PM, Allen Wirfs-Brock al...@wirfs-brock.comwrote: The draft is available at http://wiki.ecmascript.org/doku.php?id=harmony:specification_drafts#january_20_2014_draft_rev_22 Big news: Promise and Module Loading/Linking. Still a few loose ends, but we're getting

Re: New ES6 spec draft (Rev 22, Jan 20, 2014)

2014-01-21 Thread Allen Wirfs-Brock
John, js-loaders is both the initial spec. draft and the initial prototype of the module subsystem. What we have now is the integration of the that initial draft into the actual ES6 spec. In doing that there is some editorial renaming and refactoring intended to improve the spec. clarity and

Re: New ES6 spec draft (Rev 22, Jan 20, 2014)

2014-01-21 Thread Kevin Smith
First, there are plenty of standard bindings on the global object that are not constructors and yet are capitalized -- `Math` is a prime example here. Math (and Reflect, JSON, etc) are functioning not as objects with per-instance state, but as namespaces. Infinity is a value object, but

New ES6 spec draft (Rev 22, Jan 20, 2014)

2014-01-20 Thread Allen Wirfs-Brock
The draft is available at http://wiki.ecmascript.org/doku.php?id=harmony:specification_drafts#january_20_2014_draft_rev_22 Big news: Promise and Module Loading/Linking. Still a few loose ends, but we're getting there. Changes include: Promises Module loading/linking semantics Internal