Re: [Evolution-hackers] Exchange 2007 - MAPI Provider preview

2008-02-04 Thread Srinivasa Ragavan
Per,

You sure you did 'export MAPI_DEBUG=1' on a terminal and from the same
terminal, you start evolution?

I'm wondering how it works for me then :(
-Srini.

On Sun, 2008-02-03 at 23:18 -0800, Per Nystrom wrote:
 Srini,
 
 I tried MAPI_DEBUG=1, but I got the same output as I already sent
 before.
 
 BTW, I only munged out the server, domain, username, and password (it
 shouldn't really show the password in plaintext anyway, but that's minor
 compared to getting it to work at all).
 
 Thanks,
 Per
 
 
 On Mon, 2008-02-04 at 12:16 +0530, Srinivasa Ragavan wrote:
  Per,
  
  Nice to hear that the crash is gone.
  
  You can do
  
  export 'MAPI_DEBUG=1'
  evolution
  
  Try authentication and paste me out the logs. It can help be get out of
  the barrier. Do send me privately if you think it has some sensitive
  information.
  
  -Srini.
  On Sat, 2008-02-02 at 23:15 -0800, Per Nystrom wrote:
   Hi,
   
   I saw a new update showed up today in the repository so I tried it out.
   The crash is gone, but I still can't get past the authenticate dialog.
   Here's the terminal output:
   
   [EMAIL PROTECTED] ~]$ LD_LIBRARY_PATH=/opt/samba4/lib evolution
   CalDAV Eplugin starting up ...
   Loading Exchange MAPI Plugin
   
   listener is constructed 
   evolution-shell-Message: Killing old version of evolution-data-server...
   ** (evolution:10509): DEBUG: mailto URL command: evolution 
   --component=mail %s
   ** (evolution:10509): DEBUG: mailto URL program: evolution
   camel-mapi-store.c(166):camel_mapi_store_get_type:Reached 
   get uuu mapi://[EMAIL PROTECTED]/
   Find Items 9
   Couldn't Get password 9
   Create profile with uuu ppp () yyy.zzz xxx.yyy.zzz
   profpath /home/test/.evolution/mapi-profiles.ldb
   [exchange_mapi_plugin] Profile creation
   Logging into the server
   Login succeeded: Yeh
   [exchange_mapi_plugin] : ProcessNetworkProfile: 
   MAPI_E_INVALID_PARAMETER (0x80070057)
   [exchange_mapi_plugin] ProcessNetworkProfile() : 
   MAPI_E_INVALID_PARAMETER (0x80070057)
   Get Default 0
   Find Items 9
   Couldn't clear password
   
   I'm happy to help debug, just let me know what you need me to do.
   
   Thanks,
   Per
   
   On Mon, 2008-01-28 at 23:45 -0800, Per Nystrom wrote:
Excellent, I'll watch for it to show up in the repository and try again.

Thanks,
Per

On Tue, 2008-01-29 at 09:22 +0530, Srinivasa Ragavan wrote:
 Looks like a double free when the profile creation fails.
 Per, the main problem here is why the profile creation fails. We will
 push a debug build asap so that this can be seen.
 
 -Srini.
 On Mon, 2008-01-28 at 11:31 -0800, Per Nystrom wrote:
  Hello,
  
  I installed the RPMs and dependencies from
  http://download.opensuse.org/repositories/home:/jjohnny:/evolution-exchange-mapi-provider
   in a Fedora 8 i386 VM, started up Evolution with the required 
  LD_LIBRARY_PATH, tried to configure a MAPI account, and ended up 
  with a crash.  I posted details to the bugs wiki here:
  
  http://www.go-evolution.org/MAPIProvider/Bugs
  
  I'm happy to help get this moving any way I can; I have been without
  Evolution-Exchange connectivity ever since my company upgraded to
  Exchange 2007 in December and OWA light is driving me nuts.
  
  Thanks,
  Per
  
  ___
  Evolution-hackers mailing list
  Evolution-hackers@gnome.org
  http://mail.gnome.org/mailman/listinfo/evolution-hackers

___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers
   
 
___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Exchange 2007 - MAPI Provider preview

2008-02-04 Thread Srinivasa Ragavan
´╗┐William,

Looks like you got the MAPI_DEBUG working. Since you quoted that it is a
crash, can you attach to gdb or start Evolution in gdb and give me out
the traces?

William, when you delete the gconf entries, please delete the
~/.evolution/mapi_profiles.ldb also.

-Srini.

On Mon, 2008-02-04 at 12:42 +, William John Murray wrote:
 Hi guys,
 I had similar problems to Per. But I learnt something:
  When I am in his position I cannot move forward. If I try to change the
 account username etc it does not work. I get his symptom.
  But if I delete the gconf entry and restart evo from fresh
 I get to a different password entry box with a seperate domain entry.
 If I get my credentials correct here, first time, then I can go forward.
 
   Then I get a crash :). 
 There is a log on: 
http://murray.home.cern.ch/murray/evo.txt
 I have hidden some personal details, but you can see it does recover all
 my folder from the (2003) server. Yay!
   Bill
 ___
 Evolution-hackers mailing list
 Evolution-hackers@gnome.org
 http://mail.gnome.org/mailman/listinfo/evolution-hackers

___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Exchange 2007 - MAPI Provider preview

2008-02-04 Thread William John Murray

  Hi guys,
I had similar problems to Per. But I learnt something:
 When I am in his position I cannot move forward. If I try to change the
account username etc it does not work. I get his symptom.
 But if I delete the gconf entry and restart evo from fresh
I get to a different password entry box with a seperate domain entry.
If I get my credentials correct here, first time, then I can go forward.

  Then I get a crash :). 
There is a log on: 
   http://murray.home.cern.ch/murray/evo.txt
I have hidden some personal details, but you can see it does recover all
my folder from the (2003) server. Yay!
  Bill
___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Exchange 2007 - MAPI Provider preview

2008-02-04 Thread Suman Manjunath
Hi..

On Feb 4, 2008 9:58 PM, William John Murray [EMAIL PROTECTED] wrote:


  Hi Srinivasa,
Hm, I have the debug rpm,
 evolution-mapi-provider-debuginfo-20080118.3-2.1 but I am not sure how
 to use it! If I run in ddd I see this - is it enough info?


snip


 EcDoRpc_MAPI_REPL_UNION(case 21)
mapi_QueryRows: struct QueryRows_repl
unknown  : 0x02 (2)
results_count: 0x (0)
layout   : 0x00 (0)
mapi_response: (handles) number=1
handle id: 0x0f14 (3860)
length   : *
length   : 0x000f (15)
result   : MAPI_E_SUCCESS (0x0)
 exchange-mapi-connection.c(1631): exchange_mapi_get_folders_list:
 unlock(connect_lock)

 Program received signal SIGSEGV, Segmentation fault.
 [Switching to Thread 1105209680 (LWP 11659)]
 0x003dd0a795c0 in strlen () from /lib64/libc.so.6
 (gdb)


almost enough :) .. could you just get a backtrace at the SIGSEGV (type
'thread apply all bt full' at the terminal when you get the gdb prompt after
the SIGSEGV) and paste the output here ?

-Suman
___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Exchange 2007 - MAPI Provider preview

2008-02-04 Thread William John Murray

  Hi Srinivasa,
Hm, I have the debug rpm,
evolution-mapi-provider-debuginfo-20080118.3-2.1 but I am not sure how
to use it! If I run in ddd I see this - is it enough info?

|---+ Trash   : (Container class: IPF.Note 69BDFF0E)
UnRead : 0 Total : 0
EcDoRpc: struct EcDoRpc
in: struct EcDoRpc
handle   : *
handle: struct policy_handle
handle_type  : 0x (0)
uuid :
f28465ed-f3b2-4c9e-98c2-380868ee3e75
size : 0x7fff (32767)
offset   : 0x (0)
mapi_request : *
mapi_len : 0x0017 (23)
length   : 0x000f (15)
mapi_request: struct EcDoRpc_MAPI_REQ
opnum: 0x02 (2)
mapi_flags   : 0x00 (0)
handle_idx   : 0x00 (0)
u: union
EcDoRpc_MAPI_REQ_UNION(case 2)
mapi_OpenFolder: struct OpenFolder_req
handle_idx   : 0x01 (1)
folder_id:
0x95604a0e (-7683059600433610738)
unknown  : 0x00 (0)
mapi_request : (handles) number=2
handle   : 0x0fce (4046)
handle   : 0x
(4294967295)
length   : *
length   : 0x0017 (23)
max_data : 0x7fff (32767)
EcDoRpc: struct EcDoRpc
out: struct EcDoRpc
handle   : *
handle: struct policy_handle
handle_type  : 0x (0)
uuid :
f28465ed-f3b2-4c9e-98c2-380868ee3e75
size : 0x7fff (32767)
offset   : 0x (0)
mapi_response: *
mapi_response: length=10
mapi_response: ARRAY(8)
mapi_repl: struct EcDoRpc_MAPI_REPL
opnum: 0x02 (2)
handle_idx   : 0x01 (1)
error_code   : MAPI_E_SUCCESS (0x0)
u: union
EcDoRpc_MAPI_REPL_UNION(case 2)
mapi_OpenFolder: struct OpenFolder_repl
unknown  : 0x (0)
mapi_response: (handles) number=2
handle id: 0x0fce (4046)
handle id: 0x0c2a (3114)
length   : *
length   : 0x0012 (18)
result   : MAPI_E_SUCCESS (0x0)
EcDoRpc: struct EcDoRpc
in: struct EcDoRpc
handle   : *
handle: struct policy_handle
handle_type  : 0x (0)
uuid :
f28465ed-f3b2-4c9e-98c2-380868ee3e75
size : 0x7fff (32767)
offset   : 0x (0)
mapi_request : *
mapi_len : 0x0013 (19)
length   : 0x000f (15)
mapi_request: struct EcDoRpc_MAPI_REQ
opnum: 0x07 (7)
mapi_flags   : 0x00 (0)
handle_idx   : 0x00 (0)
u: union
EcDoRpc_MAPI_REQ_UNION(case 7)
mapi_GetProps: struct GetProps_req
unknown  : 0x (0)
prop_count   : 0x0001 (1)
properties: ARRAY(1)
properties   :
PR_CONTAINER_CLASS (0x3613001E)
mapi_request : (handles) number=1
handle   : 0x0c2a (3114)
length   : *
length   : 0x0013 (19)
max_data : 0x7fff (32767)
EcDoRpc: struct EcDoRpc
out: struct EcDoRpc
handle   : *
handle: struct policy_handle
handle_type  : 0x (0)
uuid :
f28465ed-f3b2-4c9e-98c2-380868ee3e75
size : 

Re: [Evolution-hackers] Exchange 2007 - MAPI Provider preview

2008-02-04 Thread Per Nystrom
Srini,

I don't know what I'm doing wrong, but here's what I did and the output
I got (munged for privacy -- uuu=username ppp=password ddd=domain
sss=exchange server):

[EMAIL PROTECTED] ~]$ export LD_LIBRARY_PATH=/opt/samba4/lib
[EMAIL PROTECTED] ~]$ export MAPI_DEBUG=1
[EMAIL PROTECTED] ~]$ evolution
CalDAV Eplugin starting up ...
Loading Exchange MAPI Plugin

listener is constructed 
evolution-shell-Message: Killing old version of evolution-data-server...
** (evolution:2771): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:2771): DEBUG: mailto URL program: evolution
camel-mapi-store.c(166):camel_mapi_store_get_type:Reached 
get uuu mapi://[EMAIL PROTECTED]/
Find Items 9
Couldn't Get password 9
Remember mapi://[EMAIL PROTECTED]/: 0/1
Create profile with uuu ppp () ddd sss
profpath /home/test/.evolution/mapi-profiles.ldb
[exchange_mapi_plugin] Profile creation
Logging into the server
Login succeeded: Yeh
[exchange_mapi_plugin] : ProcessNetworkProfile: MAPI_E_INVALID_PARAMETER 
(0x80070057)
[exchange_mapi_plugin] ProcessNetworkProfile() : MAPI_E_INVALID_PARAMETER 
(0x80070057)
Get Default 0
Find Items 0
Delete Items sss uuu 0
get uuu mapi://[EMAIL PROTECTED]/
Find Items 9
Couldn't Get password 9
Remember mapi://[EMAIL PROTECTED]/: 0/1
Create profile with uuu ppp () ddd sss
profpath /home/test/.evolution/mapi-profiles.ldb
[exchange_mapi_plugin] Profile creation
Logging into the server
Login succeeded: Yeh
[exchange_mapi_plugin] : ProcessNetworkProfile: MAPI_E_INVALID_PARAMETER 
(0x80070057)
[exchange_mapi_plugin] ProcessNetworkProfile() : MAPI_E_INVALID_PARAMETER 
(0x80070057)
Get Default 0
Find Items 0
Delete Items sss uuu 0

It seems to be looping at the authenticate dialog.  Keeps asking for my
password, and then I get the MAPI_E_INVALID_PARAMETER stuff on the
terminal.


Thanks,
Per

On Mon, 2008-02-04 at 14:30 +0530, Srinivasa Ragavan wrote:
 Per,
 
 You sure you did 'export MAPI_DEBUG=1' on a terminal and from the same
 terminal, you start evolution?
 
 I'm wondering how it works for me then :(
 -Srini.
 
 On Sun, 2008-02-03 at 23:18 -0800, Per Nystrom wrote:
  Srini,
  
  I tried MAPI_DEBUG=1, but I got the same output as I already sent
  before.
  
  BTW, I only munged out the server, domain, username, and password (it
  shouldn't really show the password in plaintext anyway, but that's minor
  compared to getting it to work at all).
  
  Thanks,
  Per
  
  
  On Mon, 2008-02-04 at 12:16 +0530, Srinivasa Ragavan wrote:
   Per,
   
   Nice to hear that the crash is gone.
   
   You can do
   
   export 'MAPI_DEBUG=1'
   evolution
   
   Try authentication and paste me out the logs. It can help be get out of
   the barrier. Do send me privately if you think it has some sensitive
   information.
   
   -Srini.
   On Sat, 2008-02-02 at 23:15 -0800, Per Nystrom wrote:
Hi,

I saw a new update showed up today in the repository so I tried it out.
The crash is gone, but I still can't get past the authenticate dialog.
Here's the terminal output:

[EMAIL PROTECTED] ~]$ LD_LIBRARY_PATH=/opt/samba4/lib evolution
CalDAV Eplugin starting up ...
Loading Exchange MAPI Plugin

listener is constructed 
evolution-shell-Message: Killing old version of evolution-data-server...
** (evolution:10509): DEBUG: mailto URL command: evolution 
--component=mail %s
** (evolution:10509): DEBUG: mailto URL program: evolution
camel-mapi-store.c(166):camel_mapi_store_get_type:Reached 
get uuu mapi://[EMAIL PROTECTED]/
Find Items 9
Couldn't Get password 9
Create profile with uuu ppp () yyy.zzz xxx.yyy.zzz
profpath /home/test/.evolution/mapi-profiles.ldb
[exchange_mapi_plugin] Profile creation
Logging into the server
Login succeeded: Yeh
[exchange_mapi_plugin] : ProcessNetworkProfile: 
MAPI_E_INVALID_PARAMETER (0x80070057)
[exchange_mapi_plugin] ProcessNetworkProfile() : 
MAPI_E_INVALID_PARAMETER (0x80070057)
Get Default 0
Find Items 9
Couldn't clear password

I'm happy to help debug, just let me know what you need me to do.

Thanks,
Per

On Mon, 2008-01-28 at 23:45 -0800, Per Nystrom wrote:
 Excellent, I'll watch for it to show up in the repository and try 
 again.
 
 Thanks,
 Per
 
 On Tue, 2008-01-29 at 09:22 +0530, Srinivasa Ragavan wrote:
  Looks like a double free when the profile creation fails.
  Per, the main problem here is why the profile creation fails. We 
  will
  push a debug build asap so that this can be seen.
  
  -Srini.
  On Mon, 2008-01-28 at 11:31 -0800, Per Nystrom wrote:
   Hello,
   
   I installed the RPMs and dependencies from
   http://download.opensuse.org/repositories/home:/jjohnny:/evolution-exchange-mapi-provider
in a Fedora 8 i386 VM, started up Evolution with the required 
   LD_LIBRARY_PATH, tried to configure a 

Re: [Evolution-hackers] Exchange 2007 - MAPI Provider preview

2008-02-04 Thread Srinivasa Ragavan
Hi William,

The trace looks fine, but I'm not able to find any segv or signal
handler call = Not able to find which thread crashed. Just do a 'bt'
Otherwise, it could be a memory corruption, I think.

Can you run like 'valgrind --tool=memcheck evolution' and paste me the
logs? 

Sorry for the multiple iterations.

-Srini.


On Mon, 2008-02-04 at 18:19 +, William John Murray wrote:
 Hello Suman,
   Here is the log. Thank you for looking at this.
  Bill
 
  thread apply all bt full
 
 Thread 8 (Thread 1105209680 (LWP 23478)):
 #0  0x003dd0ad50d8 in epoll_wait () from /lib64/libc.so.6
 No symbol table info available.
 #1  0x2aaab3d305e0 in ?? () from /opt/samba4/lib/libdcerpc.so.0
 No symbol table info available.
 #2  0x2aaab3d31032 in ?? () from /opt/samba4/lib/libdcerpc.so.0
 No symbol table info available.
 #3  0x2aaab3d2ff42 in event_loop_once ()
 from /opt/samba4/lib/libdcerpc.so.0
 No symbol table info available.
 #4  0x2aaab39ad2ab in dcerpc_request_recv ()
 from /opt/samba4/lib/libdcerpc.so.0
 No symbol table info available.
 #5  0x2aaab39ade40 in dcerpc_ndr_request_recv ()
 from /opt/samba4/lib/libdcerpc.so.0
 No symbol table info available.
 #6  0x2aaab36e45a0 in dcerpc_EcDoRpc (p=0x2aaabc020bd0,
 mem_ctx=value optimized out, r=0x41e01ca0) at
 gen_ndr/ndr_exchange_c.c:1565
   req = (struct rpc_request *) 0xfffc
 #7  0x2aaab36a4da3 in emsmdb_transaction (emsmdb=0x2aaabc020c70,
 req=0xe1fe50, repl=0x41e01d40) at libmapi/emsmdb.c:208
 r = {in = {mapi_request = 0xe1fe50, max_data = 32767, handle =
 0x2aaabc020c78, size = 32767, offset = 0, length = 0xe1fdc0}, out =
 {mapi_response = 0xe1ff20, handle = 0x2aaabc020c78, size = 14810816,
 offset = 0, length = 0xe1fdc0, result = 3016974192}}
   multi_req = value optimized out
   i = 0 '\0'
 #8  0x2aaab369db67 in OpenMsgStore (obj_store=0x41e01e70) at
 libmapi/IMAPISession.c:192
   mapi_request = (struct mapi_request *) 0x41e01a10
   mapi_response = value optimized out
   retval = value optimized out
   size = value optimized out
   mem_ctx = (TALLOC_CTX *) 0xe1fc70
   mailbox = value optimized out
 #9  0x2aaab3468c82 in exchange_mapi_connection_fetch_items
 (fid=388610298799456257, GetPropsList=0x2aaab9a43080, cn_props=8,
 build_name_id=0, res=0x0, cb=0x2aaab9a3f4e0 fetch_items_cb,
 data=0x2aaabc02e100) at exchange-mapi-connection.c:654
   retval = value optimized out
   mem_ctx = (TALLOC_CTX *) 0xe1fad0
 obj_store = {id = 0, handle = 4294967295, handles = 0x0,
 private_data = 0x0}
 obj_folder = {id = 0, handle = 4294967295, handles = 0x0,
 private_data = 0x0}
 obj_table = {id = 0, handle = 4294967295, handles = 0x0,
 private_data = 0x0}
   SPropTagArray = value optimized out
   GetPropsTagArray = value optimized out
 SRowSet = {cRows = 3007729240, aRow = 0xe09c30}
 count = 0
   i = value optimized out
   result = value optimized out
 __PRETTY_FUNCTION__ = exchange_mapi_connection_fetch_items
 #10 0x2aaab9a3f732 in mapi_refresh_folder (folder=0x2aaabc02e100,
 ex=0x41e01fc0) at camel-mapi-folder.c:522
 temp_folder_id = 388610298799456257
   mapi_store = (CamelMapiStore *) 0x719530
   status = value optimized out
 folder_id = (gchar *) 0xe09c30 05649F020001
 __PRETTY_FUNCTION__ = mapi_refresh_folder
 #11 0x2aaab9a3fbbe in mapi_refresh_info (folder=0x2aaabc02e100,
 ex=0x41e01fc0) at camel-mapi-folder.c:136
   si = value optimized out
 __PRETTY_FUNCTION__ = mapi_refresh_info
 #12 0x2aaab0577973 in ?? ()
 from /usr/lib64/evolution/2.12/components/libevolution-mail.so
 No symbol table info available.
 #13 0x2aaab0572cda in ?? ()
 from /usr/lib64/evolution/2.12/components/libevolution-mail.so
 No symbol table info available.
 #14 0x003dd3a5cde9 in ?? () from /lib64/libglib-2.0.so.0
 No symbol table info available.
 #15 0x003dd3a5b2a4 in ?? () from /lib64/libglib-2.0.so.0
 No symbol table info available.
 #16 0x003dd1606407 in start_thread () from /lib64/libpthread.so.0
 No symbol table info available.
 #17 0x003dd0ad4b0d in clone () from /lib64/libc.so.6
 No symbol table info available.
 
 Thread 5 (Thread 1094719824 (LWP 23381)):
 #0  0x003dd0a795c0 in strlen () from /lib64/libc.so.6
 No symbol table info available.
 #1  0x003dd3a54323 in g_strdup () from /lib64/libglib-2.0.so.0
 No symbol table info available.
 #2  0x2aaab9a41002 in mapi_folders_sync (store=0x719530, ex=value
 optimized out) at camel-mapi-store.c:972
 name = 0x2aaabc012b10 2006
 fid = (gchar *) 0xbc06af90 Address 0xbc06af90
 out of bounds
   priv = (CamelMapiStorePrivate *) 0x73a380
   status = value optimized out
   folder_list = (GSList *) 0x7f0c10
   temp_list = (GSList *) 0x7f0c20
   url = 0x2aaabc076710 mapi://[EMAIL PROTECTED]/
   info = value 

Re: [Evolution-hackers] Exchange 2007 - MAPI Provider preview

2008-02-04 Thread Srinivasa Ragavan

On Mon, 2008-02-04 at 14:31 -0800, Per Nystrom wrote:
 Srini,
 
 I don't know what I'm doing wrong, but here's what I did and the output
 I got (munged for privacy -- uuu=username ppp=password ddd=domain
 sss=exchange server):
 
 [EMAIL PROTECTED] ~]$ export LD_LIBRARY_PATH=/opt/samba4/lib
 [EMAIL PROTECTED] ~]$ export MAPI_DEBUG=1

Ah, this sounds challenging. You seem to be doing it right. Sure that
you have the new mapi connector installed from the repo?

-Srini.
___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Exchange 2007 - MAPI Provider preview

2008-02-04 Thread Per Nystrom
Srini,

I think so.  Here's what I've got:

[EMAIL PROTECTED] ~]# yum check-update
fedora100% |=| 2.1 kB00:00 
updates   100% |=| 2.3 kB00:00 
home:jjohnny:evolution-ex 100% |=|  951 B00:00 
fedora-debuginfo  100% |=| 2.1 kB00:00 
[EMAIL PROTECTED] ~]# rpm -qa | grep -i mapi
libmapi-0.6_HOLODECK-7.1
evolution-mapi-provider-debuginfo-20080118.3-2.1
evolution-mapi-provider-20080118.3-2.1



On Tue, 2008-02-05 at 09:53 +0530, Srinivasa Ragavan wrote:
 On Mon, 2008-02-04 at 14:31 -0800, Per Nystrom wrote:
  Srini,
  
  I don't know what I'm doing wrong, but here's what I did and the output
  I got (munged for privacy -- uuu=username ppp=password ddd=domain
  sss=exchange server):
  
  [EMAIL PROTECTED] ~]$ export LD_LIBRARY_PATH=/opt/samba4/lib
  [EMAIL PROTECTED] ~]$ export MAPI_DEBUG=1
 
 Ah, this sounds challenging. You seem to be doing it right. Sure that
 you have the new mapi connector installed from the repo?
 
 -Srini.

___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Exchange 2007 - MAPI Provider preview

2008-02-04 Thread Srinivasa Ragavan
Per,

Are you accessible on XChat? I'm 'srag' at #evolution in GimpNet
(irc.gnome.org)

I think we can resolve this faster over chat than mail :)

-Srini.

On Mon, 2008-02-04 at 20:30 -0800, Per Nystrom wrote:
 Srini,
 
 I think so.  Here's what I've got:
 
 [EMAIL PROTECTED] ~]# yum check-update
 fedora100% |=| 2.1 kB00:00
  
 updates   100% |=| 2.3 kB00:00
  
 home:jjohnny:evolution-ex 100% |=|  951 B00:00
  
 fedora-debuginfo  100% |=| 2.1 kB00:00
  
 [EMAIL PROTECTED] ~]# rpm -qa | grep -i mapi
 libmapi-0.6_HOLODECK-7.1
 evolution-mapi-provider-debuginfo-20080118.3-2.1
 evolution-mapi-provider-20080118.3-2.1
 
 
 
 On Tue, 2008-02-05 at 09:53 +0530, Srinivasa Ragavan wrote:
  On Mon, 2008-02-04 at 14:31 -0800, Per Nystrom wrote:
   Srini,
   
   I don't know what I'm doing wrong, but here's what I did and the output
   I got (munged for privacy -- uuu=username ppp=password ddd=domain
   sss=exchange server):
   
   [EMAIL PROTECTED] ~]$ export LD_LIBRARY_PATH=/opt/samba4/lib
   [EMAIL PROTECTED] ~]$ export MAPI_DEBUG=1
  
  Ah, this sounds challenging. You seem to be doing it right. Sure that
  you have the new mapi connector installed from the repo?
  
  -Srini.
 
___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers