Re: [Evolution-hackers] Exchange 2007 - MAPI Provider preview

2008-02-06 Thread Suman Manjunath
Hello Per, everyone

here's one important FYI from Julien Kerihuel of openchange:

to be able to use the MAPI plugin, your Exchange mailbox should be enabled
for MAPI. this is a setting on the server. it is a common issue to not have
it enabled.

request all of you to ensure that this setting is correct when using the
MAPI plugin. :)
apparently, this bug could sort-of be caught as soon as the profile-creation
happens.. will be looking more into it tomorrow.. although we might end up
getting the same MAPI_E_CALL_FAILED, it could be possible to identify if it
failed because of the above-mentioned reason.

-Suman
___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Exchange 2007 - MAPI Provider preview

2008-02-06 Thread Paul Smith
On Thu, 2008-02-07 at 00:47 +0530, Suman Manjunath wrote:
 to be able to use the MAPI plugin, your Exchange mailbox should be
 enabled for MAPI. this is a setting on the server. it is a common
 issue to not have it enabled.

Curious.  Does that mean that Outlook can talk to an Exchange mailbox
WITHOUT having it enabled for MAPI?  I would like to know more about
this.  One putative advantage of using MAPI, to me, would be that the
corporate IT department wouldn't even know you're using Evolution.  They
wouldn't have to make ANY changes specifically for Evo users, not even
to enable OWA (if they didn't have it enabled already).

So, if there are still Exchange mods that have to be made beyond what's
needed for Outlook users we should get in front of that I think.


Cheers!

-- 
-
 Paul D. Smith [EMAIL PROTECTED] http://make.mad-scientist.us
 Please remain calm--I may be mad, but I am a professional.--Mad Scientist



___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Exchange 2007 - MAPI Provider preview

2008-02-06 Thread Per Nystrom
On Wed, 2008-02-06 at 14:31 -0500, Paul Smith wrote:
 On Thu, 2008-02-07 at 00:47 +0530, Suman Manjunath wrote:
  to be able to use the MAPI plugin, your Exchange mailbox should be
  enabled for MAPI. this is a setting on the server. it is a common
  issue to not have it enabled.
 
 Curious.  Does that mean that Outlook can talk to an Exchange mailbox
 WITHOUT having it enabled for MAPI?  I would like to know more about
 this.  One putative advantage of using MAPI, to me, would be that the
 corporate IT department wouldn't even know you're using Evolution.  They
 wouldn't have to make ANY changes specifically for Evo users, not even
 to enable OWA (if they didn't have it enabled already).
 
 So, if there are still Exchange mods that have to be made beyond what's
 needed for Outlook users we should get in front of that I think.
 
 
 Cheers!
 

Agreed.  I thought MAPI is the protocol Outlook uses to communicate with
Exchange.  If this is not the case and there is some other uber-secret
special protocol instead, it would behoove us to figure that one out.

I don't expect my Exchange administrator to make any special
accommodations for me just because I use a different client than
Outlook.

Thanks,
Per


___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Exchange 2007 - MAPI Provider preview

2008-02-06 Thread Srinivasa Ragavan
Paul/Per,

IIRC Julien mentioned that to use Exchange 2007 against Outlook 2003,
the Public Folder store got to be created. Evolution with libmapi would
be like a Outlook 2003, connecting to Exchange 2007. It should be click
to activate it on the server. If not for Evolution, then it might be
asked for Outlook 2003 client to work with 2007 servers. If it isn't
there also, we possibly might get a failure during login.

-Srini.

On Wed, 2008-02-06 at 12:05 -0800, Per Nystrom wrote:
 On Wed, 2008-02-06 at 14:31 -0500, Paul Smith wrote:
  On Thu, 2008-02-07 at 00:47 +0530, Suman Manjunath wrote:
   to be able to use the MAPI plugin, your Exchange mailbox should be
   enabled for MAPI. this is a setting on the server. it is a common
   issue to not have it enabled.
  
  Curious.  Does that mean that Outlook can talk to an Exchange mailbox
  WITHOUT having it enabled for MAPI?  I would like to know more about
  this.  One putative advantage of using MAPI, to me, would be that the
  corporate IT department wouldn't even know you're using Evolution.  They
  wouldn't have to make ANY changes specifically for Evo users, not even
  to enable OWA (if they didn't have it enabled already).
  
  So, if there are still Exchange mods that have to be made beyond what's
  needed for Outlook users we should get in front of that I think.
  
  
  Cheers!
  
 
 Agreed.  I thought MAPI is the protocol Outlook uses to communicate with
 Exchange.  If this is not the case and there is some other uber-secret
 special protocol instead, it would behoove us to figure that one out.
 
 I don't expect my Exchange administrator to make any special
 accommodations for me just because I use a different client than
 Outlook.
 
 Thanks,
 Per
 
 
 ___
 Evolution-hackers mailing list
 Evolution-hackers@gnome.org
 http://mail.gnome.org/mailman/listinfo/evolution-hackers

___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Exchange 2007 - MAPI Provider preview

2008-02-06 Thread Per Nystrom
I guess I just don't understand then.  I can use Outlook 2003 with my
Exchange 2007 account no problem, but as you know I can't get past the
authentication using libmapi.

Thanks,
Per

On Thu, 2008-02-07 at 09:08 +0530, Srinivasa Ragavan wrote:
 Paul/Per,
 
 IIRC Julien mentioned that to use Exchange 2007 against Outlook 2003,
 the Public Folder store got to be created. Evolution with libmapi would
 be like a Outlook 2003, connecting to Exchange 2007. It should be click
 to activate it on the server. If not for Evolution, then it might be
 asked for Outlook 2003 client to work with 2007 servers. If it isn't
 there also, we possibly might get a failure during login.
 
 -Srini.
 
 On Wed, 2008-02-06 at 12:05 -0800, Per Nystrom wrote:
  On Wed, 2008-02-06 at 14:31 -0500, Paul Smith wrote:
   On Thu, 2008-02-07 at 00:47 +0530, Suman Manjunath wrote:
to be able to use the MAPI plugin, your Exchange mailbox should be
enabled for MAPI. this is a setting on the server. it is a common
issue to not have it enabled.
   
   Curious.  Does that mean that Outlook can talk to an Exchange mailbox
   WITHOUT having it enabled for MAPI?  I would like to know more about
   this.  One putative advantage of using MAPI, to me, would be that the
   corporate IT department wouldn't even know you're using Evolution.  They
   wouldn't have to make ANY changes specifically for Evo users, not even
   to enable OWA (if they didn't have it enabled already).
   
   So, if there are still Exchange mods that have to be made beyond what's
   needed for Outlook users we should get in front of that I think.
   
   
   Cheers!
   
  
  Agreed.  I thought MAPI is the protocol Outlook uses to communicate with
  Exchange.  If this is not the case and there is some other uber-secret
  special protocol instead, it would behoove us to figure that one out.
  
  I don't expect my Exchange administrator to make any special
  accommodations for me just because I use a different client than
  Outlook.
  
  Thanks,
  Per
  
  
  ___
  Evolution-hackers mailing list
  Evolution-hackers@gnome.org
  http://mail.gnome.org/mailman/listinfo/evolution-hackers

___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Exchange 2007 - MAPI Provider preview

2008-02-06 Thread Jules Colding

On Thu, 2008-02-07 at 09:08 +0530, Srinivasa Ragavan wrote:
 Paul/Per,
 
 IIRC Julien mentioned that to use Exchange 2007 against Outlook 2003,
 the Public Folder store got to be created. Evolution with libmapi would
 be like a Outlook 2003, connecting to Exchange 2007. It should be click
 to activate it on the server. If not for Evolution, then it might be
 asked for Outlook 2003 client to work with 2007 servers. If it isn't
 there also, we possibly might get a failure during login.


http://mail.gnome.org/archives/evolution-list/2008-January/msg00180.html


-- 
  jules



 -Srini.
 
 On Wed, 2008-02-06 at 12:05 -0800, Per Nystrom wrote:
  On Wed, 2008-02-06 at 14:31 -0500, Paul Smith wrote:
   On Thu, 2008-02-07 at 00:47 +0530, Suman Manjunath wrote:
to be able to use the MAPI plugin, your Exchange mailbox should be
enabled for MAPI. this is a setting on the server. it is a common
issue to not have it enabled.
   
   Curious.  Does that mean that Outlook can talk to an Exchange mailbox
   WITHOUT having it enabled for MAPI?  I would like to know more about
   this.  One putative advantage of using MAPI, to me, would be that the
   corporate IT department wouldn't even know you're using Evolution.  They
   wouldn't have to make ANY changes specifically for Evo users, not even
   to enable OWA (if they didn't have it enabled already).
   
   So, if there are still Exchange mods that have to be made beyond what's
   needed for Outlook users we should get in front of that I think.
   
   
   Cheers!
   
  
  Agreed.  I thought MAPI is the protocol Outlook uses to communicate with
  Exchange.  If this is not the case and there is some other uber-secret
  special protocol instead, it would behoove us to figure that one out.
  
  I don't expect my Exchange administrator to make any special
  accommodations for me just because I use a different client than
  Outlook.
  
  Thanks,
  Per
  
  
  ___
  Evolution-hackers mailing list
  Evolution-hackers@gnome.org
  http://mail.gnome.org/mailman/listinfo/evolution-hackers
 
 ___
 Evolution-hackers mailing list
 Evolution-hackers@gnome.org
 http://mail.gnome.org/mailman/listinfo/evolution-hackers

___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Exchange 2007 - MAPI Provider preview

2008-02-06 Thread William Murray

  Hi Per,
Could you try to connect again, using a completely fresh
account? Your symptoms look so like mine that I just feel it must be the
same. 
   BTW I do all these tests in a special test account to ensure my
normal email survives.
 Bill


___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers