Re: [Evolution-hackers] Compose Html Templates

2020-03-28 Thread Sasa Ostrouska via evolution-hackers
On Sat, Mar 28, 2020 at 3:11 PM Andre Klapper  wrote:
>
> On Sat, 2020-03-28 at 05:40 +0100, Axel Huizinga wrote:
> > how can I start do develop a template editor or is anyone already
> > working on one?
> > For now I tried to reuse templates created with thunderbird and I can
> > save them well in the templates folder but on use embedded images are
> > lost.
>
> There is some template support in Evolution:
> https://help.gnome.org/users/evolution/stable/mail-composer-message-templates
>
> If something with embedded images does not work in some templates
> folder in some Evolution version, then maybe provide more info.
> Or why some "Template Editor" is needed for something somewhere.

Hi Andre, for me for example happens that in the last times I work a lot with
emails to my suppliers, and most of them is with simple texts like
"Hello Person ! Can you please quote the following items ?"
Then I put my list of items and I write Best regards at the end.

If I prepare a template I could have the template already ready for various
suppliers, sometimes I have to put few other email addresses in the CC field.
So having a template for each supplier simplify my work and speeds it up too.

I am mostly using Evolution 3.20 , I know its a bit old, and I should
really switch to
the 3.36 in the upcoming months. But so far I found that if I create a template
some CC addresses do not get saved.
Also it is quite difficult still to create templates (at least in
3.20.x) not very
consinstent and intuitive on how to do it. Also I have not seen if I can
do some kind of shortcut to 2-3 emails or like a minigroup in the addressbook.

All this issues led me to think that would be good to step up and try
to improve that,
then Axel wrote his email and I am really interestedin the same thing.

Rgds
Sasa
>
> Thanks,
> andre
> --
> Andre Klapper  |  ak...@gmx.net
> https://blogs.gnome.org/aklapper/
>
>
> ___
> evolution-hackers mailing list
> evolution-hackers@gnome.org
> To change your list options or unsubscribe, visit ...
> https://mail.gnome.org/mailman/listinfo/evolution-hackers
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Compose Html Templates

2020-03-28 Thread Sasa Ostrouska via evolution-hackers
On Sat, Mar 28, 2020 at 9:16 PM Axel Huizinga  wrote:
>
> Am Samstag, den 28.03.2020, 15:00 +0100 schrieb Sasa Ostrouska:
>
> On Sat, Mar 28, 2020 at 5:47 AM Axel Huizinga <
>
> a...@econet4.me
>
> > wrote:
>
>
> Hi,
>
>
> Hi Axel,
>
>
> how can I start do develop a template editor or is anyone already working on 
> one?
>
> You have read my mind. I was thinking about this some time ago but
>
> since I am busy with other life things I left that
>
> apart. But I would be really interested in helping out and cooperate.
>
> I also think that evolution would benefit a lot of having a
>
> templates editor or some kind of template creation mechanism.
>
> Hi Sasa or Saxa?,
Either work well :)
>
> Sounds encouraging - any ideas how to access the data in the templates folder?
No I have no idea, I should take a deep look into the thing to
understand how it works.

>
> A simple source editor would be a useful first step.
>
>
>
> Rgds
>
> Saxa
>
>
> For now I tried to reuse templates created with thunderbird and I can save 
> them well in the templates folder but on use embedded images are lost.
>
>
> Best,
>
> Axel
>
> ___
>
> evolution-hackers mailing list
>
> evolution-hackers@gnome.org
>
>
> To change your list options or unsubscribe, visit ...
>
> https://mail.gnome.org/mailman/listinfo/evolution-hackers
>
>
> ___
> evolution-hackers mailing list
> evolution-hackers@gnome.org
> To change your list options or unsubscribe, visit ...
> https://mail.gnome.org/mailman/listinfo/evolution-hackers
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Compose Html Templates

2020-03-28 Thread Sasa Ostrouska via evolution-hackers
On Sat, Mar 28, 2020 at 5:47 AM Axel Huizinga  wrote:
>
> Hi,

Hi Axel,
>
> how can I start do develop a template editor or is anyone already working on 
> one?
You have read my mind. I was thinking about this some time ago but
since I am busy with other life things I left that
apart. But I would be really interested in helping out and cooperate.
I also think that evolution would benefit a lot of having a
templates editor or some kind of template creation mechanism.

Rgds
Saxa

> For now I tried to reuse templates created with thunderbird and I can save 
> them well in the templates folder but on use embedded images are lost.
>
> Best,
> Axel
> ___
> evolution-hackers mailing list
> evolution-hackers@gnome.org
> To change your list options or unsubscribe, visit ...
> https://mail.gnome.org/mailman/listinfo/evolution-hackers
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] evolution failing on TLSv1.3 after gnutls upgrade

2019-05-10 Thread Sasa Ostrouska via evolution-hackers
Hi all, and thanks Milan for the program. I also run an old version of
evolution 3.20.x and I get the following:

rc@rc-laptop:~/Downloads$ gcc `pkg-config --cflags --libs glib-2.0
gio-2.0` imap-conn.c -g -O0 -o imap-conn && ./imap-conn
imap.googlemail.com 993
Connected to imap.googlemail.com:993
Failed to read data from the server: Error reading data from TLS
socket: The specified session has been invalidated for some reason.

I neded to #include  on my slackware linux.

Rgds
Saxa

On Fri, May 10, 2019 at 5:07 PM James Bottomley via evolution-hackers
 wrote:
>
> On Fri, 2019-05-10 at 08:41 +0200, Milan Crha via evolution-hackers
> wrote:
> > On Thu, 2019-05-09 at 11:03 -0700, James Bottomley wrote:
> > > I can certainly test things out.
> >
> >   Hi,
> > that's great, thanks.
> >
> > > To be honest, I've had problems with TLSv1.3 every time it's been
> > > negotiated, so disabling it is a reasonable thing to do.
> >
> > I see. If you are still willing to help, then it'll be appreciated.
> >
> > > I suppose there's no gntuls-cli equivalent for glib-
> > > networking?  That
> > > would be the best way to test it.
> >
> > I agree, but I'm not aware of anything like that (which doesn't mean
> > it
> > doesn't exist). I made a little test program as promised, see the
> > attachment. The first line contains a comment with a command to
> > compile
> > and run it (against Google's IMAP server). It's only a test program,
> > mimic-ing what Evolution (or better Camel library from evolution-
> > data-
> > server) does. You may have installed development packages for glib
> > and,
> > if split, also for glib's gio, to be able to compile it.
> >
> >   Bye,
> >   Milan
> >
> > P.S.: The result of the run as is in the file itself is below:
> >
> >
> > $ ./imap-conn imap.googlemail.com 993
> >
> > Connected to imap.googlemail.com:993
> > Response: * OK Gimap ready for requests from {IPADDRESS} {SOMETOKEN}
> >
> > Request:  A01 CAPABILITY
> > Response: * CAPABILITY IMAP4rev1 UNSELECT IDLE NAMESPACE QUOTA ID
> > XLIST CHILDREN X-GM-EXT-1 XYZZY SASL-IR AUTH=XOAUTH2 AUTH=PLAIN
> > AUTH=PLAIN-CLIENTTOKEN AUTH=OAUTHBEARER AUTH=XOAUTH
> > A01 OK Thats all she wrote! {SOMETOKEN}
> >
> > Request:  A02 LOGOUT
> > Response: * BYE Logout Requested {SOMETOKEN}
> > A02 OK Quoth the raven, nevermore... {SOMETOKEN}
>
> So when I run it against my current setup (TLSv1.3 disabled) I get this
> as expected:
>
> jejb@jarvis:~> ./imap-conn bedivere.hansenpartnership.com 993
> Connected to bedivere.hansenpartnership.com:993
> Response: * OK [CAPABILITY IMAP4rev1 SASL-IR LOGIN-REFERRALS ID ENABLE IDLE 
> LITERAL+ AUTH=PLAIN] Dovecot (Debian) ready.
>
> Request:  A01 CAPABILITY
> Response: * CAPABILITY IMAP4rev1 SASL-IR LOGIN-REFERRALS ID ENABLE IDLE 
> LITERAL+ AUTH=PLAIN
>
> Request:  A02 LOGOUT
> Response: A01 OK Pre-login capabilities listed, post-login capabilities have 
> more.
>
> But when I enable TLSv1.3 in dovecot on the server I get this:
>
> jejb@jarvis:~> ./imap-conn bedivere.hansenpartnership.com 993
> Connected to bedivere.hansenpartnership.com:993
> Failed to read data from the server: Error reading data from TLS socket: The 
> specified session has been invalidated for some reason.
>
> Which isn't particularly helpful, although it does prove the issue is
> indeed in glib-networking.  Is there further debugging I should turn
> on?
>
> James
>
> ___
> evolution-hackers mailing list
> evolution-hackers@gnome.org
> To change your list options or unsubscribe, visit ...
> https://mail.gnome.org/mailman/listinfo/evolution-hackers
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Gmail TLS problem

2019-04-25 Thread Sasa Ostrouska via evolution-hackers
On Thu, Apr 25, 2019 at 4:30 PM Andre Klapper  wrote:
>
> Hi,
>
> On Thu, 2019-04-25 at 16:20 +0200, Sasa Ostrouska wrote:
> > Error while Retrieving folder list for 'x...@gmail.com'.
> > Error reading data from TLS socket: The specified session has been
> > invalidated for some reason.
>
> For the records there was a longer thread about it last month:
> https://mail.gnome.org/archives/evolution-list/2019-March/msg00077.html
>
> IMHO this is not a development related question so it should go to the
> evolution-list and not to evolution-hackers.
>
> andre
Hi Andre, many thanks for pointing that out. And sorry all to send it
to hackers list instead of
users one.

Will reply on the started thread on the other list but firstly I want
to check all is ok.

Rgds
Saxa
> --
> Andre Klapper  |  ak...@gmx.net
> https://blogs.gnome.org/aklapper/
>
>
> ___
> evolution-hackers mailing list
> evolution-hackers@gnome.org
> To change your list options or unsubscribe, visit ...
> https://mail.gnome.org/mailman/listinfo/evolution-hackers
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


[Evolution-hackers] Gmail TLS problem

2019-04-25 Thread Sasa Ostrouska via evolution-hackers
Hi, sorry for disturbing in here. I am using Evolution 3.20 and Its
quite some time now that I am unable to work normally anymore with
gmail imapx account.

Nearly everytime I am getting the following error message:

Error while Retrieving folder list for 'x...@gmail.com'.
Error reading data from TLS socket: The specified session has been
invalidated for some reason.

Sometimes it syncs but sometimes not. Does that have to do with
certificates or is google that changed something ?

It worked quite well before.

I tried to search for this error in the code but was unable to find
where this comes from.

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


[Evolution-hackers] Propper subject prefix when reply.

2015-11-11 Thread Sasa Ostrouska
Hi, I'm using evolution 3.12.11 , I know is a bit old but it works quite
well for me right now. But I noted an annoying issue when I do reply.

I work with many different countries so this means different languages. In
different
languages there is different prefix added to the email subject when you
reply.

Some people use R: others use RES: others Re: , in China there is special
characters and so on.

Now every time I get a conversation with another country I get the added
again and again this prefix (in my case Re: ) , and I end up with the
subject of the email
being as follows at the start:

Re: RES: Re: RES: some subject

Is there a way to tweak this so that evolution would have the possibility
to ignore or not add the Re: or better yet, recognize the various languages
reply prefixes ?

Was done some work in this direction ?

Rgds
Saxa

PS: Sorry if this is not the hackers list subject.
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Evolution 3.10.4 crash

2014-03-20 Thread Sasa Ostrouska
On Thu, Mar 20, 2014 at 8:51 AM, Milan Crha mc...@redhat.com wrote:

 On Wed, 2014-03-19 at 21:26 -0300, Sasa Ostrouska wrote:

  On Fri, 2014-03-07 at 17:05 +0100, Sasa
  Ostrouska wrote:
   I try to create a new folder through the
  Move to... function it
   crashes.
..
 
  Ok just filled up a bug on bugzilla:
  https://bugzilla.gnome.org/show_bug.cgi?id=726756
 
  Run it with CAMEL_DEBUG=all evolution

 Hi,

Hi Milan,


 CAMEL_DEBUG=all was not needed, I specifically asked for a backtrace,
 because it shows place of the crash, while CAMEL_DEBUG things are for
 different purposes.


Yep, thanks for the explanation, I saw it spawned a lot of database stuff.


 Anyway, I missed that you get the crash when creating a new folder,
 which is fixed by https://bugzilla.gnome.org/show_bug.cgi?id=722698

 Saw that you answered there on my bugzilla thread, thanks. I will apply
that patch
to our build.


 With respect of compiling with debug symbols, I usually use:
$ export CFLAGS='-g -O0'
 and then
$ ./configure ...  make  make install
 the projects.


Perfect, I supposed something like this would make it, I planned to made a
build of evo with debug symbols tonight at home but since
there is already a fix I will just apply the patch. Thanks anyway for the
CFLAGS thing.


 Bye,
 Milan

Rgds
Saxa




___
 evolution-hackers mailing list
 evolution-hackers@gnome.org
 To change your list options or unsubscribe, visit ...
 https://mail.gnome.org/mailman/listinfo/evolution-hackers

___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Evolution 3.10.4 crash

2014-03-11 Thread Sasa Ostrouska
On Mon, Mar 10, 2014 at 8:26 AM, Milan Crha mc...@redhat.com wrote:

 On Fri, 2014-03-07 at 17:05 +0100, Sasa Ostrouska wrote:
  Hello, I do have a problem with Evolution 3.10.4 , each time
 
  I try to create a new folder through the Move to... function it
  crashes.

 Hi,
 it works fine for me with evolution-3.10.4-2.fc20. You didn't tell where
 you create the folder, I tried under On This Computer.

 Hi Milan, I tried to create the folder with the Move To function dialog or
directly
on the side pane, under the On This Computer tree. To test I have
rightclick on the
side pane On This Computer and selected from the dropdown menu new folder.
The dialog appears entered the name test and clicking on create it crashes.



 You might want to install debuginfo packages for evolution-data-server,
 evolution and any other evolution-* package you use, then reproduce the
 crash when having evolution run under gdb:
$ gdb evolution --ex r --ex t a a bt --ex q
 which will produce backtrace of the crash.


I will try to recompile evolution with debug info and install it.


 Nonetheless, such reports belong to bugzilla, not to the mailing list:
 https://bugzilla.gnome.org/enter_bug.cgi?product=evolution


I'm sorry, I will open a bug on the bugzilla.gnome.org when i have the
backtrace.


 Bye,
 Milan

 Rgds
Saxa


 ___
 evolution-hackers mailing list
 evolution-hackers@gnome.org
 To change your list options or unsubscribe, visit ...
 https://mail.gnome.org/mailman/listinfo/evolution-hackers

___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


[Evolution-hackers] Evolution 3.10.4 crash

2014-03-07 Thread Sasa Ostrouska
Hello, I do have a problem with Evolution 3.10.4 , each time
I try to create a new folder through the Move to... function it crashes.

I tried to run it from a terminal but unfortunately doesnt give me much
info:

rc@rclaptop:~$ evolution
Migrating cached data
Migrating config data
Migrating local user data
  rmdir /home/rc/.evolution/tasks
  FAILED: Directory not empty (contents follows)
  tasks
Segmentation fault
rc@rclaptop:~$


To reproduce the crash I do: Start evolution, right-click on an message in
the inbox folder, select move to... , then right-click on an existing
folder,and select create new.. , put in the name and click on create, at
this point it crashes.

In 3.10.3 this was working ok.

Can somebody confirm ?

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] geocode-glib version

2013-09-01 Thread Sasa Ostrouska
On Sun, Sep 1, 2013 at 2:07 PM, Matthew Barnes mbar...@redhat.com wrote:

 On Sun, 2013-09-01 at 13:12 -0300, Sasa Ostrouska wrote:
  Hi I was just wondering if is there a special reason to use
  geocode-glib version 0.99.0 as there is
 
  already out a 0.99.2 so would be nice to have in configure.ac
  geocode-glib = 0.99.0 instead of geocode-glib = 0.99.0

 There were substantial API changes on the master branch of geocode-glib
 that we don't yet support.

 Ok understood.


 I don't yet know if 0.99.2 includes those changes or if it's backward
 compatible with 0.99.0.

 The changes are listed here:
http://ftp.acc.umu.se/pub/GNOME/sources/geocode-glib/0.99/geocode-glib-0.99.1.changes
and
http://ftp.acc.umu.se/pub/GNOME/sources/geocode-glib/0.99/geocode-glib-0.99.2.changes

but i think the .news files are easier to read:

http://ftp.acc.umu.se/pub/GNOME/sources/geocode-glib/0.99/geocode-glib-0.99.1.news
http://ftp.acc.umu.se/pub/GNOME/sources/geocode-glib/0.99/geocode-glib-0.99.2.news


If it's backward compatible then we can support it for Evolution 3.10,
 otherwise it has to wait for Evolution 3.11/3.12.

 Matthew Barnes

 Ok thanks for the answer.

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Reconsidering our release cycle

2013-07-23 Thread Sasa Ostrouska
On Tue, Jul 23, 2013 at 4:43 PM, Sasa Ostrouska cas...@gmail.com wrote:




 On Tue, Jul 23, 2013 at 4:10 PM, Matthew Barnes mbar...@redhat.comwrote:

 I've been kicking around this idea for awhile now, but haven't said
 anything until now.  I'm putting it out there as food for thought.

 Increasingly I'm feeling like the traditional 6-month release cycle is
 just too short for Evolution.  In terms of development, we have a pretty
 short window for landing major changes and allowing adequate time for
 testing before development freezes set in.

 But more importantly, our users seem to be constantly playing catch-up
 in terms of supported releases.  Because of the delay between upstream
 releases and distro releases, by the time users finally upgrade to a
 newer Evolution, more often than not they're upgrading to a version
 that's either nearing the tail end of its 6-month support window or is
 already unsupported.

 That's frustrating, both for users and for me as a developer, but we
 just don't have the manpower to support multiple stable releases and
 still get any kind of significant development work done.

 I'd like us to consider moving to a 12-month release cycle, which would
 sync up with GNOME's release schedule annually instead of semi-annually.

 Here's my initial proposal, if you guys are open to this:

 * Continue with the 6-month releases through the end of the year, just
   because I think we need more lead time for such a major policy change.

 * Bump Evolution's major version number to split away from GNOME's
   semi-annual release numbering.  Call the upcoming March 2014 release
   Evolution 4.0 (or perhaps even Evolution 2014... I'm open to ideas).

 * We would follow GNOME's string change announcement and freeze schedule
   in the months leading up to each March release.

 * We would continue releasing stable updates and development snapshots
   at a steady pace.  Our release schedule could even be more predictable
   than it is now.  We could do, for example, stable releases on the 1st
   Monday of each month and development snapshots on the 3rd Monday.

 Obviously there's more details to figure out, but I like the precedent
 we've set with the 3.8 branch, and I think our users appreciate it too.

 My feeling is just that at this point in the project's lifespan, our
 users would be better served by a longer support window.  They still
 want to see improvements and new features, but more than anything I
 think they just want stability and to see their bugs fixed without
 waiting half a year.

 It's just an idea.  What do you guys think?

 Matt


 More as a user than as a dev, but yes, I fully agree with you. Evolution
 is an important piece of software in my business.
 I have been using 2.26.3 up to half yer ago, as upgrading all the time in
 terms of business is really a pain in the ass and
 not worth for the few new features you can get.

 Another thing is that as you say it is important to have a stable and rock
 solid application. This is something you can get
 with good checking and testing. Of course this needs time and not only.

 So if my voice can have some impact, I'm all for a longer release cycle
 and well done development. Things done in a hurry
 usually are not good or well done.

 Especially when we talk about free software where contributors have their
 real life to take care of.

 Rgds
 Saxa


 ___
 evolution-hackers mailing list
 evolution-hackers@gnome.org
 To change your list options or unsubscribe, visit ...
 https://mail.gnome.org/mailman/listinfo/evolution-hackers



___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] crash in 3.8.2

2013-06-04 Thread Sasa Ostrouska
On Mon, Jun 3, 2013 at 6:41 AM, Milan Crha mc...@redhat.com wrote:

 On Sat, 2013-06-01 at 16:42 -0300, Sasa Ostrouska wrote:
  Ok, since I got no reply from here, I did a search and found some
  interesting things.
 
  Can somebody confirm if this is an xorg-server problem or a gnome
  one ?
 
  http://lists.debian.org/debian-x/2012/12/msg00133.html
  https://bbs.archlinux.org/viewtopic.php?pid=1263647
 

 Hi,
 I'm sorry for a late response, I could not get the external link
 content, it required login. Nonetheless, if it's exactly the same issue
 as in those two you mentioned above, then I agree it can be an issue
 with  either xorg, or gnome. I do not know which one, I believe you
 should rather ask on a gnome/gtk/xorg mailing lists, rather than on
 the evolution list.
 Bye,
 Milan

 No problem, thanks for the response. The issue is nearly the same, I have
no idea
on what those codes from BadImplementation error means, but no matter, I
will try to patch xorg-server
and see if it fixes. If so, I will report back. Thanks for now.

Rgds
Saxa


 ___
 evolution-hackers mailing list
 evolution-hackers@gnome.org
 To change your list options or unsubscribe, visit ...
 https://mail.gnome.org/mailman/listinfo/evolution-hackers

___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] crash in 3.8.2

2013-06-01 Thread Sasa Ostrouska
Ok, since I got no reply from here, I did a search and found some
interesting things.
Can somebody confirm if this is an xorg-server problem or a gnome one ?

http://lists.debian.org/debian-x/2012/12/msg00133.html
https://bbs.archlinux.org/viewtopic.php?pid=1263647

Rgds
Saxa


On Wed, May 22, 2013 at 12:15 AM, Sasa Ostrouska cas...@gmail.com wrote:




 On Mon, May 13, 2013 at 3:59 AM, Milan Crha mc...@redhat.com wrote:

 On Sun, 2013-05-12 at 16:37 -0300, Sasa Ostrouska wrote:
  bash-4.2$ export GDK_SYNCHRONIZE
  bash-4.2$ evolution
  Fontconfig warning: /etc/fonts/conf.d/44-wqy-zenhei.conf, line 11:
  Having multiple values in test isn't supported and may not work as
  expected
 
  (evolution:11791): Gdk-ERROR **: The program 'evolution' received an X
  Window System error.
  This probably reflects a bug in the program.
  The error was 'BadImplementation (server does not implement
  operation)'.

 Hi,


 Hi Milan,


 I would try to build-with/install debuginfo for evolution packages and
 then run evolution like above, only under gdb, and get a backtrace where
 it failed. Maybe it'll give a clue.

$ GDK_SYNCHRONIZE=1 gdb evolution --ex r --ex t a a bt

 I have tried this , and you can see what is the output here in the
 attached file.



 Alternatively you can follow the hint of the crash, and do this:

$ GDK_SYNCHRONIZE=1 gdb evolution --ex b gdk_x_error --ex r --ex t
 a a bt

 but that might not work without debuginfo packages for gtk3 (gdb might
 not find the gdk_x_error function).

 By the way, do you compile evolution with clutter? (Clutter is basically
 unsupported in evolution currently.) What is the GDK backend you use?
 (It's known it crashes with wayland on start, though I do not know where
 or why).
 Bye,
 Milan

 I need to check if configure pick up clutter, also i need to check what
 backend is using gdk.
 Will let you know.
 And yes, I have a my own compilled version as i'm packaging it for our
 project, www.droplinegnome.org.

 Rgds
 Saxa
  
 evolution.txthttps://docs.google.com/file/d/0B26aYegM9MTkVjVKMENxNUFMT2M/edit?usp=drive_web


 ___
 evolution-hackers mailing list
 evolution-hackers@gnome.org
 To change your list options or unsubscribe, visit ...
 https://mail.gnome.org/mailman/listinfo/evolution-hackers



___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] crash in 3.8.2

2013-05-21 Thread Sasa Ostrouska
On Mon, May 13, 2013 at 3:59 AM, Milan Crha mc...@redhat.com wrote:

 On Sun, 2013-05-12 at 16:37 -0300, Sasa Ostrouska wrote:
  bash-4.2$ export GDK_SYNCHRONIZE
  bash-4.2$ evolution
  Fontconfig warning: /etc/fonts/conf.d/44-wqy-zenhei.conf, line 11:
  Having multiple values in test isn't supported and may not work as
  expected
 
  (evolution:11791): Gdk-ERROR **: The program 'evolution' received an X
  Window System error.
  This probably reflects a bug in the program.
  The error was 'BadImplementation (server does not implement
  operation)'.

 Hi,


Hi Milan,


 I would try to build-with/install debuginfo for evolution packages and
 then run evolution like above, only under gdb, and get a backtrace where
 it failed. Maybe it'll give a clue.

$ GDK_SYNCHRONIZE=1 gdb evolution --ex r --ex t a a bt

 I have tried this , and you can see what is the output here in the
attached file.



 Alternatively you can follow the hint of the crash, and do this:

$ GDK_SYNCHRONIZE=1 gdb evolution --ex b gdk_x_error --ex r --ex t a
 a bt

 but that might not work without debuginfo packages for gtk3 (gdb might
 not find the gdk_x_error function).

 By the way, do you compile evolution with clutter? (Clutter is basically
 unsupported in evolution currently.) What is the GDK backend you use?
 (It's known it crashes with wayland on start, though I do not know where
 or why).
 Bye,
 Milan

 I need to check if configure pick up clutter, also i need to check what
backend is using gdk.
Will let you know.
And yes, I have a my own compilled version as i'm packaging it for our
project, www.droplinegnome.org.

Rgds
Saxa

 
evolution.txthttps://docs.google.com/file/d/0B26aYegM9MTkVjVKMENxNUFMT2M/edit?usp=drive_web


 ___
 evolution-hackers mailing list
 evolution-hackers@gnome.org
 To change your list options or unsubscribe, visit ...
 https://mail.gnome.org/mailman/listinfo/evolution-hackers

___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


[Evolution-hackers] crash in 3.8.2

2013-05-12 Thread Sasa Ostrouska
Hi all !

I get this:

bash-4.2$ evolution

** (evolution:11746): WARNING **: Unrecognized junk filter name
'Bogofilter' in GSettings
Fontconfig warning: /etc/fonts/conf.d/44-wqy-zenhei.conf, line 11: Having
multiple values in test isn't supported and may not work as expected

(evolution:11746): Gdk-ERROR **: The program 'evolution' received an X
Window System error.
This probably reflects a bug in the program.
The error was 'BadImplementation (server does not implement operation)'.
  (Details: serial 6704 error_code 17 request_code 142 minor_code 46)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap
bash-4.2$ export GDK_SYNCHRONIZE
bash-4.2$ evolution
Fontconfig warning: /etc/fonts/conf.d/44-wqy-zenhei.conf, line 11: Having
multiple values in test isn't supported and may not work as expected

(evolution:11791): Gdk-ERROR **: The program 'evolution' received an X
Window System error.
This probably reflects a bug in the program.
The error was 'BadImplementation (server does not implement operation)'.
  (Details: serial 4165 error_code 17 request_code 142 minor_code 46)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap
bash-4.2$


Any ideas how to solve that ?

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


[Evolution-hackers] EDS 3.8.1 build problem

2013-04-14 Thread Sasa Ostrouska
Hi, I'm trying to upgrade my evolution from 3.6.x to 3.8.x and I get the
build brake at the tests.
See below:

Making all in libebook-contacts
make[3]: Entering directory
`/tmp/DLG/work/evolution-data-server-3.8.1-1/evolution-data-server-3.8.1/tests/libebook-contacts'
  CC   test_contact_types-test-contact-types.o
  CCLD test-contact-types
../../addressbook/libebook-contacts/.libs/libebook-contacts-1.2.so:
undefined reference to `e_enum_from_string'
../../addressbook/libebook-contacts/.libs/libebook-contacts-1.2.so:
undefined reference to `e_enum_to_string'
collect2: error: ld returned 1 exit status
make[3]: *** [test-contact-types] Error 1
make[3]: Leaving directory
`/tmp/DLG/work/evolution-data-server-3.8.1-1/evolution-data-server-3.8.1/tests/libebook-contacts'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
`/tmp/DLG/work/evolution-data-server-3.8.1-1/evolution-data-server-3.8.1/tests'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
`/tmp/DLG/work/evolution-data-server-3.8.1-1/evolution-data-server-3.8.1'
make: *** [all] Error 2

I attach the configure log also. If needed I can also send the make log.

Any idea of what is wrong here ?

Rgds
Saxa
checking for a BSD-compatible install... /usr/bin/ginstall -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar
checking whether make supports nested variables... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.16... yes
checking whether to enable phonenumber support... check
checking for style of include used by make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for supported compiler flags...  -Wall -Wextra 
-Wdeprecated-declarations -Werror-implicit-function-declaration 
-Wformat-security -Winit-self -Wmissing-declarations -Wmissing-include-dirs 
-Wmissing-noreturn -Wpointer-arith -Wredundant-decls -Wundef -Wwrite-strings 
-Wdeclaration-after-statement -Wno-missing-field-initializers -Wno-sign-compare 
-Wno-unused-parameter -Wnested-externs
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking for supported compiler flags...  -Wall -Wextra 
-Wdeprecated-declarations -Werror-implicit-function-declaration 
-Wformat-security -Winit-self -Wmissing-declarations -Wmissing-include-dirs 
-Wmissing-noreturn -Wpointer-arith -Wredundant-decls -Wundef -Wwrite-strings 
-Wabi -Wnoexcept
checking if strict building is enabled... no
checking whether to enable maintainer-specific portions of Makefiles... yes
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking how to run the C preprocessor... gcc -E
checking for inline... inline
checking whether gcc and cc understand -c and -o together... yes
checking whether ln -s works... yes
checking whether make sets $(MAKE)... (cached) yes
checking for python... /usr/bin/python
checking for python version... 2.7
checking for python platform... linux2
checking for python script directory... ${prefix}/lib64/python2.7/site-packages
checking for python extension module directory... 
${exec_prefix}/lib64/python2.7/site-packages
checking whether NLS is requested... yes
checking for intltool = 0.35.5... 0.50.2 found
checking for intltool-update... /usr/bin/intltool-update
checking for intltool-merge... /usr/bin/intltool-merge
checking for intltool-extract... /usr/bin/intltool-extract
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for perl... /usr/bin/perl
checking for perl = 5.8.1... 5.16.3
checking for XML::Parser... ok
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking how to print strings... printf
checking for a sed that does not truncate output... /usr/bin/sed
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for fgrep... /usr/bin/grep -F
checking for ld used by gcc... /usr/x86_64-slackware-linux/bin/ld
checking if the linker (/usr/x86_64-slackware-linux/bin/ld) is GNU ld... yes
checking for 

Re: [Evolution-hackers] Evolution crashes while creating appointment from Mail

2013-04-08 Thread Sasa Ostrouska
I tried it too to reproduce it on 3.6.4 it didnt crash for me.

Rgds
Saxa


On Mon, Apr 8, 2013 at 10:00 AM, Milan Crha mc...@redhat.com wrote:

 On Mon, 2013-04-08 at 09:51 +0530, samarjit Adhikari wrote:
  If 1 more person can reproduce the crash along with me , I will go
  ahead and report it in Bugzilla.
 
  Are you able to reproduce using my given steps ?

 Hi,
 I tried in (to be) 3.9.1 (git master), on your original email in this
 thread, and after Discard I clicked on Johnny's reply to your message,
 and evolution didn't crash to me. It doesn't mean the bug is not
 present, it just means that it can depend on various factors. For
 example, I did this testing in my IMAP folder. On the other hand, there
 is a chance that 3.8.0 has it fixed.
 Bye,
 Milan

 ___
 evolution-hackers mailing list
 evolution-hackers@gnome.org
 To change your list options or unsubscribe, visit ...
 https://mail.gnome.org/mailman/listinfo/evolution-hackers

___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


[Evolution-hackers] evolution-mapi and evolution-ews

2013-01-30 Thread Sasa Ostrouska
Hi I'm trying to build the evolution-mapi and evolution-ews plugins for 3.6.3.

It seems that they are not finding the correct version of my
evolution-data-server-1.2 .

By looking into the thing I saw that they use pkg-config --libs in the
configure script and not pkg-config --modversion
to determine the version of evolution-data-server-1.2.

Now the strange thing is that I build up evolution-kolab without any problem.

What I get is the following:

root@slack14:/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/dbs-trunk#
pkg-config --libs evolution-data-server-1.2
Empty package name in Requires or Conflicts in file
'/usr/lib64/pkgconfig/evolution-data-server-1.2.pc'

root@slack14:/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/dbs-trunk#
pkg-config --modversion evolution-data-server-1.2
3.6.3

If I issue pkg-config --libs evolution-mail-3.0 I get the following:
root@slack14:/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/dbs-trunk#
pkg-config --libs evolution-mail-3.0-Wl,-R/usr/lib64/evolution/3.6
-Wl,--export-dynamic -pthread -L/usr/lib64/evolution/3.6
-levolution-mail -lcomposer -leshell -lemiscwidgets -leutil
-lemail-engine -ledataserverui-3.0 -lwebkitgtk-3.0 -lebook-1.2
-ljavascriptcoregtk-3.0 -lemail-utils -levolution-utils -lebackend-1.2
-lgtk-3 -lgdk-3 -latk-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0
-lcairo-gobject -lpango-1.0 -lcairo -ledataserver-1.2 -lgmodule-2.0
-lrt -lcamel-1.2 -lplc4 -lplds4 -lnspr4 -lssl3 -lsmime3 -lnss3
-lgnome-keyring -lxml2 -lsoup-2.4 -lsqlite3 -ldl -lgio-2.0
-lgobject-2.0 -lglib-2.0

Is there some problem in my build of evolution data server ?

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] mail migration

2012-12-16 Thread Sasa Ostrouska
On Mon, Dec 17, 2012 at 12:45 AM, Sasa Ostrouska cas...@gmail.com wrote:
 On Sun, Dec 16, 2012 at 10:56 PM, Sasa Ostrouska cas...@gmail.com wrote:
 On Sat, Dec 15, 2012 at 1:38 AM, Sasa Ostrouska cas...@gmail.com wrote:
 On Sat, Dec 15, 2012 at 12:38 AM, Adam Tauno Williams
 awill...@whitemice.org wrote:
 On Fri, 2012-12-14 at 23:29 +0100, Sasa Ostrouska wrote:
 On Fri, Dec 14, 2012 at 9:10 PM, Adam Tauno Williams
 awill...@whitemice.org wrote:
  On Fri, 2012-12-14 at 04:54 +0100, Sasa Ostrouska wrote:
  Hi I know this is not direclty related to hacking on evolution, but I
  would like to ask one advice.
  I have about 5Gb of e-mails on my laptop which I use for work, and it
  is still on evolution 2.26.3.
  I would like to migrate now this stuff to evolution 3.6.x
  What is the best way to do that ?
  Simply upgrading evolution seems not to work, as it starts the wizard
  as if .evolution dir doesnt exist.
 
  If all you want to do is mail then it seems like it wouldn't be a bad
  idea to make an 'external' local account (maildir or mbox [not certain
  what is available in 2.26]) and then just copy all your mail.  Upgrade.
  'Reconnect' the new evolution to that account.
 Ok how can I do that external account ? You mean use something else
 like Thunderbird ?

 No, I mean you can make an account in Evolution that stores mail locally
 in a 'standard' format like MBOX or MailDir.  You specify a directory
 and mail and mailboxes are stored in that format there.  Then you can
 just drag the mail from your On this computer mailbox (assuming you
 are POP'ing into that from somewhere).  Then you have the mail 'outside
 of Evolution'.  And the new version of Evolution can look in the same
 place for mail; you can either copy it back into on-this-computer
 [assuming it doesn't transfer automatically] after you upgrade, or just
 continue using the 'external' mail store.

 I believe this is an option for 2.26, which I certain could do at least
 MBOX, if no MH.  But I don't really remember the 2.x series that well
 [it has been a long time].

 Ok all my mail is pop and its stored on my few computers, I rsync them 
 arround.
 So all I have is a huge .evolution directory, with all what is made and 
 used by
 evolution-2.26.3 . I will try your suggestion.

 Rgds
 Saxa

 Another question I have, to install evolution 3.0.x do I need to
 install also evolution-data-server-3.0.x or can I do that with
 evolution-data-server-3.6.x ?

 Rgds
 Saxa

 Ok it seems that downgrading my evolution to 3.0.x is not an option,
 missing a lot of stuff aas deps and would meant
 to downgrade a lot of things, from gtk on.

 So I will opt for the other option as Adam suggested.

 Rgds
 Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] mail migration

2012-12-14 Thread Sasa Ostrouska
On Fri, Dec 14, 2012 at 11:24 PM, Sasa Ostrouska cas...@gmail.com wrote:
 On Fri, Dec 14, 2012 at 5:55 PM, Matthew Barnes mbar...@redhat.com wrote:
 On Fri, 2012-12-14 at 04:54 +0100, Sasa Ostrouska wrote:
 I have about 5Gb of e-mails on my laptop which I use for work, and it
 is still on evolution 2.26.3.
 I would like to migrate now this stuff to evolution 3.6.x

 What is the best way to do that ?

 Hi Sasa,
 Hi Matthew,

 While Evolution does try to automatically migrate data when necessary
 after upgrading, this is intended more for incremental upgrades, say
 from 3.4 to 3.6.

 Ok got it, thanks for this info.


 Automatic data migration becomes less tested and therefore more risky
 the more versions you skip.  Going from 2.26 to 3.6 is a huge leap!

 Yup, I believe so. But maybe its worth a try, I have many backups of
 my .evolution dir.
 I saw that 2.26 has an export option in File menu, but I suppose this
 is only for configurations
 of the accounts, or am I wrong ?

 I recommend breaking the upgrade into at least two steps, particularly
 2.26 - 3.0 - 3.6.

 Ok, will try that.

 Evolution 3.0 was the first version to convert your local mail from mbox
 format to Maildir format.  Do that first, and once you verify your local
 mail is in tact, proceed to 3.6.

 Ok very clear. Is Maildir very different from mbox ? And why the team
 has choosen to
 change the format of archiving mail ? I'm not an expert, just curious.

 Evolution 3.6 was the first version to convert your account info from
 GConf entries to plaintext data files.  Account info is now stored in
 ~/.config/evolution/sources where it's much easier to backup and copy.
 The contents of this directory determine whether Evolution runs the
 account wizard on startup.

 Ok very clear, will try to look at this data in .config/evolution .
 Now, can you please point out
 if its there some documentation about the 2.26.x evolution config and
 .evolution dir files ?

 Also if i remember well some time ago the old evo maintainer, I think
 Sirinisa or something like that
 pointed out some conversion utilities he made , maybe I'm wrong. Will
 try to search a bit the mail archives.

 Matthew Barnes

 Thanks
 Sasa

___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] mail migration

2012-12-14 Thread Sasa Ostrouska
On Fri, Dec 14, 2012 at 9:10 PM, Adam Tauno Williams
awill...@whitemice.org wrote:
 On Fri, 2012-12-14 at 04:54 +0100, Sasa Ostrouska wrote:
 Hi I know this is not direclty related to hacking on evolution, but I
 would like to ask one advice.
 I have about 5Gb of e-mails on my laptop which I use for work, and it
 is still on evolution 2.26.3.
 I would like to migrate now this stuff to evolution 3.6.x
 What is the best way to do that ?
 Simply upgrading evolution seems not to work, as it starts the wizard
 as if .evolution dir doesnt exist.

 If all you want to do is mail then it seems like it wouldn't be a bad
 idea to make an 'external' local account (maildir or mbox [not certain
 what is available in 2.26]) and then just copy all your mail.  Upgrade.
 'Reconnect' the new evolution to that account.

Ok how can I do that external account ? You mean use something else
like Thunderbird ?


 For contacts you can also select them all, save to a VCF file, and then
 import that VCF files.  That isn't bad as a backup in any case.

Ok thats clear. Thanks.
Sasa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] mail migration

2012-12-14 Thread Sasa Ostrouska
On Sat, Dec 15, 2012 at 12:38 AM, Adam Tauno Williams
awill...@whitemice.org wrote:
 On Fri, 2012-12-14 at 23:29 +0100, Sasa Ostrouska wrote:
 On Fri, Dec 14, 2012 at 9:10 PM, Adam Tauno Williams
 awill...@whitemice.org wrote:
  On Fri, 2012-12-14 at 04:54 +0100, Sasa Ostrouska wrote:
  Hi I know this is not direclty related to hacking on evolution, but I
  would like to ask one advice.
  I have about 5Gb of e-mails on my laptop which I use for work, and it
  is still on evolution 2.26.3.
  I would like to migrate now this stuff to evolution 3.6.x
  What is the best way to do that ?
  Simply upgrading evolution seems not to work, as it starts the wizard
  as if .evolution dir doesnt exist.
 
  If all you want to do is mail then it seems like it wouldn't be a bad
  idea to make an 'external' local account (maildir or mbox [not certain
  what is available in 2.26]) and then just copy all your mail.  Upgrade.
  'Reconnect' the new evolution to that account.
 Ok how can I do that external account ? You mean use something else
 like Thunderbird ?

 No, I mean you can make an account in Evolution that stores mail locally
 in a 'standard' format like MBOX or MailDir.  You specify a directory
 and mail and mailboxes are stored in that format there.  Then you can
 just drag the mail from your On this computer mailbox (assuming you
 are POP'ing into that from somewhere).  Then you have the mail 'outside
 of Evolution'.  And the new version of Evolution can look in the same
 place for mail; you can either copy it back into on-this-computer
 [assuming it doesn't transfer automatically] after you upgrade, or just
 continue using the 'external' mail store.

 I believe this is an option for 2.26, which I certain could do at least
 MBOX, if no MH.  But I don't really remember the 2.x series that well
 [it has been a long time].

Ok all my mail is pop and its stored on my few computers, I rsync them arround.
So all I have is a huge .evolution directory, with all what is made and used by
evolution-2.26.3 . I will try your suggestion.

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


[Evolution-hackers] mail migration

2012-12-13 Thread Sasa Ostrouska
Hi I know this is not direclty related to hacking on evolution, but I
would like to ask one advice.

I have about 5Gb of e-mails on my laptop which I use for work, and it
is still on evolution 2.26.3.
I would like to migrate now this stuff to evolution 3.6.x

What is the best way to do that ?

Simply upgrading evolution seems not to work, as it starts the wizard
as if .evolution dir doesnt exist.

Any tools around ?

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


[Evolution-hackers] Error while expunging folder

2011-01-04 Thread Sasa Ostrouska
Hi , I get the following error while CTRL-E.

Error storing '~/.evolution/mail/local/RC-2011/CLIENTI/SDST (mbox)':
Error storing '~/.evolution/mail/local/RC-2011/CLIENTI/DSM (mbox)':
Error storing '~/.evolution/mail/local/BRASTRAK-2011/CLIENTES/TRACTORTERRA
(mbox)': Error storing '~/.evolution/mail/local/BRASTRAK-2011/CLIENTES
(mbox)': Error storing
'~/.evolution/mail/local/RC-2011/VARIO/CHINA/ALL POWER (mbox)': Error
storing '~/.evolution/mail/local/RC-2011/VARIO/CHINA (mbox)': Error
storing '~/.evolution/mail/local/RC-2011/VARIO/XE_CURRENCY (mbox)':
Error storing '~/.evolution/mail/local/RC-2011/FORNITORI/GROUP-ITM
(mbox)': Error storing
'~/.evolution/mail/local/Sasa-Private/ALUGUETEMPORADA (mbox)': Error
storing '~/.evolution/mail/local/Sent (mbox)': Error storing
'~/.evolution/mail/local/Inbox (mbox)': Summary and folder mismatch,
even after a sync


How can I correct this ?

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] Error while expunging folder

2011-01-04 Thread Sasa Ostrouska
On Tue, Jan 4, 2011 at 8:11 AM, Akhil Laddha lak...@novell.com wrote:
 Hi Saxa,

 On Tue, 2011-01-04 at 11:43 +-0100, Sasa Ostrouska wrote:
 +AD4 Hi , I get the following error while CTRL-E.
 +AD4
 +AD4 Error storing '+AH4-/.evolution/mail/local/RC-2011/CLIENTI/SDST (mbox)':
 +AD4 Error storing '+AH4-/.evolution/mail/local/RC-2011/CLIENTI/DSM (mbox)':
 +AD4 Error storing 
 '+AH4-/.evolution/mail/local/BRASTRAK-2011/CLIENTES/TRACTORTERRA
 +AD4 (mbox)': Error storing 
 '+AH4-/.evolution/mail/local/BRASTRAK-2011/CLIENTES
 +AD4 (mbox)': Error storing
 +AD4 '+AH4-/.evolution/mail/local/RC-2011/VARIO/CHINA/ALL POWER (mbox)': Error
 +AD4 storing '+AH4-/.evolution/mail/local/RC-2011/VARIO/CHINA (mbox)': Error
 +AD4 storing '+AH4-/.evolution/mail/local/RC-2011/VARIO/XE+AF8-CURRENCY 
 (mbox)':
 +AD4 Error storing '+AH4-/.evolution/mail/local/RC-2011/FORNITORI/GROUP-ITM
 +AD4 (mbox)': Error storing
 +AD4 '+AH4-/.evolution/mail/local/Sasa-Private/ALUGUETEMPORADA (mbox)': Error
 +AD4 storing '+AH4-/.evolution/mail/local/Sent (mbox)': Error storing
 +AD4 '+AH4-/.evolution/mail/local/Inbox (mbox)': Summary and folder mismatch,
 +AD4 even after a sync
 +AD4
 +AD4
 +AD4 How can I correct this ?
 +AD4

 Please ask these queries on more relevant list which is
 evolution-list+AEA-gnome.org

 Regarding your problem, please read
 http://live.gnome.org/Evolution/FAQ+ACM-Why+AF8-do+AF8-I+AF8-get+AF8-an+AF8-error+AF8.22Summary+AF8-and+AF8-folder+AF8-mismatch.2C+AF8-even+AF8-after+AF8-a+AF8-sync.22.3F

 - Akhil

Thanks Akhil, sorry for disturbig, I thought this was the only list
for evolution.

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers


[Evolution-hackers] REFRESHING INBOX

2011-01-03 Thread Sasa Ostrouska
Hi , happy new year 2011 to all.

I'm using evolution a long time now, and the last version I use for
now is a way outdated
since it is 2.26.3 but I have a desktop on gnome 2.26.x and will soon
try to upgrade to the
last stable 2.32 one. But since I have about 4GB of mails of my work
in it I'm trying to do
that carefully.

Ok the problem I have is that when I move some directory under my
Inbox tree all the e-mails
I have in there disappear. They are just not showed, I'm sure of that
because if I vim the
.evolution/mail/local/Inbox.sdb/mydir.sdb/mydir I see all of the
missing messages in that file.

Accidentally I have dragged Inbox into some other dir, and then when I
moved it back to its
original location same thing happened.

Now I would like to ask, is there a way of redisplaying the e-mails ?

How exactly the e-mail files structure under .evolution/mail/local works ?
There are .sdb directories .cmeta .ibex.index files and others. What
is the purpose
of those files and how they are created ?


Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] evolution-2.32.1 build error

2010-12-09 Thread Sasa Ostrouska
On Thu, Dec 9, 2010 at 8:46 AM, Thomas Mittelstaedt
tmsta...@t-mittelstaedt.de wrote:
 Am Mittwoch, den 08.12.2010, 14:37 +0100 schrieb Sasa Ostrouska:
 On Wed, Dec 8, 2010 at 2:10 PM, Thomas Mittelstaedt
 tmsta...@t-mittelstaedt.de wrote:

  libevolution_a11y_la-gal-a11y-util.lo `test -f 'gal-a11y-util.c' ||
  echo './'`gal-a11y-util.c
  mv -f .deps/libevolution_a11y_la-gal-a11y-util.Tpo
  .deps/libevolution_a11y_la-gal-a11y-util.Plo
  make[2]: *** No rule to make target `../e-util/libeutil.la', needed by
  `libevolution-a11y.la'.  Stop.
  make[2]: Leaving directory `/home/sasa/evolution-2.32.1/a11y'
  make[1]: *** [all-recursive] Error 1
  make[1]: Leaving directory `/home/sasa/evolution-2.32.1'
  make: *** [all] Error 2
  s...@quadser:~/evolution-2.32.1$
 
  Any ideas ?
 
 
  Try run autoconf again. See also:
  http://mail.gnome.org/archives/evolution-list/2010-November/msg4.html.
 
  Hope that helps,
 
  --
  thomas

 thomas, thanks, I looked at the message and it doesnt suggest me
 anything. I have also tried to
 do an autoreconf -ivf but it doesn't help.

 It suggests to you to try a clean setup from scratch. See if that
 works. Create a fresh src directory, check out the sources, create that
 object dir as outlined in the above message, install the software into
 a clean directory like /opt/evo and then see if that still gives you
 errors. See also the follow-up message,
 http://mail.gnome.org/archives/evolution-list/2010-November/msg5.html.

Ok thomas, will try that. Thanks for now.

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] evolution-2.32.1 build error

2010-12-08 Thread Sasa Ostrouska
On Wed, Dec 8, 2010 at 2:10 PM, Thomas Mittelstaedt
tmsta...@t-mittelstaedt.de wrote:
 Am Dienstag, den 07.12.2010, 22:46 +0100 schrieb Sasa Ostrouska:
 On Tue, Dec 7, 2010 at 10:16 PM, Sasa Ostrouska cas...@gmail.com wrote:
  On Tue, Dec 7, 2010 at 4:20 PM, Reid Thompson reid.thomp...@ateb.com 
  wrote:
  On 12/07/2010 10:11 AM, Sasa Ostrouska wrote:
  Hi, again me. I'm getting this time the following error during
  building up evolution 2.32.1:
 
  cc1: warning: /usr/include/drm: No such file or directory
 
 
  i had to create a link on my system
  lrwxrwxrwx  1 root root     19 Nov 18 09:44 drm - /usr/include/libdrm
 
 
 
  Ok, but this wont fix th error, because this is just an warning. Any
  idea about the error ?
  It can't find libeutil.so.0 because it is still compilling it , if I
  understand it correctly.
 
  Rgds
  Saxa
 

 Running make -n gives me that.

 make[3]: Entering directory `/home/sasa/evolution-2.32.1/libgnomecanvas'
 make[3]: Nothing to be done for `all-am'.
 make[3]: Leaving directory `/home/sasa/evolution-2.32.1/libgnomecanvas'
 make[2]: Leaving directory `/home/sasa/evolution-2.32.1/libgnomecanvas'
 Making all in e-util
 make[2]: Entering directory `/home/sasa/evolution-2.32.1/e-util'
 make  all-am
 make[3]: Entering directory `/home/sasa/evolution-2.32.1/e-util'
 echo   CCLD   libeutil.la;/bin/sh ../libtool --silent --tag=CC
 --mode=link gcc  -g -O2 -fno-strict-aliasing -no-undefined
 -Wl,--no-undefined -o libeutil.la -rpath /usr/lib/evolution/2.32
 libeutil_la-e-account-utils.lo libeutil_la-e-activity.lo
 libeutil_la-e-alert.lo libeutil_la-e-alert-activity.lo
 libeutil_la-e-alert-dialog.lo libeutil_la-e-binding.lo
 libeutil_la-e-bit-array.lo libeutil_la-e-categories-config.lo
 libeutil_la-e-charset.lo libeutil_la-e-config.lo
 libeutil_la-e-datetime-format.lo libeutil_la-e-dialog-utils.lo
 libeutil_la-e-dialog-widgets.lo libeutil_la-e-event.lo
 libeutil_la-e-extensible.lo libeutil_la-e-extension.lo
 libeutil_la-e-file-utils.lo libeutil_la-e-html-utils.lo
 libeutil_la-e-icon-factory.lo libeutil_la-e-import.lo
 libeutil_la-e-io-activity.lo libeutil_la-e-logger.lo
 libeutil_la-e-marshal.lo libeutil_la-e-mktemp.lo
 libeutil_la-e-module.lo libeutil_la-e-non-intrusive-error-dialog.lo
 libeutil_la-e-poolv.lo libeutil_la-e-plugin.lo
 libeutil_la-e-plugin-ui.lo libeutil_la-e-plugin-util.lo
 libeutil_la-e-print.lo libeutil_la-e-profile-event.lo
 libeutil_la-e-selection.lo libeutil_la-e-signature.lo
 libeutil_la-e-signature-list.lo libeutil_la-e-signature-utils.lo
 libeutil_la-e-sorter.lo libeutil_la-e-sorter-array.lo
 libeutil_la-e-text-event-processor-emacs-like.lo
 libeutil_la-e-text-event-processor.lo
 libeutil_la-e-timeout-activity.lo libeutil_la-e-ui-manager.lo
 libeutil_la-e-util.lo libeutil_la-e-unicode.lo
 libeutil_la-e-xml-utils.lo libeutil_la-gconf-bridge.lo   -pthread
 -Wl,-rpath, -L/usr/lib64/nspr -ledataserverui-1.2 -lgtk-x11-2.0
 -lebook-1.2 -lgdk-x11-2.0 -latk-1.0 -lpangoft2-1.0 -lpangocairo-1.0
 -lgdk_pixbuf-2.0 -lm -lcairo -lpng14 -lpango-1.0 -lfreetype
 -lfontconfig -lcamel-1.2 -lssl3 -lsmime3 -lnss3 -ledataserver-1.2
 -lsqlite3 -lxml2 -lgconf-2 -lsoup-2.4 -lgio-2.0 -lgobject-2.0
 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 -lplds4 -lplc4 -lnspr4
 -lpthread -ldl    -lm -pthread -lgailutil -lgconf-2 -lxml2
 -lgnome-desktop-2 -lstartup-notification-1 -lunique-1.0 -lgtk-x11-2.0
 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0
 -lgdk_pixbuf-2.0 -lm -lcairo -lpng14 -lpango-1.0 -lfreetype
 -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0
 make[3]: Leaving directory `/home/sasa/evolution-2.32.1/e-util'
 make[2]: Leaving directory `/home/sasa/evolution-2.32.1/e-util'
 Making all in a11y
 make[2]: Entering directory `/home/sasa/evolution-2.32.1/a11y'
 echo   CC     libevolution_a11y_la-gal-a11y-util.lo;/bin/sh
 ../libtool --silent --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.
 -I..  -DG_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED
 -DGDK_PIXBUF_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED
 -DEDS_DISABLE_DEPRECATED -DG_DISABLE_SINGLE_INCLUDES
 -DGTK_DISABLE_SINGLE_INCLUDES -Wall -Wextra
 -Wno-missing-field-initializers -Wno-sign-compare
 -Wno-unused-parameter -Wdeclaration-after-statement
 -Werror-implicit-function-declaration -Wformat-security -Winit-self
 -Wmissing-declarations -Wmissing-include-dirs -Wmissing-noreturn
 -Wnested-externs -Wpointer-arith -Wredundant-decls -Wundef
 -Wwrite-strings -fno-strict-aliasing -pthread -DQT_SHARED -DORBIT2=1
 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include
 -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include
 -I/usr/include/atk-1.0 -I/usr/include/cairo
 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0
 -I/usr/include/pixman-1 -I/usr/include/freetype2
 -I/usr/include/libpng14 -I/usr/lib64/qt/include/QtGui
 -I/usr/include/drm -I/usr/include/libdrm
 -I/usr/lib64/qt/include/QtCore -I/usr/include/gail-1.0
 -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/libxml2
 -I/usr

[Evolution-hackers] evolution-2.32.1 build error

2010-12-07 Thread Sasa Ostrouska
Hi, again me. I'm getting this time the following error during
building up evolution 2.32.1:

cc1: warning: /usr/include/drm: No such file or directory
  CC libeutil_la-e-text-event-processor.lo
  CC libeutil_la-e-timeout-activity.lo
cc1: warning: /usr/include/drm: No such file or directory
cc1: warning: /usr/include/drm: No such file or directory
  CC libeutil_la-e-ui-manager.lo
cc1: warning: /usr/include/drm: No such file or directory
cc1: warning: /usr/include/drm: No such file or directory
cc1: warning: /usr/include/drm: No such file or directory
cc1: warning: /usr/include/drm: No such file or directory
  CC libeutil_la-e-util.lo
cc1: warning: /usr/include/drm: No such file or directory
cc1: warning: /usr/include/drm: No such file or directory
  CC libeutil_la-e-unicode.lo
  CC libeutil_la-e-xml-utils.lo
cc1: warning: /usr/include/drm: No such file or directory
cc1: warning: /usr/include/drm: No such file or directory
  CC libeutil_la-gconf-bridge.lo
cc1: warning: /usr/include/drm: No such file or directory
cc1: warning: /usr/include/drm: No such file or directory
cc1: warning: /usr/include/drm: No such file or directory
cc1: warning: /usr/include/drm: No such file or directory
  CCLD   libeutil.la
/usr/lib64/gcc/x86_64-slackware-linux/4.4.4/../../../../x86_64-slackware-linux/bin/ld:
cannot find libeutil.so.0: No such file or directory
collect2: ld returned 1 exit status
make[3]: *** [libeutil.la] Error 1
make[3]: Leaving directory `/home/sasa/evolution-2.32.1/e-util'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/sasa/evolution-2.32.1/e-util'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/sasa/evolution-2.32.1'
make: *** [all] Error 2
s...@quadser:~/evolution-2.32.1$


Any ideas ?

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] evolution-2.32.1 build error

2010-12-07 Thread Sasa Ostrouska
On Tue, Dec 7, 2010 at 4:20 PM, Reid Thompson reid.thomp...@ateb.com wrote:
 On 12/07/2010 10:11 AM, Sasa Ostrouska wrote:
 Hi, again me. I'm getting this time the following error during
 building up evolution 2.32.1:

 cc1: warning: /usr/include/drm: No such file or directory


 i had to create a link on my system
 lrwxrwxrwx  1 root root     19 Nov 18 09:44 drm - /usr/include/libdrm



Ok, but this wont fix th error, because this is just an warning. Any
idea about the error ?
It can't find libeutil.so.0 because it is still compilling it , if I
understand it correctly.

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] evolution-exchange 2.32.0 build error

2010-11-15 Thread Sasa Ostrouska
On Mon, Nov 15, 2010 at 10:13 AM, tjoen tj...@dds.nl wrote:
 On Sun, 2010-11-14 at 20:52 +0100, Sasa Ostrouska wrote:
 On Sun, Nov 14, 2010 at 12:46 PM, Sasa Ostrouska cas...@gmail.com wrote:
  On Sat, Nov 13, 2010 at 11:54 AM, tjoen tj...@dds.nl wrote:
  On Sat, 2010-11-13 at 01:18 +0100, Sasa Ostrouska wrote:
  I have troubles with evolution-exchange.
 
    CCLD   libebookbackendexchange.la
  libtool: link: only absolute run-paths are allowed
  make[2]: *** [libebookbackendexchange.la] Error 1
 
  Try a
  $ make -n  log
  Search in log for libebookbackendexchange.la
 
 
 Here is what I get:

 s...@quadser:~/evolution-exchange-2.32.0$ make -n  evo-exch.log
 make[3]: *** No rule to make target `../../server/lib/libexchange.la',

 Even better would be: make -n  evo-exch.log 21

 Also attaching the complete log.

 Some mailinglists don't like attachments.
 Better is to paste only the relevant
 libebookbackendexchange.la part.
 I think it is someting like a -Llib. If not, then an
 error in one of the .la

Here we go, the last few lines:

mv -f .deps/libexchange_storage_la-exchange-hierarchy-webdav.Tpo
.deps/libexchange_storage_la-exchange-hierarchy-webdav.Plo
echo   CC libexchange_storage_la-exchange-hierarchy.lo;/bin/sh
../../libtool --silent --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H
-I. -I../..  -DG_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED
-DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED
-DGTK_DISABLE_DEPRECATED -DE_BOOK_DISABLE_DEPRECATED
-DE_CAL_DISABLE_DEPRECATED -DG_DISABLE_SINGLE_INCLUDES
-DGTK_DISABLE_SINGLE_INCLUDES -DGSEAL_ENABLE -Wall -Wextra
-Wno-missing-field-initializers -Wno-sign-compare
-Wno-unused-parameter -Wdeclaration-after-statement
-Werror-implicit-function-declaration -Wformat-security -Winit-self
-Wmissing-declarations -Wmissing-include-dirs -Wmissing-noreturn
-Wnested-externs -Wpointer-arith -Wredundant-decls -Wundef
-Wwrite-strings -fno-strict-aliasing
-DG_LOG_DOMAIN=\evolution-exchange-storage\ -DPREFIX=\/usr\
-DSYSCONFDIR=\/usr/etc\ -DDATADIR=\/usr/share\
-DLIBDIR=\/usr/share\
-DCONNECTOR_LOCALEDIR=\/usr/share/locale\
-DCONNECTOR_GLADEDIR=\\ -I../.. -I../../server/lib
-I../../server/xntlm -I../../server/lib -pthread -DQT_SHARED
-DORBIT2=1 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include
-I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include
-I/usr/include/atk-1.0 -I/usr/include/cairo
-I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0
-I/usr/include/pixman-1 -I/usr/include/freetype2
-I/usr/include/libpng14 -I/usr/lib64/qt/include/QtGui
-I/usr/include/drm -I/usr/include/libdrm
-I/usr/lib64/qt/include/QtCore -I/usr/include/gconf/2
-I/usr/include/orbit-2.0 -I/usr/include/libxml2
-I/usr/include/libsoup-2.4   -DCAMEL_HAVE_NSS -DCAMEL_HAVE_SSL
-pthread -DORBIT2=1 -DQT_SHARED
-I/usr/include/evolution-data-server-2.32 -I/usr/include/nspr
-I/usr/include/nss -I/usr/include/glib-2.0
-I/usr/lib64/glib-2.0/include -I/usr/include/libxml2
-I/usr/include/gconf/2 -I/usr/include/libsoup-2.4
-I/usr/include/orbit-2.0 -I/usr/include/libical -I/usr/include/gtk-2.0
-I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0
-I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0
-I/usr/include/pango-1.0 -I/usr/include/pixman-1
-I/usr/include/freetype2 -I/usr/include/libpng14
-I/usr/lib64/qt/include/QtGui -I/usr/include/drm -I/usr/include/libdrm
-I/usr/lib64/qt/include/QtCore
-I/usr/include/evolution-data-server-2.32/groupwise   -I/usr/include
-DLDAP_DEPRECATED-g -O2 -fno-strict-aliasing -MT
libexchange_storage_la-exchange-hierarchy.lo -MD -MP -MF
.deps/libexchange_storage_la-exchange-hierarchy.Tpo -c -o
libexchange_storage_la-exchange-hierarchy.lo `test -f
'exchange-hierarchy.c' || echo './'`exchange-hierarchy.c
mv -f .deps/libexchange_storage_la-exchange-hierarchy.Tpo
.deps/libexchange_storage_la-exchange-hierarchy.Plo
echo   CC libexchange_storage_la-exchange-oof.lo;/bin/sh
../../libtool --silent --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H
-I. -I../..  -DG_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED
-DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED
-DGTK_DISABLE_DEPRECATED -DE_BOOK_DISABLE_DEPRECATED
-DE_CAL_DISABLE_DEPRECATED -DG_DISABLE_SINGLE_INCLUDES
-DGTK_DISABLE_SINGLE_INCLUDES -DGSEAL_ENABLE -Wall -Wextra
-Wno-missing-field-initializers -Wno-sign-compare
-Wno-unused-parameter -Wdeclaration-after-statement
-Werror-implicit-function-declaration -Wformat-security -Winit-self
-Wmissing-declarations -Wmissing-include-dirs -Wmissing-noreturn
-Wnested-externs -Wpointer-arith -Wredundant-decls -Wundef
-Wwrite-strings -fno-strict-aliasing
-DG_LOG_DOMAIN=\evolution-exchange-storage\ -DPREFIX=\/usr\
-DSYSCONFDIR=\/usr/etc\ -DDATADIR=\/usr/share\
-DLIBDIR=\/usr/share\
-DCONNECTOR_LOCALEDIR=\/usr/share/locale\
-DCONNECTOR_GLADEDIR=\\ -I../.. -I../../server/lib
-I../../server/xntlm -I../../server/lib -pthread -DQT_SHARED
-DORBIT2=1 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include
-I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include
-I/usr/include/atk-1.0 -I/usr/include

Re: [Evolution-hackers] evolution-exchange 2.32.0 build error

2010-11-15 Thread Sasa Ostrouska
On Mon, Nov 15, 2010 at 6:41 PM, tjoen tj...@dds.nl wrote:
 On Mon, 2010-11-15 at 10:24 +0100, Sasa Ostrouska wrote:
 On Mon, Nov 15, 2010 at 10:13 AM, tjoen tj...@dds.nl wrote:
  On Sun, 2010-11-14 at 20:52 +0100, Sasa Ostrouska wrote:
  On Sun, Nov 14, 2010 at 12:46 PM, Sasa Ostrouska cas...@gmail.com wrote:
   On Sat, Nov 13, 2010 at 11:54 AM, tjoen tj...@dds.nl wrote:
   On Sat, 2010-11-13 at 01:18 +0100, Sasa Ostrouska wrote:
   I have troubles with evolution-exchange.
  
     CCLD   libebookbackendexchange.la
   libtool: link: only absolute run-paths are allowed
   make[2]: *** [libebookbackendexchange.la] Error 1

 Looks like this one is solved because below is a different
 error.

Yeah, it seems strange to me, why this error solved out itself. Maybe
is the setup I use with the build-system.

 ...

 make[3]: *** No rule to make target `../../server/lib/libexchange.la',
 needed by `libexchange-storage.la'.  Stop.
 make[3]: Leaving directory 
 `/home/sasa/evolution-exchange-2.32.0/server/storage'

 Doesn't know how to make libexchange.la.
 Look in server/storage/Makefile why.


Ok, thanks for the tip, will look into that Makefile, but I suspect
that most probably all of that is caused by a
wrongly installed nss. Where I'm looking right now. This of course
then makes confusion on e-d-s which then
makes problems on evolution-exchange.

Thanks for now.
Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] evolution-mapi 0.32.0

2010-11-14 Thread Sasa Ostrouska
On Sat, Nov 13, 2010 at 9:19 PM, Sasa Ostrouska cas...@gmail.com wrote:
 On Sat, Nov 13, 2010 at 12:00 PM, tjoen tj...@dds.nl wrote:
 On Sat, 2010-11-13 at 01:21 +0100, Sasa Ostrouska wrote:
 Ok, I know you are tired, but try to look at that one also. I have
 installed and built
 e-d-s and evolution, and they both work, now trying to build up
 evo-mapi I get the
 following configure error:
 ...
 checking for EVOLUTION_DATA_SERVER... configure: error: Package
 requirements (evolution-data-server-1.2 = 2.31.6) were not met:

 Empty package name in Requires or Conflicts in file
 '/usr/lib64/pkgconfig/evolution-data-server-1.2.pc'

 it seems it can't find e-d-s ..pc file, now I'm asking, why evolution found 
 it ?

 Looks like it found the .pc but something wrong in it


Hmm, seems something is wrong with it:

# pkg-config --exists --print-errors evolution-data-server-1.2
Empty package name in Requires or Conflicts in file
'/usr/lib64/pkgconfig/evolution-data-server-1.2.pc'


Will investigate, thanks.

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] evolution-mapi 0.32.0

2010-11-14 Thread Sasa Ostrouska
On Sat, Nov 13, 2010 at 9:21 PM, Sasa Ostrouska cas...@gmail.com wrote:
 On Sat, Nov 13, 2010 at 9:19 PM, Sasa Ostrouska cas...@gmail.com wrote:
 On Sat, Nov 13, 2010 at 12:00 PM, tjoen tj...@dds.nl wrote:
 On Sat, 2010-11-13 at 01:21 +0100, Sasa Ostrouska wrote:
 Ok, I know you are tired, but try to look at that one also. I have
 installed and built
 e-d-s and evolution, and they both work, now trying to build up
 evo-mapi I get the
 following configure error:
 ...
 checking for EVOLUTION_DATA_SERVER... configure: error: Package
 requirements (evolution-data-server-1.2 = 2.31.6) were not met:

 Empty package name in Requires or Conflicts in file
 '/usr/lib64/pkgconfig/evolution-data-server-1.2.pc'

 it seems it can't find e-d-s ..pc file, now I'm asking, why evolution 
 found it ?

 Looks like it found the .pc but something wrong in it


 Hmm, seems something is wrong with it:

 # pkg-config --exists --print-errors evolution-data-server-1.2
 Empty package name in Requires or Conflicts in file
 '/usr/lib64/pkgconfig/evolution-data-server-1.2.pc'


 Will investigate, thanks.

 Rgds
 Saxa


Heh, seems really is not much info in there:

r...@quadser:/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG_2_32# cat
/usr/lib64/pkgconfig/evolution-data-server-1.2.pc
prefix=/usr
exec_prefix=${prefix}
libdir=/usr/lib64
includedir=${prefix}/include
privlibdir=${libdir}/evolution-data-server-2.32
extensiondir=${libdir}/evolution-data-server-1.2/extensions
datarootdir=${prefix}/share
datadir=${datarootdir}
privdatadir=${datadir}/evolution-data-server-2.32

execversion=2.32

Name: evolution-data-server
Description: The evolution data server for the calendar and addressbook
Version: 2.32.0
Requires: gio-2.0, ,
r...@quadser:/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG_2_32#

Will try to rebuild e-d-s.

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] evolution-mapi 0.32.0

2010-11-14 Thread Sasa Ostrouska
On Sun, Nov 14, 2010 at 12:47 PM, Sasa Ostrouska cas...@gmail.com wrote:
 On Sat, Nov 13, 2010 at 9:21 PM, Sasa Ostrouska cas...@gmail.com wrote:
 On Sat, Nov 13, 2010 at 9:19 PM, Sasa Ostrouska cas...@gmail.com wrote:
 On Sat, Nov 13, 2010 at 12:00 PM, tjoen tj...@dds.nl wrote:
 On Sat, 2010-11-13 at 01:21 +0100, Sasa Ostrouska wrote:
 Ok, I know you are tired, but try to look at that one also. I have
 installed and built
 e-d-s and evolution, and they both work, now trying to build up
 evo-mapi I get the
 following configure error:
 ...
 checking for EVOLUTION_DATA_SERVER... configure: error: Package
 requirements (evolution-data-server-1.2 = 2.31.6) were not met:

 Empty package name in Requires or Conflicts in file
 '/usr/lib64/pkgconfig/evolution-data-server-1.2.pc'

 it seems it can't find e-d-s ..pc file, now I'm asking, why evolution 
 found it ?

 Looks like it found the .pc but something wrong in it


 Hmm, seems something is wrong with it:

 # pkg-config --exists --print-errors evolution-data-server-1.2
 Empty package name in Requires or Conflicts in file
 '/usr/lib64/pkgconfig/evolution-data-server-1.2.pc'


 Will investigate, thanks.

 Rgds
 Saxa


 Heh, seems really is not much info in there:

 r...@quadser:/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG_2_32# cat
 /usr/lib64/pkgconfig/evolution-data-server-1.2.pc
 prefix=/usr
 exec_prefix=${prefix}
 libdir=/usr/lib64
 includedir=${prefix}/include
 privlibdir=${libdir}/evolution-data-server-2.32
 extensiondir=${libdir}/evolution-data-server-1.2/extensions
 datarootdir=${prefix}/share
 datadir=${datarootdir}
 privdatadir=${datadir}/evolution-data-server-2.32

 execversion=2.32

 Name: evolution-data-server
 Description: The evolution data server for the calendar and addressbook
 Version: 2.32.0
 Requires: gio-2.0, ,
 r...@quadser:/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG_2_32#

 Will try to rebuild e-d-s.

 Rgds
 Saxa

Rebuilding the e-d-s have not helped, it created the same empty .pc
file. Any ideas where should I start looking ?

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] evolution-exchange 2.32.0 build error

2010-11-14 Thread Sasa Ostrouska
On Sun, Nov 14, 2010 at 12:46 PM, Sasa Ostrouska cas...@gmail.com wrote:
 On Sat, Nov 13, 2010 at 11:54 AM, tjoen tj...@dds.nl wrote:
 On Sat, 2010-11-13 at 01:18 +0100, Sasa Ostrouska wrote:
 Hi, its again me, I have got to compile evolution-data-server and
 evolution, but now
 I have troubles with evolution-exchange.

   CCLD   libebookbackendexchange.la
 libtool: link: only absolute run-paths are allowed
 make[2]: *** [libebookbackendexchange.la] Error 1

 Try a
 $ make -n  log
 Search in log for libebookbackendexchange.la


Here is what I get:

s...@quadser:~/evolution-exchange-2.32.0$ make -n  evo-exch.log
make[3]: *** No rule to make target `../../server/lib/libexchange.la',
needed by `libexchange-storage.la'.  Stop.
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

s...@quadser:~/evolution-exchange-2.32.0$

Also attaching the complete log.

Any suggestions are very welcome.

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] evolution-mapi 0.32.0

2010-11-14 Thread Sasa Ostrouska
On Sun, Nov 14, 2010 at 10:12 PM, Reid Thompson reid.thomp...@ateb.com wrote:
 On 11/14/2010 2:40 PM, Sasa Ostrouska wrote:

 On Sun, Nov 14, 2010 at 12:47 PM, Sasa Ostrouskacas...@gmail.com  wrote:

 On Sat, Nov 13, 2010 at 9:21 PM, Sasa Ostrouskacas...@gmail.com  wrote:

 On Sat, Nov 13, 2010 at 9:19 PM, Sasa Ostrouskacas...@gmail.com
  wrote:

 On Sat, Nov 13, 2010 at 12:00 PM, tjoentj...@dds.nl  wrote:

 On Sat, 2010-11-13 at 01:21 +0100, Sasa Ostrouska wrote:

 Ok, I know you are tired, but try to look at that one also. I have
 installed and built
 e-d-s and evolution, and they both work, now trying to build up
 evo-mapi I get the
 following configure error:

 ...

 checking for EVOLUTION_DATA_SERVER... configure: error: Package
 requirements (evolution-data-server-1.2= 2.31.6) were not met:

 Empty package name in Requires or Conflicts in file
 '/usr/lib64/pkgconfig/evolution-data-server-1.2.pc'
 it seems it can't find e-d-s ..pc file, now I'm asking, why evolution
 found it ?

 Looks like it found the .pc but something wrong in it

 Hmm, seems something is wrong with it:

 # pkg-config --exists --print-errors evolution-data-server-1.2
 Empty package name in Requires or Conflicts in file
 '/usr/lib64/pkgconfig/evolution-data-server-1.2.pc'


 Will investigate, thanks.

 Rgds
 Saxa

 Heh, seems really is not much info in there:

 r...@quadser:/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG_2_32# cat
 /usr/lib64/pkgconfig/evolution-data-server-1.2.pc
 prefix=/usr
 exec_prefix=${prefix}
 libdir=/usr/lib64
 includedir=${prefix}/include
 privlibdir=${libdir}/evolution-data-server-2.32
 extensiondir=${libdir}/evolution-data-server-1.2/extensions
 datarootdir=${prefix}/share
 datadir=${datarootdir}
 privdatadir=${datadir}/evolution-data-server-2.32

 execversion=2.32

 Name: evolution-data-server
 Description: The evolution data server for the calendar and addressbook
 Version: 2.32.0
 Requires: gio-2.0, ,
 r...@quadser:/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG_2_32#

 Will try to rebuild e-d-s.

 Rgds
 Saxa

 Rebuilding the e-d-s have not helped, it created the same empty .pc
 file. Any ideas where should I start looking ?

 Rgds
 Saxa
 ___
 evolution-hackers mailing list
 evolution-hackers@gnome.org
 To change your list options or unsubscribe, visit ...
 http://mail.gnome.org/mailman/listinfo/evolution-hackers

 It's not empty.  I think the problem is this line

 Requires: gio-2.0, ,
 note the extra comma with no package preceding it which I assume this error
 is referencing:
 Empty package name in Requires or Conflicts in file

 mine contains:
 $ cat ./lib/pkgconfig/evolution-data-server-1.2.pc
 prefix=/opt/evo
 exec_prefix=${prefix}
 libdir=${exec_prefix}/lib
 includedir=${prefix}/include
 privlibdir=${libdir}/evolution-data-server-2.92
 extensiondir=${libdir}/evolution-data-server-1.2/extensions
 datarootdir=${prefix}/share
 datadir=${datarootdir}
 privdatadir=${datadir}/evolution-data-server-2.92

 execversion=2.92

 Name: evolution-data-server
 Description: The evolution data server for the calendar and addressbook
 Version: 2.91.3
 Requires: gio-2.0, nss, nspr

Yes, now the question is, why on my systems it doesn't get created
correctly, also with nss and nspr in it, since I have those pacakges
on my machine.
Probably I built them wrongly. Hmmm, thx for the tip, in any case.

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers


[Evolution-hackers] evolution-exchange 2.32.0 build error

2010-11-12 Thread Sasa Ostrouska
Hi, its again me, I have got to compile evolution-data-server and
evolution, but now
I have troubles with evolution-exchange.

I get the following error:

  CC libebookbackendexchange_la-e-book-backend-exchange.lo
  CC libebookbackendexchange_la-e-book-backend-exchange-factory.lo
  CC libebookbackendexchange_la-e-book-backend-gal.lo
  CC libebookbackendexchange_la-e-book-backend-db-cache.lo
cc1: warning: /usr/include/drm: No such file or directory
cc1: warning: /usr/include/drm: No such file or directory
cc1: warning: /usr/include/drm: No such file or directory
cc1: warning: /usr/include/drm: No such file or directory
cc1: warning: /usr/include/drm: No such file or directory
cc1: warning: /usr/include/drm: No such file or directory
cc1: warning: /usr/include/drm: No such file or directory
cc1: warning: /usr/include/drm: No such file or directory
cp apps_exchange_addressbook.schemas.in.in
apps_exchange_addressbook-2.32.schemas.in
LC_ALL=C /usr/bin/intltool-merge -s -u -c ../po/.intltool-merge-cache
../po apps_exchange_addressbook-2.32.schemas.in
apps_exchange_addressbook-2.32.schemas
Generating and caching the translation database
Merging translations into apps_exchange_addressbook-2.32.schemas.
  CCLD   libebookbackendexchange.la
libtool: link: only absolute run-paths are allowed
make[2]: *** [libebookbackendexchange.la] Error 1
rm apps_exchange_addressbook-2.32.schemas.in
make[2]: Leaving directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-exchange-2.32.0-1/evolution-exchange-2.32.0/addressbook'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-exchange-2.32.0-1/evolution-exchange-2.32.0'
make: *** [all] Error 2
Error!  make exited with status: 2
Failed package evolution-exchange

r...@quadser:/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG_2_32#


Any ideas ?

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers


[Evolution-hackers] evolution-mapi 0.32.0

2010-11-12 Thread Sasa Ostrouska
Ok, I know you are tired, but try to look at that one also. I have
installed and built
e-d-s and evolution, and they both work, now trying to build up
evo-mapi I get the
following configure error:

checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GNOME_PLATFORM... yes
checking for EVOLUTION_DATA_SERVER... configure: error: Package
requirements (evolution-data-server-1.2 = 2.31.6) were not met:

Empty package name in Requires or Conflicts in file
'/usr/lib64/pkgconfig/evolution-data-server-1.2.pc'

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables
EVOLUTION_DATA_SERVER_CFLAGS
and EVOLUTION_DATA_SERVER_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Error!  Configure exited with status: 1
Failed package evolution-mapi

r...@quadser:/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG_2_32#

it seems it can't find e-d-s ..pc file, now I'm asking, why evolution found it ?

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers


[Evolution-hackers] e-d-s 2.32.0 error during make install

2010-11-11 Thread Sasa Ostrouska
Hello, I get this error during make install phase:



make[4]: Entering directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal'
make[5]: Entering directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal'
test -z /usr/lib64 || /usr/bin/mkdir -p
/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64
 /bin/sh ../../libtool   --mode=install /usr/bin/ginstall -c -s
libecal-1.2.la 
'/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64'
libtool: install: warning: relinking `libecal-1.2.la'
libtool: install: (cd
/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal;
/bin/sh 
/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/libtool
 --silent --tag CC --mode=relink gcc -O2 -fPIC -pipe -march=x86-64
-version-info 10:2:2 -Wl,--no-undefined -o libecal-1.2.la -rpath
/usr/lib64 libecal_1_2_la-e-cal-marshal.lo libecal_1_2_la-e-cal.lo
libecal_1_2_la-e-cal-component.lo libecal_1_2_la-e-cal-recur.lo
libecal_1_2_la-e-cal-time-util.lo
libecal_1_2_la-e-cal-check-timezones.lo
libecal_1_2_la-e-cal-system-timezone.lo libecal_1_2_la-e-cal-util.lo
libecal_1_2_la-e-cal-view.lo ../../calendar/libegdbus/libegdbus-cal.la
../../libedataserver/libedataserver-1.2.la -pthread -lgio-2.0
-lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lical -licalss
-licalvcal -lxml2 -lgconf-2 -lglib-2.0 -inst-prefix-dir
/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1)
libtool: install: /usr/bin/ginstall -c .libs/libecal-1.2.so.8.2.2T
/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64/libecal-1.2.so.8.2.2
libtool: install: strip --strip-unneeded
/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64/libecal-1.2.so.8.2.2
libtool: install: (cd
/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64
 { ln -s -f libecal-1.2.so.8.2.2 libecal-1.2.so.8 || { rm -f
libecal-1.2.so.8  ln -s libecal-1.2.so.8.2.2 libecal-1.2.so.8; }; })
libtool: install: (cd
/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64
 { ln -s -f libecal-1.2.so.8.2.2 libecal-1.2.so || { rm -f
libecal-1.2.so  ln -s libecal-1.2.so.8.2.2 libecal-1.2.so; }; })
libtool: install: /usr/bin/ginstall -c .libs/libecal-1.2.lai
/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64/libecal-1.2.la
libtool: install: warning: remember to run `libtool --finish /usr/lib64'
test -z /usr/include/evolution-data-server-2.32/libecal ||
/usr/bin/mkdir -p
/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/include/evolution-data-server-2.32/libecal
 /usr/bin/ginstall -c -m 644 e-cal.h e-cal-component.h e-cal-recur.h
e-cal-time-util.h e-cal-check-timezones.h e-cal-system-timezone.h
e-cal-types.h e-cal-util.h e-cal-view.h
'/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/include/evolution-data-server-2.32/libecal'
test -z /usr/lib64/pkgconfig || /usr/bin/mkdir -p
/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64/pkgconfig
 /usr/bin/ginstall -c -m 644 libecal-1.2.pc
'/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64/pkgconfig'
make[5]: Leaving directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal'
make[4]: Leaving directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal'
make[3]: Leaving directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal'
Making install in libedata-cal
make[3]: Entering directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
make  install-am
make[4]: Entering directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
make[5]: Entering directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
test -z /usr/lib64 || /usr/bin/mkdir -p
/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64
 /bin/sh ../../libtool   --mode=install /usr/bin/ginstall -c -s
libedata-cal-1.2.la
'/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64'
libtool: install: warning: relinking 

Re: [Evolution-hackers] e-d-s 2.32.0 error during make install

2010-11-11 Thread Sasa Ostrouska
Ok, now I'm on the list.

On Thu, Nov 11, 2010 at 3:56 PM, Sasa Ostrouska cas...@gmail.com wrote:
 Hello, I get this error during make install phase:



 make[4]: Entering directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal'
 make[5]: Entering directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal'
 test -z /usr/lib64 || /usr/bin/mkdir -p
 /home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64
  /bin/sh ../../libtool   --mode=install /usr/bin/ginstall -c -s
 libecal-1.2.la 
 '/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64'
 libtool: install: warning: relinking `libecal-1.2.la'
 libtool: install: (cd
 /home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal;
 /bin/sh 
 /home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/libtool
  --silent --tag CC --mode=relink gcc -O2 -fPIC -pipe -march=x86-64
 -version-info 10:2:2 -Wl,--no-undefined -o libecal-1.2.la -rpath
 /usr/lib64 libecal_1_2_la-e-cal-marshal.lo libecal_1_2_la-e-cal.lo
 libecal_1_2_la-e-cal-component.lo libecal_1_2_la-e-cal-recur.lo
 libecal_1_2_la-e-cal-time-util.lo
 libecal_1_2_la-e-cal-check-timezones.lo
 libecal_1_2_la-e-cal-system-timezone.lo libecal_1_2_la-e-cal-util.lo
 libecal_1_2_la-e-cal-view.lo ../../calendar/libegdbus/libegdbus-cal.la
 ../../libedataserver/libedataserver-1.2.la -pthread -lgio-2.0
 -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lical -licalss
 -licalvcal -lxml2 -lgconf-2 -lglib-2.0 -inst-prefix-dir
 /home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1)
 libtool: install: /usr/bin/ginstall -c .libs/libecal-1.2.so.8.2.2T
 /home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64/libecal-1.2.so.8.2.2
 libtool: install: strip --strip-unneeded
 /home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64/libecal-1.2.so.8.2.2
 libtool: install: (cd
 /home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64
  { ln -s -f libecal-1.2.so.8.2.2 libecal-1.2.so.8 || { rm -f
 libecal-1.2.so.8  ln -s libecal-1.2.so.8.2.2 libecal-1.2.so.8; }; })
 libtool: install: (cd
 /home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64
  { ln -s -f libecal-1.2.so.8.2.2 libecal-1.2.so || { rm -f
 libecal-1.2.so  ln -s libecal-1.2.so.8.2.2 libecal-1.2.so; }; })
 libtool: install: /usr/bin/ginstall -c .libs/libecal-1.2.lai
 /home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64/libecal-1.2.la
 libtool: install: warning: remember to run `libtool --finish /usr/lib64'
 test -z /usr/include/evolution-data-server-2.32/libecal ||
 /usr/bin/mkdir -p
 /home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/include/evolution-data-server-2.32/libecal
  /usr/bin/ginstall -c -m 644 e-cal.h e-cal-component.h e-cal-recur.h
 e-cal-time-util.h e-cal-check-timezones.h e-cal-system-timezone.h
 e-cal-types.h e-cal-util.h e-cal-view.h
 '/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/include/evolution-data-server-2.32/libecal'
 test -z /usr/lib64/pkgconfig || /usr/bin/mkdir -p
 /home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64/pkgconfig
  /usr/bin/ginstall -c -m 644 libecal-1.2.pc
 '/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64/pkgconfig'
 make[5]: Leaving directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal'
 make[4]: Leaving directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal'
 make[3]: Leaving directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal'
 Making install in libedata-cal
 make[3]: Entering directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
 make  install-am
 make[4]: Entering directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
 make[5]: Entering directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
 test -z /usr/lib64 || /usr/bin/mkdir -p
 /home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64
  /bin/sh ../../libtool   --mode=install /usr/bin/ginstall

Re: [Evolution-hackers] e-d-s 2.32.0 error during make install

2010-11-11 Thread Sasa Ostrouska
Ok, I have applied the patch I found here:
https://bugzilla.gnome.org/show_bug.cgi?id=628238

but no luck, now I get that error:

make[5]: Leaving directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal'
make[4]: Leaving directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal'
make[3]: Leaving directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal'
Making install in libedata-cal
make[3]: Entering directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
make  install-am
make[4]: Entering directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
make[5]: Entering directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
test -z /usr/lib64 || /usr/bin/mkdir -p
/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64
 /bin/sh ../../libtool   --mode=install /usr/bin/ginstall -c -s
libedata-cal-1.2.la
'/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64'
libtool: install: warning: relinking `libedata-cal-1.2.la'
libtool: install: (cd
/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal;
/bin/sh 
/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/libtool
 --silent --tag CC --mode=relink gcc -O2 -fPIC -pipe -march=x86-64
-version-info 10:0:0 -Wl,--no-undefined -o libedata-cal-1.2.la -rpath
/usr/lib64 libedata_cal_1_2_la-e-data-cal-enumtypes.lo
libedata_cal_1_2_la-e-cal-backend.lo
libedata_cal_1_2_la-e-cal-backend-cache.lo
libedata_cal_1_2_la-e-cal-backend-factory.lo
libedata_cal_1_2_la-e-cal-backend-intervaltree.lo
libedata_cal_1_2_la-e-cal-backend-sexp.lo
libedata_cal_1_2_la-e-cal-backend-sync.lo
libedata_cal_1_2_la-e-cal-backend-util.lo
libedata_cal_1_2_la-e-cal-backend-store.lo
libedata_cal_1_2_la-e-cal-backend-file-store.lo
libedata_cal_1_2_la-e-data-cal.lo
libedata_cal_1_2_la-e-data-cal-view.lo
../../calendar/libegdbus/libegdbus-cal.la
../../calendar/libecal/libecal-1.2.la
../../libedataserver/libedataserver-1.2.la
../../libebackend/libebackend-1.2.la -pthread -lgio-2.0 -lgobject-2.0
-lgmodule-2.0 -lgthread-2.0 -lrt -lical -licalss -licalvcal -lxml2
-lgconf-2 -lglib-2.0 -inst-prefix-dir
/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1)
.libs/libedata_cal_1_2_la-e-cal-backend-file-store.o: In function
`e_cal_util_get_component_occur_times':
e-cal-backend-file-store.c:(.text+0x170b): undefined reference to
`e_cal_recur_ensure_end_dates'
e-cal-backend-file-store.c:(.text+0x1946): undefined reference to
`e_cal_recur_obtain_enddate'
e-cal-backend-file-store.c:(.text+0x19cf): undefined reference to
`e_cal_recur_obtain_enddate'
collect2: ld returned 1 exit status
libtool: install: error: relink `libedata-cal-1.2.la' with the above
command before installing it
make[5]: *** [install-libLTLIBRARIES] Error 1
make[5]: Leaving directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
make[4]: *** [install-am] Error 2
make[4]: Leaving directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
make[3]: *** [install] Error 2
make[3]: Leaving directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory
`/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0'
make: *** [install-strip] Error 2
Error!  Configure exited with status: 2
Failed package evolution-data-server

r...@quadser:/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG_2_32#

Any ideas ?
Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] e-d-s 2.32.0 error during make install

2010-11-11 Thread Sasa Ostrouska
On Fri, Nov 12, 2010 at 1:18 AM, Sasa Ostrouska cas...@gmail.com wrote:
 Ok, I have applied the patch I found here:
 https://bugzilla.gnome.org/show_bug.cgi?id=628238

 but no luck, now I get that error:

 make[5]: Leaving directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal'
 make[4]: Leaving directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal'
 make[3]: Leaving directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libecal'
 Making install in libedata-cal
 make[3]: Entering directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
 make  install-am
 make[4]: Entering directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
 make[5]: Entering directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
 test -z /usr/lib64 || /usr/bin/mkdir -p
 /home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64
  /bin/sh ../../libtool   --mode=install /usr/bin/ginstall -c -s
 libedata-cal-1.2.la
 '/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1/usr/lib64'
 libtool: install: warning: relinking `libedata-cal-1.2.la'
 libtool: install: (cd
 /home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal;
 /bin/sh 
 /home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/libtool
  --silent --tag CC --mode=relink gcc -O2 -fPIC -pipe -march=x86-64
 -version-info 10:0:0 -Wl,--no-undefined -o libedata-cal-1.2.la -rpath
 /usr/lib64 libedata_cal_1_2_la-e-data-cal-enumtypes.lo
 libedata_cal_1_2_la-e-cal-backend.lo
 libedata_cal_1_2_la-e-cal-backend-cache.lo
 libedata_cal_1_2_la-e-cal-backend-factory.lo
 libedata_cal_1_2_la-e-cal-backend-intervaltree.lo
 libedata_cal_1_2_la-e-cal-backend-sexp.lo
 libedata_cal_1_2_la-e-cal-backend-sync.lo
 libedata_cal_1_2_la-e-cal-backend-util.lo
 libedata_cal_1_2_la-e-cal-backend-store.lo
 libedata_cal_1_2_la-e-cal-backend-file-store.lo
 libedata_cal_1_2_la-e-data-cal.lo
 libedata_cal_1_2_la-e-data-cal-view.lo
 ../../calendar/libegdbus/libegdbus-cal.la
 ../../calendar/libecal/libecal-1.2.la
 ../../libedataserver/libedataserver-1.2.la
 ../../libebackend/libebackend-1.2.la -pthread -lgio-2.0 -lgobject-2.0
 -lgmodule-2.0 -lgthread-2.0 -lrt -lical -licalss -licalvcal -lxml2
 -lgconf-2 -lglib-2.0 -inst-prefix-dir
 /home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/STAGE/evolution-data-server-2.32.0-1)
 .libs/libedata_cal_1_2_la-e-cal-backend-file-store.o: In function
 `e_cal_util_get_component_occur_times':
 e-cal-backend-file-store.c:(.text+0x170b): undefined reference to
 `e_cal_recur_ensure_end_dates'
 e-cal-backend-file-store.c:(.text+0x1946): undefined reference to
 `e_cal_recur_obtain_enddate'
 e-cal-backend-file-store.c:(.text+0x19cf): undefined reference to
 `e_cal_recur_obtain_enddate'
 collect2: ld returned 1 exit status
 libtool: install: error: relink `libedata-cal-1.2.la' with the above
 command before installing it
 make[5]: *** [install-libLTLIBRARIES] Error 1
 make[5]: Leaving directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
 make[4]: *** [install-am] Error 2
 make[4]: Leaving directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
 make[3]: *** [install] Error 2
 make[3]: Leaving directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar/libedata-cal'
 make[2]: *** [install-recursive] Error 1
 make[2]: Leaving directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0/calendar'
 make[1]: *** [install-recursive] Error 1
 make[1]: Leaving directory
 `/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG/WORK/evolution-data-server-2.32.0-1/evolution-data-server-2.32.0'
 make: *** [install-strip] Error 2
 Error!  Configure exited with status: 2
 Failed package evolution-data-server

 r...@quadser:/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/DLG_2_32#

 Any ideas ?
 Rgds
 Saxa


Ok sorry , I'm stupid, I forogot to autoreconf after I installed the patch.
Solved it.

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers