Re: [Evolution-hackers] Compile Evolution-Mapi 3.1.1 - Error on libmapi.h

2011-05-18 Thread tudstudent
. Regards, Bas Milan Crha wrote: On Mon, 2011-05-16 at 10:35 -0700, tudstudent wrote: export LD_LIBRARY_PATH=$PREFIX/lib:$PREFIX/samba/lib export PKG_CONFIG_PATH=$PREFIX/lib/pkgconfig:$PREFIX/samba/lib/pkgconfig: $PREFIX/share/pkgconfig then: pkg-config --cflags libmapi

Re: [Evolution-hackers] Compile Evolution-Mapi 3.1.1 - Error on libmapi.h

2011-05-16 Thread tudstudent
Milan Crha wrote: On Sun, 2011-05-15 at 22:39 -0700, tudstudent wrote: ... When compiling evolution-mapi-3.1.1 I get stuck with the following error: ... exchange-mapi-connection.c: In function 'exchange_mapi_util_get_attachments': exchange-mapi-connection.c:1272:5: warning: passing

Re: [Evolution-hackers] Compile Evolution-Mapi 3.1.1 - Error on libmapi.h

2011-05-16 Thread tudstudent
was: | /* confdefs.h */ /code Milan Crha wrote: On Sun, 2011-05-15 at 23:33 -0700, tudstudent wrote: So I have only 1 libmapi.h installed on my system. Furthermore I have looked into libmapi.h: uint32_tcast_SPropValue(TALLOC_CTX *, struct mapi_SPropValue

Re: [Evolution-hackers] Compile Evolution-Mapi 3.1.1 - Error on libmapi.h

2011-05-16 Thread tudstudent
in the pkg-config search path. Perhaps you should add the directory containing `talloc.pc' to the PKG_CONFIG_PATH environment variable Package 'talloc', required by 'MAPI', not found This package is installed. Milan Crha wrote: On Mon, 2011-05-16 at 01:45 -0700, tudstudent wrote: Okey, maybe

[Evolution-hackers] Compile Evolution-Mapi 3.1.1 - Error on libmapi.h

2011-05-15 Thread tudstudent
Last couple of days I have completely recompiled Evolution 3.1.1 (as RPM - never done this before so a big job for me). But after some fighting with other packages I got stuck with libmapi.h When compiling evolution-mapi-3.1.1 I get stuck with the following error: [code]