[Evolution-hackers] evolution-mapi and evolution-ews

2013-01-30 Thread Sasa Ostrouska
Hi I'm trying to build the evolution-mapi and evolution-ews plugins for 3.6.3.

It seems that they are not finding the correct version of my
evolution-data-server-1.2 .

By looking into the thing I saw that they use pkg-config --libs in the
configure script and not pkg-config --modversion
to determine the version of evolution-data-server-1.2.

Now the strange thing is that I build up evolution-kolab without any problem.

What I get is the following:

root@slack14:/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/dbs-trunk#
pkg-config --libs evolution-data-server-1.2
Empty package name in Requires or Conflicts in file
'/usr/lib64/pkgconfig/evolution-data-server-1.2.pc'

root@slack14:/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/dbs-trunk#
pkg-config --modversion evolution-data-server-1.2
3.6.3

If I issue pkg-config --libs evolution-mail-3.0 I get the following:
root@slack14:/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/dbs-trunk#
pkg-config --libs evolution-mail-3.0-Wl,-R/usr/lib64/evolution/3.6
-Wl,--export-dynamic -pthread -L/usr/lib64/evolution/3.6
-levolution-mail -lcomposer -leshell -lemiscwidgets -leutil
-lemail-engine -ledataserverui-3.0 -lwebkitgtk-3.0 -lebook-1.2
-ljavascriptcoregtk-3.0 -lemail-utils -levolution-utils -lebackend-1.2
-lgtk-3 -lgdk-3 -latk-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0
-lcairo-gobject -lpango-1.0 -lcairo -ledataserver-1.2 -lgmodule-2.0
-lrt -lcamel-1.2 -lplc4 -lplds4 -lnspr4 -lssl3 -lsmime3 -lnss3
-lgnome-keyring -lxml2 -lsoup-2.4 -lsqlite3 -ldl -lgio-2.0
-lgobject-2.0 -lglib-2.0

Is there some problem in my build of evolution data server ?

Rgds
Saxa
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] evolution-mapi and evolution-ews

2013-01-30 Thread Milan Crha
On Tue, 2013-01-29 at 23:33 -0300, Sasa Ostrouska wrote:
 By looking into the thing I saw that they use pkg-config --libs in the
 configure script and not pkg-config --modversion
 to determine the version of evolution-data-server-1.2.

Hi,
I see in configure.ac or evolution-mapi only this:

   PKG_CHECK_MODULES(EVOLUTION_DATA_SERVER, evolution-data-server-$EDS_PACKAGE 
= eds_minimum_version)

thus I guess this was translated to the code you found by the autotools,
where can lye the issue, because the evolution-data-server-1.2.pc
doesn't provide anything useful (no Libs, nor Cflags), thus I guess it
can safely die and only the sublibraries can  be used directly, which
they are already anyway. Just a thought.

 root@slack14:/home/sasa/DEVELOPMENT/DROPLINE_GNOME/DBS/dbs-trunk#
 pkg-config --libs evolution-data-server-1.2
 Empty package name in Requires or Conflicts in file
 '/usr/lib64/pkgconfig/evolution-data-server-1.2.pc'

This returns for me:
   -lgio-2.0 -lssl3 -lsmime3 -lnss3 -lgobject-2.0 -lglib-2.0 -lnssutil3
   -lplds4 -lplc4 -lnspr4 -lpthread -ldl

Bye,
Milan

___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-hackers