[Evolution-hackers] [PATCH] evolution-ews: implement Exchange categories as evolution labels (read only)

2011-05-23 Thread James Bottomley
colour you add to a message via the categories in outlook (or the outlook web server) automatically appears in evolution. The next phase will be to allow evolution to modify the categories. Signed-off-by: James Bottomley james.bottom...@parallels.com diff --git a/src/camel/camel-ews-folder.c b/src

Re: [Evolution-hackers] [PATCH] evolution-ews: implement Exchange categories as evolution labels (read only)

2011-05-23 Thread James Bottomley
On Mon, 2011-05-23 at 12:19 +0100, David Woodhouse wrote: On Mon, 2011-05-23 at 14:41 +0400, James Bottomley wrote: + + /* this is a mapping from Exchange/Outlook categories to +* evolution labels based on the standard colours */ + const gchar *labels

Re: [Evolution-hackers] [PATCH] evolution-ews: implement Exchange categories as evolution labels (read only)

2011-05-23 Thread James Bottomley
On Mon, 2011-05-23 at 14:21 +0200, Milan Crha wrote: On Mon, 2011-05-23 at 14:41 +0400, James Bottomley wrote: This patch ... Hi, could you use Gnome's bugzilla for patch reviews, please? Consider this more an RFC requiring feedback than a patch requiring review. James It has

Re: [Evolution-hackers] [PATCH] evolution-ews: implement Exchange categories as evolution labels (read only)

2011-05-23 Thread James Bottomley
On Mon, 2011-05-23 at 14:34 +0100, David Woodhouse wrote: On Mon, 2011-05-23 at 17:08 +0400, James Bottomley wrote: could you use Gnome's bugzilla for patch reviews, please? Consider this more an RFC requiring feedback than a patch requiring review. For Evo-EWS I'm much happier

Re: [Evolution-hackers] [PATCH] evolution-ews: implement Exchange categories as evolution labels (read only)

2011-06-30 Thread James Bottomley
On Mon, 2011-06-27 at 13:22 +0100, David Woodhouse wrote: On Mon, 2011-05-23 at 16:55 +0400, James Bottomley wrote: I kid you not. You can see this just by going to your own outlook web server (when you highlight a message, you'll see an empty tall oblong, click and it will bring up

[Evolution-hackers] evolution-ews connection problem

2011-07-05 Thread James Bottomley
This is a bit weird: I have two FC14 systems both connecting identically (the evolution configuration is actually cloned between them). One connects just fine, but the other won't do the initial mailbox scan. The log is full of (evolution:2589): libsoup-CRITICAL **: soup_session_get_connection:

Re: [Evolution-hackers] evolution-ews connection problem

2011-07-05 Thread James Bottomley
On Tue, 2011-07-05 at 10:35 -0400, Matthew Barnes wrote: On Tue, 2011-07-05 at 09:04 -0500, James Bottomley wrote: This is a bit weird: I have two FC14 systems both connecting identically (the evolution configuration is actually cloned between them). One connects just fine, but the other

Re: [Evolution-hackers] evolution-ews connection problem

2011-07-05 Thread James Bottomley
On Tue, 2011-07-05 at 18:01 +0300, Ocheretny, Pavel wrote: On Tue, 2011-07-05 at 17:47 +0300, James Bottomley wrote: Well, as I said, they're both FC14 systems, so yes, the version on both is libsoup-2.32.2-1.fc14.i686 James Try to run EWS_DEBUG=2 evolution the send the log file

Re: [Evolution-hackers] evolution-ews connection problem

2011-07-10 Thread James Bottomley
On Tue, 2011-07-05 at 10:36 -0500, James Bottomley wrote: On Tue, 2011-07-05 at 18:01 +0300, Ocheretny, Pavel wrote: On Tue, 2011-07-05 at 17:47 +0300, James Bottomley wrote: Well, as I said, they're both FC14 systems, so yes, the version on both is libsoup-2.32.2-1.fc14.i686

[Evolution-hackers] [PATCH v2] evolution-ews: implement Exchange categories as evolution labels

2011-07-12 Thread James Bottomley
From: James Bottomley jbottom...@parallels.com This patch adds evolution labels to an exchange back end via outlook categories. The outlook categories perform roughly the same function and evolution even mirrors their colour scheme. This patch allows evolution to fill in the labels from the EWS

[Evolution-hackers] [PATCH] evolution-ews: fix draft flag on sent items

2011-07-13 Thread James Bottomley
From: James Bottomley jbottom...@parallels.com What's happening currently is that the outlook web server shows all my sent messages with a yellow banner wrongly saying This Message has not been Sent. The design of EWS is that you should append to folders with MessageDisposition SaveOnly and send

[Evolution-hackers] [PATCH] ews-exchange: allow set/reset of Importance flag

2011-07-13 Thread James Bottomley
From: James Bottomley jbottom...@parallels.com When you have a lot of people who set the Importance flag to high on all their incoming messages, it's useful to be able to reset it so that only genuinely important messages remain flagged in your folders. This patch implements the ability to set

[Evolution-hackers] [PATCH] evolution-ews: fix calendar failure when specifying UTC as the TimeZone

2011-07-16 Thread James Bottomley
From: James Bottomley jbottom...@parallels.com If you use evolution to specify an appointment in UTC, currently it gets translated as native time in whatever timezone the exchange server happens to be running. The bug is that the UTC timezone has no properties, so the check for standard

[Evolution-hackers] evolution-ews timezone handling bug

2011-07-17 Thread James Bottomley
Hi All, Now that I've got evolution-ews working with UTC, I noticed that we have another bug with the handling of timezones that don't do daylight savings (it's not just UTC ... you can see the same thing with America/Phoenix for the same reason). To See the bug, Just schedule 12 recurring

[Evolution-hackers] password storage problem with evolution calendar

2011-07-20 Thread James Bottomley
I notice this most often with evolution-ews, but I have seen it with google calendar as well. The calendar basically loses its ability to retrieve stored passwords and has to keep asking for them every time. What's happening is that the uri= property in gconf has been reset to the base_uri,

[Evolution-hackers] evolution-ews: complete failure of git head calendar to work

2011-08-01 Thread James Bottomley
From this patch: commit 250164f2ec01cb3dad1fa4985e4a4a8a92dc3206 Author: Pavel Ocheretny pochere...@src.gnome.org Date: Wed Jul 27 13:04:59 2011 +0300 Move SOAP calls to use EWS_EXCHANGE_2007_SP1. this patch is for QA mostly, s It fails to load the calendar with this error:

Re: [Evolution-hackers] evolution-ews: complete failure of git head calendar to work

2011-08-02 Thread James Bottomley
On Tue, 2011-08-02 at 09:28 +0300, Pavel Ocheretny wrote: On Tue, 2011-08-02 at 01:29 +0300, James Bottomley wrote: With the current git head, it just crashes in e_cal_backend_open(). Please see, https://mail.gnome.org/archives/evolution-list/2011-August/msg3.html OK, that works

[Evolution-hackers] Imminent critical SSL problem in evolution 3.10

2014-10-25 Thread James Bottomley
It looks like the recently released openssl 1.0.1j breaks evolution by causing it to have no overlapping cyphersuites. I've created a bug for it here: https://bugzilla.gnome.org/show_bug.cgi?id=739179 But it needs fixing as a matter of urgency, since this is the version most desktop distros

Re: [Evolution-hackers] Imminent critical SSL problem in evolution 3.10

2014-10-27 Thread James Bottomley
On Mon, 2014-10-27 at 07:13 +0100, Milan Crha wrote: On Sat, 2014-10-25 at 11:53 -0700, James Bottomley wrote: It looks like the recently released openssl 1.0.1j breaks evolution by causing it to have no overlapping cyphersuites. I've created a bug for it here: https

Re: [Evolution-hackers] Imminent critical SSL problem in evolution 3.10

2014-10-29 Thread James Bottomley
On Wed, 2014-10-29 at 07:56 +0100, Milan Crha wrote: On Mon, 2014-10-27 at 10:00 -0700, James Bottomley wrote: OK, I reopened it as incomplete. You can't close it as FIXED when it isn't upstream in the gnome tree because that's going to cause massive confusion: a package maintainer

[Evolution-hackers] Need help debugging owncloud caldav problem

2015-11-17 Thread James Bottomley
At least, it may not necessarily be a caldav problem, I think it might actually be an ical parsing issue. The symptoms are that I've exported about 1,300 events from my google calendar and imported it successfully into owncloud. Verification via the web calendar and also the caldav android

Re: [Evolution-hackers] Need help debugging owncloud caldav problem

2015-11-18 Thread James Bottomley
On Wed, 2015-11-18 at 07:53 +0100, Milan Crha wrote: > On Tue, 2015-11-17 at 09:42 -0800, James Bottomley wrote: > > Shows they're all present, including the ones evolution is not > > displaying. I suspect there's some issue somewhere in the ical file > > that's causing a pa

Re: [Evolution-hackers] Need help debugging owncloud caldav problem

2015-11-25 Thread James Bottomley
On Tue, 2015-11-24 at 18:32 +0100, Milan Crha wrote: > On Tue, 2015-11-24 at 15:17 +0300, James Bottomley wrote: > > DTSTART;TZID=America/Los_Angeles:20131024T18 > > DTEND;TZID="America/Los_Angeles;VALUE=":20131024T20 > > > > Removing the quotes and th

Re: [Evolution-hackers] Need help debugging owncloud caldav problem

2015-11-26 Thread James Bottomley
On Thu, 2015-11-26 at 09:06 +0100, Milan Crha wrote: > On Thu, 2015-11-26 at 08:01 +0300, James Bottomley wrote: > > I'm thinking currently the fix might be in libical. Both the issues: > > converting VALUE= to VALUE=x and adding it to the TZID look to be > > bugs in that l

Re: [Evolution-hackers] Need help debugging owncloud caldav problem

2015-11-25 Thread James Bottomley
On Wed, 2015-11-25 at 15:23 +0100, Milan Crha wrote: > On Wed, 2015-11-25 at 12:21 +0300, James Bottomley wrote: > > On Tue, 2015-11-24 at 18:32 +0100, Milan Crha wrote: > > > On Tue, 2015-11-24 at 15:17 +0300, James Bottomley wrote: > > > > DTSTART;TZID=Ameri

Re: [Evolution-hackers] Need help debugging owncloud caldav problem

2015-11-24 Thread James Bottomley
On Wed, 2015-11-18 at 10:03 -0800, James Bottomley wrote: > On Wed, 2015-11-18 at 07:53 +0100, Milan Crha wrote: > > On Tue, 2015-11-17 at 09:42 -0800, James Bottomley wrote: > > > Shows they're all present, including the ones evolution is not > > > displaying. I

Re: [Evolution-hackers] evolution failing on TLSv1.3 after gnutls upgrade

2019-05-16 Thread James Bottomley via evolution-hackers
On Thu, 2019-05-16 at 09:05 +0200, Milan Crha via evolution-hackers wrote: > On Wed, 2019-05-15 at 15:49 -0700, James Bottomley wrote: > > gnutls Add support for timeouts on GnuTLS pulls > > > > So if you apply that on top of 2.54.1, the test programme works > > aga

Re: [Evolution-hackers] evolution failing on TLSv1.3 after gnutls upgrade

2019-05-15 Thread James Bottomley via evolution-hackers
On Mon, 2019-05-13 at 18:00 +0200, Milan Crha via evolution-hacker > Consider filling a bug against glib-networking [1] and ask them > whether they can do anything about it. You've a clear view what is > going on in the background, thus you'd be able to explain the problem > to them. Feel free to

[Evolution-hackers] evolution failing on TLSv1.3 after gnutls upgrade

2019-05-09 Thread James Bottomley via evolution-hackers
On OpenSUSE running evolution-3.26.6-lp150.2.6.x86_64, installing gnutls-3.6.7-lp150.9.1.x86_64 Lead to evolution failing on my dovecot imap server with Error reading data from TLS socket: The specified session has been invalidated for some reason Turning on ssl verbose debugging on the

Re: [Evolution-hackers] evolution failing on TLSv1.3 after gnutls upgrade

2019-05-09 Thread James Bottomley via evolution-hackers
On Thu, 2019-05-09 at 18:42 +0200, Milan Crha via evolution-hackers wrote: > On Thu, 2019-05-09 at 08:37 -0700, James Bottomley via evolution- > hackers wrote: > > On OpenSUSE running evolution-3.26.6-lp150.2.6.x86_64, installing > > > > gnutls-3.6.7-lp150.9.1.x86_64 &g

Re: [Evolution-hackers] evolution failing on TLSv1.3 after gnutls upgrade

2019-05-13 Thread James Bottomley via evolution-hackers
On Mon, 2019-05-13 at 09:17 +0200, Milan Crha via evolution-hackers wrote: > On Sun, 2019-05-12 at 11:04 -0700, James Bottomley via evolution- > hackers wrote: [...] > > I think the solution is to simply bar glib-networking below 2.55.2 > > from using gnutls VERS-TLS1.3 which

Re: [Evolution-hackers] evolution failing on TLSv1.3 after gnutls upgrade

2019-05-10 Thread James Bottomley via evolution-hackers
On Fri, 2019-05-10 at 08:41 +0200, Milan Crha via evolution-hackers wrote: > On Thu, 2019-05-09 at 11:03 -0700, James Bottomley wrote: > > I can certainly test things out. > > Hi, > that's great, thanks. > > > To be honest, I've had problems with TLSv1.3 every ti

Re: [Evolution-hackers] evolution failing on TLSv1.3 after gnutls upgrade

2019-05-12 Thread James Bottomley via evolution-hackers
On Fri, 2019-05-10 at 23:23 +0200, Sasa Ostrouska via evolution-hackers wrote: > Hi all, and thanks Milan for the program. I also run an old version > of evolution 3.20.x and I get the following: > > rc@rc-laptop:~/Downloads$ gcc `pkg-config --cflags --libs glib-2.0 > gio-2.0` imap-conn.c -g -O0