Re: [Evolution-hackers] LFS in evolution-data-server

2010-07-10 Thread Yves-Alexis Perez
On jeu., 2010-07-08 at 14:19 +0200, Yves-Alexis Perez wrote:
 Hey there,
 
 I'm the current evolution/eds/gtkhtml maintainer in Debian, and I'd like
 to ask a question. 

Ping? Any idea on that?
-- 
Yves-Alexis


signature.asc
Description: This is a digitally signed message part
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] LFS in evolution-data-server

2010-07-10 Thread Matthew Barnes
On Thu, 2010-07-08 at 14:19 +0200, Yves-Alexis Perez wrote:
 I recently enabled large file support in evolution-data-server in
 Debian. It seems that it leaded to the discover of some bugs on i386
 installs (like http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=580419 /
 https://bugzilla.gnome.org/show_bug.cgi?id=612082  and
 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=585921 /
 https://bugzilla.gnome.org/show_bug.cgi?id=619098) which leaded to crashes.

After applying the patches in #612082 and the one-line fix in #619098,
are you still seeing reports of problems?  It seemed to me the issue had
at least quieted down if not been fixed entirely.

___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] LFS in evolution-data-server

2010-07-10 Thread Yves-Alexis Perez
On sam., 2010-07-10 at 07:00 -0400, Matthew Barnes wrote:
 On Thu, 2010-07-08 at 14:19 +0200, Yves-Alexis Perez wrote:
  I recently enabled large file support in evolution-data-server in
  Debian. It seems that it leaded to the discover of some bugs on i386
  installs (like http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=580419 /
  https://bugzilla.gnome.org/show_bug.cgi?id=612082  and
  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=585921 /
  https://bugzilla.gnome.org/show_bug.cgi?id=619098) which leaded to crashes.
 
 After applying the patches in #612082 and the one-line fix in #619098,
 are you still seeing reports of problems?  It seemed to me the issue had
 at least quieted down if not been fixed entirely.
 

It was a more generic questions. Those bugs are fixed, and it's better
they are fixed than hidden.

But if enabling LFS means codepaths not well tested are used and bugs
are discovered, it's bad and good at the same time. Bad because we see
nasty bugs which make evolution crash, good because rarely used
codepaths are now used more often and those bugs can be identified and
fixed.

Now, would you recommend enabling LFS in Debian stable? I'm wondering,
especially since it's not enabled by default.

Cheers, and thanks for your time.
-- 
Yves-Alexis


signature.asc
Description: This is a digitally signed message part
___
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers