Re: [Evolution-hackers] build Evolution with jhbuild - unsuccessfull result

2010-04-02 Thread Kjartan Maraas
to., 01.04.2010 kl. 19.04 +0300, skrev Ivan A. Kostyuk:
 Hello Kjartan.
 I have installed packages: gettext, gettext-base (version 0.17-2ubuntu1)
 
And did that help in any way? Maybe it's not finding them in your system
prefix? Tried jhbuild bootstrap?

Cheers
Kjartan


___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] build Evolution with jhbuild - unsuccessfull result

2010-04-01 Thread Ivan A. Kostyuk
Hello Thomas.

My environment - Ubuntu 8.04 64-bit
Evolution 2.28

On Sun, 2010-03-28 at 21:30 +0200, Thomas Mittelstaedt wrote:
 Which version of evolution are you trying to build? On which operating
 system / distribution are you? Output below hints that you are
 on a 64-bit system, right?
 
 Am Sonntag, den 28.03.2010, 21:41 +0300 schrieb Ivan A. Kostyuk:
  Hello dear colleagues.
  
  I did the build with help of jhbuild I got following errors:
  Running aclocal-1.11...
  /home/WORK/opt/gnome2/share/aclocal/audiofile.m4:12: warning:
  underquoted definition of AM_PATH_AUDIOFILE
  /home/WORK/opt/gnome2/share/aclocal/audiofile.m4:12:   run info
  '(automake)Extending aclocal'
  /home/WORK/opt/gnome2/share/aclocal/audiofile.m4:12:   or see
  http://sources.redhat.com/automake/automake.html#Extending-aclocal
  configure.in:44: warning: AM_NLS is m4_require'd but not m4_defun'd
  m4/intltool.m4:27: IT_PROG_INTLTOOL is expanded from...
  configure.in:44: the top level
  Running autoconf...
  configure.in:44: warning: AM_NLS is m4_require'd but not m4_defun'd
  m4/intltool.m4:27: IT_PROG_INTLTOOL is expanded from...
  configure.in:44: the top level
  configure:3087: error: possibly undefined macro: AM_NLS
If this token and others are legitimate, please use
  m4_pattern_allow.
See the Autoconf documentation.
  *** Error during phase configure of gnome-doc-utils: ## Error
  running ./autogen.sh --prefix /home/WORK/opt/gnome2 --libdir
  '/home/WORK/opt/gnome2/lib64'  --disable-static --disable-gtk-doc  ***
  [8/68]
  
  *** Configuring icon-naming-utils *** [48/68]
  ./configure --prefix /home/WORK/opt/gnome2 --libdir
  '/home/WORK/opt/gnome2/lib64'  --disable-static --disable-gtk-doc 
  checking for a BSD-compatible
  install... /home/eventissimus/.local/bin/install-check
  checking whether build environment is sane... yes
  checking for a thread-safe mkdir -p... /bin/mkdir -p
  checking for gawk... no
  checking for mawk... mawk
  checking whether make sets $(MAKE)... yes
  checking whether to enable maintainer-specific portions of Makefiles...
  no
  checking for perl... /usr/bin/perl
  checking for XML::Simple... configure: error: XML::Simple perl module is
  required for icon-naming-utils
  *** Error during phase configure of icon-naming-utils: ## Error
  running ./configure --prefix /home/WORK/opt/gnome2 --libdir
  '/home/WORK/opt/gnome2/lib64'  --disable-static --disable-gtk-doc  ***
  [48/68]
  
  I gave up the modules and in the final I got that the following modules
  were not built:
  gnome-doc-utils gtk-doc glib libIDL ORBit2 cairo gobject-introspection
  pango atk shared-mime-info gtk+ dbus dbus-glib libbonobo libglade
  eggdbus polkit gconf gstreamer enchant libproxy libsoup pygobject
  libgweather PolicyKit hal gnome-keyring evolution-data-server
  icon-naming-utils gnome-icon-theme gtkhtml desktop-file-utils
  gnome-mime-data dbus-python pycairo pygtk avahi gamin gnome-vfs libgnome
  libgnomecanvas libbonoboui libgnomeui libnotify evolution
  
  What should I do in order to fix that modules?
  
  Thank you in advance,
  Ivan
  
  
  ___
  Evolution-hackers mailing list
  Evolution-hackers@gnome.org
  http://mail.gnome.org/mailman/listinfo/evolution-hackers
 

___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] build Evolution with jhbuild - unsuccessfull result

2010-04-01 Thread Thomas Mittelstaedt
Ivan,


Am Donnerstag, den 01.04.2010, 19:03 +0300 schrieb Ivan A. Kostyuk:
 Hello Thomas.
 
 My environment - Ubuntu 8.04 64-bit
 Evolution 2.28

So, you are on ubuntu, have a 64-bit system and wish to build evolution
2.28, right?

On http://live.gnome.org/Evolution/#Developer_Resources, there is a nice
little link to http://mad-scientist.us/evolution.html, which uses a 
Makefile file rather than jhbuild to check out the sources from git
and build it. When I started to build evolution a little more than
a year ago, I did just that and it worked very nicely for me.

Under How to use it, it says:
By default, the makefile checks out and builds the latest version on
the Git trunk for all packages. If you want to build the latest on a
specific branch, set the branch make variable to the version number;
e.g. branch := 2.28.

Hope that helps.

 
 
 On Sun, 2010-03-28 at 21:30 +0200, Thomas Mittelstaedt wrote:
  Which version of evolution are you trying to build? On which operating
  system / distribution are you? Output below hints that you are
  on a 64-bit system, right?
  
  Am Sonntag, den 28.03.2010, 21:41 +0300 schrieb Ivan A. Kostyuk:
   Hello dear colleagues.
   
   I did the build with help of jhbuild I got following errors:
   Running aclocal-1.11...
   /home/WORK/opt/gnome2/share/aclocal/audiofile.m4:12: warning:
   underquoted definition of AM_PATH_AUDIOFILE
   /home/WORK/opt/gnome2/share/aclocal/audiofile.m4:12:   run info
   '(automake)Extending aclocal'
   /home/WORK/opt/gnome2/share/aclocal/audiofile.m4:12:   or see
   http://sources.redhat.com/automake/automake.html#Extending-aclocal
   configure.in:44: warning: AM_NLS is m4_require'd but not m4_defun'd
   m4/intltool.m4:27: IT_PROG_INTLTOOL is expanded from...
   configure.in:44: the top level
   Running autoconf...
   configure.in:44: warning: AM_NLS is m4_require'd but not m4_defun'd
   m4/intltool.m4:27: IT_PROG_INTLTOOL is expanded from...
   configure.in:44: the top level
   configure:3087: error: possibly undefined macro: AM_NLS
 If this token and others are legitimate, please use
   m4_pattern_allow.
 See the Autoconf documentation.
   *** Error during phase configure of gnome-doc-utils: ## Error
   running ./autogen.sh --prefix /home/WORK/opt/gnome2 --libdir
   '/home/WORK/opt/gnome2/lib64'  --disable-static --disable-gtk-doc  ***
   [8/68]
   
   *** Configuring icon-naming-utils *** [48/68]
   ./configure --prefix /home/WORK/opt/gnome2 --libdir
   '/home/WORK/opt/gnome2/lib64'  --disable-static --disable-gtk-doc 
   checking for a BSD-compatible
   install... /home/eventissimus/.local/bin/install-check
   checking whether build environment is sane... yes
   checking for a thread-safe mkdir -p... /bin/mkdir -p
   checking for gawk... no
   checking for mawk... mawk
   checking whether make sets $(MAKE)... yes
   checking whether to enable maintainer-specific portions of Makefiles...
   no
   checking for perl... /usr/bin/perl
   checking for XML::Simple... configure: error: XML::Simple perl module is
   required for icon-naming-utils
   *** Error during phase configure of icon-naming-utils: ## Error
   running ./configure --prefix /home/WORK/opt/gnome2 --libdir
   '/home/WORK/opt/gnome2/lib64'  --disable-static --disable-gtk-doc  ***
   [48/68]
   
   I gave up the modules and in the final I got that the following modules
   were not built:
   gnome-doc-utils gtk-doc glib libIDL ORBit2 cairo gobject-introspection
   pango atk shared-mime-info gtk+ dbus dbus-glib libbonobo libglade
   eggdbus polkit gconf gstreamer enchant libproxy libsoup pygobject
   libgweather PolicyKit hal gnome-keyring evolution-data-server
   icon-naming-utils gnome-icon-theme gtkhtml desktop-file-utils
   gnome-mime-data dbus-python pycairo pygtk avahi gamin gnome-vfs libgnome
   libgnomecanvas libbonoboui libgnomeui libnotify evolution
   
   What should I do in order to fix that modules?
   
   Thank you in advance,
   Ivan
   
   
   ___
   Evolution-hackers mailing list
   Evolution-hackers@gnome.org
   http://mail.gnome.org/mailman/listinfo/evolution-hackers
  
 

-- 
thomas


___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers


Re: [Evolution-hackers] build Evolution with jhbuild - unsuccessfull result

2010-03-30 Thread Kjartan Maraas
sø., 28.03.2010 kl. 21.41 +0300, skrev Ivan A. Kostyuk:
 Hello dear colleagues.
 
 I did the build with help of jhbuild I got following errors:
 Running aclocal-1.11...
 /home/WORK/opt/gnome2/share/aclocal/audiofile.m4:12: warning:
 underquoted definition of AM_PATH_AUDIOFILE
 /home/WORK/opt/gnome2/share/aclocal/audiofile.m4:12:   run info
 '(automake)Extending aclocal'
 /home/WORK/opt/gnome2/share/aclocal/audiofile.m4:12:   or see
 http://sources.redhat.com/automake/automake.html#Extending-aclocal
 configure.in:44: warning: AM_NLS is m4_require'd but not m4_defun'd
 m4/intltool.m4:27: IT_PROG_INTLTOOL is expanded from...
 configure.in:44: the top level
 Running autoconf...
 configure.in:44: warning: AM_NLS is m4_require'd but not m4_defun'd
 m4/intltool.m4:27: IT_PROG_INTLTOOL is expanded from...
 configure.in:44: the top level
 configure:3087: error: possibly undefined macro: AM_NLS
   If this token and others are legitimate, please use
 m4_pattern_allow.
   See the Autoconf documentation.
 *** Error during phase configure of gnome-doc-utils: ## Error
 running ./autogen.sh --prefix /home/WORK/opt/gnome2 --libdir
 '/home/WORK/opt/gnome2/lib64'  --disable-static --disable-gtk-doc  ***
 [8/68]
 
I think this is due to a missing gettext-devel on your system.

 *** Configuring icon-naming-utils *** [48/68]
 ./configure --prefix /home/WORK/opt/gnome2 --libdir
 '/home/WORK/opt/gnome2/lib64'  --disable-static --disable-gtk-doc 
 checking for a BSD-compatible
 install... /home/eventissimus/.local/bin/install-check
 checking whether build environment is sane... yes
 checking for a thread-safe mkdir -p... /bin/mkdir -p
 checking for gawk... no
 checking for mawk... mawk
 checking whether make sets $(MAKE)... yes
 checking whether to enable maintainer-specific portions of Makefiles...
 no
 checking for perl... /usr/bin/perl
 checking for XML::Simple... configure: error: XML::Simple perl module is
 required for icon-naming-utils
 *** Error during phase configure of icon-naming-utils: ## Error
 running ./configure --prefix /home/WORK/opt/gnome2 --libdir
 '/home/WORK/opt/gnome2/lib64'  --disable-static --disable-gtk-doc  ***
 [48/68]
 
And this is similarly a missing perl-XML-Simple package.

Also, you should probably run jhbuild bootstrap if you don't have a very
recent distro.

Cheers
Kjartan


___
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers