Re: [FFmpeg-devel] [PATCH 0/2] add sad 32x32 with sse2/avx2 optimizations.

2018-07-24 Thread myp...@gmail.com
On Tue, Jul 17, 2018 at 7:25 PM Jun Zhao wrote: > > V2: - update performance data > - hold on minterpolate filter improvement (need to more talk for > minterpolate improvement) > > Jun Zhao (2): > lavutil/pixelutils: add sad_32x32 in pixelutils API. > avutil/pixelutils: sad_32x32

Re: [FFmpeg-devel] [PATCH 3/3] lavfi/motion_estimation: use pixelutils API for sad.

2018-07-16 Thread myp...@gmail.com
wrote: > > >> > > >> > > >>On Thu, 12 Jul 2018, myp...@gmail.com wrote: > > >> > > >>>On Thu, Jul 12, 2018 at 12:43 AM Marton Balint wrote: > > >>>> > > >>>> > > >>>> > > &g

Re: [FFmpeg-devel] [PATCH V2 2/2] lavc/hevc_ps: use skip_bits instead of get_bits when skip bits.

2018-07-15 Thread myp...@gmail.com
On Fri, Jul 13, 2018 at 6:28 PM Michael Niedermayer wrote: > > On Thu, Jul 12, 2018 at 10:28:44PM +0800, Jun Zhao wrote: > > use skip_bits when want to skip some bits. > > > > Signed-off-by: Jun Zhao > > --- > > libavcodec/hevc_ps.c |2 +- > > 1 files changed, 1 insertions(+), 1

Re: [FFmpeg-devel] [PATCH V2 1/2] lavc/hevc_ps: Refine sps_range_extension parse.

2018-07-15 Thread myp...@gmail.com
On Fri, Jul 13, 2018 at 6:34 PM Michael Niedermayer wrote: > On Thu, Jul 12, 2018 at 10:28:43PM +0800, Jun Zhao wrote: > > Signed-off-by: Jun Zhao > > --- > > libavcodec/hevc_ps.c |6 ++ > > 1 files changed, 2 insertions(+), 4 deletions(-) > > > > diff --git a/libavcodec/hevc_ps.c

Re: [FFmpeg-devel] mistake in patch "Add lensfun filter"

2018-07-11 Thread myp...@gmail.com
On Thu, Jul 12, 2018 at 12:47 PM Stephen Seo wrote: > > Hi, > > It appears I used the wrong license in libavfilter/vf_lensfun.c > > It derives from the Lensfun library that uses (L)GPL3, but I used GPL2 by > mistake. > > Should I 'git send-email' the whole patch again with this mistake resolved,

Re: [FFmpeg-devel] [PATCH 3/3] lavfi/motion_estimation: use pixelutils API for sad.

2018-07-11 Thread myp...@gmail.com
On Thu, Jul 12, 2018 at 12:43 AM Marton Balint wrote: > > > > On Wed, 11 Jul 2018, Jun Zhao wrote: > > > use pixelutils API for sad in motion estimation. > > Does it make sense to improve this code? I thought a superior and faster > approach was a result of 2017 GSOC task: > >

Re: [FFmpeg-devel] [PATCH 2/2] lavc/hevc_ps: use skip_bits instead of get_bits when skip bits.

2018-07-08 Thread myp...@gmail.com
On Mon, Jul 9, 2018 at 8:41 AM James Almer wrote: > > On 7/8/2018 9:16 PM, myp...@gmail.com wrote: > > On Sat, Jul 7, 2018 at 6:32 PM Carl Eugen Hoyos wrote: > >> > >> 2018-07-07 7:48 GMT+02:00, Jun Zhao : > >>> use skip_bits when want to skip some

Re: [FFmpeg-devel] [PATCH 2/2] lavc/hevc_ps: use skip_bits instead of get_bits when skip bits.

2018-07-08 Thread myp...@gmail.com
On Sat, Jul 7, 2018 at 6:32 PM Carl Eugen Hoyos wrote: > > 2018-07-07 7:48 GMT+02:00, Jun Zhao : > > use skip_bits when want to skip some bits. > > > > Signed-off-by: Jun Zhao > > --- > > libavcodec/hevc_ps.c | 2 +- > > 1 file changed, 1 insertion(+), 1 deletion(-) > > > > diff --git

Re: [FFmpeg-devel] [PATCH] lavfi/minterpolate: fix blending calc issue.

2018-07-08 Thread myp...@gmail.com
On Fri, Jul 6, 2018 at 3:21 PM Steven Liu wrote: > > myp...@gmail.com 于2018年7月4日周三 下午3:05写道: > > > > On Wed, Jun 27, 2018 at 5:52 PM Jun Zhao wrote: > > > > > > the right blending calc is: > > > (alpha * Frame_2 + (MAX - alpha) * Frame_1 + 5

Re: [FFmpeg-devel] [PATCH] lavfi/minterpolate: fix blending calc issue.

2018-07-04 Thread myp...@gmail.com
On Wed, Jun 27, 2018 at 5:52 PM Jun Zhao wrote: > > the right blending calc is: > (alpha * Frame_2 + (MAX - alpha) * Frame_1 + 512) >> 10 > > Signed-off-by: Jun Zhao > --- > libavfilter/vf_minterpolate.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git

Re: [FFmpeg-devel] [PATCH] doc/filters: add documentation to all existing OpenCL filters, except tonemap filter

2018-07-02 Thread myp...@gmail.com
On Tue, Jul 3, 2018 at 10:51 AM Danil Iashchenko wrote: > > Add documentation to all existing OpenCL filters, except tonemap filter. > > --- > Creation of the seperate section for OpenCL filters is motivated by > developing support for Vulkan and CUDA and it is easier to show the > capabilities

Re: [FFmpeg-devel] [PATCH v2 3/4] hwcontext_opencl: Remove the opencl_device_init in opencl_device_derive

2018-07-01 Thread myp...@gmail.com
On Thu, Jun 28, 2018 at 11:50 PM Mark Thompson wrote: > > On 21/06/18 12:45, Jun Zhao wrote: > > In opencl device derived case, don't need to call opencl_device_init. > > > > Signed-off-by: Jun Zhao > > --- > > libavutil/hwcontext_opencl.c | 7 ++- > > 1 file changed, 2 insertions(+), 5

Re: [FFmpeg-devel] [PATCH v2 4/4] hwcontext_opencl: remove an unused variable

2018-07-01 Thread myp...@gmail.com
On Thu, Jun 28, 2018 at 11:52 PM Mark Thompson wrote: > > On 21/06/18 12:45, Jun Zhao wrote: > > remove an unused variable > > > > Signed-off-by: Jun Zhao > > --- > > libavutil/hwcontext_opencl.c | 1 - > > 1 file changed, 1 deletion(-) > > > > diff --git a/libavutil/hwcontext_opencl.c

Re: [FFmpeg-devel] [PATCH v2 1/4] configure: fix check for opencl_vaapi_intel_media.

2018-07-01 Thread myp...@gmail.com
On Thu, Jun 28, 2018 at 11:51 PM Mark Thompson wrote: > > On 21/06/18 12:45, Jun Zhao wrote: > > opencl_vaapi_intel_media doesn't depend on libmfx, OpenCL™ Drivers > > and Runtimes for Intel® Architectureis is a standalone release, more > > information can be found in the link: > >

Re: [FFmpeg-devel] [PATCH v2 3/4] hwcontext_opencl: Remove the opencl_device_init in opencl_device_derive

2018-06-24 Thread myp...@gmail.com
On Thu, Jun 21, 2018 at 7:50 PM Carl Eugen Hoyos wrote: > > 2018-06-21 13:45 GMT+02:00, Jun Zhao : > > In opencl device derived case, don't need to call opencl_device_init. > > > > Signed-off-by: Jun Zhao > > --- > > libavutil/hwcontext_opencl.c | 7 ++- > > 1 file changed, 2 insertions(+),

Re: [FFmpeg-devel] [PATCH v4 1/2] lavfi: add opencl tonemap filter.

2018-06-20 Thread myp...@gmail.com
On Thu, Jun 21, 2018 at 8:33 AM Mark Thompson wrote: > > On 19/06/18 02:57, Ruiling Song wrote: > > This filter does HDR(HDR10/HLG) to SDR conversion with tone-mapping. > > > > An example command to use this filter with vaapi codecs: > > FFMPEG -init_hw_device vaapi=va:/dev/dri/renderD128

Re: [FFmpeg-devel] [PATCH v1 00/11] Replace magic number by micro for bprint init

2018-06-15 Thread myp...@gmail.com
On Sun, Jun 10, 2018 at 5:28 PM Nicolas George wrote: > > Jun Zhao (2018-06-10): > > v1: - Replace magic number by micro for bprint init > > I will not oppose the patch series, but I think it is useless clutter of > the history. The special values are not magic, they are logical or > standard. >

Re: [FFmpeg-devel] [PATCH 1/2] fftools/ffmpeg: fix memory leak issue.

2018-06-14 Thread myp...@gmail.com
On Thu, Jun 14, 2018 at 9:44 PM Nicolas George wrote: > > Jun Zhao (2018-06-13): > > need to call av_bprint_finalize to free the memory source to match > > av_bprint_init. > > As you may have seen, in this case too, the buffer is never allocated > dynamically. > > The av_bprint_finalize() already

Re: [FFmpeg-devel] [PATCH] avdevice/v4l2enc: add video4linux2 name alias

2018-06-14 Thread myp...@gmail.com
On Fri, Jun 15, 2018 at 5:56 AM Lou Logan wrote: > > On Thu, Jun 14, 2018, at 1:39 PM, Lou Logan wrote: > > Makes v4l2 indev name consistent with the v4l2 indev. > > Should say: > Makes v4l2 outdev name consistent with the v4l2 indev. > > I changed this locally before sending, but forgot to

Re: [FFmpeg-devel] [PATCH 2/2] fftools/ffmpeg_filter: fix memory leak issue.

2018-06-13 Thread myp...@gmail.com
On Wed, Jun 13, 2018 at 9:59 PM Nicolas George wrote: > > Jun Zhao (2018-06-13): > > need to call av_bprint_finalize to free the memory source to match > > av_bprint_init. > > No, this buffer is never allocated dynamically. > > Regards, Thanks the comments, I think I have some misunderstand for

Re: [FFmpeg-devel] [PATCH v1 00/11] Replace magic number by micro for bprint init

2018-06-10 Thread myp...@gmail.com
On Mon, Jun 11, 2018 at 8:48 AM myp...@gmail.com wrote: > > On Sun, Jun 10, 2018 at 5:28 PM Nicolas George wrote: > > > > Jun Zhao (2018-06-10): > > > v1: - Replace magic number by micro for bprint init > > > > I will not oppose the patch se

Re: [FFmpeg-devel] [PATCH v1 00/11] Replace magic number by micro for bprint init

2018-06-10 Thread myp...@gmail.com
On Sun, Jun 10, 2018 at 5:28 PM Nicolas George wrote: > > Jun Zhao (2018-06-10): > > v1: - Replace magic number by micro for bprint init > > I will not oppose the patch series, but I think it is useless clutter of > the history. The special values are not magic, they are logical or > standard.

Re: [FFmpeg-devel] [PATCH v2 16/36] vaapi_encode: Clean up rate control configuration

2018-06-07 Thread myp...@gmail.com
On Fri, Jun 8, 2018 at 7:45 AM Mark Thompson wrote: > > Query which modes are supported and select between VBR and CBR based > on that - this removes all of the codec-specific rate control mode > selection code. > --- > doc/encoders.texi | 2 - > libavcodec/vaapi_encode.c |

Re: [FFmpeg-devel] [PATCH v2 24/36] lavc/cbs: Add JPEG support

2018-06-07 Thread myp...@gmail.com
On Fri, Jun 8, 2018 at 7:46 AM Mark Thompson wrote: > > --- > configure | 2 + > libavcodec/Makefile | 1 + > libavcodec/cbs.c | 6 + > libavcodec/cbs_internal.h | 1 + > libavcodec/cbs_jpeg.c

Re: [FFmpeg-devel] [PATCH 1/2] lavc/dolby_e: fix make checkheaders

2018-06-04 Thread myp...@gmail.com
2018-06-04 22:52 GMT+08:00 James Almer : > On 6/4/2018 11:18 AM, Jun Zhao wrote: >> move the the function init_tables() definitions from header file >> to .c file to fix make checkheaders. > > What compile flags are you using? checkheaders seems to work just fine > on a normal build. >

Re: [FFmpeg-devel] [PATCH v3 4/4] configure: fix check for opencl_vaapi_intel_media.

2018-06-03 Thread myp...@gmail.com
2018-06-04 2:18 GMT+08:00 Mark Thompson : > On 03/06/18 04:15, Jun Zhao wrote: >> opencl_vaapi_intel_media doesn't depend on libmfx, OpenCL™ Drivers >> and Runtimes for Intel® Architectureis is a standalone release, more >> information can be found in the link: >>

Re: [FFmpeg-devel] [PATCH v2 3/4] configure: fix check for opencl

2018-06-03 Thread myp...@gmail.com
2018-06-03 11:04 GMT+08:00 James Almer : > On 6/2/2018 11:58 PM, Jun Zhao wrote: >> add pkg-config support for opencl check. >> >> Signed-off-by: Jun Zhao >> --- >> configure | 1 + >> 1 file changed, 1 insertion(+) >> >> diff --git a/configure b/configure >> index 22eeca2..69b8827 100755 >> ---

Re: [FFmpeg-devel] [PATCH v3 3/4] configure: fix check for opencl

2018-06-03 Thread myp...@gmail.com
2018-06-04 1:53 GMT+08:00 Mark Thompson : > > On 03/06/18 04:15, Jun Zhao wrote: > > add pkg-config support for opencl check. > > > > Signed-off-by: Jun Zhao > > --- > > configure | 3 ++- > > 1 file changed, 2 insertions(+), 1 deletion(-) > > > > diff --git a/configure b/configure > > index

Re: [FFmpeg-devel] [PATCH v3 2/4] lavfi/opencl: remove redundancy header.

2018-06-03 Thread myp...@gmail.com
2018-06-04 1:43 GMT+08:00 Mark Thompson : > On 03/06/18 04:15, Jun Zhao wrote: >> remove redundancy header >> >> Signed-off-by: Jun Zhao >> --- >> libavfilter/opencl.c | 3 --- >> 1 file changed, 3 deletions(-) >> >> diff --git a/libavfilter/opencl.c b/libavfilter/opencl.c >> index

Re: [FFmpeg-devel] [PATCH v3 1/4] lavu/hwcontext_opecl: fix the build warning

2018-06-03 Thread myp...@gmail.com
2018-06-04 1:42 GMT+08:00 Mark Thompson : > On 03/06/18 04:15, Jun Zhao wrote: >> fix the build warning when use Portable Computing Language (pocl). >> >> Signed-off-by: Jun Zhao >> --- >> libavutil/hwcontext_opencl.c | 8 >> 1 file changed, 8 insertions(+) >> >> diff --git

Re: [FFmpeg-devel] [PATCH] lavfi: add opencl tonemap filter.

2018-05-29 Thread myp...@gmail.com
2018-05-29 13:54 GMT+08:00 Ruiling Song : > This filter does HDR(HDR10/HLG) to SDR conversion with tone-mapping. > > An example command to use this filter with vaapi codecs: > FFMPEG -init_hw_device vaapi=va:/dev/dri/renderD128 -init_hw_device \ > opencl=ocl@va -hwaccel vaapi -hwaccel_device va

Re: [FFmpeg-devel] [PATCH v2 0/2] dump more codec information

2018-05-28 Thread myp...@gmail.com
2018-05-27 21:04 GMT+08:00 Mark Thompson : > On 27/05/18 02:38, Jun Zhao wrote: >> V2: - fix the alignment as Reto Kromer's comment >> - improve the characterization as Mark's comments >> >> Jun Zhao (2): >> cmdutils: print missing caps in print_codec(). >> cmdutils: dump

Re: [FFmpeg-devel] [PATCH 2/2] lavu/hwcontext_vaapi: add nv21 map

2018-05-23 Thread myp...@gmail.com
2018-05-24 8:07 GMT+08:00 Mark Thompson : > On 23/05/18 11:29, Jun Zhao wrote: >> Signed-off-by: Jun Zhao >> --- >> libavutil/hwcontext_vaapi.c | 3 +++ >> 1 file changed, 3 insertions(+) >> >> diff --git a/libavutil/hwcontext_vaapi.c

Re: [FFmpeg-devel] [PATCH 1/2] lavu/hwcontext_vaapi: dump more decoding error details.

2018-05-23 Thread myp...@gmail.com
2018-05-24 8:05 GMT+08:00 Mark Thompson : > On 23/05/18 11:29, Jun Zhao wrote: >> dump more decoding error details when sync surface fail. >> >> Signed-off-by: Jun Zhao >> --- >> libavutil/hwcontext_vaapi.c | 17 + >> 1 file changed, 17

Re: [FFmpeg-devel] [PATCH] lavfi: add opencl tonemap filter.

2018-05-21 Thread myp...@gmail.com
2018-05-21 14:50 GMT+08:00 Ruiling Song : > This filter does HDR(HDR10/HLG) to SDR conversion with tone-mapping. > > An example command to use this filter with vaapi codecs: > FFMPEG -init_hw_device vaapi=va:/dev/dri/renderD128 -init_hw_device \ > opencl=ocl@va -hwaccel

Re: [FFmpeg-devel] [PATCH v2 0/3] Enhancement NAL type debug

2018-05-15 Thread myp...@gmail.com
2018-05-14 17:45 GMT+08:00 Jun Zhao : > v2: - cover all h264/hevc NAL unit type > - use table replace switch when map NAL type to string/name > > Jun Zhao (3): > lavc/h2645_parse: log more HEVC NAL type. > lavc/h2645_parse: rename the nal_unit_name to

Re: [FFmpeg-devel] [PATCH 1/3] hwcontext: Do not call device_init again when deriving an existing device

2018-05-14 Thread myp...@gmail.com
2018-05-15 5:58 GMT+08:00 Mark Thompson : > The change in 309d660775e2b47af6723a0477c4d753bc0c54f4 to call device_init > when doing derivation missed this case - we should only call it if we > actually made a new device. > --- > libavutil/hwcontext.c | 7 +++ > 1 file changed,

Re: [FFmpeg-devel] [PATCH 4/4] lavc/cbs_h2645: fix no slice data trigger the assert.

2018-05-13 Thread myp...@gmail.com
2018-05-11 23:38 GMT+08:00 James Almer : > On 5/11/2018 7:10 AM, Mark Thompson wrote: >> On 11/05/18 06:11, Jun Zhao wrote: >>> when the NALU data with zero, just give a warning. >>> >>> Fixes ticket #7200 >>> >>> Signed-off-by: Jun Zhao >>> --- >>>

Re: [FFmpeg-devel] [PATCH 4/4] lavc/cbs_h2645: fix no slice data trigger the assert.

2018-05-13 Thread myp...@gmail.com
2018-05-11 18:10 GMT+08:00 Mark Thompson : > On 11/05/18 06:11, Jun Zhao wrote: >> when the NALU data with zero, just give a warning. >> >> Fixes ticket #7200 >> >> Signed-off-by: Jun Zhao >> --- >> libavcodec/cbs_h2645.c | 6 +- >> 1 file changed, 5

Re: [FFmpeg-devel] [PATCH 3/4] lavc/h2645_parse: add h264_nal_unit_name for h264 NAL type.

2018-05-13 Thread myp...@gmail.com
2018-05-11 18:19 GMT+08:00 Mark Thompson : > On 11/05/18 06:11, Jun Zhao wrote: >> Signed-off-by: Jun Zhao >> --- >> libavcodec/h2645_parse.c | 26 -- >> 1 file changed, 24 insertions(+), 2 deletions(-) >> >> diff --git

Re: [FFmpeg-devel] [PATCH 3/3] doc/protocols: documents tcp_mss

2018-05-06 Thread myp...@gmail.com
2018-05-06 23:16 GMT+08:00 Gyan Doshi : > > > On 5/6/2018 8:42 PM, Jun Zhao wrote: > >> +@item tcp_mss=@var{bytes} >> +Set maximum segment size for outgoing TCP packets, expressed bytes. > > > 'expressed bytes' --> 'expressed in bytes' > > or just 'in bytes' (preferred). > >

Re: [FFmpeg-devel] [PATCH 2/3] lavf/tcp: add option to setting Maximum Segment Size

2018-05-06 Thread myp...@gmail.com
2018-05-07 5:17 GMT+08:00 Michael Niedermayer : > On Sun, May 06, 2018 at 11:12:13PM +0800, Jun Zhao wrote: >> This can change the the MSS value announced to the other end in >> the initial TCP packet, it's can be used when failed Path MTU >> discovery. >> >> Signed-off-by:

<    1   2   3   4   5   6