Re: [FFmpeg-devel] [PATCH][GSoC] dshow add support for saving and loading of capture devices

2015-04-22 Thread Michael Niedermayer
On Wed, Apr 22, 2015 at 11:02:56AM -0600, Roger Pack wrote: > On 4/22/15, Máté Sebők wrote: > > Of course can it be only in the error block - just deleted the other > > releases. > > Also no need for NULL-ing either in this case. > > Perfect. OK LGTM now. Recommend applying. applied thanks

Re: [FFmpeg-devel] [PATCH][GSoC] dshow add support for saving and loading of capture devices

2015-04-22 Thread Roger Pack
On 4/22/15, Máté Sebők wrote: > Of course can it be only in the error block - just deleted the other > releases. > Also no need for NULL-ing either in this case. Perfect. OK LGTM now. Recommend applying. -roger- > On Wed, Apr 22, 2015 at 6:26 PM, Roger Pack wrote: > >> On 4/22/15, Máté Sebők

Re: [FFmpeg-devel] [PATCH][GSoC] dshow add support for saving and loading of capture devices

2015-04-22 Thread Máté Sebők
Of course can it be only in the error block - just deleted the other releases. Also no need for NULL-ing either in this case. On Wed, Apr 22, 2015 at 6:26 PM, Roger Pack wrote: > On 4/22/15, Máté Sebők wrote: > > Added NULL-ing after release on load and save, lower-cased the #include > > "shlwa

Re: [FFmpeg-devel] [PATCH][GSoC] dshow add support for saving and loading of capture devices

2015-04-22 Thread Roger Pack
On 4/22/15, Máté Sebők wrote: > Added NULL-ing after release on load and save, lower-cased the #include > "shlwapi.h" and added release of pers_stream in the error handler. OK the crash is gone now. I'd like to have the IStream_Release only in one section, however. Would it be possible to remove

Re: [FFmpeg-devel] [PATCH][GSoC] dshow add support for saving and loading of capture devices

2015-04-22 Thread Máté Sebők
Added NULL-ing after release on load and save, lower-cased the #include "shlwapi.h" and added release of pers_stream in the error handler. There is no other pers_stream, only in the save because the OleLoadFromStream loads directly to the described object. On Wed, Apr 22, 2015 at 4:46 PM, Roger P

Re: [FFmpeg-devel] [PATCH][GSoC] dshow add support for saving and loading of capture devices

2015-04-22 Thread Roger Pack
On 4/22/15, Michael Niedermayer wrote: > On Wed, Apr 22, 2015 at 01:40:03PM +0200, Hendrik Leppkes wrote: >> On Wed, Apr 22, 2015 at 1:12 PM, Michael Niedermayer >> wrote: >> > On Wed, Apr 22, 2015 at 12:47:59PM +0200, Máté Sebők wrote: >> >> Indeed, sorry i've forgotten to change the Eclipse' EO

Re: [FFmpeg-devel] [PATCH][GSoC] dshow add support for saving and loading of capture devices

2015-04-22 Thread Roger Pack
On 4/22/15, Máté Sebők wrote: > Indeed, sorry i've forgotten to change the Eclipse' EOL to unix-- now > fixed. > > Error handler fixed. Thank you it's very close. A few more nits and we'll be there. You have +if (ofile_stream) +IStream_Release(ofile_stream); in there twice.

Re: [FFmpeg-devel] [PATCH][GSoC] dshow add support for saving and loading of capture devices

2015-04-22 Thread Michael Niedermayer
On Wed, Apr 22, 2015 at 01:40:03PM +0200, Hendrik Leppkes wrote: > On Wed, Apr 22, 2015 at 1:12 PM, Michael Niedermayer wrote: > > On Wed, Apr 22, 2015 at 12:47:59PM +0200, Máté Sebők wrote: > >> Indeed, sorry i've forgotten to change the Eclipse' EOL to unix-- now > >> fixed. > >> > >> Error han

Re: [FFmpeg-devel] [PATCH][GSoC] dshow add support for saving and loading of capture devices

2015-04-22 Thread Hendrik Leppkes
On Wed, Apr 22, 2015 at 1:12 PM, Michael Niedermayer wrote: > On Wed, Apr 22, 2015 at 12:47:59PM +0200, Máté Sebők wrote: >> Indeed, sorry i've forgotten to change the Eclipse' EOL to unix-- now fixed. >> >> Error handler fixed. >> >> Parameter names changed to audio(/video)_device_load(/save) as

Re: [FFmpeg-devel] [PATCH][GSoC] dshow add support for saving and loading of capture devices

2015-04-22 Thread Michael Niedermayer
On Wed, Apr 22, 2015 at 12:47:59PM +0200, Máté Sebők wrote: > Indeed, sorry i've forgotten to change the Eclipse' EOL to unix-- now fixed. > > Error handler fixed. > > Parameter names changed to audio(/video)_device_load(/save) as I think the > to_file and from_file is evident and is specified in

Re: [FFmpeg-devel] [PATCH][GSoC] dshow add support for saving and loading of capture devices

2015-04-22 Thread Máté Sebők
Indeed, sorry i've forgotten to change the Eclipse' EOL to unix-- now fixed. Error handler fixed. Parameter names changed to audio(/video)_device_load(/save) as I think the to_file and from_file is evident and is specified in the help. About the "fake" input: by loading a device filter from fil

Re: [FFmpeg-devel] [PATCH][GSoC] dshow add support for saving and loading of capture devices

2015-04-21 Thread Roger Pack
OK some verbiage nits: +@item capture_audio_device_load I'd suggest naming it it audio_device_load_from_filename instead. Similar for video. +Load an audio capture filter device from file instead of searching +it by name. It c, if the filter +supports the serialization of its properties to. +To