Re: [FFmpeg-devel] [PATCH] avcodec/vda: define av_vda_default_init2 when CONFIG_H264_VDA_HWACCEL equ 0

2016-10-21 Thread Michael Niedermayer
On Tue, Oct 18, 2016 at 12:14:56AM +1100, Xidorn Quan wrote:
> This isn't maintained by me. You should probaby ping Sebastien Zwickert <
> dilar...@free.fr>.
> 
> But this change looks trivial, so I think it is fine.

applied

thx

[...]
-- 
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

Dictatorship naturally arises out of democracy, and the most aggravated
form of tyranny and slavery out of the most extreme liberty. -- Plato


signature.asc
Description: Digital signature
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel


Re: [FFmpeg-devel] [PATCH] avcodec/vda: define av_vda_default_init2 when CONFIG_H264_VDA_HWACCEL equ 0

2016-10-17 Thread Xidorn Quan
This isn't maintained by me. You should probaby ping Sebastien Zwickert <
dilar...@free.fr>.

But this change looks trivial, so I think it is fine.

- Xidorn

On Mon, Oct 17, 2016 at 7:01 PM, Steven Liu  wrote:

> ping Xidorn Quan
>
> 2016-10-15 6:01 GMT+08:00 wm4 :
>
>> On Thu, 13 Oct 2016 20:57:07 +0800
>> Steven Liu  wrote:
>>
>> > ping
>> >
>> > 2016-10-12 17:36 GMT+08:00 Steven Liu :
>> >
>> > > on OSX:
>> > > ../configure --disable-everything --enable-demuxer=hls make
>> > > error message: Undefined symbols for architecture x86_64:
>> > > "_av_vda_default_init2", referenced from:_videotoolbox_init in
>> > > ffmpeg_videotoolbox.o
>> > > so add av_vda_default_init2 when CONFIG_H264_VDA_HWACCEL=0
>> > >
>> > > Signed-off-by: Steven Liu 
>> > > ---
>> > >  libavcodec/vda.c |5 +
>> > >  1 files changed, 5 insertions(+), 0 deletions(-)
>> > >
>> > > diff --git a/libavcodec/vda.c b/libavcodec/vda.c
>> > > index 4670140..819ae03 100644
>> > > --- a/libavcodec/vda.c
>> > > +++ b/libavcodec/vda.c
>> > > @@ -73,6 +73,11 @@ int av_vda_default_init(AVCodecContext *avctx)
>> > >  return AVERROR(ENOSYS);
>> > >  }
>> > >
>> > > +int av_vda_default_init2(AVCodecContext *avctx, AVVDAContext
>> *vdactx)
>> > > +{
>> > > +return AVERROR(ENOSYS);
>> > > +}
>> > > +
>> > >  void av_vda_default_free(AVCodecContext *ctx)
>> > >  {
>> > >  }
>> > > --
>> > > 1.7.1
>> > >
>> > >
>> > >
>> > > ___
>> > > ffmpeg-devel mailing list
>> > > ffmpeg-devel@ffmpeg.org
>> > > http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
>> > >
>> > ___
>> > ffmpeg-devel mailing list
>> > ffmpeg-devel@ffmpeg.org
>> > http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
>>
>> Patch ok, but I can't push for a while (and I'm not VDA maintainer).
>> ___
>> ffmpeg-devel mailing list
>> ffmpeg-devel@ffmpeg.org
>> http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
>>
>
>
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel


Re: [FFmpeg-devel] [PATCH] avcodec/vda: define av_vda_default_init2 when CONFIG_H264_VDA_HWACCEL equ 0

2016-10-17 Thread Steven Liu
ping Xidorn Quan

2016-10-15 6:01 GMT+08:00 wm4 :

> On Thu, 13 Oct 2016 20:57:07 +0800
> Steven Liu  wrote:
>
> > ping
> >
> > 2016-10-12 17:36 GMT+08:00 Steven Liu :
> >
> > > on OSX:
> > > ../configure --disable-everything --enable-demuxer=hls make
> > > error message: Undefined symbols for architecture x86_64:
> > > "_av_vda_default_init2", referenced from:_videotoolbox_init in
> > > ffmpeg_videotoolbox.o
> > > so add av_vda_default_init2 when CONFIG_H264_VDA_HWACCEL=0
> > >
> > > Signed-off-by: Steven Liu 
> > > ---
> > >  libavcodec/vda.c |5 +
> > >  1 files changed, 5 insertions(+), 0 deletions(-)
> > >
> > > diff --git a/libavcodec/vda.c b/libavcodec/vda.c
> > > index 4670140..819ae03 100644
> > > --- a/libavcodec/vda.c
> > > +++ b/libavcodec/vda.c
> > > @@ -73,6 +73,11 @@ int av_vda_default_init(AVCodecContext *avctx)
> > >  return AVERROR(ENOSYS);
> > >  }
> > >
> > > +int av_vda_default_init2(AVCodecContext *avctx, AVVDAContext *vdactx)
> > > +{
> > > +return AVERROR(ENOSYS);
> > > +}
> > > +
> > >  void av_vda_default_free(AVCodecContext *ctx)
> > >  {
> > >  }
> > > --
> > > 1.7.1
> > >
> > >
> > >
> > > ___
> > > ffmpeg-devel mailing list
> > > ffmpeg-devel@ffmpeg.org
> > > http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
> > >
> > ___
> > ffmpeg-devel mailing list
> > ffmpeg-devel@ffmpeg.org
> > http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
>
> Patch ok, but I can't push for a while (and I'm not VDA maintainer).
> ___
> ffmpeg-devel mailing list
> ffmpeg-devel@ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
>
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel


Re: [FFmpeg-devel] [PATCH] avcodec/vda: define av_vda_default_init2 when CONFIG_H264_VDA_HWACCEL equ 0

2016-10-14 Thread wm4
On Thu, 13 Oct 2016 20:57:07 +0800
Steven Liu  wrote:

> ping
> 
> 2016-10-12 17:36 GMT+08:00 Steven Liu :
> 
> > on OSX:
> > ../configure --disable-everything --enable-demuxer=hls make
> > error message: Undefined symbols for architecture x86_64:
> > "_av_vda_default_init2", referenced from:_videotoolbox_init in
> > ffmpeg_videotoolbox.o
> > so add av_vda_default_init2 when CONFIG_H264_VDA_HWACCEL=0
> >
> > Signed-off-by: Steven Liu 
> > ---
> >  libavcodec/vda.c |5 +
> >  1 files changed, 5 insertions(+), 0 deletions(-)
> >
> > diff --git a/libavcodec/vda.c b/libavcodec/vda.c
> > index 4670140..819ae03 100644
> > --- a/libavcodec/vda.c
> > +++ b/libavcodec/vda.c
> > @@ -73,6 +73,11 @@ int av_vda_default_init(AVCodecContext *avctx)
> >  return AVERROR(ENOSYS);
> >  }
> >
> > +int av_vda_default_init2(AVCodecContext *avctx, AVVDAContext *vdactx)
> > +{
> > +return AVERROR(ENOSYS);
> > +}
> > +
> >  void av_vda_default_free(AVCodecContext *ctx)
> >  {
> >  }
> > --
> > 1.7.1
> >
> >
> >
> > ___
> > ffmpeg-devel mailing list
> > ffmpeg-devel@ffmpeg.org
> > http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
> >  
> ___
> ffmpeg-devel mailing list
> ffmpeg-devel@ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-devel

Patch ok, but I can't push for a while (and I'm not VDA maintainer).
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel


Re: [FFmpeg-devel] [PATCH] avcodec/vda: define av_vda_default_init2 when CONFIG_H264_VDA_HWACCEL equ 0

2016-10-13 Thread Steven Liu
ping

2016-10-12 17:36 GMT+08:00 Steven Liu :

> on OSX:
> ../configure --disable-everything --enable-demuxer=hls make
> error message: Undefined symbols for architecture x86_64:
> "_av_vda_default_init2", referenced from:_videotoolbox_init in
> ffmpeg_videotoolbox.o
> so add av_vda_default_init2 when CONFIG_H264_VDA_HWACCEL=0
>
> Signed-off-by: Steven Liu 
> ---
>  libavcodec/vda.c |5 +
>  1 files changed, 5 insertions(+), 0 deletions(-)
>
> diff --git a/libavcodec/vda.c b/libavcodec/vda.c
> index 4670140..819ae03 100644
> --- a/libavcodec/vda.c
> +++ b/libavcodec/vda.c
> @@ -73,6 +73,11 @@ int av_vda_default_init(AVCodecContext *avctx)
>  return AVERROR(ENOSYS);
>  }
>
> +int av_vda_default_init2(AVCodecContext *avctx, AVVDAContext *vdactx)
> +{
> +return AVERROR(ENOSYS);
> +}
> +
>  void av_vda_default_free(AVCodecContext *ctx)
>  {
>  }
> --
> 1.7.1
>
>
>
> ___
> ffmpeg-devel mailing list
> ffmpeg-devel@ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
>
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel