Re: [FFmpeg-user] Problem with configuring with yasm

2019-12-20 Thread Carl Eugen Hoyos
Am Fr., 20. Dez. 2019 um 18:05 Uhr schrieb Mahmood Naderan : > --extra-cflags=-I,-I > is not correct. The correct syntax is > --extra-cflags=-I --extra-cflags= -I or simpler: --extra-cflags='-Idir1 -Idir2' Please do not top-post here, Carl Eugen ___

Re: [FFmpeg-user] Driver does not support the required nvenc API version

2019-12-20 Thread Mahmood Naderan
Yes. Thank you very much. I was able to run with nv-codec 8.2 $ git checkout sdk/8.2 and recompile ffmpeg. Regards, Mahmood On Fri, Dec 20, 2019 at 10:43 PM Dennis Mungai wrote: > On Fri, 20 Dec 2019, 21:57 Mahmood Naderan, wrote: > > > >recommended R440 (with Turing). > > > > Dennis, >

Re: [FFmpeg-user] Driver does not support the required nvenc API version

2019-12-20 Thread Dennis Mungai
On Fri, 20 Dec 2019, 21:57 Mahmood Naderan, wrote: > >recommended R440 (with Turing). > > Dennis, > I am using TitanV which is Volta. > > Regards, > Mahmood > You have an RTX 2080 on the same system. See your nvidia-smi output. To use an older driver, then downgrade nv-codec-headers to an

Re: [FFmpeg-user] Driver does not support the required nvenc API version

2019-12-20 Thread Mahmood Naderan
>recommended R440 (with Turing). Dennis, I am using TitanV which is Volta. Regards, Mahmood ___ ffmpeg-user mailing list ffmpeg-user@ffmpeg.org https://ffmpeg.org/mailman/listinfo/ffmpeg-user To unsubscribe, visit link above, or email

Re: [FFmpeg-user] Driver does not support the required nvenc API version

2019-12-20 Thread Mahmood Naderan
I don't have root access. What should I do to use older ffmpeg and existing nv-codec? Regards, Mahmood On Fri, Dec 20, 2019 at 9:51 PM Dennis Mungai wrote: > On Fri, 20 Dec 2019, 20:58 Mahmood Naderan, wrote: > > > Hi > > I use this command which fails with this error message > > > > $

Re: [FFmpeg-user] Driver does not support the required nvenc API version

2019-12-20 Thread Dennis Mungai
On Fri, 20 Dec 2019, 20:58 Mahmood Naderan, wrote: > Hi > I use this command which fails with this error message > > $ ./ffmpeg -init_hw_device cuda=0 -filter_hw_device 0 -i vid1080.mp4 -vf > format=nv12,hwupload,scale_npp=1280:720 -c:v h264_nvenc 720p2.mp4 > ffmpeg version N-96097-g99f505d2df

[FFmpeg-user] Driver does not support the required nvenc API version

2019-12-20 Thread Mahmood Naderan
Hi I use this command which fails with this error message $ ./ffmpeg -init_hw_device cuda=0 -filter_hw_device 0 -i vid1080.mp4 -vf format=nv12,hwupload,scale_npp=1280:720 -c:v h264_nvenc 720p2.mp4 ffmpeg version N-96097-g99f505d2df Copyright (c) 2000-2019 the FFmpeg developers built with gcc 7

Re: [FFmpeg-user] Extracting information from ffmpeg logs when streaming

2019-12-20 Thread Verachten Bruno
Hi there, thanks to SO, I have found an approach that gives me more or less what I was looking for. mkfifo ffmpeg.logfmpeg -y -f lavfi -i testsrc=duration=10:size=1920x1080:rate=25 -progress pipe:3 null.mkv 3> ffmpeg.logcat ffmpeg.log |awk

Re: [FFmpeg-user] Problem with configuring with yasm

2019-12-20 Thread Mahmood Naderan
OK. --extra-cflags=-I,-I is not correct. The correct syntax is --extra-cflags=-I --extra-cflags= -I Regards, Mahmood On Fri, Dec 20, 2019 at 6:40 PM Mahmood Naderan wrote: > >You're going to have to install the full CUDA SDK. > >The headers I see missing in your config are indeed present in

Re: [FFmpeg-user] Problem with configuring with yasm

2019-12-20 Thread Mahmood Naderan
>You're going to have to install the full CUDA SDK. >The headers I see missing in your config are indeed present in the CUDA SDK. I actually have that in my home. I mean cuda toolkit and samples. I can see npp.h and its libraries there. $ cd ~/cuda-10.1.168/ $ ls include/npp* include/nppcore.h

Re: [FFmpeg-user] Problem with configuring with yasm

2019-12-20 Thread Dennis Mungai
On Fri, 20 Dec 2019, 15:23 Mahmood Naderan, wrote: > I have attached config.log.zip. > At the end, it is looking for npp.h and some other things. I can not find > in which package npp.h exists. All I see are library files. > > gcc -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE >

Re: [FFmpeg-user] Problem with configuring with yasm

2019-12-20 Thread Mahmood Naderan
I have attached config.log.zip. At the end, it is looking for npp.h and some other things. I can not find in which package npp.h exists. All I see are library files. gcc -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600 -DPIC

Re: [FFmpeg-user] Problem with configuring with yasm

2019-12-20 Thread Dennis Mungai
On Fri, 20 Dec 2019, 13:52 Mahmood Naderan, wrote: > >ERROR: libnpp not found > > I even extracted > > https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64/cuda-npp-10-1_10.1.168-1_amd64.deb > and copied all libnpp files to my own cuda directory. > > $ ls > libnppc.so.10

Re: [FFmpeg-user] Problem with configuring with yasm

2019-12-20 Thread Mahmood Naderan
>ERROR: libnpp not found I even extracted https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64/cuda-npp-10-1_10.1.168-1_amd64.deb and copied all libnpp files to my own cuda directory. $ ls libnppc.so.10 libnppicom.so.10libnppig.so.10 libnppisu.so.10

Re: [FFmpeg-user] Problem with configuring with yasm

2019-12-20 Thread Mahmood Naderan
> Remove yasm/include from extra-cflags, remove yasm/lib from extra-ldflags >and use --x86asmexe=/home/mahmood/yasm-1.3.0/bin/yasm Thank you. I got it. also fixed nv-coded-headers. However, libnpp is not found although I have manually downloaded the deb package and extracted it to get

Re: [FFmpeg-user] Problem with configuring with yasm

2019-12-20 Thread Carl Eugen Hoyos
Am Fr., 20. Dez. 2019 um 11:08 Uhr schrieb Mahmood Naderan : > On a system which I can not install package, I have built yasm from source > as below: > > mahmood@fury0:/home/mahmood/yasm-1.3.0$ ls bin/ > vsyasm yasm ytasm > mahmood@fury0:/home/mahmood/yasm-1.3.0$ ls lib > libyasm.a >

[FFmpeg-user] Problem with configuring with yasm

2019-12-20 Thread Mahmood Naderan
Hi, On a system which I can not install package, I have built yasm from source as below: mahmood@fury0:/home/mahmood/yasm-1.3.0$ ls bin/ vsyasm yasm ytasm mahmood@fury0:/home/mahmood/yasm-1.3.0$ ls lib libyasm.a mahmood@fury0:/home/mahmood/yasm-1.3.0$ ls include/ libyasm libyasm.h