Re: [FFmpeg-user] extract first 26 seconds not workings as expected

2020-06-29 Thread Leonardo via ffmpeg-user
Hello Carl, > Please test current FFmpeg git head, if the issue is reproducible > provide an input sample. I tested with current git and the results were the same. As noticed by Moritz at the output of ffprobe $ ffprobe part1.mp4 ffprobe version N-98341-gcca982ee01 Copyright (c) 2007-2020

Re: [FFmpeg-user] extract first 26 seconds not workings as expected

2020-06-29 Thread Leonardo via ffmpeg-user
Hello >You may want to try the option "-copyinkf" ("copy initial >non-keyframes") when using "-c copy". I tried with this option, but the extracted part was "grayed" at the beginning. The only workaround that I found that worked was $ ffmpeg -i main.mp4 -vf "trim=start=0:end=26" part1.mp4

Re: [FFmpeg-user] extract first 26 seconds not workings as expected

2020-06-29 Thread Moritz Barsnick
On Sun, Jun 28, 2020 at 18:31:15 +, Leonardo via ffmpeg-user wrote: > $ ffmpeg -i main.mp4 -ss 00:00:00.00 -t 00:00:26.00 -c copy part1.mp4 [...] > frame=  322 fps=0.0 q=-1.0 Lsize= 523kB time=00:00:25.95 bitrate= > 165.2kbits/s speed=8.19e+03x     > video:519kB audio:0kB subtitle:0kB

Re: [FFmpeg-user] extract first 26 seconds not workings as expected

2020-06-28 Thread Carl Eugen Hoyos
Am So., 28. Juni 2020 um 20:31 Uhr schrieb Leonardo via ffmpeg-user : > I have a video (main.mp4 - that has about 52 minutes) that I want to cut its > first 26 seconds. > > For this, I'm using command > > $ ffmpeg -i main.mp4 -ss 00:00:00.00 -t 00:00:26.00 -c copy part1.mp4 > ffmpeg version

[FFmpeg-user] extract first 26 seconds not workings as expected

2020-06-28 Thread Leonardo via ffmpeg-user
Hello, I have a video (main.mp4 - that has about 52 minutes) that I want to cut its first 26 seconds. For this, I'm using command $ ffmpeg -i main.mp4 -ss 00:00:00.00 -t 00:00:26.00 -c copy part1.mp4 ffmpeg version 4.2.3 Copyright (c) 2000-2020 the FFmpeg developers   built with gcc 8