Re: [FFmpeg-user] Issue Crossbuilding ffplay with openembedded

2014-07-10 Thread Moritz Barsnick
On Thu, Jul 10, 2014 at 05:42:24 -0700, Rickoo wrote: My problem is that ffmpeg ffprobe and ffserver are built but not ffplay. Can someone help me with that? We can't guess your error messages. Please attach config.log. Thanks, Moritz ___ ffmpeg-user

Re: [FFmpeg-user] Reg: CPU Usage Issue

2014-07-18 Thread Moritz Barsnick
On Fri, Jul 18, 2014 at 11:31:36 +0200, Moritz Barsnick wrote: On Fri, Jul 18, 2014 at 14:56:22 +0530, subeesh.babu wrote: Can any one suggest how to reduce the CPU usage . Did you even read my reply? (You quoted it.) Have you tried the suggestion? Did it help? Furthermore, if you do wish

Re: [FFmpeg-user] Problem using FFMpeg, x11grab, and FFServer

2014-07-30 Thread Moritz Barsnick
On Tue, Jul 29, 2014 at 23:01:15 -0500, Joel Longanecker wrote: think i've narrowed down my problem to the parameters I am calling ffmpeg with. I have difficulty matching your command line arguments with the output. Can you produce the full, uncut output, not just the errors? Including the

Re: [FFmpeg-user] FFmpeg 0.5.14 released

2014-07-31 Thread Moritz Barsnick
On Thu, Jul 31, 2014 at 17:22:25 +0200, Reindl Harald wrote: Just curious: is FFmpeg 0.5 still maintained? 0.5.14 was released on 2014-07-20 and promoted in a tweet. looks so but surely only critical security fixes You can follow the commits here:

Re: [FFmpeg-user] Problem about changing container mp4 to ts (hevc coded)

2014-08-07 Thread Moritz Barsnick
On Thu, Aug 07, 2014 at 07:55:55 +0900, BongChan Cho wrote: it doesn't work. That is not a very complete error description. Please show us the ffmpeg command line and full, uncut console output. Thanks, Moritz ___ ffmpeg-user mailing list

Re: [FFmpeg-user] Extract frames from an AVI and then frames to AVI

2014-08-08 Thread Moritz Barsnick
Hi Virgil, On Fri, Aug 08, 2014 at 17:43:40 +0200, Virgil Stokes wrote: I would like to know a method that could be used to first, extract frames from an AVI file $ ffmpeg -i in.avi -f image2 image%05d.png and then reconstruct the AVI from these extracted frames. $ ffmpeg -f image2 -i

Re: [FFmpeg-user] Incorrect value in RIFF WAV byterate field in ffmpeg 0.10.x

2014-08-12 Thread Moritz Barsnick
On Tue, Aug 12, 2014 at 09:04:31 +, Wilfried Weissmann wrote: Sorry, I was referring to the 0.10 branch. I would like to stay on that branch to have a chance to get upstream versions from the rpmfusion repository. Interesting. For EPEL/RHEL5 (that's what you were refering to?) I see

Re: [FFmpeg-user] How to build ffmpeg statically with librtmp support

2014-08-17 Thread Moritz Barsnick
On Sun, Aug 17, 2014 at 14:27:27 +0800, Han Jiang wrote: libavformat/libavformat.a(librtmp.o): In function `rtmp_read_seek': librtmp.c:(.text+0x30): undefined reference to `RTMP_SendSeek' Does your linking command line which is throughing this error even have -lrtmp or librtmp.a in it? Moritz

Re: [FFmpeg-user] mpegts file seems corrupt but plays back fine in VLC

2014-08-19 Thread Moritz Barsnick
Hi, On Wed, Aug 13, 2014 at 12:46:26 +0200, Ibrahim Tachijian wrote: Using the generated dump.ts I am trying to do the following command but failing. ./ffmpeg -i dump.ts -acodec copy -vcodec copy -f mpegts dump2.ts Did you read this error message at the very end?: [mpegts @ 0xaffe720]

Re: [FFmpeg-user] Strange results with delogo filter, maybe a bug

2014-08-26 Thread Moritz Barsnick
Hi Andy, On Tue, Aug 26, 2014 at 11:18:38 +0200, sxe wrote: I hope so cause i have no idea what do do :) , i can test if you like me to. I could build ffmpeg from git and apply the patch. What I also meant is that there may be side-effects to this. There is probably a good reason for this

Re: [FFmpeg-user] add image to an mp3 video?

2014-08-28 Thread Moritz Barsnick
On Thu, Aug 28, 2014 at 07:27:33 -0600, mB wrote: Could it be that the version of ffmpeg I am using is not compatible with this code? I’ve tried several different versions with no luck but may have not hit on the right one? Possibly the code is incorrect? Any help? No help if you don't show

Re: [FFmpeg-user] I have problem when I configure ffmpeg in win7

2014-09-02 Thread Moritz Barsnick
On Tue, Sep 02, 2014 at 11:18:12 +0800, 翁丞世 wrote: – Install MinGW in c:nMinGW (any path is possible) and make sure that c compiler, c++ compiler, MSYS Basic System and MinGW Developer Toolkit should be chosen while installing; [...] I stuck at this step, it told me C compiler test failed.,

Re: [FFmpeg-user] udp_resolve_host: Name or service not known

2014-09-02 Thread Moritz Barsnick
On Tue, Sep 02, 2014 at 12:31:45 +0530, Ajay Parashar wrote: But ffmpeg sends below error udp_resolve_host: Name or service not known udp://226.0.0.0.1:1234: Input/output error How did you check that that host is actually available? A little hint: It probably can't be, because 226.0.0.0.1 is

Re: [FFmpeg-user] When merging an image with audio the resulting mp4 has a black screen

2014-09-02 Thread Moritz Barsnick
Hi gfmonk, On Tue, Sep 02, 2014 at 11:14:56 -0700, gfmonk wrote: I am in the process of converting an existing application to the latest version of ffmpeg. When I merge an jpg and wav file to create an mp4 I get a black screen. Which player are you using to view the resulting file? Because:

Re: [FFmpeg-user] How to record audio and video from FaceTime HD Camera in OSX

2014-09-07 Thread Moritz Barsnick
On Sat, Sep 06, 2014 at 11:25:42 -0400, Jay Muthialu wrote: As you can see from the output it lists the FaceTime HD Camera as device ID 0. But it does not show the inbuilt microphone. We can't see any output. https://ffmpeg.org/pipermail/ffmpeg-user/2014-September/023302.html If you did

Re: [FFmpeg-user] Regarding yuyv422I

2014-09-07 Thread Moritz Barsnick
On Sat, Sep 06, 2014 at 17:24:33 +0530, senthilnathan wrote: Thanks for your mail. Please find below the command we used, ./ffmpeg -s 720x576 -f v4l2 -pix_fmt yuyv422 -i /dev/video0 -target pal-vcd -vcodec mpeg4 -f mpegts -q 5 -r 16 -s 360x288 udp:10.5.20.13:1234 This does not suffice.

Re: [FFmpeg-user] How to record audio and video from FaceTime HD Camera in OSX

2014-09-07 Thread Moritz Barsnick
On Sun, Sep 07, 2014 at 07:37:56 -0400, Jay Muthialu wrote: Output in OSX listing the AV devices identified Ah. Back in June, ffmpeg's avfoundation didn't support audio yet, and I think that hasn't changed: https://ffmpeg.org/pipermail/ffmpeg-user/2014-June/021768.html I think these are the

Re: [FFmpeg-user] a problem while installing ffmpeg from SHELL

2014-09-08 Thread Moritz Barsnick
On Mon, Sep 08, 2014 at 00:42:21 +0100, hh280 . wrote: ERROR: libfdk_aac not found You don't seem to have libfdk_aac installed correctly. Did the libfdk_aac section of the instructions go okay? https://trac.ffmpeg.org/wiki/CompilationGuide/Centos#CompilationInstallation Include the

Re: [FFmpeg-user] How to record audio and video from FaceTime HD Camera in OSX

2014-09-08 Thread Moritz Barsnick
Hi Jay, On Sun, Sep 07, 2014 at 12:01:25 -0400, Jay Muthialu wrote: I went through all the patches specified in the link but I am not sure how to apply the patches. Could you please guide me on how to apply the patches and also what would be command I would have to use to take audio input ?

Re: [FFmpeg-user] How to record audio and video from FaceTime HD Camera in OSX

2014-09-08 Thread Moritz Barsnick
Hi Jay, [oops, sent too early] On Sun, Sep 07, 2014 at 12:01:25 -0400, Jay Muthialu wrote: I went through all the patches specified in the link but I am not sure how to apply the patches. Could you please guide me on how to apply the patches and also what would be command I would have to use

Re: [FFmpeg-user] stroboscope effect

2014-09-08 Thread Moritz Barsnick
On Mon, Sep 08, 2014 at 03:16:52 +0200, Gerion Entrup wrote: ffplay -f lavfi -i color=black:s=512x512 -vf framestep=3,drawbox=x=0:y=0:w=512:h=512:color=white:t=500 framestep selects every n-th frame and passes that on to the following filter chain, which is not what you want. You want the

Re: [FFmpeg-user] Multiple tees in a single FFMPEG instance

2014-09-08 Thread Moritz Barsnick
On Sun, Sep 07, 2014 at 21:22:13 +0300, Soner CAN wrote: prevent FFMPEG encode the same file twice. But when I try to use two tee's it needs to transcode again. [...] -filter_complex [0:0]scale=640x480[large];[0:0]scale=240x50[small] You are requesting two different outputs: One in 640x480,

Re: [FFmpeg-user] Encoding 3gp6 with MPEG-4 Visual and Simple at L1

2014-09-16 Thread Moritz Barsnick
On Tue, Sep 16, 2014 at 07:50:09 +, Carl Eugen Hoyos wrote: What is the difference between 3gp4 and 3gp6? I was about to suggest something similar - how about just changing the metadata (that which ffmpeg/ffprobe reports as major_brand and compatible_brands)? Could that solve the problem?

Re: [FFmpeg-user] Encoding 3gp6 with MPEG-4 Visual and Simple at L1

2014-09-16 Thread Moritz Barsnick
I’m not really sure. If I use -vcodec libx264, I get 3gp6, and if I use -vcodec mpeg4, I get 3gp4. But if I do libx264, I can’t get MPEG-4 Visual and Simple@L1 to come out. You're adhering to mediainfo a little bit too strictly here. Question is: What does your device expect (and what does

Re: [FFmpeg-user] -strict unofficial error

2014-09-17 Thread Moritz Barsnick
On Wed, Sep 17, 2014 at 13:38:11 +0200, ypatios wrote: when using “-strict unofficial” with the latest ffmpeg versions i get the following error: It seems that was removed in 2011: https://lists.ffmpeg.org/pipermail/ffmpeg-devel/2011-February/102761.html What are you trying to achieve?

Re: [FFmpeg-user] -strict unofficial error

2014-09-17 Thread Moritz Barsnick
On Wed, Sep 17, 2014 at 13:51:44 +, Carl Eugen Hoyos wrote: Moritz Barsnick barsnick at gmx.net writes: It seems that was removed in 2011: No, inofficial was removed. Well, d'uh. My bad. These are the definitions from libavcodec/avcodec.h: #define FF_COMPLIANCE_VERY_STRICT 2

Re: [FFmpeg-user] How to record audio and video from FaceTime HD Camera in OSX

2014-09-22 Thread Moritz Barsnick
On Mon, Sep 22, 2014 at 10:50:05 -0400, Jay Muthialu wrote: $ ffmpeg -f avfoundation -i video=FaceTime HD Camera:audio=Built-in Microphone -r 29.97 -y out.mov I don't see any indication in the source (looking at those patches from April 2014) that this syntax is supported. Possibly just $

Re: [FFmpeg-user] ffmpeg muxing raw video with audio file

2014-09-25 Thread Moritz Barsnick
On Thu, Sep 25, 2014 at 12:59:09 +0200, Steffen Richter - m.objects wrote: Anatol anatol2...@gmail.com wrote: Putting '-async 1' on an input side (before '-i') might help ^ I already tried all available -vsync options. ^ -async != -vsync Moritz

Re: [FFmpeg-user] [mp2] how to encode high-pitch audio to mp2 file?

2014-09-25 Thread Moritz Barsnick
On Thu, Sep 25, 2014 at 17:42:46 +0800, linxs wrote: How can I use mp2 to encode high pitch audio? Whether a 19 kHz tone is properly encoded or not certainly depends on the implementation of the psychoacoutic model. The library twolame (which is not the ffmpeg native implementation you're

Re: [FFmpeg-user] [mp2] how to encode high-pitch audio to mp2 file?

2014-09-25 Thread Moritz Barsnick
I analyzed mp2 made by ffmpeg. I found that sine wave whose frequency large than 14500HZ is eliminated. Is there any way to keep the high pitch audio in mp2 made by ffmpeg? Have you tried building ffmpeg with libtwolame (./configure --enable-libtwolame) and using it (-c:a libtwolame)?

Re: [FFmpeg-user] -filter_complex Gudiance Needed

2014-09-25 Thread Moritz Barsnick
Hi Steve, On Thu, Sep 25, 2014 at 17:05:05 +0100, Steve Kelly wrote: ffmpeg -i TEST.MXF —filter_complex [0:1][0:2] amerge=inputs=2, aformat=sample_fmts=s16:channel_layouts=stereo [a_out] -map '[0:v]' -map '[a_out]' -codec:v prores -profile:v 3 -codec:a pcm_s16le TEST_CONV.mov Gives an

Re: [FFmpeg-user] libvo-amrwbenc.so.0: cannot open shared object file

2014-09-30 Thread Moritz Barsnick
On Mon, Sep 29, 2014 at 22:50:38 +0200, Reindl Harald wrote: instead learn to use rpmbuild While I _totally_ advocate this, ffmpeg is the one tool which I don't do this for. I use the rpmfusion repository for various tools, and they tend to depend upon the ffmpeg-libs package or its

Re: [FFmpeg-user] Can I use ffmpeg to combine audio streams in .ts file?

2014-09-30 Thread Moritz Barsnick
On Tue, Sep 30, 2014 at 15:48:17 +0200, skyscan...@gmx.ca wrote: That merges the four audio streams into a single stream. This doesn't give me 5.1 but I don't see any way to selectively pluck channels from streams and map them to 5.1 output (not saying it isn't possible, just that I can't

[FFmpeg-user] This syntax is deprecated. Use '|' to separate the list items. (Was: What is the difference between versions of ffmpeg?)

2014-10-04 Thread Moritz Barsnick
Hello KS (just to give you some name), On Sat, Oct 04, 2014 at 20:56:30 +0200, skyscan...@gmx.ca wrote: I do have another question: When I am running ffmpeg this way, it prints out the following four lines as part of its output - I notice them because they are all or part in green and yellow

Re: [FFmpeg-user] This syntax is deprecated. Use '|' to separate the list items. (Was: What is the difference between versions of ffmpeg?)

2014-10-04 Thread Moritz Barsnick
On Sat, Oct 04, 2014 at 23:05:54 +0200, skyscan...@gmx.ca wrote: So it appears that it does want the | rather than the : after the 5.1 as well. Yes, while trying to improve the documentation, I have figured out the same. They are apparently not separate parameters, but a single parameter as a

Re: [FFmpeg-user] libvo-amrwbenc.so.0: cannot open shared object file

2014-10-04 Thread Moritz Barsnick
Hallo Harald, On Tue, Sep 30, 2014 at 12:09:55 +0200, Reindl Harald wrote: i do the same - ffmpeg under /usr/local/bin with static linked x264 but packed as RPM - it don't collide with the rpmfuison ffmpeg-libs package that way Good point. Except that I use a lot of self-built libs (ahead of

Re: [FFmpeg-user] ffserver config for HLS

2014-10-07 Thread Moritz Barsnick
On Tue, Oct 07, 2014 at 14:10:49 +0800, ajay parashar wrote: Stream #0:0 - #1:0 (ac3 (native) - ac3 (native)) Stream #0:2 - #1:1 (h264 (native) - h264 (libx264)) Error while opening encoder for output stream #1:0 - maybe incorrect parameters such as bit_rate, rate, width or height I

Re: [FFmpeg-user] For HLS, playlist.m3u8 file skips last segment entry

2014-10-08 Thread Moritz Barsnick
and arguments as you, and I don't see any issues. Perhaps you can try with testsrc as well? Moritz barsnick@sunshine:~/tmp/ffmpeg_segment_test ffmpeg -f lavfi -i 'testsrc=size=704x480:duration=00\\:01\\:02.76' -vcodec libx264 -f ssegment -hls_list_size 10 -segment_list playlist.m3u8 -segment_time 10

Re: [FFmpeg-user] rtsp streaming

2014-10-08 Thread Moritz Barsnick
On Mon, Oct 06, 2014 at 11:49:33 +0530, Shatrughna Pandey wrote: where i am going wrong ...? You're going wrong in that you're not showing us the complete output of your commands. That would be a good start for understanding what is going wrong. Thanks, Moritz

Re: [FFmpeg-user] ffplay not found

2014-10-10 Thread Moritz Barsnick
On Fri, Oct 10, 2014 at 13:09:45 +0200, Reindl Harald wrote: Another question, after compiling, I cannot find out the executable ffplay. How to compile it? ./configure --help What that doesn't tell you though is that you need libsdl, and it needs to be found, in order to have ffplay

Re: [FFmpeg-user] c:v copy - output file is empty, nothing was encoded

2014-10-10 Thread Moritz Barsnick
developers This version is way too old. Use a recent one or build your own from git. Because it works for me (two week old snapshot), see below. Moritz :-) barsnick@sunshine:/tmp ffmpeg -i snippet.h264 -r 25 -c:v copy snippet.mp4 -y ffmpeg version 2.4.git Copyright (c) 2000-2014 the FFmpeg

Re: [FFmpeg-user] UDP Packet size option

2014-10-13 Thread Moritz Barsnick
Hi Sajjad, On Sun, Oct 12, 2014 at 03:34:32 +0100, Sajjad Moshen wrote: I've been trying to get my decoder to read my UDP feed but for some odd reason it doesn't like when I add the ?pkt_size=1316 option to my unicast stream. ffmpeg is your encoder and some other program is your decoder,

Re: [FFmpeg-user] ffplay not found

2014-10-13 Thread Moritz Barsnick
On Sat, Oct 11, 2014 at 07:01:35 +, Carl Eugen Hoyos wrote: Concerning --enable-ffplay: I just like to add that this should not be part of any sane configure line, it does NOT do what most people expect, ffplay is built if libsdl-devel is installed. BTW, this is somewhat different from

Re: [FFmpeg-user] Right audio channel shifted

2014-10-14 Thread Moritz Barsnick
Hi Alex, I guess there is somehing wrong with the channel mapping, but without the fliter_complex the mapping seems to be okay. I think the filter_complex messes up the mapping. Note this mapping from your output: Stream mapping: Stream #0:2 (pcm_s24le) - atrim atrim - Stream #0:0

Re: [FFmpeg-user] Any ffmpeg plugin for image stabilization that handles walking tilt?

2014-10-14 Thread Moritz Barsnick
On Tue, Oct 14, 2014 at 12:07:16 -0300, Fernando Cassia wrote: Someone on the above post talks about the vidstabdetect and vidstabtransform filters, but without giving further detail on why those are better. I think I have read something, but can't recall where. That said, have you looked at

Re: [FFmpeg-user] configuring the ffmpeg failed,need a hand.

2014-10-14 Thread Moritz Barsnick
On Tue, Oct 14, 2014 at 11:14:12 +0800, 津瑞 wrote: I have done such work before the upper working including downloading the sdl1.2,x264,libvpx and configuring them without error. Please show us your ./configure command line and attach the resulting config.log file. You may also want to show

Re: [FFmpeg-user] Failed to resolve hostname: Ubuntu static builds

2014-10-16 Thread Moritz Barsnick
On Wed, Oct 15, 2014 at 09:37:01 -0700, hdn8 wrote: ffprobe version N-41351-g676110e- http://johnvansickle.com/ffmpeg/ Copyright (c) 2007-2014 the FFmpeg developers built on Oct 15 2014 01:22:19 with gcc 4.8 (Debian 4.8.3-11) [...] [tcp @ 0x3f82100] Failed to resolve hostname

Re: [FFmpeg-user] How to create trapezoid videos with ffmpeg?

2014-10-16 Thread Moritz Barsnick
Hi Zenny, On Wed, Oct 15, 2014 at 10:55:40 +0200, Zenny wrote: New to ffmpeg. How can one create a trapezoid shaped video as a overlay to the background as seen at http://www.youtube.com/watch?v=_380o5B9MrA (starts at 00:02:25) using ffmpeg command? I can't seem to find a filter which does

Re: [FFmpeg-user] How to create trapezoid videos with ffmpeg?

2014-10-18 Thread Moritz Barsnick
On Fri, Oct 17, 2014 at 11:18:04 -0700, Nicholas Robbins wrote: Ok, I'm not sure what you meant by an easy way, but the formula for what to put into the perspective filter options to essentially have it be the inverse (where to send the corners, not what to send to the corners) is huge mess,

Re: [FFmpeg-user] ffmpeg Gopro and server

2014-10-24 Thread Moritz Barsnick
Hi, On Thu, Oct 23, 2014 at 19:02:49 +0200, Francesco Menegoni wrote: any suggestions are welcome ^__^ Similar to what Andrey replied: Life (and encoding) is more complicated than this. It seems you're not only a newbie on this list. ;-) You need to consider: What are your - target users and

Re: [FFmpeg-user] ffmpeg/ffserver h264 webcam streaming

2014-10-28 Thread Moritz Barsnick
On Mon, Oct 27, 2014 at 20:52:13 +, Ricardo Mota wrote: I'm trying to setup a h264 streaming from my webcam to the web using the following configuration file for ffserver. - ffserver.conf http://pastebin.com/ig74S0Zq For reference, here is one relevant part: Stream test.mp4

[FFmpeg-user] lying about metadata output?

2014-10-29 Thread Moritz Barsnick
Hi, I just encountered a situation where there was a mismatch between what ffmpeg claimed to put into its output metadata, and what was actually put into the resulting file. Why do I bother? It's confusing, and also caused me to try to manipulate the metadata further, although ffmpeg was already

Re: [FFmpeg-user] Problems getting the very last frames of videos using av_read_frame

2014-10-30 Thread Moritz Barsnick
On Thu, Oct 30, 2014 at 12:15:34 +, Peter Rennert wrote: except for the last frames. It seems as av_read_frame only reads until the last key frame and does not go beyond it. Do you ever see Unable to decode video picture: %d from

Re: [FFmpeg-user] Capture android device screen

2014-10-31 Thread Moritz Barsnick
On Thu, Oct 30, 2014 at 11:07:01 +0200, Ben Amsallem wrote: http://ffmpeg.org/pipermail/ffmpeg-user/2013-January/012941.html Any luck with solving this issue? I am facing the same problem myself. That can't work, x11grab is meant to grab from an X11 display server, and I somehow doubt that

Re: [FFmpeg-user] Naming an audio track

2014-11-02 Thread Moritz Barsnick
On Sun, Nov 02, 2014 at 23:24:58 +0100, Tomáš Hnyk wrote: encoder : HandBrake 0.9.9 2013051800 Okay, now we know how to produce a file in which VLC recognizes the names of audio streams: $ HandBrakeCLI [...] --aname Name of audio track 1,Name of audio track 2 Only HandBrake and VLC

Re: [FFmpeg-user] Naming an audio track

2014-11-03 Thread Moritz Barsnick
On Mon, Nov 03, 2014 at 01:47:23 +, Carl Eugen Hoyos wrote: $ HandBrakeCLI [...] --aname Name of audio track 1,Name of audio track 2 If somebody could now either upload a small sample or provide an actual command line, we could try to implement the missing feature... Sorry, I was quite

Re: [FFmpeg-user] Naming an audio track

2014-11-03 Thread Moritz Barsnick
[Replying to self] On Mon, Nov 03, 2014 at 10:21:39 +0100, Moritz Barsnick wrote: I do not know, though, whether name is a header such as stco or udta. So apparently we're looking as MPEG4/MOV containers here. That's what Tomáš was using as well, and where I managed to reproduce. Using

Re: [FFmpeg-user] Naming an audio track

2014-11-03 Thread Moritz Barsnick
On Mon, Nov 03, 2014 at 12:12:21 +0100, Moritz Barsnick wrote: I do see ffmpeg has a function named mov_write_track_udta_tag(), called from mov_write_trak_tag(), called from mov_write_moov_tag(), but I don't know if it gets used and whether it does the right thing from VLC's point of view

Re: [FFmpeg-user] How can I convert mpeg2 5.1 audio to ac3?

2014-11-05 Thread Moritz Barsnick
On Tue, Nov 04, 2014 at 20:12:56 +0100, blue...@caramail.com wrote: XBMC WILL play Dolby encoded files correctly if the channels are all present and not encoded in some weird format, in fact it is very good at that. That's understood. It would be really great if ffmpeg could detect these

Re: [FFmpeg-user] How can I convert mpeg2 5.1 audio to ac3?

2014-11-05 Thread Moritz Barsnick
On Wed, Nov 05, 2014 at 23:01:57 +, Carl Eugen Hoyos wrote: el_processor.cpp is not license-compatible but Because it's GPLv2+, but libavfilter is LGPL? (Just checking, this makes sense. indicates that it is possible to achieve what is needed. Reading the code may help to understand

Re: [FFmpeg-user] FFmpeg record RTMP to FLV

2014-11-06 Thread Moritz Barsnick
On Thu, Nov 06, 2014 at 13:21:28 +0100, shacky wrote: ffmpeg version 1.2.4 Copyright (c) 2000-2013 the FFmpeg developers This is a quite old version. I don't know if RTMP support was as good back then as it is now. 2.4.x is current. please try to get hold of that, or use latest git if you

Re: [FFmpeg-user] How can I convert mpeg2 5.1 audio to ac3?

2014-11-11 Thread Moritz Barsnick
On Tue, Nov 11, 2014 at 07:11:33 -0600, Mike Brown wrote: That doesn't make any sense. AC3 5.1 is usually done at 384 kbps, while AC3 2.0 is 192 kbps. The 192 kbps difference is a drop in the bucket compared to all of the other packets that make up the transponder mux. I think you're right -

Re: [FFmpeg-user] How can I convert mpeg2 5.1 audio to ac3?

2014-11-11 Thread Moritz Barsnick
On Tue, Nov 11, 2014 at 13:46:26 +, Andy Furniss wrote: For some reason this thread has split into two for me and I didn't see the other bit. You can see the thread structure and that other branch about here: http://thread.gmane.org/gmane.comp.video.ffmpeg.user/54545/focus=54575 [Selfishly

Re: [FFmpeg-user] FFMPEG RPM for centos

2014-11-12 Thread Moritz Barsnick
Hi Sravan, On Tue, Nov 11, 2014 at 18:27:30 +, Sravan Kasarla wrote: I am new ffmpeg user. I would like to get an RPM for ffmpeg and its dependencies for latest version. Where can I get those RPM's from? You can get RPMs from RPMFusion:

Re: [FFmpeg-user] Parsed_pan_0 This syntax is deprecated. Use '|' to separate the list items

2014-11-18 Thread Moritz Barsnick
On Tue, Nov 18, 2014 at 11:39:02 +, Carl Eugen Hoyos wrote: I think online documentation should be fixed. Please consider sending a patch. I have had one lying around here for the last couple of weeks - ever since I got annoyed by that warning. (See some other thread here.) I don't recall

Re: [FFmpeg-user] Parsed_pan_0 This syntax is deprecated. Use '|' to separate the list items

2014-11-18 Thread Moritz Barsnick
On Tue, Nov 18, 2014 at 23:34:27 +0900, Kimio Miyamura wrote: Please consider sending a patch. Patch for documentation? Just replace : with |? That's basically it. See attached. Too lazy to format correctly and properly send to the correct list right now, with comments. Might do so later.

Re: [FFmpeg-user] Worse quality than mencoder

2014-11-26 Thread Moritz Barsnick
Hi n32, On Tue, Nov 25, 2014 at 19:14:00 +0100, n...@email.cz wrote: The output is surprisingly the same: Are you absolutely sure? It's very long, especially from mencoder, so I dropped some insignificant lines (marked as {more times}), which are similar to previous, so hopefully nobody

Re: [FFmpeg-user] Worse quality than mencoder [SOLVED]

2014-11-26 Thread Moritz Barsnick
On Wed, Nov 26, 2014 at 14:36:52 +0100, Jan Sever wrote: The encoders set some parameters for quicker first pass (I knew that), I wasn't aware of that, but didn't actually find any source indicating to having to use the same parameters either (which is why I added AFAIU). but what I didn't

Re: [FFmpeg-user] About compile fail on ffmpeg

2014-11-27 Thread Moritz Barsnick
On Thu, Nov 27, 2014 at 13:22:56 +0800, ha...@mail.ustc.edu.cn wrote: Hello,I'm using the Cygwin and NDK r5b to compile the ffmpeg , but it always fail,and the tips are : /toolchains/arm-linux-androideabi-4.4.3/prebuilt/windows/bin/arm-linux-androideabi-gcc is unable to create an executable

Re: [FFmpeg-user] How To Play YouTube Videos using FFPLAy

2014-11-30 Thread Moritz Barsnick
On Sun, Nov 30, 2014 at 15:40:11 -0800, DopeLabs wrote: what i usually end up doing is using youtube-dl to get the video url from youtube. $ youtube-dl -g https://www.youtube.com/watch?v=holhZM1OpTc Thanks, I was missing the -g option! BTW, I often need -F to figure out the correct (dash)

Re: [FFmpeg-user] OS X screen record by ffmpeg

2014-12-02 Thread Moritz Barsnick
On Mon, Dec 01, 2014 at 22:03:18 -0500, David Peterson wrote: Will this work in the same manner to screen record IOS? Have you tried? iOS appears to also provide AVFoundation, AFAICS. Moritz ___ ffmpeg-user mailing list ffmpeg-user@ffmpeg.org

Re: [FFmpeg-user] Use of -ifo_palette

2014-12-02 Thread Moritz Barsnick
Hi, On Tue, Dec 02, 2014 at 11:12:44 -0500, Dave Rice wrote: I’d like to use the new -ifo_palette option but it is returned as an unrecognized option. ffmpeg -ifo_palette VTS_09_0.IFO -analyzeduration 30k -probesize 30k -i WELCOME9-1.vob ffmpeg version 2.4.4 Copyright (c)

Re: [FFmpeg-user] Use ffmpeg to convert stereo audio to mono

2014-12-05 Thread Moritz Barsnick
Could we know how ffmpeg determine audio channel number from MP4 file? MP4 container indicates it's channel count is 2, but ffprobe shows mono as expected. ffprobe probably looks at the actual AAC stream? Here's a hint: http://sourceforge.net/p/opencore-amr/mailman/message/31876733/ The

Re: [FFmpeg-user] Invalid stream specifier

2014-12-12 Thread Moritz Barsnick
Hi Radu, On Fri, Dec 12, 2014 at 10:22:58 +, Radu Grigorovici wrote: the frames at 100 fps and blend them in successive steps to 50 fps and then to 25 fps. The problem is i get an error saying Invalid stream specifier: fps50 and don't know how to fix it. [...] ffmpeg -r 100 -i

Re: [FFmpeg-user] AVI and Timecode

2014-12-12 Thread Moritz Barsnick
On Fri, Dec 12, 2014 at 15:32:59 +0100, Dietmar Thal wrote: There are several problems with these: Premiere skips randomly loading 1.'s when importing many of them, crashes from time to time with 2. and 3. worked best but from time to time i get playback errors and skipped frames. That

Re: [FFmpeg-user] ./configure error

2014-12-16 Thread Moritz Barsnick
Hi Brandon, On Mon, Dec 15, 2014 at 15:50:13 -0700, Brandon Northcutt wrote: ERROR: opencl not found The important error is /usr/bin/ld: cannot find -lOpenCL My system is x86_64 Fedora 20 with all opencl rpm packages installed: AFAIU, you need an OpenCL loader and an actual implementation.

Re: [FFmpeg-user] dvd_nav_packet mapping order issue

2014-12-16 Thread Moritz Barsnick
On Tue, Dec 16, 2014 at 22:06:18 +0100, Sub Phil wrote: Stream map '0:d' matches no streams. Another possibility would be to use -dn to surpress (all) data streams. Moritz ___ ffmpeg-user mailing list ffmpeg-user@ffmpeg.org

Re: [FFmpeg-user] fixed size cropping rectangle, moving in time

2014-12-16 Thread Moritz Barsnick
Hi Sub, On Tue, Dec 16, 2014 at 22:22:48 +0100, Sub Phil wrote: I wish to have a fixed size cropping rectangle, that changes its x-position after say 15 sec for an initial x position of say 200 to 100. Do I miss some quotes?? F:\ffmpeg -i timeC.mp4 -vf

Re: [FFmpeg-user] MPEG AC-3 Error

2014-12-19 Thread Moritz Barsnick
On Fri, Dec 19, 2014 at 18:02:39 -0800, Kirk Bocek wrote: 2.2.4-67.el6 Does that sound current enough? Much better than 0.x. For reproducing bugs, testing the latest Git is preferred. As for the container format, I am confused by your statement. MPG is the source file's format. It plays

Re: [FFmpeg-user] Applying filters for selected frames?

2014-12-21 Thread Moritz Barsnick
Hi Jan, On Sun, Dec 21, 2014 at 17:52:16 +0100, Jan Sever wrote: is it possible to apply filters (-vf) in ffmpeg only for selected frames? Yes, for certain filters. Check this: https://ffmpeg.org/ffmpeg-filters.html#Timeline-editing Whether a filter supports this doesn't seem to be stated in

Re: [FFmpeg-user] Applying filters for selected frames?

2014-12-21 Thread Moritz Barsnick
On Sun, Dec 21, 2014 at 19:36:07 +, Carl Eugen Hoyos wrote: You should not use a deinterlacing filter on non-interlaced material. My bad, thanks for the clarification. I think I had this thread in the back of my mind: http://ffmpeg.org/pipermail/ffmpeg-user/2014-May/021412.html which

Re: [FFmpeg-user] ffmpeg ffplay produce gray frames from h264 input

2014-12-23 Thread Moritz Barsnick
On Tue, Dec 23, 2014 at 15:39:12 +0200, Сергей Добродей wrote: I can provide a sample video. You should first describe your issue. Please also include full command line and console output. https://drive.google.com/a/synesis.ru/file/d/0B11bqzYgay7MT1lXZVU3Mm5HS1k/view?usp=sharing Is that a

Re: [FFmpeg-user] build ffmpeg failed

2014-12-24 Thread Moritz Barsnick
On Wed, Dec 24, 2014 at 16:05:35 +0800, 朱昌 wrote: ./configure [...] -miphoneos-version-min=“8.1” [...] [...] clang: error: invalid version number in '-miphoneos-version-min=“8.1”' Those are not proper quotation marks. It seems they are interpreted as part of the string. You should use ''

Re: [FFmpeg-user] LLossless (10 Bit RGB 444) and (10 Bit YUV 422) Compression

2014-12-28 Thread Moritz Barsnick
On Sun, Dec 28, 2014 at 19:47:17 +, Carl Eugen Hoyos wrote: How do you know? I am not saying you are wrong but I would like to understand this better. AJA _does_ seem to differentiate between R10g, R10k and r10k: https://www.aja.com/assets/support/files/981/en/kona_pc_manual_5.0.pdf The

Re: [FFmpeg-user] Fastest lossless codec and settings.

2015-01-01 Thread Moritz Barsnick
On Thu, Jan 01, 2015 at 18:14:15 +0100, Zsolt wrote: Interestingly even rawvideo and the other uncompressed formats I tried resulted in high max/near-max CPU usage. Interesting. Lot of recommendations, which is cool. But isn't there some sort of agreement which is the fastest lossless

Re: [FFmpeg-user] webm to mpg

2015-01-02 Thread Moritz Barsnick
On Fri, Jan 02, 2015 at 06:40:54 -0500, Ajtim wrote: I have still problem with converting youtube webm to mpg and than made a dvd which doesn't plays good on dvd recorder on tv. I think you failed to answer all the questions last time you asked, back in April. ffmpeg version 2.3.5 Copyright

Re: [FFmpeg-user] removing logo

2015-02-04 Thread Moritz Barsnick
On Wed, Feb 04, 2015 at 15:57:20 +, Eng.Hany Ahmed wrote: this is helpful with transcoding the movie thank you very much for care and help but how i can use this with copy method because it's not work You cannot copy a stream while at the same time trying to change the content. To copy

Re: [FFmpeg-user] removing logo

2015-02-03 Thread Moritz Barsnick
Hi Hany, On Tue, Feb 03, 2015 at 01:01:57 +, Eng.Hany Ahmed wrote: Helloi have videos have logo in the top of the corner i want make pixelate blur for this logo like in the photo In which photo? i tried to using water mark but i have 2 problems 1- it's take many resources of the cpu

Re: [FFmpeg-user] removing logo

2015-02-07 Thread Moritz Barsnick
On Sat, Feb 07, 2015 at 18:08:13 +, Eng.Hany Ahmed wrote: this is helpful with transcoding the movie thank you very much for care and help but how i can use this with copy method because it's not workThe code line i using nice -n 8 ffmpeg -i tesmov.mp4 -map 0 -vcodec copy -scodec copy

Re: [FFmpeg-user] How can I determine if a 10bit videofile has full 10bit video data or 8bit (+ 2bits zeros) data

2015-01-16 Thread Moritz Barsnick
On Fri, Jan 16, 2015 at 14:10:38 +0100, Christoph Gerstbauer wrote: I am searching for a possibility to check if a 10bit 4:2:2 videofile (v210 codec or ffvhuff codec) has a) 8bit+2empty bits or b) full 10bit data in the video stream. You'll probably need to export it to raw YUV or RGB

Re: [FFmpeg-user] Image Conversion TIFF JPEG with yuv422 chroma subsampling

2015-01-20 Thread Moritz Barsnick
On Tue, Jan 20, 2015 at 17:16:47 +0100, Andrea Rastelli wrote: I'm sorry but even with your help seems impossible to properly convert my images. It may depend heavily on the input, but at least I can successfully create JPEG from a TIFF, and it can be read by many programs: $ ffmpeg -i

Re: [FFmpeg-user] FFMPEG for encoding to Multichannel ALAC

2015-01-19 Thread Moritz Barsnick
Hi Rashed, On Mon, Jan 19, 2015 at 17:22:18 +0530, Rashed wrote: I am trying to generate multichannel ALAC content using FFMPEG but somehow is seem to be getting only up to stereo. Is this a limitation of FFMPEG or am i doing something incorrectly. ffmpeg -i pcmfile_48k_16bit_5.1.wav

Re: [FFmpeg-user] output jpeg quality

2015-01-15 Thread Moritz Barsnick
On Thu, Jan 15, 2015 at 00:05:51 -0800, Green Koopa wrote: When outputting frames like this, is there a way to put the frame number/time in the output file name? Otherwise, it looks like I have to use the drawtext filter to add it to the images. Sure. It's mentioned here:

Re: [FFmpeg-user] Usages about multi outputs

2015-01-15 Thread Moritz Barsnick
On Thu, Jan 15, 2015 at 10:27:02 +0100, Moritz Barsnick wrote: On Thu, Jan 15, 2015 at 16:35:20 +0800, xiaoyao...@163.com wrote: ./ffmpeg -i input.mp4 -i logo.png -filter_complex yadif=deint=1,subtitles=subtitle.ass,delogo=x=60:y=60:w=100:h=77:band=10,overlay=10:10,split=2[a][b] -map

Re: [FFmpeg-user] Usages about multi outputs

2015-01-15 Thread Moritz Barsnick
On Thu, Jan 15, 2015 at 18:06:26 +0800, xiaoyao...@163.com wrote: Perfect! It works with small change from -map 0:a to -map 0:a. Actually, you meant my -map [0:a]. Sorry, my bad. There _should_ also be some way to encode your audio only once, since both your encodings are identical. Someone

Re: [FFmpeg-user] Image Conversion TIFF JPEG with yuv422 chroma subsampling

2015-01-21 Thread Moritz Barsnick
On Wed, Jan 21, 2015 at 09:33:21 +0100, Andrea Rastelli wrote: Actually the problem is not in the creation of the JPEG itself, but in the resulting chroma subsampling that (apparently) is not stored in the FFmpeg resulting image. You did not mention this so far within this thread, if I may

Re: [FFmpeg-user] transcoding mp3 to wav

2015-01-22 Thread Moritz Barsnick
On Thu, Jan 22, 2015 at 10:08:35 -0700, jd1008 wrote: it does the conversion, but does not honour the bitrate param. How do I force the bitrate param for the ourput? You didn't show us the output of your ffmpeg command. Anyway, your approach is wrong. The bitrate of a WAV file is defined by

Re: [FFmpeg-user] Using ffmpeg to create video wall

2015-02-18 Thread Moritz Barsnick
Hi, Matt, On Wed, Feb 18, 2015 at 09:46:24 +, Matt Conway wrote: Cheers for getting back to me! Here is the uncut output from the command prompt. C:\Users\adminffmpeg -i rtsp:// root:FishAxisFood12@192.168.0.4/axis-media/media.amp -an -r 30 -f avi udp://239.0.1.23:1234 FFmpeg

Re: [FFmpeg-user] Using ffmpeg to create video wall

2015-02-17 Thread Moritz Barsnick
On Tue, Feb 17, 2015 at 16:39:07 +, Matt Conway wrote: and the command on the clients (For top left tile)- avconv --tile-code=41 udp://239.0.1.23:1234 avconf is not ffmpeg and is not supported here. ffmpeg may share some of the shortcomings you are observing, but you won't know until you

Re: [FFmpeg-user] Streaming to ustream/twitch from Raspberry Pi

2015-02-19 Thread Moritz Barsnick
On Thu, Feb 19, 2015 at 11:18:00 -0900, Lou wrote: Are you intending to re-encode? Do you not want to stream copy instead? http://ffmpeg.org/ffmpeg.html#Stream-copy 1280x720 [SAR 1:1 DAR 16:9], q=2-31, 200 kb/s, 30 fps, 1k tbn, 30 tbc Do you really want to be using flv1 as the encoder? It's

  1   2   3   4   5   6   7   8   9   10   >