[Flashcoders] Error #1009 shows randomly

2009-06-30 Thread Isaac Alves
Hello fellows,
I've bought at Flash Den a code of an Infinite Level Menu (from MBMedia) and
I'm pulling my hair out.

It throws that well known error as the text of the button doesn't show when
it should:

“TypeError: Error #1009: cannot access a  property or method of a null
object reference. at local.display:rimaryButton/frame7()”
That without touching the code or elements on the stage. Actually, if inside
the main.fla file, I go inside the Expanding Menu and then inside the
Primary Button MovieClip and select the text field and at that point I test
the movie, it works correctly. As long as I leave the Primary Button
movieclip and test the movie, it throws that error again!

Obs: It is not actually  randomly that it  throws that error. I've tried a
thousand times to test the movie within a certain state  , that means,foe
example, when I'm iinside a certain movieclip  with the textfield selected.
and in that specific situation it always throws (or not) the error.

You know, I select a movieclip , test Movie and it works. I deselect it,
test movie  and it doesn't . Its seems like a bug... that's very bizarre.

Please help !!!
Thanks a lot,
Isaac
___
Flashcoders mailing list
Flashcoders@chattyfig.figleaf.com
http://chattyfig.figleaf.com/mailman/listinfo/flashcoders


Re: [Flashcoders] Error #1009 shows randomly

2009-06-30 Thread Sidney de Koning

Hi Isaac,

As far as i can see it that you took off the P when going through the  
code, since it gives an error that it canot find  
local.display:rimaryButton on frame 7.
Try looking there, maybee you changed the linkage identifier or the  
classname.


HTH,

Sidney de Koning

On Jun 30, 2009, at 4:49 PM, Isaac Alves wrote:


Hello fellows,
I've bought at Flash Den a code of an Infinite Level Menu (from  
MBMedia) and

I'm pulling my hair out.

It throws that well known error as the text of the button doesn't  
show when

it should:

“TypeError: Error #1009: cannot access a  property or method of a null
object reference. at local.display:rimaryButton/frame7()”
That without touching the code or elements on the stage. Actually,  
if inside

the main.fla file, I go inside the Expanding Menu and then inside the
Primary Button MovieClip and select the text field and at that point  
I test

the movie, it works correctly. As long as I leave the Primary Button
movieclip and test the movie, it throws that error again!

Obs: It is not actually  randomly that it  throws that error. I've  
tried a
thousand times to test the movie within a certain state  , that  
means,foe
example, when I'm iinside a certain movieclip  with the textfield  
selected.

and in that specific situation it always throws (or not) the error.

You know, I select a movieclip , test Movie and it works. I deselect  
it,
test movie  and it doesn't . Its seems like a bug... that's very  
bizarre.


Please help !!!
Thanks a lot,
Isaac
___
Flashcoders mailing list
Flashcoders@chattyfig.figleaf.com
http://chattyfig.figleaf.com/mailman/listinfo/flashcoders


Sidney de Koning - be a geek, in rockstar style!
Flash / AIR Developer @ www.funky-monkey.nl
Technical Writer @ www.insideria.com

___
Flashcoders mailing list
Flashcoders@chattyfig.figleaf.com
http://chattyfig.figleaf.com/mailman/listinfo/flashcoders