RE: [Flashcoders] missing glyphs

2008-01-25 Thread Mendelsohn, Michael
Thanks Ain.  There doesn't seem to be much of a solution.   I couldn't open the 
fla in the zip file, but I'm guessing you created it in CS3, which I don't 
have.  (8) 

However, I did come up with a not versatile workaround for my purposes:

// where tf is a TextFormat...
// unicode glyphs not showing up
//var symbol:String = (i == 0) ? \u2264 : \u2265;
//var symbol:String = (i == 0) ? ≤ : ≥;
var symbol:String = (i == 0) ?  : ;
objMarkText.text = String(Objective:  + symbol +   + _root[String(kra + 
(i + 1) + objective)]);
// workaround for unicode glyphs not showing up...
tf.underline = true;
objMarkText.setTextFormat(11, tf);
tf.underline = false;


-Original Message-
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of Ain Tohvri
Sent: Friday, January 25, 2008 11:16 AM
To: Flash Coders List
Subject: Re: [Flashcoders] missing glyphs

No guarantees, but you might want to check out this Michael: 
http://tekkie.flashbit.net/flash/embedding-fonts-in-flash-cs3

___
Flashcoders mailing list
Flashcoders@chattyfig.figleaf.com
http://chattyfig.figleaf.com/mailman/listinfo/flashcoders


Re: [Flashcoders] missing glyphs

2008-01-25 Thread Ain Tohvri

No guarantees, but you might want to check out this Michael: 
http://tekkie.flashbit.net/flash/embedding-fonts-in-flash-cs3

Regards,

Ain Tohvri
Flashbit LLC


On 23.01.2008, at 18:06, Mendelsohn, Michael wrote:


Hi list...
I've embedded a font that I confirmed in Windows' character map that  
it has the glyphs for ≤ and ≥.  These glyphs trace fine, but they  
don't appear in my textField.  Any idea what I'm missing?


Thanks,
- Michael M.



var objMarkText:TextField = _root.createTextField(tf, 1, 0, 0, 1,  
1);

objMarkText.embedFonts = true;
var symbol:String = (i==0)?\u2264:\u2265;
objMarkText.text = symbol;
trace(objMarkText.text);

// traces correctly...but glyph doesn't show up in objMarkText.text


___
Flashcoders mailing list
Flashcoders@chattyfig.figleaf.com
http://chattyfig.figleaf.com/mailman/listinfo/flashcoders



___
Flashcoders mailing list
Flashcoders@chattyfig.figleaf.com
http://chattyfig.figleaf.com/mailman/listinfo/flashcoders


RE: [Flashcoders] missing glyphs

2008-01-25 Thread Mendelsohn, Michael
Thanks for replying Cory.  I am doing that.  I have a TextFormat with an 
embedded font that is displaying correctly.  The issue is these two glyphs of 
that font not showing up.  The rest of the font's characters are there.

Even when I use either of these when building the string, the glyphs don't 
display:
var symbol:String = (i == 0) ? ≤ : ≥;
// or...
var symbol:String = (i == 0) ? \u2264 : \u2265;

Also, trace(symbol) traces the glyphs no problem.

I *thought* actionscript is saved as Unicode, or maybe that's just .as files.  
This is script in the .fla itself.  Maybe that has something to do with it?

Still thinking...
- MM


 If you set the embedFonts property to true for a text field, you must
specify a font for that text by using the font property of a
TextFormat object applied to the text field. If the specified font is
not embedded in the SWF file, the text is not displayed.

___
Flashcoders mailing list
Flashcoders@chattyfig.figleaf.com
http://chattyfig.figleaf.com/mailman/listinfo/flashcoders


Re: [Flashcoders] missing glyphs

2008-01-24 Thread Cory Petosky
From the docs:

If you set the embedFonts property to true for a text field, you must
specify a font for that text by using the font property of a
TextFormat object applied to the text field. If the specified font is
not embedded in the SWF file, the text is not displayed.

On 1/23/08, Mendelsohn, Michael [EMAIL PROTECTED] wrote:
 Hi list...
 I've embedded a font that I confirmed in Windows' character map that it has 
 the glyphs for ≤ and ≥.  These glyphs trace fine, but they don't appear in my 
 textField.  Any idea what I'm missing?

 Thanks,
 - Michael M.



 var objMarkText:TextField = _root.createTextField(tf, 1, 0, 0, 1, 1);
 objMarkText.embedFonts = true;
 var symbol:String = (i==0)?\u2264:\u2265;
 objMarkText.text = symbol;
 trace(objMarkText.text);

 // traces correctly...but glyph doesn't show up in objMarkText.text


 ___
 Flashcoders mailing list
 Flashcoders@chattyfig.figleaf.com
 http://chattyfig.figleaf.com/mailman/listinfo/flashcoders



-- 
Cory Petosky : Lead Developer : PUNY
1618 Central Ave NE Suite 130
Minneapolis, MN 55413
Office: 612.216.3924
Mobile: 240.422.9652
Fax: 612.605.9216
http://www.punyentertainment.com

___
Flashcoders mailing list
Flashcoders@chattyfig.figleaf.com
http://chattyfig.figleaf.com/mailman/listinfo/flashcoders


[Flashcoders] missing glyphs

2008-01-23 Thread Mendelsohn, Michael
Hi list...
I've embedded a font that I confirmed in Windows' character map that it has the 
glyphs for ≤ and ≥.  These glyphs trace fine, but they don't appear in my 
textField.  Any idea what I'm missing?

Thanks,
- Michael M.



var objMarkText:TextField = _root.createTextField(tf, 1, 0, 0, 1, 1);
objMarkText.embedFonts = true;
var symbol:String = (i==0)?\u2264:\u2265;
objMarkText.text = symbol;
trace(objMarkText.text);

// traces correctly...but glyph doesn't show up in objMarkText.text


___
Flashcoders mailing list
Flashcoders@chattyfig.figleaf.com
http://chattyfig.figleaf.com/mailman/listinfo/flashcoders