Re: [Flightgear-devel] multiple --generic record/playback errors

2010-02-11 Thread Alex Buzin
On Tue, Feb 9, 2010 at 1:37 PM, John Denker wrote:
Has anybody used the --generic record/playback feature recently?

The same trouble was discussed at 2008 :
http://www.mail-archive.com/flightgear-devel@lists.sourceforge.net/msg16539.html
and
http://www.mail-archive.com/flightgear-devel@lists.sourceforge.net/msg15655.html

With respect,
Alex



--
SOLARIS 10 is the OS for Data Centers - provides features such as DTrace,
Predictive Self Healing and Award Winning ZFS. Get Solaris 10 NOW
http://p.sf.net/sfu/solaris-dev2dev
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


[Flightgear-devel] Missed file in CVS

2010-01-12 Thread Alex Buzin
Hi!
The file KLN89/kln89.cxx rev. 1.18 contains the next lines

#if ENABLE_ATCDCL
#include ATCDCL/ATCProjection.hxx
#else
#include kln89_align.hxx
#endif

But the file kln89_align.hxx is absent and with ENABLE_ATCDCL=FALSE it 
raises an error.
**Can somebody fix this.

With respect,
Alex


--
This SF.Net email is sponsored by the Verizon Developer Community
Take advantage of Verizon's best-in-class app development support
A streamlined, 14 day to market process makes app distribution fast and easy
Join now and get one step closer to millions of Verizon customers
http://p.sf.net/sfu/verizon-dev2dev 
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] New Sound system committed

2009-10-12 Thread Alex Buzin
Hi,
I got an error with the Sunday CVS - FG crashed while exiting .
gdb reports SIGSEGV error at file soundmgr_openal.cxx, line 159.

Error was fixed by changing lines 157-159 from:
buffer_map_iterator buffers_current = _buffers.begin();
buffer_map_iterator buffers_end = _buffers.end();
for ( ; buffers_current != buffers_end; ++buffers_current ) {
to :
buffer_map_iterator buffers_current;
while(_buffers.size()){
buffers_current = _buffers.begin();


With respect,
Alex



--
Come build with us! The BlackBerry(R) Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay 
ahead of the curve. Join us from November 9 - 12, 2009. Register now!
http://p.sf.net/sfu/devconference
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] [PATCH] 3D Clouds update

2009-10-12 Thread Alex Buzin
Stuart Buchanan wrote:
 Scott Hamilton wrote:
   
 On Tue, 2009-10-06 at 22:06 -0400, William Harrison wrote:

 
Maybe it's just me, but has anyone noticed a dramatic performance 
 decrease with 3d clouds after this patch?
 
  yep, from 30fps to 2fps...
   

 I'm very surprised that performance has decreased so significantly. However, 
 there is a possible explanation.

 The code falls back to a 2D cloud layer if a 3D cloud isn't defined for a 
 specific cloud type (st, ac etc.). IIRC
 previously we didn't define a 3D stratus layer, so we'd get a 2D layer 
 instead.

 The updated 3D clouds include stratus layers (which look rather nice IMO), 
 but require quite a larger number
 of sprites - something like 40 per cloud. I've seen a small perf hit from the 
 new stratus layers, but nothing like
 what you have reported.

 I suspect what you are seeing if the difference between a 2D and 3D cloud.

 What performance change are you seeing with, say, cumulus clouds, which 
 haven't changed much?

 BTW - I've updated Docs/Readme.3Dclouds with information on the new format, 
 if anyone is interested in enhancing
 the clouds.

 -Stuart
   

What I have seen (airplane-ufo, altitude - 2000ft, cloud layer 0 = 
4000ft, overcast, cloud layer 1 = 19500ft, cirrus):
1. 3D clouds OFF from command line: FPS=70, memory usage 360M, layer 0 - 
visible.

2. 3D clouds ON from  command line: memory usage from 800M up to 1.2G
- pitch =0 deg : FPS=10-12
- pitch =90 deg : FPS=70
- pitch =-90 deg : FPS=70

3. 3D clouds ON from  command line, than switch OFF from menu : FPS = 
60-70, memory usage 700-800M

4. 3D clouds ON from  command line,  start at lat,lon = 0, 0 (no scenery 
loaded) : NO clouds in layer 0, both 3D and 2D. If switch 3D clouds OFF 
from menu then 2D clouds appears.

With respect,
Alex



--
Come build with us! The BlackBerry(R) Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay 
ahead of the curve. Join us from November 9 - 12, 2009. Register now!
http://p.sf.net/sfu/devconference
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


[Flightgear-devel] FG crashes when changing visibility

2009-10-12 Thread Alex Buzin
Hi,
I was noticed that FG hangs and than crashes if pressing z key. If 
visibility value is not controlled by user, it can be occasionally 
**increased to a huge value (1000 km). In this case TileLoader is 
trying to load hundreds of tiles. At the beginning I was expected  a 
number of tiles to be limited by the size of TileCache (100), but I was 
mistaken. Size of TileCache is growing in routine 
FGTileMgr::schedule_needed( ... ) to make space for all tiles.

On my PC when /environment/visibility-m   500-1000km memory usage grows 
from 300M up to 3G an this leads to crash.

Can somebody limit the value in property /environment/visibility-m or 
the value of variable vis in FGTileMgr::schedule_needed( ... ). The 
maximum value of 100km will be acceptable IMHO.

With respect,
Alex


--
Come build with us! The BlackBerry(R) Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay 
ahead of the curve. Join us from November 9 - 12, 2009. Register now!
http://p.sf.net/sfu/devconference
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] Is ther any MSVC example code to send/receive data to FG over an internet connection?

2009-09-25 Thread Alex Buzin
Randall Green wrote:

 I am testing a new Primary Flight Display with a tunnel
 in the sky. It will run on a separate computer and I
 need FlightGear for it's flight dynamics. I'ld like the PFD to
 receive Lat, lon, altitude, heading, pitch, roll, alpha
 and beta from FG and also I'ld like to tell FG to put
 out the gear and flaps when the altitude first goes below
 1000 ft.
 Curt Olson says that I could do it with an internet connection,
 to gather variables and send commands.
 Is there any example code written in MSVC I could look at
 to make the internet connection on the PFD end?

 Thanks,
 Randy Green

Look here:
http://cvs.flightgear.org/viewvc/source/examples/netfdm/
It is not MSVC, but for MSWin.

With respect,
Alex



--
Come build with us! The BlackBerryreg; Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay 
ahead of the curve. Join us from November 9#45;12, 2009. Register now#33;
http://p.sf.net/sfu/devconf
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] Weird Sun and weather bugs

2009-09-22 Thread Alex Buzin
Erik Hofman wrote:
 It's way more extreme than that, the dewpoint once in a while seems to 
 reset to -2.8308 from it's current value causing the humidity to jump 
 way beyond 100% (I've seen 1200%). I could limit the humidity to 100% 
 but that only hides the problem.

 I did not find why the dewpoint varies that much.

 Erik

   
I have made a log in function _recalc_alt_dewpoint() with the last 
environment.cxx from CVS (rev 1.31).
Here is written at level flight:

step to _recalc_alt_dewpoint () elevation_ft is 41981.8 dewpoint_degc is 
-56.5 temperature_degc is -56.5
step to _recalc_alt_dewpoint () elevation_ft is 41981.8 dewpoint_degc is 
-2.8308 temperature_degc is -2.8308
step to _recalc_alt_dewpoint () elevation_ft is 41981.8 dewpoint_degc is 
-56.5 temperature_degc is -56.5
step to _recalc_alt_dewpoint () elevation_ft is 41981.8 dewpoint_degc is 
-56.5 temperature_degc is -56.5
step to _recalc_alt_dewpoint () elevation_ft is 41981.8 dewpoint_degc is 
-56.5 temperature_degc is -56.5
step to _recalc_alt_dewpoint () elevation_ft is 41981.8 dewpoint_degc is 
-56.5 temperature_degc is -56.5
step to _recalc_alt_dewpoint () elevation_ft is 41981.8 dewpoint_degc is 
-56.5 temperature_degc is -56.5
step to _recalc_alt_dewpoint () elevation_ft is 41981.8 dewpoint_degc is 
-56.5 temperature_degc is -56.5
step to _recalc_alt_dewpoint () elevation_ft is 41981.8 dewpoint_degc is 
-56.5 temperature_degc is -56.5
step to _recalc_alt_dewpoint () elevation_ft is 41981.8 dewpoint_degc is 
-2.8308 temperature_degc is -2.8308
step to _recalc_alt_dewpoint () elevation_ft is 41981.8 dewpoint_degc is 
-56.5 temperature_degc is -56.5
step to _recalc_alt_dewpoint () elevation_ft is 41981.8 dewpoint_degc is 
-56.5 temperature_degc is -56.5
step to _recalc_alt_dewpoint () elevation_ft is 41981.8 dewpoint_degc is 
-56.5 temperature_degc is -56.5
step to _recalc_alt_dewpoint () elevation_ft is 41981.8 dewpoint_degc is 
-56.5 temperature_degc is -56.5

So problem is in the value of temperature_degc.

It seems to be a couple of errors connected with environment.
1) File: fg_commands.cxx, routine: static bool 
do_set_dewpoint_sea_level_degc (const SGPropertyNode * arg)
variable dewpoint_sea_level_degc is defined as
double dewpoint_sea_level_degc = 
arg-getDoubleValue(dewpoint-degc, 5.0);
may be correct is:
double dewpoint_sea_level_degc = 
arg-getDoubleValue(dewpoint-sea-level-degc, 5.0);

2) File: environment.cxx, routine: void interpolate (const FGEnvironment 
* env1, const FGEnvironment * env2, double fraction, FGEnvironment * result)
   the lines :
result-set_dewpoint_degc
(do_interp(env1-get_dewpoint_sea_level_degc(),
   env2-get_dewpoint_sea_level_degc(),
   fraction));
may be correct is:
result-set_dewpoint_sea_level_degc
(do_interp(env1-get_dewpoint_sea_level_degc(),
   env2-get_dewpoint_sea_level_degc(),
   fraction));

With respect,
Alex





--
Come build with us! The BlackBerryreg; Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay 
ahead of the curve. Join us from November 9#45;12, 2009. Register now#33;
http://p.sf.net/sfu/devconf
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] Weird Sun and weather bugs

2009-09-22 Thread Alex Buzin
Here it is!!
At procedure void FGEnvironment::set_elevation_ft (double e)
change :
_recalc_alt_dewpoint();
_recalc_alt_pt();
to :
_recalc_alt_pt();
_recalc_alt_dewpoint();

 It corrects all.

With respect,
Alex





--
Come build with us! The BlackBerryreg; Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay 
ahead of the curve. Join us from November 9#45;12, 2009. Register now#33;
http://p.sf.net/sfu/devconf
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] Weird Sun and weather bugs

2009-09-18 Thread Alex Buzin
Victhor Foster wrote:
 I don't remember when this started, I think it was a week or so. Well,  
 the Sun bug is simple: switching time to Dawn/Dusk will cause the sun  
 colors to start flashing between the correct colors and morning/noon/ 
 afternoon colors. The weather bug is: after about 1 ft MSL (I  
 think) it starts raining. When I get past about 15000 ft MSL snow  
 starts falling. It stops after some time, eventually. I don't recall  
 seeing snow falling on my last plane trip :P
   
I got snow at 4000 - 6000ft and it is depending on plane speed. While 
using ufo FDM at zero speed snow stop.
Noticeable scenery flashing starts at altitudes above 2ft without 
time switching. At altitudes ~4ft flash colors become dark.

With respect,
Alex




--
Come build with us! The BlackBerryreg; Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay 
ahead of the curve. Join us from November 9#45;12, 2009. Register now#33;
http://p.sf.net/sfu/devconf
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


[Flightgear-devel] ufo.nas and divide by zero

2009-04-04 Thread Alex Buzin

Hi!
I have got range exception when flying UFO. Looking in sources open that
problem is in ufo.nas line 420:
me.marker = Model.new(Aircraft/ufo/Models/marker.ac, 
geo.Coord.new().set_xyz(0, 0, 0));
When passing zeros to geo.Coord.set_xyz(), there is devide by zero in
function SGGeodesy::SGCartToGeod(). This puts NAN to Elevation.

Problem can be fixed in two ways:
1 Change ufo.nas to initialize geo.Coord  using function set_latlon(0,
0, 0). Or was some reason to put model at the Earth center?
2 Fix SGGeodesy::SGCartToGeod() to test input point is (0, 0, 0), and
put to output (0, 0, 0) without calculations. Or solve it in some other
way to avoid divide by zero.

Can somebody consider this and make fix in CVS?

With respect,
  Alex





_
Drag n’ drop—Get easy photo sharing with Windows Live™ Photos.

http://www.microsoft.com/windows/windowslive/products/photos.aspx--
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


[Flightgear-devel] access violation in FGFontCache

2009-04-04 Thread Alex Buzin

Hi!
In GUI style I put one font for  and . This give 
access violation error. The problem is in FGFontCache destructor.

Class FGFontCache contains two Maps : TexFontMap _texFonts and PuFontMap 
_puFonts. _texFonts contains fonts being read from the data/Fonts. 
PuFontMap contains fnt structure which is referencing to texfont from 
_texFonts. A number of fnt structures from _puFonts can refer to a 
single texFont.
In destructor fnt::~fnt() member fnt::texfont is deleted. But 
fnt::texfont is a copy of fntTexFont* from _texFonts. So when second fnt 
structure is deleting it try to delete the fntTexFont which was deleted 
at previous step. This deleting of deleted structure leads to Access 
Violation.

Second possible problem is in FGFontCache destructor. _puFonts map is 
deleted here but not _texFonts map. Can this lead to memory leak?

With respect,
Alex


_
Invite your mail contacts to join your friends list with Windows Live Spaces. 
It's easy!
http://spaces.live.com/spacesapi.aspx?wx_action=createwx_url=/friends.aspxmkt=en-us--
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] Q: OpenGL version requirement for FlightGear 1.9.1

2009-02-06 Thread Alex Buzin

David L. Page wrote:
 Unfortunately, Chromium doesn't support OpenGL 2.0 or higher, right now.
 As I know FG 1.9.0 is using shaders to render trees and clouds. May be 
this is a problem.
Try to find FG 1.0.0 or 0.9.10, it can be at the same FTP resource as 1.9.1.

Alex


_
Invite your mail contacts to join your friends list with Windows Live Spaces. 
It's easy!
http://spaces.live.com/spacesapi.aspx?wx_action=createwx_url=/friends.aspxmkt=en-us--
Create and Deploy Rich Internet Apps outside the browser with Adobe(R)AIR(TM)
software. With Adobe AIR, Ajax developers can use existing skills and code to
build responsive, highly engaging applications that combine the power of local
resources and data with the reach of the web. Download the Adobe AIR SDK and
Ajax docs to start building applications today-http://p.sf.net/sfu/adobe-com___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] Translations

2008-12-20 Thread Alex Buzin

Hi!
Does this translated strings is using anyware? I did not find references
in source code for this strings.
I was trying to change the file strings-default.xml , but did not see
any differences  in GUI.

With respect,
   Alex




_
Show them the way! Add maps and directions to your party invites. 
http://www.microsoft.com/windows/windowslive/events.aspx--
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] Output communication problem

2008-12-19 Thread Alex Buzin



Hi!

As I understand you want to get controls in Matlab from FG. But FG do
not run any useable FDM and if you are trying to send data to Mathlab as
FGNetFDM it can be zeros or loopback (data was sending from MathLab to
FG). What protocol you are using for this connection?
If data to FG is sending via native-fdm then FG mast send controls via
native-ctrls protocol.

With respect,
Alex
_
Drag n’ drop—Get easy photo sharing with Windows Live™ Photos.

http://www.microsoft.com/windows/windowslive/photos.aspx
--
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] Tarball of bleeding edge CVS snapshot

2008-12-05 Thread Alex Buzin

Fabian Grodek wrote:
 I'm using Tortoise.
 Can somebody tell me what should be the command line? Something like:
 :pserver:[EMAIL PROTECTED]:/var/cvs/FlightGear..
 Thank you.
 Fabian

Look at the http://www.flightgear.org/cvs/anoncvs.html



_
Explore the seven wonders of the world
http://search.msn.com/results.aspx?q=7+wonders+worldmkt=en-USform=QBRE--
SF.Net email is Sponsored by MIX09, March 18-20, 2009 in Las Vegas, Nevada.
The future of the web can't happen without you.  Join us at MIX09 to help
pave the way to the Next Web now. Learn more and register at
http://ad.doubleclick.net/clk;208669438;13503038;i?http://2009.visitmix.com/___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


[Flightgear-devel] Error in HUD

2008-08-24 Thread Alex Buzin
Hi,
Some time ago I was in need to display altitude in meters on HUD. I have 
copied desired HUD to airplane folder and check it working. Then I change 
disp_scaling to 0.3048 and got strange altitude scale. As I understand we 
got foot scale with meter markers. After studying sources I desided that 
instr_item::get_value() have to return scaled value. With this I got normal 
altitude scales but broken roll scale. New study made it clear that problem 
is in the file hud_dnst.cxx.
In call to instr_item() parameter data_scaling is missed:
instr_item(x, y, width, height,
chn1_source, options, working),
Problem was fixed by changing it to :
instr_item(x, y, width, height,
chn1_source, 1, options, working),

Can somebody fix this in CVS.

PS
At July I was asked for some of mine changes for FG. May be it will be 
usefull for somebody else. Descriptions and links for downloading are at 
http://buz6919.newmail.ru/FlightGear.html. They will stay here till 
September or October.
If You got problems with downloading (there may be pages on Russian), feel 
free to ask archives via e-mail.

With respect,
Alex


-
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK  win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100url=/
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] Flash with altitude change

2008-04-26 Thread Alex Buzin
Hi!

On Friday, April 25, 2008 Melchior FRANZ wrote

 * Adam Dershowitz -- Thursday 24 April 2008:
 I spent a while trying to track this down, and finally figured out
 what is going on.  The problem is that generic.cxx can only handle
 floats, and that is not enough resolution for latitude and longitude,
 so the last few digits are lost in the conversion.

 Eeew. I never thought of this possibility, but that makes sense.
 I'm not an fg networking user, so I can't comment on or commit
 your patches. I'll leave that to Curt.  :-)

No, this is not the problem. May be in some cases. I provide FG with 
data at 100Hz in binary form (my extension for generic protocol). The data 
can be lost while converting from double to float only. At 0.9.10 all was 
fine but not at 1.0.0.

I look CVS for fix. It removes continuous high-level jitter but 
sometimes screen flashes. I can not specify now how to reproduce it. This 
can be set aside for future investigation.

With respect,
Alex



-
This SF.net email is sponsored by the 2008 JavaOne(SM) Conference 
Don't miss this year's exciting event. There's still time to save $100. 
Use priority code J8TL2D2. 
http://ad.doubleclick.net/clk;198757673;13503038;p?http://java.sun.com/javaone
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] Flash with altitude change

2008-04-26 Thread Alex Buzin
Hi!
On Saturday, April 26, 2008 Adam Dershowitz wrote

 Then your extension must be handling the input differently.  When data
 is read in from a text file, using --generic it is not possible with
 the current code to read in a double.  It is called an FG_DOUBLE in
 some places in the code, but it is converted to a float before it is
 written to the property tree.The actual line of code in
 generic.cxx was:

 _in_message[i].prop-setFloatValue((float)val);

The initial reason was to read data from binary file and now it can make 
full i/o in binary form. But I did not change pointed line and FG got float 
data without truncation due to converting to/from text form.  As I wrote 
there were no problems with 0.9.10. May be with text form this can cause 
problems.
But I think there is no difference between double and float while 
reading with format 12.9f. Did you try to change i/o format in playback.xml 
without changing generic.cxx?

 With respect,
Alex


-
This SF.net email is sponsored by the 2008 JavaOne(SM) Conference 
Don't miss this year's exciting event. There's still time to save $100. 
Use priority code J8TL2D2. 
http://ad.doubleclick.net/clk;198757673;13503038;p?http://java.sun.com/javaone
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] Controlling FlightGear FDM through genericinputwith UDP

2008-04-21 Thread Alex Buzin
Hi!
On Sunday, April 20, 2008 Haluk Sevener wrote:


 All I want to do is just send the commands to a FlightGear instance
 over network with UDP, at the same time listening the properties of
 the aircraft over network by using the same protocol. In other words,
 I want to implement an external control mechanism.

I have the same progrmme. It get from FlightGear terrain elevation and 
send to FG airplane position, orientation, control deposition, etc. The only 
difference is that I have to modify generic protocol for binary i/o.


 Anyway, I started the instances with the following
 commands:

 (master) fgfs --generic=socket,out,1000,127.0.0.1,7755,udp,udptest
 (slave) fgfs --generic=socket,in,1000,127.0.0.1,7755,udp,udptest

Do you really run 2 FlightGear instances at a single PC at 1000Hz? Try 
to run at 100Hz or less.
I think commans must be :
 (master) fgfs --generic=socket,out,100,127.0.0.1,7755,udp,udptest
 (slave) fgfs --generic=socket,in,100,,7755,udp,udptest  --fdm=external

You may try to change host from 127.0.0.1 to localhost on master 
instance.
If you using firewall make sure to open port 7755. I really had this problem 
with firewall.

If this will not help, check udptest.xml as I have wrote. What is in 
input/input tags.

With respect,
Alex


-
This SF.net email is sponsored by the 2008 JavaOne(SM) Conference 
Don't miss this year's exciting event. There's still time to save $100. 
Use priority code J8TL2D2. 
http://ad.doubleclick.net/clk;198757673;13503038;p?http://java.sun.com/javaone
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] Flash with altitude change

2008-04-20 Thread Alex Buzin
Hi!

On Saturday 19 April 2008 Curtis Olson  wrote:

Would it be possible to introduce a bit of smoothing on your end, so that 
the aircraft position updates
are more smooth and continuous?  If nothing else it would be interesting 
to see if this fixes your
problem, and also to see how much smoothing is required to make the 
problem go away.

External programm should not drive FG view. I provide 100Hz FDM data for 
FlightGear, is it low rate? The problem is that update of some systems must 
be synchronized, and we have to define this systems.
I look CVS for Melchior fix. May be some was missed (I am using PLIB 
version) but jitting is present. Now its level is acceptable. May be it will 
be removed if using something similar to
if ( global_multi_loop  0) {
globals-get_viewmgr()-update(delta_time_sec);
}

Now I roll back to 0.9.10 it is more stable for me. I have check a 
number of airplanes and found that at 1.0.0 I can fly without problems UFO 
only. 


-
This SF.net email is sponsored by the 2008 JavaOne(SM) Conference 
Don't miss this year's exciting event. There's still time to save $100. 
Use priority code J8TL2D2. 
http://ad.doubleclick.net/clk;198757673;13503038;p?http://java.sun.com/javaone
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] Controlling FlightGear FDM through generic inputwith UDP

2008-04-20 Thread Alex Buzin
Hi!

On Friday, April 18, 2008 Haluk Sevener wrote:

 How can I run the master-slave model with generic i/o interface?
How can I control a FG instance with over network using generic interface 
with socket input option? (I failed doing this  one. maybe my input 
format in the xml configuration is invalid. but it's ok for the output 
stuff.)

What options your using to start FlightGear with generic i/o?
Check your .xml file carefully. It should contain tags input/input 
and output/output with the similar chunks. Master writes to the socket 
chunks from output/output and the Slave reads from input/input. If 
input chunks does not correspond to output chunks, your can get strange 
results.
If your have wrote a C++ code to handle incoming messages, now try to 
change your C++ code to drive FG using position and orientation only.
I am using generic protocol to drive FlightGear from external program. 
Protocol was changed to use binary i/o, not only binary output as it is done 
in current CVS code.


With respect,
Alex


-
This SF.net email is sponsored by the 2008 JavaOne(SM) Conference 
Don't miss this year's exciting event. There's still time to save $100. 
Use priority code J8TL2D2. 
http://ad.doubleclick.net/clk;198757673;13503038;p?http://java.sun.com/javaone
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] LANDING SIMULINK

2008-03-10 Thread Alex Buzin

Hi!

On Sun, Mar 9, 2008 José Ignacio Cogolludo Galán  wrote:
 I am trying to do a simulation of the flight of an aircfraft in Simulink 
 to visualize in FlightGear. My model
 flights correctly, but when it is on the ground, the model can't stay 
 here. I mean, my aircraft doesn't
 recognize the level of the ground and it can fly under the ground!, so it 
 won't be able to land. I suppose
 is a problem with the above ground level (AGL) between my model in 
 Simulink and Flightgear.
 Nevertheless, I don't know what I need to do. Does anybody how to solve 
 this problem?

I connect FlightGear with my programm (which is external FDM) through 
generic protocol. Generic protocol was changed to accept in/out in binary 
form (not corresponding to that one in CVS tree which does binary output 
only). From FG property tree I take /position/ground-elev-m and my FDM 
programm calculates altitude above ground level. Landing gear wheels at FG 
moves a bit under the ground, but I think this is because LG struts 
compression is calculated in my programm but the airplane model does not 
simulate strut compression.

With respect,
Alex 


-
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse012070mrt/direct/01/
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


Re: [Flightgear-devel] BUG when replay with generic protocol

2008-02-22 Thread Alex Buzin
On Thursday 21 February 2008 Melchior FRANZ wrote
 
 If anyone could tell me which command line exactly was used
 to record, and which to replay then I'd check this out.
 

I got it when flying UFO and recording flight with 
--generic=file,out,100,flight.dat,playback
FDM was running at 100Hz.

Then I change FDM to external and play recorded flight with
--generic=file,in,100,flight.dat,playback
As I understand jitting amplitude depends on airplane speed.

The problem was solved by mowing the line 
globals-get_viewmgr()-update(delta_time_sec);
upwards after the line
fgUpdateTimeDepCalcs();

But I'm not sure that this is a good solution.

With respect,
Alex

-
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse012070mrt/direct/01/
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel


[Flightgear-devel] BUG when replay with generic protocol

2008-02-09 Thread Alex Buzin
I have write the flight to the file using generic protocol (with 
playback.xml). When replaying flight in Cockpit View all is fine, but when I 
switch to Chase View picture starts to jitter.
I got this at Flightgear-1.0.0 at v0.9.10 this effect is not present.
I build FG from sources at Windows, is someone have the same feature at 
other systems. And how this can be fixed?

With respect,
Alex 


-
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse012070mrt/direct/01/
___
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel