[Flightgear-devel] BUG when replay with generic protocol

2008-02-09 Thread Alex Buzin
I have write the flight to the file using generic protocol (with playback.xml). When replaying flight in Cockpit View all is fine, but when I switch to Chase View picture starts to jitter. I got this at Flightgear-1.0.0 at v0.9.10 this effect is not present. I build FG from sources at Windows,

Re: [Flightgear-devel] BUG when replay with generic protocol

2008-02-22 Thread Alex Buzin
On Thursday 21 February 2008 Melchior FRANZ wrote If anyone could tell me which command line exactly was used to record, and which to replay then I'd check this out. I got it when flying UFO and recording flight with --generic=file,out,100,flight.dat,playback FDM was running at 100Hz.

Re: [Flightgear-devel] LANDING SIMULINK

2008-03-10 Thread Alex Buzin
Hi! On Sun, Mar 9, 2008 José Ignacio Cogolludo Galán wrote: I am trying to do a simulation of the flight of an aircfraft in Simulink to visualize in FlightGear. My model flights correctly, but when it is on the ground, the model can't stay here. I mean, my aircraft doesn't recognize the

Re: [Flightgear-devel] Flash with altitude change

2008-04-20 Thread Alex Buzin
Hi! On Saturday 19 April 2008 Curtis Olson wrote: Would it be possible to introduce a bit of smoothing on your end, so that the aircraft position updates are more smooth and continuous? If nothing else it would be interesting to see if this fixes your problem, and also to see how much

Re: [Flightgear-devel] Controlling FlightGear FDM through generic inputwith UDP

2008-04-20 Thread Alex Buzin
Hi! On Friday, April 18, 2008 Haluk Sevener wrote: How can I run the master-slave model with generic i/o interface? How can I control a FG instance with over network using generic interface with socket input option? (I failed doing this one. maybe my input format in the xml configuration is

Re: [Flightgear-devel] Controlling FlightGear FDM through genericinputwith UDP

2008-04-21 Thread Alex Buzin
Hi! On Sunday, April 20, 2008 Haluk Sevener wrote: All I want to do is just send the commands to a FlightGear instance over network with UDP, at the same time listening the properties of the aircraft over network by using the same protocol. In other words, I want to implement an external

Re: [Flightgear-devel] Flash with altitude change

2008-04-26 Thread Alex Buzin
Hi! On Friday, April 25, 2008 Melchior FRANZ wrote * Adam Dershowitz -- Thursday 24 April 2008: I spent a while trying to track this down, and finally figured out what is going on. The problem is that generic.cxx can only handle floats, and that is not enough resolution for latitude and

Re: [Flightgear-devel] Flash with altitude change

2008-04-26 Thread Alex Buzin
Hi! On Saturday, April 26, 2008 Adam Dershowitz wrote Then your extension must be handling the input differently. When data is read in from a text file, using --generic it is not possible with the current code to read in a double. It is called an FG_DOUBLE in some places in the code, but it

[Flightgear-devel] Error in HUD

2008-08-24 Thread Alex Buzin
Hi, Some time ago I was in need to display altitude in meters on HUD. I have copied desired HUD to airplane folder and check it working. Then I change disp_scaling to 0.3048 and got strange altitude scale. As I understand we got foot scale with meter markers. After studying sources I desided

Re: [Flightgear-devel] Tarball of bleeding edge CVS snapshot

2008-12-05 Thread Alex Buzin
Fabian Grodek wrote: I'm using Tortoise. Can somebody tell me what should be the command line? Something like: :pserver:[EMAIL PROTECTED]:/var/cvs/FlightGear.. Thank you. Fabian Look at the http://www.flightgear.org/cvs/anoncvs.html

Re: [Flightgear-devel] Output communication problem

2008-12-19 Thread Alex Buzin
Hi! As I understand you want to get controls in Matlab from FG. But FG do not run any useable FDM and if you are trying to send data to Mathlab as FGNetFDM it can be zeros or loopback (data was sending from MathLab to FG). What protocol you are using for this connection? If data to FG is

Re: [Flightgear-devel] Translations

2008-12-20 Thread Alex Buzin
Hi! Does this translated strings is using anyware? I did not find references in source code for this strings. I was trying to change the file strings-default.xml , but did not see any differences in GUI. With respect, Alex

Re: [Flightgear-devel] Q: OpenGL version requirement for FlightGear 1.9.1

2009-02-06 Thread Alex Buzin
David L. Page wrote: Unfortunately, Chromium doesn't support OpenGL 2.0 or higher, right now. As I know FG 1.9.0 is using shaders to render trees and clouds. May be this is a problem. Try to find FG 1.0.0 or 0.9.10, it can be at the same FTP resource as 1.9.1. Alex

[Flightgear-devel] ufo.nas and divide by zero

2009-04-04 Thread Alex Buzin
Hi! I have got range exception when flying UFO. Looking in sources open that problem is in ufo.nas line 420: me.marker = Model.new(Aircraft/ufo/Models/marker.ac, geo.Coord.new().set_xyz(0, 0, 0)); When passing zeros to geo.Coord.set_xyz(), there is devide by zero in function

[Flightgear-devel] access violation in FGFontCache

2009-04-04 Thread Alex Buzin
Hi! In GUI style I put one font for and . This give access violation error. The problem is in FGFontCache destructor. Class FGFontCache contains two Maps : TexFontMap _texFonts and PuFontMap _puFonts. _texFonts contains fonts being read from the data/Fonts. PuFontMap contains fnt structure

Re: [Flightgear-devel] Weird Sun and weather bugs

2009-09-18 Thread Alex Buzin
Victhor Foster wrote: I don't remember when this started, I think it was a week or so. Well, the Sun bug is simple: switching time to Dawn/Dusk will cause the sun colors to start flashing between the correct colors and morning/noon/ afternoon colors. The weather bug is: after about 1

Re: [Flightgear-devel] Weird Sun and weather bugs

2009-09-22 Thread Alex Buzin
Erik Hofman wrote: It's way more extreme than that, the dewpoint once in a while seems to reset to -2.8308 from it's current value causing the humidity to jump way beyond 100% (I've seen 1200%). I could limit the humidity to 100% but that only hides the problem. I did not find why the

Re: [Flightgear-devel] Weird Sun and weather bugs

2009-09-22 Thread Alex Buzin
Here it is!! At procedure void FGEnvironment::set_elevation_ft (double e) change : _recalc_alt_dewpoint(); _recalc_alt_pt(); to : _recalc_alt_pt(); _recalc_alt_dewpoint(); It corrects all. With respect, Alex

Re: [Flightgear-devel] Is ther any MSVC example code to send/receive data to FG over an internet connection?

2009-09-25 Thread Alex Buzin
Randall Green wrote: I am testing a new Primary Flight Display with a tunnel in the sky. It will run on a separate computer and I need FlightGear for it's flight dynamics. I'ld like the PFD to receive Lat, lon, altitude, heading, pitch, roll, alpha and beta from FG and also I'ld like to tell

Re: [Flightgear-devel] New Sound system committed

2009-10-12 Thread Alex Buzin
Hi, I got an error with the Sunday CVS - FG crashed while exiting . gdb reports SIGSEGV error at file soundmgr_openal.cxx, line 159. Error was fixed by changing lines 157-159 from: buffer_map_iterator buffers_current = _buffers.begin(); buffer_map_iterator buffers_end =

Re: [Flightgear-devel] [PATCH] 3D Clouds update

2009-10-12 Thread Alex Buzin
Stuart Buchanan wrote: Scott Hamilton wrote: On Tue, 2009-10-06 at 22:06 -0400, William Harrison wrote: Maybe it's just me, but has anyone noticed a dramatic performance decrease with 3d clouds after this patch? yep, from 30fps to 2fps... I'm very surprised

[Flightgear-devel] FG crashes when changing visibility

2009-10-12 Thread Alex Buzin
Hi, I was noticed that FG hangs and than crashes if pressing z key. If visibility value is not controlled by user, it can be occasionally **increased to a huge value (1000 km). In this case TileLoader is trying to load hundreds of tiles. At the beginning I was expected a number of tiles to be

[Flightgear-devel] Missed file in CVS

2010-01-12 Thread Alex Buzin
Hi! The file KLN89/kln89.cxx rev. 1.18 contains the next lines #if ENABLE_ATCDCL #include ATCDCL/ATCProjection.hxx #else #include kln89_align.hxx #endif But the file kln89_align.hxx is absent and with ENABLE_ATCDCL=FALSE it raises an error. **Can somebody fix this. With respect,

Re: [Flightgear-devel] multiple --generic record/playback errors

2010-02-11 Thread Alex Buzin
On Tue, Feb 9, 2010 at 1:37 PM, John Denker wrote: Has anybody used the --generic record/playback feature recently? The same trouble was discussed at 2008 : http://www.mail-archive.com/flightgear-devel@lists.sourceforge.net/msg16539.html and