Re: cvs commit: xml-fop/src/java/org/apache/fop/layoutmgrKnuthElement.java KnuthBox.java KnuthGlue.java KnuthPenalty.java

2004-12-07 Thread Luca Furini
Glen Mazza wrote:

 Luca, I think we should be using getWidth() instead of
 getW(), correct?

Yes, it would be much clearer!
I'm going to rename:
  getW() - getWidth()
  getY() - getStretch()
  getZ() - getShrink()
  getP() - getPenaltyValue()

The last name is quite long: I first thought of getPenalty() or
getValue(), but they seemed less clear to me.

Regards
Luca





Re: cvs commit: xml-fop/src/java/org/apache/fop/layoutmgrKnuthElement.java KnuthBox.java KnuthGlue.java KnuthPenalty.java

2004-12-07 Thread Glen Mazza
Sounds good.

--- Luca Furini [EMAIL PROTECTED] wrote:

 Glen Mazza wrote:
 
  Luca, I think we should be using getWidth()
 instead of
  getW(), correct?
 
 Yes, it would be much clearer!
 I'm going to rename:
   getW() - getWidth()
   getY() - getStretch()
   getZ() - getShrink()
   getP() - getPenaltyValue()
 
 The last name is quite long: I first thought of
 getPenalty() or
 getValue(), but they seemed less clear to me.
 
 Regards
 Luca