Re: [jira] [Commented] (FOP-2741) Exclamatory (!) symbol not being rendered properly in AFP

2017-09-28 Thread vghegadi
Thanks Christopher, Chris and Glen for your inputs. Chris, {code:java} {code} gives me U and not !. What should be my alternative solution for this? -- Sent from: http://apache-fop.1065347.n5.nabble.com/FOP-Dev-f18203.html

Re: [jira] [Commented] (FOP-2741) Exclamatory (!) symbol not being rendered properly in AFP

2017-09-28 Thread vghegadi
gave me ! mark -- Sent from: http://apache-fop.1065347.n5.nabble.com/FOP-Dev-f18203.html

Re: [jira] [Commented] (FOP-2741) Exclamatory (!) symbol not being rendered properly in AFP

2017-09-28 Thread Chris
I understand the point you are making. This is open source so patches that improve the status quo are welcome. :-) But as I already mentioned I don't know of a practical way to meet the requirement. Thanks, Chris On 27/09/2017 17:45, Christopher R. Maden wrote: > On 09/27/2017 09:44 AM, Chris

Re: [jira] [Commented] (FOP-2741) Exclamatory (!) symbol not being rendered properly in AFP

2017-09-27 Thread Christopher R. Maden
On 09/27/2017 09:44 AM, Chris wrote: I'm finding your tone pretty aggressive, but will attempt to answer despite that... Since Fonts vendors can build the codepages anyway they choose, we cannot simply build a static map that takes Unicode and maps to any custom codepage. Thus the user must

Re: [jira] [Commented] (FOP-2741) Exclamatory (!) symbol not being rendered properly in AFP

2017-09-27 Thread Chris
I'm finding your tone pretty aggressive, but will attempt to answer despite that... Since Fonts vendors can build the codepages anyway they choose, we cannot simply build a static map that takes Unicode and maps to any custom codepage. Thus the user must specify non standard code points or

Re: [jira] [Commented] (FOP-2741) Exclamatory (!) symbol not being rendered properly in AFP

2017-09-26 Thread Christopher R. Maden
On 09/26/2017 11:08 AM, Chris Bowditch (JIRA) wrote: [ https://issues.apache.org/jira/browse/FOP-2741?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16180912#comment-16180912 ] Chris Bowditch commented on FOP-2741: - The

[jira] [Commented] (FOP-2741) Exclamatory (!) symbol not being rendered properly in AFP

2017-09-26 Thread Chris Bowditch (JIRA)
[ https://issues.apache.org/jira/browse/FOP-2741?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16180956#comment-16180956 ] Chris Bowditch commented on FOP-2741: - Well that's the problem the x is required before 55 to represent

[jira] [Commented] (FOP-2741) Exclamatory (!) symbol not being rendered properly in AFP

2017-09-26 Thread Vikas (JIRA)
[ https://issues.apache.org/jira/browse/FOP-2741?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16180937#comment-16180937 ] Vikas commented on FOP-2741: i meant - > Exclamatory (!) symbol not being rendered properly in AFP >

[jira] [Commented] (FOP-2741) Exclamatory (!) symbol not being rendered properly in AFP

2017-09-26 Thread Vikas (JIRA)
[ https://issues.apache.org/jira/browse/FOP-2741?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16180933#comment-16180933 ] Vikas commented on FOP-2741: Thanks Chris. I now have in my file. But, it puts U in afp. Am i missing

[jira] [Commented] (FOP-2741) Exclamatory (!) symbol not being rendered properly in AFP

2017-09-26 Thread Chris Bowditch (JIRA)
[ https://issues.apache.org/jira/browse/FOP-2741?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16180912#comment-16180912 ] Chris Bowditch commented on FOP-2741: - The solution is to insert code point x55 into the XSL-FO, e.g.

[jira] [Commented] (FOP-2741) Exclamatory (!) symbol not being rendered properly in AFP

2017-09-26 Thread Vikas (JIRA)
[ https://issues.apache.org/jira/browse/FOP-2741?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16180900#comment-16180900 ] Vikas commented on FOP-2741: Chris, thanks for the response. I will try in FOP-user mailing list going forward.

[jira] [Commented] (FOP-2741) Exclamatory (!) symbol not being rendered properly in AFP

2017-09-26 Thread Chris Bowditch (JIRA)
[ https://issues.apache.org/jira/browse/FOP-2741?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16180870#comment-16180870 ] Chris Bowditch commented on FOP-2741: - JIRA seems to be encoding what I put above. You need to put