Re: Release planning

2007-11-13 Thread Jeremias Maerki
Hmm, probably:
- Make a branch
- Restore Java 1.3 compatibility
- Tag the branch
- Release vote

Frankly, I'm not very keen on the second step. I have more pressing
matters than to be able to help here at the moment. Sorry. Do you really
need Java 1.3 compatibility for the PDF transcoder? I mean you could
release without it and we publish the PDF transcoder as a separate
artifact on the next FOP release. The problem with current FOP Trunk is
that I don't believe it's stable enough to be released right now. But
maybe I'm just too careful...

On 13.11.2007 11:48:01 Cameron McCormack wrote:
snip/
 FOP guys, what’s needed to get a pdf-transcoder that runs under Java
 1.3 yet has that new PDF text support?
snip/

Jeremias Maerki


Re: Release planning

2007-11-13 Thread Vincent Hennebert
Hi,

Jeremias Maerki wrote:
 Hmm, probably:
 - Make a branch
 - Restore Java 1.3 compatibility
 - Tag the branch
 - Release vote
 
 Frankly, I'm not very keen on the second step. I have more pressing
 matters than to be able to help here at the moment. Sorry. Do you really
 need Java 1.3 compatibility for the PDF transcoder? I mean you could
 release without it and we publish the PDF transcoder as a separate
 artifact on the next FOP release. The problem with current FOP Trunk is
 that I don't believe it's stable enough to be released right now. But
 maybe I'm just too careful...

No, I second that. I would also wait a bit before making a new 
release...
And would it be possible to release just the PDF transcoder?

Vincent


Re: Release planning

2007-11-13 Thread Cameron McCormack
Jeremias Maerki:
 Hmm, probably:
 - Make a branch
 - Restore Java 1.3 compatibility
 - Tag the branch
 - Release vote
 
 Frankly, I'm not very keen on the second step. I have more pressing
 matters than to be able to help here at the moment. Sorry. Do you really
 need Java 1.3 compatibility for the PDF transcoder? I mean you could
 release without it and we publish the PDF transcoder as a separate
 artifact on the next FOP release. The problem with current FOP Trunk is
 that I don't believe it's stable enough to be released right now. But
 maybe I'm just too careful...

Fair enough, I can live without the bleeding edge pdf-transcoder in the
1.7 release.  (I may make my nightly build scripts pull SVN FOP too, so
that the latest pdf-transcoder can be included.)

-- 
Cameron McCormack, http://mcc.id.au/
xmpp:[EMAIL PROTECTED]  ▪  ICQ 26955922  ▪  MSN [EMAIL PROTECTED]


Re: Release planning

2007-11-13 Thread Cameron McCormack
Hervé Girod:
 I had a crash on my laptop hardrive, but I was able to restore it (it 
 seemed to be some Windows stuff after all, and not a really hard crash, 
 but still I had to reformat and make a full reinstall of Windows, Java, 
 Netbeans, etc..)... Can you give me until the end of the Week-end before 
 making the release ? I just need to look at bug #43595 (maybe incomplete 
 fix for bug 42961), and check a last time that all is with some 
 standard WMF files to be sure that nothing is broken in that area 
 before 1.7.

Sure thing.

-- 
Cameron McCormack, http://mcc.id.au/
xmpp:[EMAIL PROTECTED]  ▪  ICQ 26955922  ▪  MSN [EMAIL PROTECTED]


Re: Release planning

2007-11-13 Thread Jeremias Maerki
From my point of view, yes, absolutely. One could be a nitpicker and say
that the binary didn't include the transcoder and it's not part of the
release but I wouldn't go that far. The important thing is that the
whole thing is done off properly released sources which don't have any
legal issues and such. And that's, I think, the intention of the rule
that we must only ship released third-parties.

Jeremias Maerki



On 14.11.2007 00:43:16 Cameron McCormack wrote:
 Jeremias Maerki:
  Hmm, probably:
  - Make a branch
  - Restore Java 1.3 compatibility
  - Tag the branch
  - Release vote
 
 Oh, and procedurally is it OK for me to download the FOP 0.94 sources,
 build the pdf-transcoder.jar and commit that to Batik’s repository, or
 does there need to be a proper release of the pdf-transcoder.jar from
 FOP’s side?
 
 -- 
 Cameron McCormack, http://mcc.id.au/
   xmpp:[EMAIL PROTECTED]  ▪  ICQ 26955922  ▪  MSN [EMAIL PROTECTED]