Re: Strange irregularities in page breaking

2002-12-08 Thread Oleg Tkachenko
Matthias Brunner wrote: I have set up a test case (http://blumenstrasse.vol.at/~mb/foptest.zip, 15KB) with all necessary files included. Just copy all of them into a clean FOP 0.20.4 directory. Then issue these commands: ./fop.sh -xml lpdoc.xml -xsl lp2pdf.xsl -pdf cli.pdf ./embedtest.sh

Re: Strange irregularities in page breaking

2002-12-06 Thread Matthias Brunner
On Wednesday 04 December 2002 15:12, Matthias Brunner wrote: On Wednesday 04 December 2002 13:12, Oleg Tkachenko wrote: Okay, next attempt: show us how are you running FOP from the command line and from an embedding. I have set up a test case (http://blumenstrasse.vol.at/~mb/foptest.zip,

Re: Strange irregularities in page breaking

2002-12-04 Thread Oleg Tkachenko
Matthias Brunner wrote: I copied fop.sh and changed only one line to start my class which I copied to FOP_HOME/lib. So I think every setting and the classpath will be the same. Yet output remains different. I don't understand. Software used: fop 0.20.4, JDK 1.4.1_01, Linux Okay, next attempt:

Re: Strange irregularities in page breaking

2002-12-04 Thread Matthias Brunner
On Wednesday 04 December 2002 13:12, Oleg Tkachenko wrote: Okay, next attempt: show us how are you running FOP from the command line and from an embedding. Oleg, thanks for your commitment. I have set up a test case (http://blumenstrasse.vol.at/~mb/foptest.zip, 15KB) with all necessary

Re: Strange irregularities in page breaking

2002-12-03 Thread Oleg Tkachenko
Matthias Brunner wrote: I have encountered the following problem: Input files and stylesheets are *exactly* the same. 73 pages are rendered regardless of whether calling from code/command line. (Tried with both PDF and XML renderer) But on page 63 and subsequent fop called from java code breaks

Re: Strange irregularities in page breaking

2002-12-03 Thread Matthias Brunner
On Tuesday 03 December 2002 20:11, Oleg Tkachenko wrote: And fop -x ... did not even work! Did you mean -c? No, -x for dump all configuration settings. Why are these differences? Make sure you are embedding FOP in the same way you are running it from command line (I mean the same