Re: International Fonts - Problem with print

2005-11-21 Thread Sai N
I tried something the other day and it worked... I removed the tags representing italic and bold..

font metrics-file=C:\projects\fop-0.20.5\fonts\arialuni.xml kerning=yes embed-file=C:\WINNT\Fonts\arialuni.ttf font-triplet name=arialuni style=normal weight=normal/
 /font font metrics-file=C:\projects\fop-0.20.5\fonts\batang.xml kerning=yes embed-file=C:\WINNT\Fonts\batang.ttf font-triplet name=batang style=normal weight=normal/
 /font
But now I am unable tosee bold and italic in my rendered documents.. I guess I have to figure out if there is a different file for italic and bold part of these fonts ?

To you point.. I am using JDK 1.4.2,and I have tried using 1.5 also... in both cases it gives me the same outcome..

Thanks,
Sai

On 11/21/05, Chris Bowditch [EMAIL PROTECTED] wrote:
Sai N wrote: Hello, I am trying to use FOP to print certain documents (in FO) written in
 some International Languages (Japaneese, Korean, Chinese etc). For some reason the characters are printed at an angle, it looks like everything is in italic. Even the english characters in the document behave in the
 same way. If I try to create the PDF from the same FO, it works fine and looks great. I have tried using different fonts (Arial Unicode, MS Mincho, Batang) and this happens with everything
The PrintRenderer uses Java AWT Fonts, so the problem is likely causedby your JDK. What JDK version and OS are you running on?Chris-
To unsubscribe, e-mail: [EMAIL PROTECTED]For additional commands, e-mail: 
[EMAIL PROTECTED]


International Fonts - Problem with print

2005-11-18 Thread Sai N
Hello,

I am trying to use FOP to print certain documents (in FO)written in some International Languages (Japaneese, Korean, Chinese etc). For some reason the characters are printed at an angle, it looks likeeverything is initalic. Even the english characters in the document behave in the same way. If I try to create the PDF from the same FO, it works fine and looks great. I have tried using different fonts (Arial Unicode, MS Mincho, Batang) and this happens with everything. 


This is how I registered my Fonts with FOP

font metrics-file=C:\javalib\fop-0.20.5\fonts\msmincho.xml  embed-file=C:\WINNT\Fonts\msmincho.ttf kerning=yes font-triplet name=Mincho style=normal weight=normal/
 font-triplet name=Mincho style=normal weight=bold/ font-triplet name=Mincho style=italic weight=normal/ font-triplet name=Mincho style=italic weight=bold/
 /font
 font metrics-file=C:\javalib\fop-0.20.5\fonts\batang.xml kerning=yes embed-file=C:\WINNT\Fonts\batang.ttf font-triplet name=batang style=normal weight=normal/
 font-triplet name=batang style=normal weight=bold/ font-triplet name=batang style=normal weight=bolder/ font-triplet name=batang style=italic weight=normal/
 font-triplet name=batang style=italic weight=bold/ font-triplet name=batang style=italic weight=bolder/ /font
 font metrics-file=C:\javalib\fop-0.20.5\fonts\arialuni.xml kerning=yes embed-file=C:\WINNT\Fonts\arialuni.ttf font-triplet name=arialuni style=normal weight=normal/
 font-triplet name=arialuni style=normal weight=bold/ font-triplet name=arialuni style=normal weight=bolder/ font-triplet name=arialuni style=italic weight=normal/
 font-triplet name=arialuni style=italic weight=bold/ font-triplet name=arialuni style=italic weight=bolder/ /font


Has any one experienced this, any solution ??? 

Thanks,
Sai