Re: Headless exception with fop 1.1rc1

2012-08-12 Thread Mike DiChiappari
'. You can file a bug on the AWT problem at [1] [1] https://issues.apache.org/bugzilla/enter_bug.cgi?product=Fop make sure to include information on your execution environment and full console output from the command invocation On Fri, Aug 10, 2012 at 10:56 AM, Mike DiChiappari mdichiapp

Headless exception with fop 1.1rc1

2012-08-10 Thread Mike DiChiappari
I'm a newbie who just downloaded fop 1.1.rc1. I didn't get very far before getting a Headless exception (see below). Note I'm using JDK 1.6 and tried this on Windows XP and Window 7. Note that the problem doesn't occur with fop 0.93. I was following the Getting Started instructions, which

[no subject]

2012-02-02 Thread Mike Ferrando
http://schnorchel61.sc.funpic.de/dji/481353.html - To unsubscribe, e-mail: fop-users-unsubscr...@xmlgraphics.apache.org For additional commands, e-mail: fop-users-h...@xmlgraphics.apache.org

Re: Problem with fo:external-graphic element in processing output from either Saxon or Xalan

2011-10-07 Thread Mike Chambers
obtained via a Ubuntu repository package. Many Thanks, Mike - To unsubscribe, e-mail: fop-users-unsubscr...@xmlgraphics.apache.org For additional commands, e-mail: fop-users-h...@xmlgraphics.apache.org

Re: Problem with fo:external-graphic element in processing output from either Saxon or Xalan

2011-10-07 Thread Mike Chambers
Hi Mehdi, Thanks for pointing me in the right direction re: XSLT queries ; apologies for mis-posting - it's been a busy week getting up to speed with a whole host of new acronyms, concepts, and complex software packages. Best Regards, Mike

Problem with fo:external-graphic element in processing output from either Saxon or Xalan

2011-10-06 Thread Mike Chambers
Hi, I am getting this runtime error: org.apache.fop.fo.ValidationException: file:/home/mike/source/docbook/sample_doc2_xalan.fo:1:66363: Error(1/66363): fo:external-graphic is not a valid child element of fo:flow. after I added imagedata fileref=Screenshot1.png/ to a very simple DocBook XML

Re: Extended characters not rendered using FOP 1.0

2011-09-20 Thread mike 675
There have been a lot of changes between 0.20.5 and 1.0, although Unicode characters should be displayed properly, provided FOP can find a font containing a glyph for the character. Did you get an error or warning message? What does not rendered mean precisely: is there a blank instead of the

Extended characters not rendered using FOP 1.0

2011-09-19 Thread mike 675
Using FOP 0.25, the rarr; (Unicode 2192) symbol was rendered OK in PDF. After moving to FOP 1.0, the right arrow symbol is not rendered. This is my XSL param: xsl:param name=body.font.familyHelvetica/xsl:param Has the way FOP handles extended characters changed since 0.20.5? -- View this

Re: fox: extensions, XSL parameters for

2011-09-13 Thread mike 675
.extensions.html [2] http://www.docbook.org/guidelines Le 12/09/2011 12:30, mike 675 a écrit : Using FOP 1.0. How can I access the following FOP extension through the XSL stylesheets? fox:orphan-content-limit I have enabled FOP 1 extensions as follows: xsl:param name=fop1.extensions

fox: extensions, XSL parameters for

2011-09-12 Thread mike 675
Using FOP 1.0. How can I access the following FOP extension through the XSL stylesheets? fox:orphan-content-limit I have enabled FOP 1 extensions as follows: xsl:param name=fop1.extensions select=1/ Is there an equivalent parameter that enables the fox:orphan-content-limit extension? --

Page breaks for program listings

2011-08-19 Thread mike 675
Using FOP 1.0. Docbook XML - FO - PDF. Some of the page breaks for my programlistings look bad. They leave a single orphan line at the bottom of the page. I have tried the following FO processing instructions for the relevant blocks, but they have no effect. ?dbfo keep-together=always ? (is

Re: FOP 1.0 Japanese # marks

2011-08-17 Thread mike 675
/ or directory to tell FOP where my fonts are? mike 675 wrote: Like this, maybe? xsl:param name=body.font.familySazanami/xsl:param mehdi houshmand wrote: Hi Mike, In the FO you are using Helvetica,Symbol,ZapfDingbats not Sazanami, you have to set the font name with the font-family

Re: FOP 1.0 Japanese # marks

2011-08-17 Thread mike 675
OK, I've solved this. It turns out that the new FOP 1.0 config parameters auto-detect/ and directory have no effect! I used an embed-url statement instead and FOP was able to use the Japanese font. mike 675 wrote: I used to use FOP 0.20.5 to build Japanese PDFs and they looked fine. Now

Open Source alternatives to Arial Unicode

2011-08-17 Thread mike 675
I'm using Red Hat Linux 5.5. What are the best open source font alternatives to MS Arial Unicode for Japanese and Chinese (ZH-CN) PDF output? I have Japanese and Chinese font packs installed. The following fonts are Japanese, I think: Sazanami Mincho Sazanami Gothic These fonts are Chinese, I

RE: FOP 1.0 Japanese # marks

2011-08-15 Thread mike 675
should be. Eric Douglas wrote: You don't supply metrics in 1.0. -Original Message- From: mike 675 [mailto:m_mcl...@yahoo.co.uk] Sent: Friday, August 12, 2011 11:35 AM To: fop-users@xmlgraphics.apache.org Subject: RE: FOP 1.0 Japanese # marks I see the config file format

Re: FOP 1.0 Japanese # marks

2011-08-15 Thread mike 675
Like this, maybe? xsl:param name=body.font.familySazanami/xsl:param mehdi houshmand wrote: Hi Mike, In the FO you are using Helvetica,Symbol,ZapfDingbats not Sazanami, you have to set the font name with the font-family attribute. Hope that helps Mehdi On 15 August 2011 10:37

FOP 1.0 font cache: how long are fonts cached for?

2011-08-15 Thread mike 675
The FOP docs say that the fop font cache is on by default. How long are fonts cached for. What if I have a setting of auto-detect/ to detect *all* fonts on my system. Then I change my fop config file to just use my own fonts: fonts directory/home/jdoe/temp/directory /fonts Are the system wide

Re: FOP 1.0 Japanese # marks

2011-08-12 Thread mike 675
My process is: DocBook XML to FO using xsltproc and XSL stylesheets. FO to PDF using fop-1.0 Japanese language pack is installed on RH5.5. Japanese XML is UTF-8 and displays fine in Oxygen XML editor and in Gedit. Rob Sargent-4 wrote: What's your process? On 08/11/2011 01:48 PM, mike 675

RE: FOP 1.0 Japanese # marks

2011-08-12 Thread mike 675
@xmlgraphics.apache.org Subject: Re: FOP 1.0 Japanese # marks Do you mean configure FOP 1.0 to use a Japanese font? Or is there an XSL stylesheet option to do this? Or do I manually edit the .fo file. Thanks, Mike --- On Fri, 12/8/11, Sergiu Dumitriu ser...@xwiki.com wrote: From: Sergiu Dumitriu ser

RE: FOP 1.0 Japanese # marks

2011-08-12 Thread mike 675
I see the config file format has changed from 0.20.5. 0.20.5 config file used these params: embed-file metrics-file 1.0 config file uses these params: embed-url metrics-url Am I on to something? mike 675 wrote: It's the default fop.xconf file. I haven't made any changes or specified any

RE: FOP 1.0 Japanese # marks

2011-08-12 Thread mike 675
=ArialMT style=normal weight=bold/ Eric Douglas wrote: You don't supply metrics in 1.0. -Original Message- From: mike 675 [mailto:m_mcl...@yahoo.co.uk] Sent: Friday, August 12, 2011 11:35 AM To: fop-users@xmlgraphics.apache.org Subject: RE: FOP 1.0 Japanese # marks

RE: FOP 1.0 Japanese # marks

2011-08-12 Thread mike 675
I seem to have lost some markup somewhere. But the default fop.xconf has font metrics-url entries mike 675 wrote: The default config file has an example that includes metrics... font-triplet name=Arial style=normal weight=normal/ font-triplet name=ArialMT style

FOP 1.0 Japanese # marks

2011-08-11 Thread mike 675
I used to use FOP 0.20.5 to build Japanese PDFs and they looked fine. Now after upgrading to FOP 1.0 the PDF build completes with no errors. But the PDF file is full of # marks. I am running on Red Hat 5.5. -- View this message in context:

Re: Complicated front page layouts: use tables?

2011-08-05 Thread mike 675
Rob Sargent-4 wrote: two-column page layout with full-page-length sized blocks might do the trick. Thanks. How do I select a non-standard front page layout like this? I am working using the titlepage.template.xml file to generate the fop markup for my front page. -- View this message

Re: Complicated front page layouts: use tables?

2011-08-05 Thread mike 675
Thanks. I need to work out how to edit my template file to get your fo: stylesheet markup. Rob Sargent-4 wrote: bottom-posted On 08/05/2011 08:53 AM, mike 675 wrote: Rob Sargent-4 wrote: two-column page layout with full-page-length sized blocks might do the trick. Thanks. How do I

Re: ExampleXML2PDF.java ERROR

2011-05-11 Thread Mike Ferrando
Dinuka, Let me know if you don't get a response. I can send you some files that will work. Sincerely, Mike Ferrando Washington, DC From: dinuka dayarathna dinukaonl...@gmail.com To: fop-users@xmlgraphics.apache.org Sent: Wed, May 11, 2011 2:06:44 PM Subject

Re: example mathml.fo xml and xsl

2011-01-27 Thread mike anderl
yes, i use fop with jeuclid. it works with the mathml.fo example from jeuclid. so fo-pdf with fop+jeuclid works. but xml+xsl - pdf doesnt work. so i hoped someone can post a working xml(with mathml)+xsl example. thx for the help mike Jeremias Maerki-2 wrote: Are you using an older version

Re: FOP Exception

2009-04-10 Thread Mike . Miller
xalan-2.7.0.jar xerceslmpl-2.7.1.jar xml-apis-1.3.04.jar xml-apis-ext-1.2.04.jar Am I missing something? M.M. = Hi Mike On 09.04.2009 18:40:16 Mike.Miller wrote: I've run into the following error in my attempt to implement the FOP package in a Lotus Domino application

Fw: FOP Exception

2009-04-09 Thread Mike . Miller
I've run into the following error in my attempt to implement the FOP package in a Lotus Domino application: java.lang.UnsupportedOperationException: Don't know how to handle application/pdf as an output format. Neither an FOEventHandler, nor a Renderer could be found for this output format. at

Re: Suggested Additions to FOP code

2008-08-21 Thread Mike Ferrando
Jeremias, I had tried this page and got the same result. Adobe Subject was blank. This is why I suggested the code change. Thanks, -Mike - Original Message From: Jeremias Maerki [EMAIL PROTECTED] To: fop-users@xmlgraphics.apache.org Sent: Thursday, August 21, 2008 8:25:53 AM

Suggested Additions to FOP code

2008-08-20 Thread Mike Ferrando
()); I was able to get dc:description in my XMP metadata as a result of this simple change. Sincerely, Mike Ferrando Washington, DC - To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL

Re: config file embedding issues

2008-08-19 Thread Mike Ferrando
Friends, Wow, this is really awesome! I was totally successful creating the PDF. I embedded only the fonts I wanted, etc. Thanks so much! -Mike - Original Message From: Pascal Sancho [EMAIL PROTECTED] To: fop-users@xmlgraphics.apache.org Sent: Tuesday, August 19, 2008 4:43:55 AM

Re: config file embedding issues

2008-08-19 Thread Mike Ferrando
(like java) and then act accordingly. This has really helped. Thanks! -Mike - Original Message From: Chris Bowditch [EMAIL PROTECTED] To: fop-users@xmlgraphics.apache.org Sent: Tuesday, August 19, 2008 4:03:28 AM Subject: Re: config file embedding issues Mike Ferrando wrote: Hi Mike

Re: config file embedding issues

2008-08-18 Thread Mike Ferrando
Pascal, fo:page-sequence does not have a font-family or font-size attribute? Can you give me a code example? Thanks, -Mike - Original Message From: Pascal Sancho [EMAIL PROTECTED] To: fop-users@xmlgraphics.apache.org Sent: Monday, August 18, 2008 5:02:11 AM Subject: RE: config file

config file embedding issues

2008-08-15 Thread Mike Ferrando
Friends, I can't figure out what is wrong. I am trying to generate a PDF/A-1b using FOP 0.94. No matter how I write my userconfig file, I get an error message that Helvetica must be embedded. I include my useconfig below. I have added CODE 2000 into the fonts for testing purposes only. -Mike

Re: config file embedding issues (trace)

2008-08-15 Thread Mike Ferrando
Friends, I forgot to post the trace. [below] -Mike [java] [ERROR] FOP - Exception org.apache.fop.pdf.PDFConformanceException: For PDF/A-1b, all fonts, even the base 14 fonts, have to be embedded! Offending font: Helveticaorg.apache.fop.pdf.PDFConformanceException: For PDF/A-1b, all f

RE: TIFF generation using FOP .094

2008-05-23 Thread Mike Scott
I'm using fop from command line - can anyone tell me how to configure a tiff renderer for fop. I've been looking at tiffrenderer class but haven't found anything except calling from servlet (I'm using vb.net). Thanks Mike -Original Message- From: Mike Scott [mailto:[EMAIL PROTECTED

RE: TIFF generation using FOP .094

2008-05-21 Thread Mike Scott
Andre, Thanks for info. I'm using from command line but I get error: SEVERE: Exception org.apache.fop.apps.FOPException: Renderer has not been set! Is there somewhere I need to specify a renderer? Thanks Mike -Original Message- From: Andreas Delmelle [mailto:[EMAIL PROTECTED

Re: Keeping text together in two different table cells

2006-08-23 Thread Mike Ferrando
by a for-each somewhere in your stylesheet? Again, I think the problem is that you are getting too many table-cell elements in your table-row element. Hope this helps. Mike Ferrando Library Technician Library of Congress Washington, DC 202-707-4454 --- Jacqueline Radebaugh [EMAIL PROTECTED

Re: putting an svg element into an fo document

2006-02-20 Thread Mike Ferrando
that it may be more spec than a beginner will need or be able to use in practice. Mike Ferrando Library Technician Library of Congress Washington, DC 202-707-4454 --- Paul Tremblay [EMAIL PROTECTED] wrote: On Mon, Feb 20, 2006 at 12:43:06PM -0500, Tracey Zellmann wrote: Thanks. Your example

Problem with linefeed and whitespaces

2006-02-01 Thread Mike
Mike - To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]

Problem with spanned table cells and borders

2006-01-30 Thread Mike
! Regards Mike Simple sample-code with one table-row: fo:table table-layout=fixed fo:table-column column-width=30mm / fo:table-column column-width=30mm / fo:table-column column-width=30mm / fo:table-body fo:table-row height=10mm

Re: template parameters

2005-12-05 Thread Mike Trotman
select='elements' xsl:with-param name='v1' select='value of v1'/ /xsl:apply-templates ... xsl:template match='elements' xsl:param name='v1' select='/..'/ xsl:value-of select='$v1'/ /xsl:template Any help? Mike Johan wrote: Hi all... I'm having trouble getting parameter values into my

Re: fo:external-graphic limitation?

2005-11-29 Thread mike
Thank to all of you and sorry for not getting back earlier. It worked fine when changing $photo by {$photo}. Thanx again for your help. --mike - To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL

fo:external-graphic limitation?

2005-11-23 Thread mike
fo:external-graphic src=$logo_path/ /fo:block [...] I've checked the value of logo_path and it is correct. Maybe there's another way to do it ... Any idea? thanx, --mike

Re: XSL Question

2005-11-22 Thread Mike Ferrando
Glen M., Could you post some of your XML source document (maybe a bigger chunk). Could you then give us an example of what the output is supposed to look like if everything went perfectly? Thanks, Mike Ferrando Library Technician Library of Congress Washington, DC 202-707-4454 --- Glen Mazza

Re: XSL Question

2005-11-22 Thread Mike Ferrando
Glen M., Sorry. Mike Ferrando Library Technician Library of Congress Washington, DC 202-707-4454 --- Glen Mazza [EMAIL PROTECTED] wrote: Mike Ferrando wrote: Glen M., Could you post some of your XML source document (maybe a bigger chunk). I'm not the one who asked the question

Re: FOP font width for custom font (Arial)

2005-11-19 Thread Mike Trotman
There is one other thing to check for - that your printed PDF is not being 'scaled to fit', use draft quality etc. - because I forgot once and wasted a lot of time. Mike The Web Maestro wrote: On Nov 17, 2005, at 5:22 PM, Manuel Mall wrote I just did my own test and the results

Re: Large PDF - Performance

2005-11-11 Thread Mike Trotman
XSLT for your processor. Mike Danny wrote: Thank you all for the suggestions. Here is what I have done so far, maybe this could help others with projects that they are working on. I ran a 1000 TRANSACTION element version of the detrpt1.xml through two different XSLT processors, both from

Re: Relative URLs

2005-08-12 Thread Mike Trotman
' attribute on an element in the FO to define what should be taken as the base url for that element and child elements - but I haven't tried this with FOP - so don't know if it works / is supported. I too will be interested to see any helpful comments on this. Mike Sonja Löhr wrote: It's

Re: Problem when link has contentid

2005-07-22 Thread Mike Trotman
and then processing the FO file with FOP would identify which part of the process causes the problem. Mike Fabrizio Caldas wrote: Mike, You're right, my example link is no coherent with the one I use. This is a better example f the link I'm using: http://www.example.com/fop/test.jsp?pageType

Re: Document off by a line

2005-07-14 Thread Mike Trotman
in the vertical spacing calculations somewhere that generates an extra line. Mike Neil Guinto wrote: So, when you use pre-printed forms, do you mean that the multi-page documents are actually collections of forms (different pages but all the same layout)? Exactly. If the form itself is only

Re: Fonts in inline elements in a single block

2005-06-29 Thread Mike Trotman
Can someone refresh my memory? I have a vague recollection that FOP 0.20.5 's fo:inline lacked either background-color or text color support. But I can't find any reference to this anywhere now - and I think both of the above are required for Basic conformance for fo:inline. And - I have a PDF

Re: table-row and sub table-rows problem:SUCCESS! and one more.

2005-06-01 Thread Mike Trotman
immediately before (i.e. this is the 1st) so the IF would be something like xsl:if test='not(preceding-sibling::REPEAT[1])' fo:table-row ... ... and then the fo:table-cells for your titles /fo:table-row /xsl:if Also see below for where to insert this. Mike David Kim wrote: Mike, You are right! I

Re: How to force a page break between tables

2005-05-10 Thread Mike Trotman
). Mike Richard Mixon (qwest) wrote: Mike Trotman wrote: If you wrap you table inside fo:block break-before='page' ...Table ... /fo:block it should work as Jay said. I had tried that before, then I say you used single quote (should not matter, I know) so I said let's

Re: Rép. : SVG positionning problem

2005-05-03 Thread Mike Trotman
. Maybe FOP has some calculation (or cacheing?) of default viewBox size? Mike Willy Reinhardt wrote: The problem seems to be related to a difference of FOP processing between tag fo:instream-foreign-object and tag fo:external-graphic sr=.../ because if I include the svg by using external-graphics it work

Re: Basic help needed

2005-04-21 Thread Mike Trotman
then this sounds horribly inefficient - but I can't think of anything else where you could set the width based on the font used at that point in the document and still give you the normal flow benefits. Mike Ashley Martens wrote: I trying to convert a simple text document, with no line feeds

Re: FOP - external-graphic in absolutely positioned block container - increase the width and the image vanishes!

2005-04-20 Thread Mike Trotman
J.Pietschmann wrote: Roland Neilands wrote: I have also seen logos disappear when the logo itself was much bigger than the block-container and it spat the dummy rather than scale the image down. I think that was only on certain image types (jpg?). IIRC the image scaling code uses the available

Re: LINKS

2005-04-20 Thread Mike Trotman
And a simple example: fo:basic-link color='teal' external-destination='url(http://www.google.com)' Google /fo:basic-link Matthias Wessendorf wrote: Hi, I have currently no idea howto create a *external* hyperlink with XSL-FO In my document I'd like to see something similar to this: a

Re: FOP - external-graphic in absolutely positioned block container - increase the width and the image vanishes!

2005-04-20 Thread Mike Trotman
J.Pietschmann wrote: Mike Trotman wrote: From my recent experiments, using absolutely positioned block-containers, I think the image is scaled so that the width is the maximum width of the image but the height is not constrained (though uniformly scaled). I don't think so. Have a look

Re: FOP - -noannotations

2005-04-19 Thread Mike Trotman
. rotated pages. Mike Andreas L. Delmelle wrote: -Original Message- From: Andreas L. Delmelle [mailto:[EMAIL PROTECTED] snip / I'm also thinking... Currently FOP 0.20.5 produces PDF conforming to the 1.3 Specification (Acrobat 4.0) --maybe that version still lacks the necessary

Re: Generating table of contents using FO and FOP?

2005-04-19 Thread Mike J Boyersmith
Solution Technologies) Mike J Boyersmith [EMAIL PROTECTED] 04/19/2005 11:43 AM Please respond to fop-users@xmlgraphics.apache.org To fop-users@xmlgraphics.apache.org cc Subject Re: Generating table of contents using FO and FOP? Thought I'd share this with the list, I found another way to render

Re: FOP - -noannotations

2005-04-18 Thread Mike Trotman
of breaking it / changing the documents it provides or producing many new messages complaining about RC4 providers. Any further guidance would be welcome. Mike Andreas L. Delmelle wrote: -Original Message- From: Mike Trotman [mailto:[EMAIL PROTECTED] Hi, Does the binary version have PDF

Re: FOP - -noannotations

2005-04-18 Thread Mike Trotman
Thanks Patrick - this is invaluable advice! I have MANY bookmarks in all my documents - so I will put the encryption investigation on a lower priority (as I have lived without it for 4 years so far). Mike Talken, Patrick (AGRE) wrote: Hi Mike, I went through the same ordeal, and when I finally

Re: FOP - -noannotations

2005-04-18 Thread Mike Trotman
Thanks for looking at this Andreas Andreas L. Delmelle wrote: -Original Message- From: Mike Trotman [mailto:[EMAIL PROTECTED] Yes - I am opening these in Acrobat Reader 7.0. I know previous versions of Reader didn't allow adding comments. but I know version 7.0 allows adding comments

FOP - external-graphic in absolutely positioned block container.

2005-04-18 Thread Mike Trotman
as the 1st line. Does anyone have any clue as to why this is happening - or what I am doing wrong? Mike P.S. I've also encountered some non-intuitive positioning behaviour when using xsl-region-end or xsl-region-after. The origins for absolute position seem to be relative to the top LH corner