Re: [fossil-users] The backoffice. Was: strange delay and messages during `fossil (uv) sync'

2018-08-07 Thread Andy Bradford
Thus said Richard Hipp on Tue, 07 Aug 2018 11:02:03 -0400: > That would delay the second HTTP request coming over the SSH connection. When I suggested that, I didn't understand enough about the backoffice design---specifically that it was a long-running task. After reading the forum page you

Re: [fossil-users] The backoffice. Was: strange delay and messages during `fossil (uv) sync'

2018-08-07 Thread Richard Hipp
On 8/7/18, Andy Bradford wrote: > > Then I suggest that we simply make backoffice_run() smart enough to know > that it has already run once: That would delay the second HTTP request coming over the SSH connection. I have the post up now at:

Re: [fossil-users] The backoffice. Was: strange delay and messages during `fossil (uv) sync'

2018-08-07 Thread Andy Bradford
Thus said Richard Hipp on Tue, 07 Aug 2018 10:21:34 -0400: > yes, we do want backoffice to run for SSH transport. Then I suggest that we simply make backoffice_run() smart enough to know that it has already run once: For example, perhaps instead of a panic here, backoffice_run() should just

Re: [fossil-users] The backoffice. Was: strange delay and messages during `fossil (uv) sync'

2018-08-07 Thread joerg van den hoff
On 07.08.18 16:16 , Andy Bradford wrote: > Thus said joerg van den hoff on Tue, 07 Aug 2018 16:10:15 +0200: > >> why did I see the problem only when actually cloning from another >> machine, whereas a clone using ssh while being loggedin to the server >> machine still worked? in both

Re: [fossil-users] The backoffice. Was: strange delay and messages during `fossil (uv) sync'

2018-08-07 Thread Richard Hipp
On 8/7/18, Andy Bradford wrote: > Does it make sense to have backoffice_run() in the SSH transport? If > not, then your fix is apropos. yes, we do want backoffice to run for SSH transport. My "fix" is really a work-around, not a true fix. We need to devise a proper fix for this, but I

Re: [fossil-users] The backoffice. Was: strange delay and messages during `fossil (uv) sync'

2018-08-07 Thread Andy Bradford
Thus said joerg van den hoff on Tue, 07 Aug 2018 16:10:15 +0200: > why did I see the problem only when actually cloning from another > machine, whereas a clone using ssh while being loggedin to the server > machine still worked? in both cases the ssh communication should be > the same,

Re: [fossil-users] The backoffice. Was: strange delay and messages during `fossil (uv) sync'

2018-08-07 Thread joerg van den hoff
On 07.08.18 15:53 , Richard Hipp wrote: Please build the from the tip of the forum-v2 branch and let me know whether or not it is working for you. if the server machine is running that version, yes it does indeed. thanks a lot for looking into this issue ... I see from the checkin message

Re: [fossil-users] The backoffice. Was: strange delay and messages during `fossil (uv) sync'

2018-08-07 Thread Andy Bradford
Thus said Richard Hipp on Tue, 07 Aug 2018 09:53:35 -0400: > Please build the from the tip of the forum-v2 branch and let me know > whether or not it is working for you. I was just about to submit a similar fix but you beat me to it. The reason why this doesn't work the same as a

Re: [fossil-users] The backoffice. Was: strange delay and messages during `fossil (uv) sync'

2018-08-07 Thread Richard Hipp
Please build the from the tip of the forum-v2 branch and let me know whether or not it is working for you. On 8/7/18, joerg van den hoff wrote: > > > On 07.08.18 00:36, Richard Hipp wrote: > > On 8/6/18, joerg van den hoff wrote: > >> question: the observation that it seemingly is related

Re: [fossil-users] The backoffice. Was: strange delay and messages during `fossil (uv) sync'

2018-08-07 Thread joerg van den hoff
On 07.08.18 00:36, Richard Hipp wrote: > On 8/6/18, joerg van den hoff wrote: >> question: the observation that it seemingly is related specifically to >> repos holding uv files is unimportant/irrelevant? or does that have >> implications where to look? > > This is not much help in debugging.

Re: [fossil-users] The backoffice. Was: strange delay and messages during `fossil (uv) sync'

2018-08-06 Thread Richard Hipp
On 8/6/18, joerg van den hoff wrote: > this is a pure > CLI/ssh scenario. The ssh transport works by invoking the same HTTP processing engine as is used on a website, just on the far end of an ssh tunnel. It's all the same under the covers. That said, I do remember making some minor changes to

Re: [fossil-users] The backoffice. Was: strange delay and messages during `fossil (uv) sync'

2018-08-06 Thread joerg van den hoff
On 06.08.18 22:19, Richard Hipp wrote: > Here is the technical problem I am having difficulty with. My > currently solution is (probably) what is causing the delays and errors > you are seeing. Suggestions from you are any mailing list reader on > how to solve this problem are appreciated. I've