Latest kernel requires CD in drive to boot

2003-08-31 Thread Doug Barton
I've cvsup'ed and built world/kernel from the latest sources to this point, and on my desktop I have the problem that's been previously discussed about not being able to boot without a disc in the CD-RW that's on ata1-master. I've included an annotated verbose dmsesg below. I have the following

ATAng atacontrol issue

2003-08-31 Thread Andre Guibert de Bruet
As reported to sos@, with a little extra debugging at the bottom... --- I was playing with atacontrol reinit'ing all of the channels that are installed on my machine, when I accidentally tried to reinit channel '4', which clearly doesn't exist. Here's what showed up at the serial

Inappropriate ioctl for device (CDIOCREADAUDIO)

2003-08-31 Thread Peter Kostouros
Hi I am using cd2mp3 (which uses dagrab) to copy an audio file. Unfortunately I receive the following message: dagrab: read raw ioctl failed at lba 33 length 12: Inappropriate ioctl for device I hope the following snippet of code from dagrab might be useful: void cd_read_audio(int lba,int

Re: pcic device causes kernel build failure

2003-08-31 Thread M. Warner Losh
In message: [EMAIL PROTECTED] Doug Barton [EMAIL PROTECTED] writes: : I found my problem, when I got this new laptop two weeks ago I : UN-commented the pcic cardbus bridge just in case. This worked fine up : till 8/27, my last build on that machine. Starting last night, with that :

Re: sony vaio pcg-gr390

2003-08-31 Thread M. Warner Losh
In message: [EMAIL PROTECTED] Putinas [EMAIL PROTECTED] writes: : I rebooted my notebook to freebsd and was thinking how to save log file if : kernel doesn't boot ... and strange thing happened kernel booted up no hang. : ( after I rebooted 3 times more - hanging in same place like

Re: aac related panics

2003-08-31 Thread Chip Norkus
On Saturday 30 August 2003 04:06 pm, Peter Jeremy wrote: On Fri, Aug 29, 2003 at 10:54:10PM -0500, Chip Norkus wrote: My company is working on a new hosting infrastructure, and I'd like to use FreeBSD if possible, so any help at all would be greatly appreciated as we plan to use these

Re: need some debugging help

2003-08-31 Thread Kenneth D. Merry
On Sat, Aug 30, 2003 at 09:22:10 +0200, Poul-Henning Kamp wrote: In message [EMAIL PROTECTED], Kenneth D. Merry writes: I think I have everything setup correctly, but I keep getting panics inside the GEOM code with these patches. (Memory modified after free.) I don't know whether I've just

Re: nvidia.ko freezes system in -current

2003-08-31 Thread Hendrik Hasenbein
Andrew Atrens wrote: The nvidia probe code gets invoked for every pci device discovered on the bus. The can't-attach-memory-resource thing essentially means that the driver is trying to attach to a device that isn't a graphics card. Ok. That seems to be the cause for the death of fsck on boot,

5.1-REL won't buildworld - fresh cvsup

2003-08-31 Thread ODHIAMBO Washington
For the last 3 days, I have cvsupped and wouldn't ever succeed with `make buildworld`. What could the problem be? Below are snippets from the fail: Once I do, `make buildworld` I see the following at the top of the output: Running test variables PASS: Test variables detected no regression,

Re: /lib symlinks problem?

2003-08-31 Thread Ruslan Ermilov
On Sun, Aug 31, 2003 at 02:07:42PM +0200, Alexander Leidinger wrote: On Sat, 30 Aug 2003 21:56:53 +0300 Ruslan Ermilov [EMAIL PROTECTED] wrote: I think a workaround would be to use absolute symlinks (at least as an option). I might be missing an obvious, but I just don't see a

Re: panic: softdep_deallocate_dependencies: dangling deps

2003-08-31 Thread Christian Brueffer
--LwbuP8dfxhLLLUfV Content-Type: text/plain; charset=us-ascii Content-Disposition: inline Content-Transfer-Encoding: quoted-printable On Sun, Aug 31, 2003 at 05:28:10AM -0400, Jeff Roberson wrote: On Sun, 31 Aug 2003, Christian Brueffer wrote: =20 Hi, got a panic on my server tonight.

ATAng not detecting drives

2003-08-31 Thread Jan Srzednicki
Hello sir, I've just cvsupped the new -C source, and installed a new kernel. My CD-RW could not be detected: FreeBSD 5.1-CURRENT #7: Sun Aug 31 12:21:57 CEST 2003 [EMAIL PROTECTED]:/usr/obj/usr/src/sys/MOONDANCE Preloaded elf kernel /boot/kernel/kernel at 0xc0545000. Preloaded elf module

Re: more hints

2003-08-31 Thread Kenneth Culver
If I remove device pmtimer from my config, I get a consistent panic, or variation of: Fatal trap 12: page fault while in kernel mode fault virtual address = 0x0 fault code = supervisor read, page not present instruction pointer = 0x8:0xc0135b0a7 stack pointer =

Re: su in free(): warning: chunk is already free

2003-08-31 Thread Christoph P. Kukulies
On Sun, Aug 31, 2003 at 07:24:32PM +1000, Tim Robbins wrote: On Sat, Aug 30, 2003 at 06:38:02PM +0200, Christoph Kukulies wrote: On my 5.1-current I logged in from outside and tried su getting: $ su su in free(): warning: chunk is already free su: pam_start: system error I'm

Re: fxp0: device timeout in -current from 31.8.

2003-08-31 Thread Bernd Walter
On Sun, Aug 31, 2003 at 01:55:49PM +0200, Andreas Klemm wrote: I tried to install FreeBSD 5.1-current from 30.07. and 31.08 on my wifes machine. Unluckily I experience problems with the fxp driver. On google I found a similar report from June 3rd.

panic: softdep_deallocate_dependencies: dangling deps

2003-08-31 Thread Christian Brueffer
--D9sZ58tf58331Q5M Content-Type: text/plain; charset=us-ascii Content-Disposition: inline Content-Transfer-Encoding: quoted-printable Hi, got a panic on my server tonight. Coredump available for further debuggung. FreeBSD haakonia.hitnet.rwth-aachen.de 5.1-CURRENT FreeBSD 5.1-CURRENT #6: =

Re: /lib symlinks problem?

2003-08-31 Thread Alexander Leidinger
On Sat, 30 Aug 2003 21:56:53 +0300 Ruslan Ermilov [EMAIL PROTECTED] wrote: I think a workaround would be to use absolute symlinks (at least as an option). I might be missing an obvious, but I just don't see a reason why we should use relative linking here: we should just link to where

Re: buildworld seg faulting.

2003-08-31 Thread Steve Kargl
On Sun, Aug 31, 2003 at 07:52:15PM +1000, Alastair G. Hogge wrote: Hello list, For the past couple of weeks I've been tyring to keep my system up to date with cvsup. However, when ever I run a buildworld I get problems with gcc (I think it's gcc). I've tried nuking /usr/obj and running

buildworld seg faulting.

2003-08-31 Thread Alastair G. Hogge
Hello list, For the past couple of weeks I've been tyring to keep my system up to date with cvsup. However, when ever I run a buildworld I get problems with gcc (I think it's gcc). I've tried nuking /usr/obj and running make clean many tims before each build but this doesn't help. What I've

Re: panic: softdep_deallocate_dependencies: dangling deps

2003-08-31 Thread Jeff Roberson
On Sun, 31 Aug 2003, Christian Brueffer wrote: On Sun, Aug 31, 2003 at 05:28:10AM -0400, Jeff Roberson wrote: On Sun, 31 Aug 2003, Christian Brueffer wrote: Hi, got a panic on my server tonight. Coredump available for further debuggung. FreeBSD haakonia.hitnet.rwth-aachen.de

Re: ATA-ng

2003-08-31 Thread Andrew Lankford
Anyhow please upgrade to the latest that should fix the problems with the probe missing some devices. -Søren To that I can only say #uname -a FreeBSD bogushost2 5.1-CURRENT FreeBSD 5.1-CURRENT #22: Sun Aug 31 01:55:17 EDT 2003[EMAIL PROTECTED]:/usr/obj/usr/src/sys/ARL5KERNEL i386

strange behavior of loader

2003-08-31 Thread Alexander Leidinger
Hi, I see some strange behavior of the loader with different CFLAGS, it either resets the system immediately or the bootblock tells me it has a wrong format. CFLAGS CPUTYPE failes -O2 -pipe -fno-strict-aliasing athlon yes -O2 -pipe -fno-strict-aliasing

Re: fxp0: device timeout in -current from 31.8.

2003-08-31 Thread Andreas Klemm
tnx for the pointer. I changed the card placement and free'd one IRQ (3) by disabling COM2 in BIOS. This did the trick. Andreas /// -- Andreas Klemm - Powered by FreeBSD 5.1-CURRENT Need a magic printfilter today ? - http://www.apsfilter.org/

Re: ATAng not detecting drives

2003-08-31 Thread Soren Schmidt
It seems Jan Srzednicki wrote: ad0: 19546MB FUJITSU MPF3204AT [39714/16/63] at ata0-master UDMA66 ad1: 39093MB FUJITSU MPG3409AH EF [79428/16/63] at ata0-slave UDMA66 ata1-slave: FAILURE - ATA_IDENTIFY status=51READY,DSC,ERROR error=4ABORTED acd0: CDROM CD-540E at ata1-master UDMA33 cd0 at

Re: su in free(): warning: chunk is already free

2003-08-31 Thread Tim Robbins
On Sat, Aug 30, 2003 at 06:38:02PM +0200, Christoph Kukulies wrote: On my 5.1-current I logged in from outside and tried su getting: $ su su in free(): warning: chunk is already free su: pam_start: system error I'm not sure whether my system is absolutely in sync but I'd think with

pcmcia card not detected properly

2003-08-31 Thread raoul.megelas
Hi all, I just upgraded Current. In a Dell Inspiron 8000 laptop a pcmcia card is not detected properly. Some lines from dmesg: FreeBSD 5.1-CURRENT #13: Thu Aug 28 21:06:05 CEST 2003 Preloaded elf module /boot/kernel/acpi.ko at 0xc071d280. ... acpi0: DELL CPi R

Re: panic: softdep_deallocate_dependencies: dangling deps

2003-08-31 Thread Jeff Roberson
On Sun, 31 Aug 2003, Christian Brueffer wrote: Hi, got a panic on my server tonight. Coredump available for further debuggung. FreeBSD haakonia.hitnet.rwth-aachen.de 5.1-CURRENT FreeBSD 5.1-CURRENT #6: Thu Aug 28 00:16:19 CEST 2003 [EMAIL PROTECTED]:/usr/obj/usr/src/sys/LORIEN i386

Re: need some debugging help

2003-08-31 Thread Poul-Henning Kamp
In message [EMAIL PROTECTED], Kenneth D. Merry writes: Anyway, I got some debugging output, and I've attached dmesg output. Let me know whether anything in there looks suspicious or points to a possible problem. There's nothing which jumps out at me, and I guess the best strategy is hunting

fxp0: device timeout in -current from 31.8.

2003-08-31 Thread Andreas Klemm
of the University of California. All rights reserved. FreeBSD 5.1-20030831-SNAP #0: Sun Aug 31 09:33:55 GMT 2003 [EMAIL PROTECTED]:/usr/obj/usr/src/sys/GENERIC Preloaded elf kernel /boot/kernel/kernel at 0xc0752000. Preloaded elf module /boot/kernel/acpi.ko at 0xc07521f4. Timecounter i8254 frequency

Re: /lib symlinks problem?

2003-08-31 Thread Alexander Leidinger
On Sun, 31 Aug 2003 17:52:24 +0300 Ruslan Ermilov [EMAIL PROTECTED] wrote: Doh, you're of course right! An updated patch is attached. I successfully tested an installworld, nm doesn't fail anymore in my environment and cdrdao compiles just fine. Bye, Alexander. -- It is easier

Re: fxp0: device timeout in -current from 31.8.

2003-08-31 Thread Tobias Roth
On Sun, Aug 31, 2003 at 01:55:49PM +0200, Andreas Klemm wrote: I tried to install FreeBSD 5.1-current from 30.07. and 31.08 on my wifes machine. Unluckily I experience problems with the fxp driver. On google I found a similar report from June 3rd.

Re: ATA-ng

2003-08-31 Thread D. Rock
Soren Schmidt schrieb: It seems Chris Petrik wrote: Think it would be a wise thing to do is to make a kernel option to use ATAng and one to use the old ATAold or something you commited a important part of the system without throughly testing it and most people dont use SMP i would think to do

Re: fxp0: device timeout in -current from 31.8.

2003-08-31 Thread Tobias Roth
On Sun, Aug 31, 2003 at 03:24:36PM +0200, Bernd Walter wrote: On Sun, Aug 31, 2003 at 01:55:49PM +0200, Andreas Klemm wrote: I tried to install FreeBSD 5.1-current from 30.07. and 31.08 on my wifes machine. Unluckily I experience problems with the fxp driver. On google I found a

automated clean up of /usr/lib because of /lib

2003-08-31 Thread Alexander Leidinger
Hi, shouldn't we add something like ---snip--- for i in /lib/lib*.so.*; do lib=$(basename $i) [ -f /usr/lib/$lib ] chflags noschg /usr/lib/$lib rm /usr/lib/$lib done ---snip--- into UPDATING or append it to the end of installworld? Bye, Alexander. -- I believe

Filesystem problem

2003-08-31 Thread Kevin Bockman
Hi. I have been experencing some filesystem problems for the last month or so. I was running 4.8-STABLE and updated to 5.1-RELEASE-p2. While I was running 4.8 and I tried to run a command that required hard disk activity, the process would 'hang' and I would no longer be able to ssh or telnet in.

Re: Compaq desktop does not work without ACPI

2003-08-31 Thread Doug White
On Fri, 29 Aug 2003, Oleg Polyakov wrote: I upgraded old Compaq Despro EP from 5.1-Release to Current as of Aug 27th (cvsupped) and last line I see after boot is Mounting root from ufs:/dev/ad0s1a. The box just can't go past this point. boot -v gives one more line start_init: trying

Re: 5.1-REL won't buildworld - fresh cvsup

2003-08-31 Thread Ruslan Ermilov
On Sun, Aug 31, 2003 at 01:27:30PM +0300, ODHIAMBO Washington wrote: For the last 3 days, I have cvsupped and wouldn't ever succeed with `make buildworld`. What could the problem be? Below are snippets from the fail: What are you trying to cvsup to? 5.1-RELEASE? This is the static

Re: -current of today, kconsole and others crash with signal 6

2003-08-31 Thread Andreas Klemm
On Sat, Aug 30, 2003 at 02:58:12PM +0200, Andreas Klemm wrote: JFYI: This hasn't been the case 1 month ago with kernel/os from July 30. A recompilation of everything (portupgrade -avf) helped, sorry for the false alarm. Andreas /// -- Andreas Klemm - Powered by FreeBSD 5.1-CURRENT

Re: Filesystem problem

2003-08-31 Thread Scott M. Likens
On Sun, 2003-08-31 at 11:36, Kevin Bockman wrote: Hi. I have been experencing some filesystem problems for the last month or so. I was running 4.8-STABLE and updated to 5.1-RELEASE-p2. While I was running 4.8 and I tried to run a command that required hard disk activity, the process would

Re: Filesystem problem

2003-08-31 Thread Robert Watson
On Sun, 31 Aug 2003, Kevin Bockman wrote: Anyone have any suggestions? I can not control-C out of 'man vmstat'. While doing 'make' in /usr/src/sys/boot it was hanging on as, when I restarted it, it got to i386/libi386 and will not do anything else. I'm running that through serial console,

ATA-ng, Asus A7V, Promise UDMA-100 controller

2003-08-31 Thread Guy Helmer
I just tried to upgrade my 4.8 machine to -current cvsupped Aug 30. However, the new kernel (GENERIC) has crashed to the debugger two out of the three times that I've tried to boot it. Nothing is attached to ata3 (the second Promise channel). A SAMSUNG SC-140B CD-ROM at at ata0-master (PIO4), a

Anyone ported HCF/HSF modem drivers to FreeBSD?

2003-08-31 Thread Nate Lawson
I asked this on -hackers a little while ago but no response. I'm curious if anyone has made an attempt to port these Winmodem drivers. http://www.linuxant.com/drivers/ -Nate ___ [EMAIL PROTECTED] mailing list

Re: Filesystem problem

2003-08-31 Thread Kevin Bockman
Thanks for the help. I'm positive that this is an OS problem as there are no hard errors reported on the console. This problem just happened to start 10 minutes after I rebooted and updated -STABLE on Aug 10th. I was running -STABLE from April before I believe for 4 months straight with no

Re: Filesystem problem

2003-08-31 Thread Kevin Bockman
I'd also like to note that if I go into single user mode and fsck a couple times -- it works fine still in single user mode. If I go back into multi-- up pops the weasel. --- Robert Watson [EMAIL PROTECTED] wrote: On Sun, 31 Aug 2003, Kevin Bockman wrote: Anyone have any suggestions? I

Re: automated clean up of /usr/lib because of /lib

2003-08-31 Thread Doug Barton
There was a discussion of this recently, and the conclusion was more or less that doing this in an automated fashion is frought with danger, since you don't know for sure what else besides system components the user has put in the various directories. I've been using the following combination of

Re: Anyone ported HCF/HSF modem drivers to FreeBSD?

2003-08-31 Thread Larry Rosenman
--On Sunday, August 31, 2003 15:02:36 -0700 Nate Lawson [EMAIL PROTECTED] wrote: I asked this on -hackers a little while ago but no response. I'm curious if anyone has made an attempt to port these Winmodem drivers. http://www.linuxant.com/drivers/ I've been asking for a year and a half, and

interesting time_t error...

2003-08-31 Thread Scott M. Likens
I noticed this earlier. /usr/bin/tar: Archive octal value 20366603014 is out of time_t range; assuming two's complement /usr/bin/tar: Archive octal value 20366603014 is out of time_t range; assuming two's complement I was doing portupgrade on xine-ui. Knowing how to read the time I know it's