Re: Kernel panic with ipfw pipes

2000-11-23 Thread Russell Vincent
On Wed, Nov 22, 2000 at 09:19:41PM -0500, Bosko Milekic wrote: The attached kernel panic occurs when a connection is made that would pass through an ipfw pipe configured as: Please try this patch and report: http://people.freebsd.org/~bmilekic/ip_pipe.diff That seems to have done

Mutex, SMBUS, ACPI (Re: how to mutex'ify a device driver)

2000-11-23 Thread Nicolas Souchu
On Wed, Nov 22, 2000 at 04:58:32PM -0800, Archie Cobbs wrote: As a relatively simple exercise in -current kernel programming, I'm planning to mutex'ify the ichsmb(4) device driver (this is a relatively simple driver that currently uses splhigh()). I'd appreciate some feedback if what I'm

Re: RE: COMPAT_SVR4 broken after uipc_syscalls commit (1.77)

2000-11-23 Thread Matt Dillon
: :Okay, this time I'll even include the entire patch... : :-- Danny J. Zerkel :[EMAIL PROTECTED] Thanks Danny. I've comitted it. -Matt To Unsubscribe: send mail to [EMAIL PROTECTED] with "unsubscribe freebsd-current" in the body of the message

Re: RFC: /dev/console - /var/log/messages idea/patch

2000-11-23 Thread Alexander Leidinger
On 22 Nov, Ashley Penney wrote: The attached patch is a "proof-of-concept" on which I would like to get some comments: I'm only a moronic user, but this would make my life easier. My machine switches into 132x43 on startup, and I always lose the output. So this Its in the scrollback

slight improvement in locore.s?

2000-11-23 Thread Julian Elischer
locore.s includes: #define ALLOCPAGES(foo) \ movlR(physfree), %esi ; \ movl$((foo)*PAGE_SIZE), %eax ; \ addl%esi, %eax ; \ movl%eax, R(physfree) ; \ movl%esi, %edi ; \ movl$((foo)*PAGE_SIZE),%ecx ; \ xorl

Re: Confusing error messages from shell image activation

2000-11-23 Thread Alfred Perlstein
* Mike Meyer [EMAIL PROTECTED] [001122 22:41] wrote: Could I get some feedback on URL: http://www.freebsd.org/cgi/query-pr.cgi?pr=22755 ? It's just a one-line kernel patch with some attendant updates in the kernel and libc, but it makes dealing with broken #! scripts *much* saner, and no one

Re: slight improvement in locore.s?

2000-11-23 Thread Matt Dillon
:might it be a very slight optimisation to change this to: :#define ALLOCPAGES(foo) \ :movlR(physfree), %esi ; \ :... :movl$((foo)*PAGE_SIZE), %eax ; \ ... but why? -Matt To Unsubscribe: send mail to [EMAIL PROTECTED] with

Re: slight improvement in locore.s?

2000-11-23 Thread David Greenman
locore.s includes: #define ALLOCPAGES(foo) \ movlR(physfree), %esi ; \ movl$((foo)*PAGE_SIZE), %eax ; \ addl%esi, %eax ; \ movl%eax, R(physfree) ; \ movl%esi, %edi ; \ movl$((foo)*PAGE_SIZE),%ecx ; \ xorl

Re: slight improvement in locore.s?

2000-11-23 Thread janb
It does not impair readability. As long as that is true, I believe its prudent to save every byte possible... Only my 2 cents worth. JAn On Thu, 23 Nov 2000, David Greenman wrote: locore.s includes: #define ALLOCPAGES(foo) \ movlR(physfree), %esi ; \ movl

Re: slight improvement in locore.s?

2000-11-23 Thread Daniel C. Sobral
[EMAIL PROTECTED] wrote: It does not impair readability. As long as that is true, I believe its prudent to save every byte possible... My two cents. It's an improvement in speed (unmeasurable, granted :) and size (a couple of bytes). It doesn't have any disadvantage. So, if someone is

Re: page coloring

2000-11-23 Thread Alan Cox
Hi. Isn't the page coloring algoritm in _vm_page_list_find totally bogus? No, it's not. The comment is, however, misplaced. It describes the behavior of an inline function in vm_page.h, and not the function it precedes. It skips queue pq[index PQ_L2_MASK]. That's correct. The

Re: page coloring

2000-11-23 Thread Mike Smith
Isn't the page coloring algoritm in _vm_page_list_find totally bogus? No, it's not. The comment is, however, misplaced. It describes the behavior of an inline function in vm_page.h, and not the function it precedes. Hrm. My comment was based on John Dyson's own observations on its

Re: slight improvement in locore.s?

2000-11-23 Thread Julian Elischer
that's all I was thinking.. I actually think it DOES improve readability.. because I spent time wondering why the same line was there twice :-) I was just reading the file and thought, 'hey why not'? then I thought probably it's doing something I don't understand.. but I think I was right

Re: RFC: /dev/console - /var/log/messages idea/patch

2000-11-23 Thread Cyrille Lefevre
Alexander Leidinger [EMAIL PROTECTED] writes: On 22 Nov, Ashley Penney wrote: The attached patch is a "proof-of-concept" on which I would like to get some comments: I'm only a moronic user, but this would make my life easier. My machine switches into 132x43 on startup, and I

Re: Confusing error messages from shell image activation

2000-11-23 Thread Mike Meyer
Alfred Perlstein [EMAIL PROTECTED] types: * Mike Meyer [EMAIL PROTECTED] [001122 22:41] wrote: Could I get some feedback on URL: http://www.freebsd.org/cgi/query-pr.cgi?pr=22755 ? It's just a one-line kernel patch with some attendant updates in the kernel and libc, but it makes dealing