Re: slight improvement in locore.s?

2000-11-29 Thread Bruce Evans
On Wed, 29 Nov 2000, Julian Elischer wrote: > Bruce Evans wrote: > > > > On Thu, 23 Nov 2000, Julian Elischer wrote: > > > > > locore.s includes: > > > #define ALLOCPAGES(foo) \ > > > movlR(physfree), %esi ; \ > > > movl$((foo)*PAGE_SIZE), %eax ; \ > > > addl

Re: slight improvement in locore.s?

2000-11-29 Thread Julian Elischer
Bruce Evans wrote: > > On Thu, 23 Nov 2000, Julian Elischer wrote: > > > locore.s includes: > > #define ALLOCPAGES(foo) \ > > movlR(physfree), %esi ; \ > > movl$((foo)*PAGE_SIZE), %eax ; \ > > addl%esi, %eax ; \ > > movl%eax, R(physfree) ; \ > >

Re: slight improvement in locore.s?

2000-11-28 Thread Bruce Evans
On Thu, 23 Nov 2000, Julian Elischer wrote: > locore.s includes: > #define ALLOCPAGES(foo) \ > movlR(physfree), %esi ; \ > movl$((foo)*PAGE_SIZE), %eax ; \ > addl%esi, %eax ; \ > movl%eax, R(physfree) ; \ > movl%esi, %edi ; \ >

Re: slight improvement in locore.s?

2000-11-24 Thread Matt Dillon
My two cents: If it's assembly, and it works, and you didn't write it... then don't mess with it unless you absolutely have to. -Matt To Unsubscribe: send mail to [EMAIL PROTECTED] with "unsubscribe freebsd-current" in the body of the message

Re: slight improvement in locore.s?

2000-11-23 Thread Julian Elischer
that's all I was thinking.. I actually think it DOES improve readability.. because I spent time wondering why the same line was there twice :-) I was just reading the file and thought, 'hey why not'? then I thought probably it's doing something I don't understand.. but I think I was right the

Re: slight improvement in locore.s?

2000-11-23 Thread Marcel Moolenaar
Julian Elischer wrote: > > movl$((foo)*PAGE_SIZE), %eax ; \ ... > movl$((foo)*PAGE_SIZE),%ecx ; \ > might it be a very slight optimisation to change this to: > movl$((foo)*PAGE_SIZE), %eax ; \ > movl%eax, %ecx ; \ ... I don't k

Re: slight improvement in locore.s?

2000-11-23 Thread Daniel C. Sobral
[EMAIL PROTECTED] wrote: > > It does not impair readability. As long as that is true, I believe its > prudent to save every byte possible... My two cents. It's an improvement in speed (unmeasurable, granted :) and size (a couple of bytes). It doesn't have any disadvantage. So, if someone is will

Re: slight improvement in locore.s?

2000-11-23 Thread janb
It does not impair readability. As long as that is true, I believe its prudent to save every byte possible... Only my 2 cents worth. JAn On Thu, 23 Nov 2000, David Greenman wrote: > >locore.s includes: > >#define ALLOCPAGES(foo) \ > >movlR(physfree), %esi ; \ > >movl$(

Re: slight improvement in locore.s?

2000-11-23 Thread David Greenman
>locore.s includes: >#define ALLOCPAGES(foo) \ >movlR(physfree), %esi ; \ >movl$((foo)*PAGE_SIZE), %eax ; \ >addl%esi, %eax ; \ >movl%eax, R(physfree) ; \ >movl%esi, %edi ; \ >movl$((foo)*PAGE_SIZE),%ecx ; \ >xorl

Re: slight improvement in locore.s?

2000-11-23 Thread Matt Dillon
:might it be a very slight optimisation to change this to: :#define ALLOCPAGES(foo) \ :movlR(physfree), %esi ; \ :... :movl$((foo)*PAGE_SIZE), %eax ; \ ... but why? -Matt To Unsubscribe: send mail to [EMAIL PROTECTED] with "unsu

slight improvement in locore.s?

2000-11-23 Thread Julian Elischer
locore.s includes: #define ALLOCPAGES(foo) \ movlR(physfree), %esi ; \ movl$((foo)*PAGE_SIZE), %eax ; \ addl%esi, %eax ; \ movl%eax, R(physfree) ; \ movl%esi, %edi ; \ movl$((foo)*PAGE_SIZE),%ecx ; \ xorl%eax,%eax