Re: Time keeping Issues with the low-resolution TSC timecounter

2011-06-21 Thread Jung-uk Kim
On Friday 17 June 2011 02:54 pm, Jung-uk Kim wrote: On Friday 17 June 2011 01:45 pm, Ian FREISLICH wrote: Jung-uk Kim wrote: On Thursday 16 June 2011 03:10 am, Ian FREISLICH wrote: Jung-uk Kim wrote: 1481522037144590601.0098392393 149596940414447367

Re: Time keeping Issues with the low-resolution TSC timecounter

2011-06-21 Thread Jung-uk Kim
On Tuesday 21 June 2011 04:53 pm, Jung-uk Kim wrote: Can you please try the attached patch? It should disable TSC/TSC-low timecounter for your CPU models, I think. Sorry, I attached a wrong patch. Please ignore the previous one and try this, instead. Jung-uk Kim Index:

Re: Time keeping Issues with the low-resolution TSC timecounter

2011-06-21 Thread Fabian Keil
Jung-uk Kim j...@freebsd.org wrote: On Tuesday 21 June 2011 04:53 pm, Jung-uk Kim wrote: Can you please try the attached patch? It should disable TSC/TSC-low timecounter for your CPU models, I think. Sorry, I attached a wrong patch. Please ignore the previous one and try this,

[head tinderbox] failure on ia64/ia64

2011-06-21 Thread FreeBSD Tinderbox
TB --- 2011-06-21 21:38:22 - tinderbox 2.7 running on freebsd-current.sentex.ca TB --- 2011-06-21 21:38:22 - starting HEAD tinderbox run for ia64/ia64 TB --- 2011-06-21 21:38:22 - cleaning the object tree TB --- 2011-06-21 21:38:44 - cvsupping the source tree TB --- 2011-06-21 21:38:44 -

Re: CFT: msk(4) 64bit DMA support

2011-06-21 Thread YongHyeon PYUN
On Sun, Jun 05, 2011 at 02:23:57PM -0400, David Schultz wrote: 85;95;0cOn Thu, May 26, 2011, YongHyeon PYUN wrote: Here is a patch that implements 64bit DMA on msk(4). If you use msk(4) on a system that has more than 4GB memory, please try the patch at the following URL and let me know

Re: atkbdc broken on current ?

2011-06-21 Thread David Xu
On 2011/05/05 21:21, Damjan Marion wrote: Hi, I have issue with old HP DL380G3 server. When I use ILO virtual console to manage server. Seems that 9-CURRENT fails to detect atkbdc. When I boot 8.2-RELEASE it works well. 8.2 dmesg shows: atkbdc0: Keyboard controller (i8042) port

Re: Exactly that commit (was Re: Latest -current 100% hang at the late boot stage)

2011-06-21 Thread Kenneth D. Merry
On Wed, Jun 22, 2011 at 00:49:34 +0400, Andrey Chernov wrote: On Tue, Jun 21, 2011 at 10:17:19AM -0600, Kenneth D. Merry wrote: ps alltrace show locks show msgbuf Hopefully that will give us something to start looking at... This would really work a lot better if there is any way

Re: Exactly that commit (was Re: Latest -current 100% hang at the late boot stage)

2011-06-21 Thread Andrey Chernov
On Tue, Jun 21, 2011 at 09:54:04PM -0600, Kenneth D. Merry wrote: These two are interesting: http://img825.imageshack.us/img825/1249/21062011014m.jpg http://img839.imageshack.us/img839/3791/21062011015.jpg It looks like the GEOM event thread is stuck inside the cd(4) driver. The cd(4)

Re: Exactly that commit (was Re: Latest -current 100% hang at the late boot stage)

2011-06-21 Thread Andrey Chernov
Remove cd/acd from your kernel config to see if that allows you to boot? I unplug DVDs physically and kernel finally boots! BTW both DVDs was empty during the hanged boot and works normally under Win7. -- http://ache.vniz.net/ ___

Reproducible panic with TRIM and ufs snapshots

2011-06-21 Thread Yamagi Burmeister
Hi, I encountered a panic in the 2011/05 snapshot of 9-current. Snapshot creation an UFS filesystem with or without SU+J leads to panic: % mdconfig -a -t malloc -s 128m % newfs -U -O2 -t /dev/md0 % mount /dev/md0 /mnt % mksnap_ffs /mnt /mnt/foo = panic My system is: fbsd-vbox# uname -a

Re: [PATCH] ipfw call/return rule actions

2011-06-21 Thread Luigi Rizzo
On Tue, Jun 21, 2011 at 10:22:40AM +, Vadim Goncharov wrote: Hi, I have made a patch http://nuclight.avtf.net/vadim/ipfw_call_20110620.diff which adds a call and return rule actions to make it possible to organize subroutines with rules - skipto is like goto and only allows jumps

[head tinderbox] failure on ia64/ia64

2011-06-21 Thread FreeBSD Tinderbox
TB --- 2011-06-21 10:09:09 - tinderbox 2.7 running on freebsd-current.sentex.ca TB --- 2011-06-21 10:09:09 - starting HEAD tinderbox run for ia64/ia64 TB --- 2011-06-21 10:09:09 - cleaning the object tree TB --- 2011-06-21 10:09:20 - cvsupping the source tree TB --- 2011-06-21 10:09:20 -

Re: Exactly that commit (was Re: Latest -current 100% hang at the late boot stage)

2011-06-21 Thread Kenneth D. Merry
On Mon, Jun 20, 2011 at 15:46:56 +0400, Andrey Chernov wrote: On Mon, Jun 20, 2011 at 11:01:46AM +0300, Kostik Belousov wrote: On Mon, Jun 20, 2011 at 11:02:22AM +0400, Andrey Chernov wrote: On Sun, Jun 19, 2011 at 08:15:43PM -0600, Justin T. Gibbs wrote: On 6/19/11 6:19 PM, Andrey

Re: TLS bug?

2011-06-21 Thread Jason Evans
On 06/17/2011 02:35 PM, Marius Strobl wrote: On Fri, Jun 17, 2011 at 03:31:29PM -0400, Nathaniel W Filardo wrote: On Fri, Jun 17, 2011 at 08:07:13PM +0200, Marius Strobl wrote: Using bonnie++ I can't reproduce this (didn't try mysql) but I have I seem to have good luck reproducing it with -r

Re: udav: vendor 0x0fe6, product: 0x9700

2011-06-21 Thread Luiz Gustavo S. Costa
Hi Hans ! theoretically would only do this, put the id's in the files for the udav.c work, but was not so, the driver did not work with these entries, simply could not allocate a PHY. Dmesg: ugen0.2: vendor 0x0fe6 at usbus0 udav0: vendor 0x0fe6 USB 2.0 10100M Ethernet Adaptor, class 0/0, rev

Re: udav: vendor 0x0fe6, product: 0x9700

2011-06-21 Thread Hans Petter Selasky
On Tuesday 21 June 2011 19:17:13 Luiz Gustavo S. Costa wrote: Hi Hans ! theoretically would only do this, put the id's in the files for the udav.c work, but was not so, the driver did not work with these entries, simply could not allocate a PHY. Dmesg: ugen0.2: vendor 0x0fe6 at usbus0

xpt_action_default: CCB type 0xe not supported

2011-06-21 Thread George Kontostanos
Fresh installation and after world kernel update I get these messages during boot: xpt_action_default: CCB type 0xe not supported xpt_action_default: CCB type 0xe not supported The system is running GENERIC with debugging for use in current off options. Full dmesg attached. Regards, --

Re: xpt_action_default: CCB type 0xe not supported

2011-06-21 Thread Matt
On 06/21/11 10:51, George Kontostanos wrote: Fresh installation and after world kernel update I get these messages during boot: xpt_action_default: CCB type 0xe not supported xpt_action_default: CCB type 0xe not supported The system is running GENERIC with debugging for use in current off

Re: xpt_action_default: CCB type 0xe not supported

2011-06-21 Thread Hartmann, O.
On 06/21/11 19:58, Matt wrote: On 06/21/11 10:51, George Kontostanos wrote: Fresh installation and after world kernel update I get these messages during boot: xpt_action_default: CCB type 0xe not supported xpt_action_default: CCB type 0xe not supported The system is running GENERIC with

Re: Exactly that commit (was Re: Latest -current 100% hang at the late boot stage)

2011-06-21 Thread Will Andrews
Hi Andrey, On Mon, Jun 20, 2011 at 5:46 AM, Andrey Chernov a...@freebsd.org wrote: As the second message in the thread states, I try first even 223296 with the same hang and the same xpt_action_default: CCB type 0xe not supported As I think, DDB's 'ps' indicates that kernel waits something

Re: xpt_action_default: CCB type 0xe not supported

2011-06-21 Thread Andrey Chernov
On Tue, Jun 21, 2011 at 08:51:02PM +0300, George Kontostanos wrote: Fresh installation and after world kernel update I get these messages during boot: xpt_action_default: CCB type 0xe not supported xpt_action_default: CCB type 0xe not supported +1 on ICH9 SATA -- http://ache.vniz.net/

Re: xpt_action_default: CCB type 0xe not supported

2011-06-21 Thread Garrett Cooper
On Tue, Jun 21, 2011 at 11:22 AM, Andrey Chernov a...@freebsd.org wrote: On Tue, Jun 21, 2011 at 08:51:02PM +0300, George Kontostanos wrote: Fresh installation and after world kernel update I get these messages during boot: xpt_action_default: CCB type 0xe not supported xpt_action_default:

Re: Exactly that commit (was Re: Latest -current 100% hang at the late boot stage)

2011-06-21 Thread George Kontostanos
After applying the patch the system does not boot anymore! It hangs after probing for scsi devices. On Tue, Jun 21, 2011 at 8:58 PM, Will Andrews w...@firepipe.net wrote: Hi Andrey, On Mon, Jun 20, 2011 at 5:46 AM, Andrey Chernov a...@freebsd.org wrote: As the second message in the thread

Re: xpt_action_default: CCB type 0xe not supported

2011-06-21 Thread Scott Long
On Jun 21, 2011, at 1:13 PM, Garrett Cooper wrote: On Tue, Jun 21, 2011 at 11:22 AM, Andrey Chernov a...@freebsd.org wrote: On Tue, Jun 21, 2011 at 08:51:02PM +0300, George Kontostanos wrote: Fresh installation and after world kernel update I get these messages during boot:

Re: Exactly that commit (was Re: Latest -current 100% hang at the late boot stage)

2011-06-21 Thread Andrey Chernov
On Tue, Jun 21, 2011 at 11:58:17AM -0600, Will Andrews wrote: Hi Andrey, On Mon, Jun 20, 2011 at 5:46 AM, Andrey Chernov a...@freebsd.org wrote: As the second message in the thread states, I try first even 223296 with the same hang and the same xpt_action_default: CCB type 0xe not

Re: Exactly that commit (was Re: Latest -current 100% hang at the late boot stage)

2011-06-21 Thread Andrey Chernov
On Tue, Jun 21, 2011 at 10:17:19AM -0600, Kenneth D. Merry wrote: ps alltrace show locks show msgbuf Hopefully that will give us something to start looking at... This would really work a lot better if there is any way to get a serial console on the machine. The above will produce a