Intel Centrino Advanced-N + WiMAX 6250 doesn't work

2011-09-07 Thread Tz-Huan Huang
Hi, I have a lenovo X201s with a Intel Centrino Advanced-N + WiMAX 6250 bundled. The device seems recognized as iwn0 correctly but it just doesn't work. The command ifconfig wlan0 up scan return immediately and nothing showed. Is the device not supported, or do I miss something? Any suggestion

Re: Intel Centrino Advanced-N + WiMAX 6250 doesn't work

2011-09-07 Thread Tz-Huan Huang
On Wed, Sep 7, 2011 at 14:10, Tz-Huan Huang tzh...@gmail.com wrote: Hi, I have a lenovo X201s with a Intel Centrino Advanced-N + WiMAX 6250 bundled. The device seems recognized as iwn0 correctly but it just doesn't work. The command ifconfig wlan0 up scan return immediately and nothing

Re: Intel Centrino Advanced-N + WiMAX 6250 doesn't work

2011-09-07 Thread Tz-Huan Huang
On Wed, Sep 7, 2011 at 15:52, Andreas Tobler andreast-l...@fgznet.ch wrote: - Original Message From: Tz-Huan Huang tzh...@gmail.com To: freebsd-current@freebsd.org freebsd-current@freebsd.org Subject: Re: Intel Centrino Advanced-N + WiMAX 6250 doesn't work Date: 07/09/11

Re: Intel Centrino Advanced-N + WiMAX 6250 doesn't work

2011-09-07 Thread Andreas Tobler
- Original Message From: Tz-Huan Huang tzh...@gmail.com To: freebsd-current@freebsd.org freebsd-current@freebsd.org Subject: Re: Intel Centrino Advanced-N + WiMAX 6250 doesn't work Date: 07/09/11 09:40 On Wed, Sep 7, 2011 at 14:10, Tz-Huan Huang lt;tzh...@gmail.comgt; wrote:

[ANNOUNCE] 802.11n TX aggregation support for Atheros 11n NICs

2011-09-07 Thread Adrian Chadd
Hi all, I apologise up front for the cross-posting. Please redirect all future queries about this to freebsd-wirel...@freebsd.org. I guess the cat is out of the bag (and it hasn't killed anyone yet.) For the last 6 or so months, the if_ath driver and net80211 802.11n support has been updated to

Re: Intel Centrino Advanced-N + WiMAX 6250 doesn't work

2011-09-07 Thread Adrian Chadd
Hi! Hm, maybe the iwn driver doesn't have the 6250 support? Is it supposed to use 6000/6200 specific calibration (and other routines), or is it using the 5000 routines correctly? Has the card successfully loaded the firmware in? Adrian ___

Re: BETA2 panic

2011-09-07 Thread Bernhard Schmidt
On Tue, Sep 6, 2011 at 22:42, Joel Dahl j...@vnode.se wrote: On 05-09-2011  9:02, Bernhard Schmidt wrote: On Mon, Sep 5, 2011 at 08:24, Joel Dahl j...@vnode.se wrote: On 05-09-2011  5:09, Adrian Chadd wrote: On 5 September 2011 01:04, Joel Dahl j...@vnode.se wrote: Hi, I upgraded my

[ANNOUNCE] 802.11n TX aggregation support for Atheros 11n NICs

2011-09-07 Thread Adrian Chadd
Hi all, I apologise up front for the cross-posting. Please redirect all future queries about this to freebsd-wirel...@freebsd.org. I guess the cat is out of the bag (and it hasn't killed anyone yet.) For the last 6 or so months, the if_ath driver and net80211 802.11n support has been updated to

Shared libraries version bump?

2011-09-07 Thread Thomas Mueller mueller6727
When FreeBSD 9.0_BETA1 was announced, the announcement included a notice that shared library version would be updated some time prior to BETA2, which would necessitate rebuilding all ports. Has this happened yet? I don't want to rebuild all ports at the wrong time. I notice BETA2 has been

Re: RELENG_8 / mpt / zpool Errors

2011-09-07 Thread Matt Thyer
On 7 September 2011 13:54, Tim Gustafson t...@soe.ucsc.edu wrote: What are the drives exactly? You may have issues like TLER or frequent head parking. Are these SATA, SCSI or SAS and are port multipliers in use? root@bsd-03: dmesg | grep da6 da6 at mpt0 bus 0 scbus1 target 1 lun 0 da6:

Re: Intel Centrino Advanced-N + WiMAX 6250 doesn't work

2011-09-07 Thread Bernhard Schmidt
On Wed, Sep 7, 2011 at 09:39, Tz-Huan Huang tzh...@gmail.com wrote: On Wed, Sep 7, 2011 at 14:10, Tz-Huan Huang tzh...@gmail.com wrote: Hi, I have a lenovo X201s with a Intel Centrino Advanced-N + WiMAX 6250 bundled. The device seems recognized as iwn0 correctly but it just doesn't work.

Re: Shared libraries version bump?

2011-09-07 Thread Kostik Belousov
On Wed, Sep 07, 2011 at 09:14:12AM +, Thomas Mueller mueller6727@bellsouth.net wrote: When FreeBSD 9.0_BETA1 was announced, the announcement included a notice that shared library version would be updated some time prior to BETA2, which would necessitate rebuilding all ports. Has this

Re: RELENG_8 / mpt / zpool Errors

2011-09-07 Thread Matt Thyer
On 7 September 2011 19:07, Matt Thyer matt.th...@gmail.com wrote: On 7 September 2011 13:54, Tim Gustafson t...@soe.ucsc.edu wrote: What are the drives exactly? You may have issues like TLER or frequent head parking. Are these SATA, SCSI or SAS and are port multipliers in use?

Re: Intel Centrino Advanced-N + WiMAX 6250 doesn't work

2011-09-07 Thread Kevin Lo
Tz-Huan Huang wrote: Hi, I have a lenovo X201s with a Intel Centrino Advanced-N + WiMAX 6250 bundled. The device seems recognized as iwn0 correctly but it just doesn't work. The command ifconfig wlan0 up scan return immediately and nothing showed. Is the device not supported, or do I miss

Re: BETA2 panic

2011-09-07 Thread Joel Dahl
On 07-09-2011 10:59, Bernhard Schmidt wrote: On Tue, Sep 6, 2011 at 22:42, Joel Dahl j...@vnode.se wrote: On 05-09-2011  9:02, Bernhard Schmidt wrote: On Mon, Sep 5, 2011 at 08:24, Joel Dahl j...@vnode.se wrote: On 05-09-2011  5:09, Adrian Chadd wrote: On 5 September 2011 01:04, Joel

Re: http://www.freebsd.org/marketing/os-comparison.html

2011-09-07 Thread Aldis Berjoza
This is interesting, and could be mentioned in updated page http://www.phoronix.com/scan.php?page=articleitem=linux_games_bsdnum=1 -- Aldis Berjoza http://www.bsdroot.lv/ signature.asc Description: PGP signature

Re: BETA2 panic

2011-09-07 Thread Bernhard Schmidt
On Wed, Sep 7, 2011 at 12:53, Joel Dahl j...@vnode.se wrote: On 07-09-2011 10:59, Bernhard Schmidt wrote: On Tue, Sep 6, 2011 at 22:42, Joel Dahl j...@vnode.se wrote: On 05-09-2011  9:02, Bernhard Schmidt wrote: On Mon, Sep 5, 2011 at 08:24, Joel Dahl j...@vnode.se wrote: On 05-09-2011  

Re: Intel Centrino Advanced-N + WiMAX 6250 doesn't work

2011-09-07 Thread Bernhard Schmidt
On Wed, Sep 7, 2011 at 12:10, Kevin Lo ke...@freebsd.org wrote: Tz-Huan Huang wrote: Hi, I have a lenovo X201s with a Intel Centrino Advanced-N + WiMAX 6250 bundled. The device seems recognized as iwn0 correctly but it just doesn't work. The command ifconfig wlan0 up scan return

Re: Intel Centrino Advanced-N + WiMAX 6250 doesn't work

2011-09-07 Thread Tz-Huan Huang
On Wed, Sep 7, 2011 at 17:20, Bernhard Schmidt bschm...@techwires.net wrote: On Wed, Sep 7, 2011 at 09:39, Tz-Huan Huang tzh...@gmail.com wrote: On Wed, Sep 7, 2011 at 14:10, Tz-Huan Huang tzh...@gmail.com wrote: $ uname -a FreeBSD bud 9.0-BETA2 FreeBSD 9.0-BETA2 #2: Tue Sep  6 16:50:09 CST

Re: Intel Centrino Advanced-N + WiMAX 6250 doesn't work

2011-09-07 Thread Tz-Huan Huang
On Wed, Sep 7, 2011 at 20:34, Bernhard Schmidt bschm...@freebsd.org wrote: On Wed, Sep 7, 2011 at 12:10, Kevin Lo ke...@freebsd.org wrote: Please try attached patch. It seems like OpenBSD added support for 6205, but I'm not sure if it works for 6250. Okay, I am re-building the kernel now,

Re: Intel Centrino Advanced-N + WiMAX 6250 doesn't work

2011-09-07 Thread Tz-Huan Huang
On Wed, Sep 7, 2011 at 16:53, Adrian Chadd adr...@freebsd.org wrote: Hi! Hm, maybe the iwn driver doesn't have the 6250 support? Is it supposed to use 6000/6200 specific calibration (and other routines), or is it using the 5000 routines correctly? Has the card successfully loaded the

Re: Intel Centrino Advanced-N + WiMAX 6250 doesn't work

2011-09-07 Thread Tz-Huan Huang
On Wed, Sep 7, 2011 at 21:11, Tz-Huan Huang tzh...@gmail.com wrote: On Wed, Sep 7, 2011 at 20:34, Bernhard Schmidt bschm...@freebsd.org wrote: On Wed, Sep 7, 2011 at 12:10, Kevin Lo ke...@freebsd.org wrote: Please try attached patch. It seems like OpenBSD added support for 6205, but I'm not

Re: Intel Centrino Advanced-N + WiMAX 6250 doesn't work

2011-09-07 Thread Bernhard Schmidt
On Wed, Sep 7, 2011 at 15:11, Tz-Huan Huang tzh...@gmail.com wrote: On Wed, Sep 7, 2011 at 20:34, Bernhard Schmidt bschm...@freebsd.org wrote: On Wed, Sep 7, 2011 at 12:10, Kevin Lo ke...@freebsd.org wrote: Please try attached patch. It seems like OpenBSD added support for 6205, but I'm not

Re: Intel Centrino Advanced-N + WiMAX 6250 doesn't work

2011-09-07 Thread Tz-Huan Huang
On Wed, Sep 7, 2011 at 21:30, Bernhard Schmidt bschm...@freebsd.org wrote: On Wed, Sep 7, 2011 at 15:11, Tz-Huan Huang tzh...@gmail.com wrote: On Wed, Sep 7, 2011 at 20:34, Bernhard Schmidt bschm...@freebsd.org wrote: On Wed, Sep 7, 2011 at 12:10, Kevin Lo ke...@freebsd.org wrote: Please try

FreeBSD 9.0-BETA2 Available...

2011-09-07 Thread Ken Smith
The second BETA build of the 9.0-RELEASE release cycle is now available. Since this is the first release of a brand new branch I cross-post the announcements on both -current and -stable. But just so you know most of the developers active in head pay more attention to the -current mailing list.

Re: RELENG_8 / mpt / zpool Errors

2011-09-07 Thread Tim Gustafson
Advice is: Use -STABLE and not -RELEASE Upgrade firmware Avoid port multipliers As I'm using cheap 4K green drives I had to use wdidle3.exe to fix the 8 second head parking and I also had to use gnop to force my ZFS pool to use 4K transfers. We're already using -STABLE; we update

Re: FreeBSD 9.0 BETA2 gpart resize -s uses whole disk on first resize

2011-09-07 Thread Andrey V. Elsukov
On 07.09.2011 04:21, Mikael Fridh wrote: Hi gurus, FreeBSD freebsd9.mg8.tmtowtdi.se 9.0-BETA2 FreeBSD 9.0-BETA2 #0: Wed Aug 31 18:07:44 UTC 2011 r...@farrell.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC amd64 When resizing a partition, on first attempt it uses up the whole disk. Only on

Re: FreeBSD 9.0 BETA2 gpart resize -s uses whole disk on first resize

2011-09-07 Thread Andrey V. Elsukov
On 07.09.2011 04:21, Mikael Fridh wrote: Resizing from any smaller size to a larger size initially uses up the whole disk, like if -s was not used at all even if it's as little as one logical disk block. I'm wondering if anyone else can reproduce. Also, can you show the output of this

WITHOUT_GCC flag disables installation of /usr/bin/cpp too -- is it Ok?

2011-09-07 Thread Lev Serebryakov
Hello, freebsd-current. I'm building NanoBSD image based on latest HEAD sources. I've added WITHOUT_GCC to install configuration, as I don't need gcc/g++ (it is documented in man src.conf as disabling exactly gcc and g++), but it affect /usr/bin/cpp too. And I need cpp for some config

Re: ZFS: i/o error - all block copies unavailable after upgrading to r225312

2011-09-07 Thread Andriy Gapon
on 02/09/2011 16:35 Andriy Gapon said the following: Then: - obtain this patch http://people.freebsd.org/~avg/zfstest.head.diff - cd sys/boot/zfs - apply the patch to zfstest.c - cc -I. -I../../cddl/boot/zfs zfstest.c -o zfstest - run the resulting binary as root and provide your pool

Re: WITHOUT_GCC flag disables installation of /usr/bin/cpp too -- is it Ok?

2011-09-07 Thread Dimitry Andric
On 2011-09-07 18:10, Lev Serebryakov wrote: I'm building NanoBSD image based on latest HEAD sources. I've added WITHOUT_GCC to install configuration, as I don't need gcc/g++ (it is documented in man src.conf as disabling exactly gcc and g++), but it affect /usr/bin/cpp too. And I need cpp for

Re: WITHOUT_GCC flag disables installation of /usr/bin/cpp too -- is it Ok?

2011-09-07 Thread Lev Serebryakov
Hello, Dimitry. You wrote 7 сентября 2011 г., 21:17:20: I'm building NanoBSD image based on latest HEAD sources. I've added WITHOUT_GCC to install configuration, as I don't need gcc/g++ (it is documented in man src.conf as disabling exactly gcc and g++), but it affect /usr/bin/cpp too. And

Re: WITHOUT_GCC flag disables installation of /usr/bin/cpp too -- is it Ok?

2011-09-07 Thread Dimitry Andric
On 2011-09-07 19:20, Lev Serebryakov wrote: ... I think, that /usr/bin/cpp is valuable by itself, as it is handy generic preprocessor tool, useful for preparing complex ipfw scripts, for example. All others are bundled together, for sure. I think, it is good idea to exclude cpp from this

Re: panic: sched_priority: invalid priority 3990 on r225375

2011-09-07 Thread John Baldwin
On Sunday, September 04, 2011 7:21:23 pm Ryan Stone wrote: I've gotten the following panic twice while running recent builds of head under VirtualBox(FreeBSD 8.2 host). panic: sched_priority: invalid priority 3990: nice 0, ticks 1227873280 ftick 175669871 ltick 175679894 tick pri 3818 The

Re: ath0 no longer attaches, cardbus problems?

2011-09-07 Thread Daniel Eischen
On Tue, 6 Sep 2011, John Baldwin wrote: On Tuesday, September 06, 2011 3:34:58 pm Daniel Eischen wrote: On Tue, 6 Sep 2011, John Baldwin wrote: Looks like I had a typo in my original e-mail, try debug.acpi.disabled=hostres rather than debug.acpi.disable=hostres. Ok, I'll try that.

Re: FreeBSD 9.0 BETA2 gpart resize -s uses whole disk on first resize

2011-09-07 Thread Mikael Fridh
2011/9/7 Andrey V. Elsukov a...@freebsd.org: On 07.09.2011 04:21, Mikael Fridh wrote: Hi gurus, FreeBSD freebsd9.mg8.tmtowtdi.se 9.0-BETA2 FreeBSD 9.0-BETA2 #0: Wed Aug 31 18:07:44 UTC 2011 r...@farrell.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  amd64 When resizing a partition, on first

Re: FreeBSD 9.0-BETA2 Available...

2011-09-07 Thread Bruce Cran
On 07/09/2011 15:51, Ken Smith wrote: As before one of the many new features of 9.0 we would like tested is the new installer, so fresh installs on test systems are encouraged. The shift in the directory layout described above is in part due to the new installer. FTP-based installs of BETA1

Re: FreeBSD 9.0-BETA2 Available...

2011-09-07 Thread Garrett Cooper
On Wed, Sep 7, 2011 at 1:35 PM, Bruce Cran br...@cran.org.uk wrote: On 07/09/2011 15:51, Ken Smith wrote: As before one of the many new features of 9.0 we would like tested is the new installer, so fresh installs on test systems are encouraged. The shift in the directory layout described

-CURRENT (BETA2) nfs client surprise

2011-09-07 Thread Lev Serebryakov
Hello, Freebsd-current. I've built NanoBSD image for my router based on latest HEAD sources. Image contains minimal set of kernel modules and custom kernel with NFSCLIENT option. Router mounts /usr/home via NFS with this /etc/fstab line: 192.168.134.2:/usr/home /usr/home nfs

Re: -CURRENT (BETA2) nfs client surprise

2011-09-07 Thread Garrett Cooper
2011/9/7 Lev Serebryakov l...@freebsd.org: Hello, Freebsd-current.  I've built NanoBSD image for my router based on latest HEAD sources. Image contains minimal set of kernel modules and custom kernel with NFSCLIENT option. It needs to be changed to NFSCL: $ svngrep -r NFSCL

Re: -CURRENT (BETA2) nfs client surprise

2011-09-07 Thread Lev Serebryakov
Hello, Garrett. You wrote 8 сентября 2011 г., 0:55:11: It needs to be changed to NFSCL: $ svngrep -r NFSCL /sys/i386/conf/GENERIC options NFSCL # New Network Filesystem Client options NFS_ROOT# NFS usable as /, requires NFSCL Yep, I found

Re: -CURRENT (BETA2) nfs client surprise

2011-09-07 Thread Rick Macklem
Lev Serebryakov wrote: Hello, Freebsd-current. I've built NanoBSD image for my router based on latest HEAD sources. Image contains minimal set of kernel modules and custom kernel with NFSCLIENT option. Router mounts /usr/home via NFS with this /etc/fstab line: 192.168.134.2:/usr/home

Re: -CURRENT (BETA2) nfs client surprise

2011-09-07 Thread John Baldwin
On Wednesday, September 07, 2011 5:02:47 pm Lev Serebryakov wrote: Hello, Garrett. You wrote 8 сентября 2011 г., 0:55:11: It needs to be changed to NFSCL: $ svngrep -r NFSCL /sys/i386/conf/GENERIC options NFSCL # New Network Filesystem Client options

Re: ath0 no longer attaches, cardbus problems?

2011-09-07 Thread John Baldwin
On Wednesday, September 07, 2011 4:18:25 pm Daniel Eischen wrote: On Tue, 6 Sep 2011, John Baldwin wrote: On Tuesday, September 06, 2011 3:34:58 pm Daniel Eischen wrote: On Tue, 6 Sep 2011, John Baldwin wrote: Looks like I had a typo in my original e-mail, try

Re: ath0 no longer attaches, cardbus problems?

2011-09-07 Thread Daniel Eischen
On Wed, 7 Sep 2011, John Baldwin wrote: On Wednesday, September 07, 2011 4:18:25 pm Daniel Eischen wrote: On Tue, 6 Sep 2011, John Baldwin wrote: On Tuesday, September 06, 2011 3:34:58 pm Daniel Eischen wrote: On Tue, 6 Sep 2011, John Baldwin wrote: Looks like I had a typo in my original

-CURRENT (BETA1) zfs pool recognized as corrupted

2011-09-07 Thread Sebastian Chmielewski
hi I've tried to import my zfs pool on: FreeBSD-9.0-BETA1-amd64-memstick.img My system currently runs 9.0-BETA1 and pool works correctly. zpool import returns: pool: zroot id: 3239789026273107181 state: FAULTED status: One or more devices contains corrupted data. action: The pool cannot be

FreeBSD 9.0 and 4-socket Intel XEON E7-4870 system -- 80 logical CPUs

2011-09-07 Thread Hartmann, O.
Watching the ncpu number, I realized that FreeBSD is limited to 64 processors. Some vendors offer now 4-socket Intel Xeon E7-4870 systems. This Westmere based CPU has 10 physical and 20 logical cores, summa summarum 80 cores. Is FreeBSD 9.0 capable of handling such a server?

Re: FreeBSD 9.0 and 4-socket Intel XEON E7-4870 system -- 80 logical CPUs

2011-09-07 Thread Garrett Cooper
On Wed, Sep 7, 2011 at 3:27 PM, Hartmann, O. ohart...@zedat.fu-berlin.de wrote:   Watching the ncpu number, I realized that FreeBSD is limited to 64   processors.   Some vendors offer now 4-socket Intel Xeon E7-4870 systems. This   Westmere   based CPU has 10 physical  and 20 logical cores,

Re: PAM/setloginclass link error in jail

2011-09-07 Thread Ben Kelly
Just for the archives, this turned out to be a problem with updating the ezjail basejail directory. I had run ezjail-admin update -i, but for some reason it did not install the new libc.so.7 while it did install pretty much everything else. Moving the old basejail out of the way and

8-stable - 9-current upgrade

2011-09-07 Thread Kevin Oberman
I've been looking for any information on any special steps required to update from 8-stable to 9-current. /usr/src/UPDATING is a bit out of date as it has instructions for going from 5-stable to current, although the instruction may well be the same. I am particularly concerned with things like

Re: 8-stable - 9-current upgrade

2011-09-07 Thread David Wolfskill
On Wed, Sep 07, 2011 at 05:12:45PM -0700, Kevin Oberman wrote: ... I am particularly concerned with things like header files (/usr/include) that might bite me if not deleted. This isn't specific to that upgrade, but when I do a make installworld, I augment the instructions from UPDATING,

Re: Intel Centrino Advanced-N + WiMAX 6250 doesn't work

2011-09-07 Thread Adrian Chadd
Sweet. Bernhard, can you get this committed to -HEAD before 9.0-RC1 ? Adrian ___ freebsd-current@freebsd.org mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail to

Re: ZFS: i/o error - all block copies unavailable after upgrading to r225312

2011-09-07 Thread Peter Jeremy
On 2011-Sep-07 19:35:09 +0300, Andriy Gapon a...@freebsd.org wrote: Thanks to a lot of excellent testing, debugging and analysis from Sebastian (which went behind the scenes) we now have this patch: http://people.freebsd.org/~avg/zfs-boot-gang.diff ... If you use compression for a filesystem where