Re: CURRENT: EFI boot failure

2014-09-16 Thread Nathan Whitehorn
On 09/15/14 22:51, O. Hartmann wrote: Am Mon, 15 Sep 2014 17:39:26 -0700 Nathan Whitehorn nwhiteh...@freebsd.org schrieb: On 09/15/14 17:36, Allan Jude wrote: On 2014-09-15 20:05, O. Hartmann wrote: Installing FreeBSD-11.0-CURRENT-amd64-20140903-r270990 on a Laptop works for UEFI fine.

Huawei E3272 tester needed

2014-09-16 Thread Nick Hibma
Hi, Is there someone who is able to test support for the Huawei E3272 card with CURRENT after 269584? I have not been able to confirm that it works. Thanks in advance. Nick The change: Author: n_hibma Date: Tue Aug 5 12:08:50 2014 New Revision: 269584 URL:

Re: libthr and main thread stack size

2014-09-16 Thread Konstantin Belousov
On Mon, Sep 15, 2014 at 03:47:41PM -0600, Justin T. Gibbs wrote: On Aug 8, 2014, at 5:22 AM, Konstantin Belousov kostik...@gmail.com wrote: ? Below is the patch which adds environment variable LIBPTHREAD_BIGSTACK_MAIN. Setting it to any value results in the main thread stack left as

Re: CURRENT: EFI boot failure

2014-09-16 Thread Bjoern A. Zeeb
On 16 Sep 2014, at 00:05 , O. Hartmann ohart...@zedat.fu-berlin.de wrote: Installing FreeBSD-11.0-CURRENT-amd64-20140903-r270990 on a Laptop works for UEFI fine. After I updated the sources to r271649, recompiled world and kernel (as well as installed), now I get stuck with the screen

Re: _ftello() modification requires additional capsicum rights, breaking tcpdump and dhclient

2014-09-16 Thread Mateusz Guzik
On Fri, Sep 12, 2014 at 09:29:56PM -0700, Peter Wemm wrote: On Thursday, September 11, 2014 12:38:02 PM Patrick Kelsey wrote: On Wed, Sep 10, 2014 at 3:00 AM, Andrey Chernov a...@freebsd.org wrote: On 09.09.2014 21:53, Patrick Kelsey wrote: I don't think it is worth the trouble, as given

Re: 11.0-CURRENT and Lenovo ThinkPad E540: No LAN, no WiFI

2014-09-16 Thread O. Hartmann
Am Mon, 15 Sep 2014 18:25:34 -0700 Adrian Chadd adr...@freebsd.org schrieb: Hi, Try updating to the latest -HEAD. It at least makes dhclient behave better. -a On 15 September 2014 18:19, Kevin Oberman rkober...@gmail.com wrote: On Mon, Sep 15, 2014 at 2:38 PM, O. Hartmann

Re: Huawei E3272 tester needed

2014-09-16 Thread Milan Obuch
On Tue, 16 Sep 2014 09:40:45 +0200 Nick Hibma n...@van-laarhoven.org wrote: Hi, Is there someone who is able to test support for the Huawei E3272 card with CURRENT after 269584? I have not been able to confirm that it works. Thanks in advance. Nick Hi, I did fresh svn update,

Re: 11.0-CURRENT and Lenovo ThinkPad E540: No LAN, no WiFI

2014-09-16 Thread Adrian Chadd
Ah, jumbo frames. Maybe you got lucky and some ethernet drivers default to accepting larger frames even if the MTU is 1500. -a ___ freebsd-current@freebsd.org mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send

Daily head port building regression logs

2014-09-16 Thread Bryan Drewery
Hi, I am planning to enable daily head build logs of ports to current@. The idea is that only new regressions will generate 1 mail with a list of failures. This list will only include *new* failures. It will not nag every day if some port is still broken. This will only work well if the ports

New spam on all my current machine consoles

2014-09-16 Thread Sean Bruno
HV_KVP: open /dev/hv_kvp_dev failed; error: 2 No such file or directory I assume that there is missing error handling in or logic here somewhere as every one of my machines is spamming my consoles on startup with this new message. sean ___

Re: New spam on all my current machine consoles

2014-09-16 Thread Garrett Cooper
On Sep 16, 2014, at 11:40, Sean Bruno sbr...@ignoranthack.me wrote: HV_KVP: open /dev/hv_kvp_dev failed; error: 2 No such file or directory I assume that there is missing error handling in or logic here somewhere as every one of my machines is spamming my consoles on startup with this

Re: New spam on all my current machine consoles

2014-09-16 Thread Sean Bruno
On Tue, 2014-09-16 at 11:45 -0700, Garrett Cooper wrote: On Sep 16, 2014, at 11:40, Sean Bruno sbr...@ignoranthack.me wrote: HV_KVP: open /dev/hv_kvp_dev failed; error: 2 No such file or directory I assume that there is missing error handling in or logic here somewhere as every one

Re: New spam on all my current machine consoles

2014-09-16 Thread Konstantin Belousov
On Tue, Sep 16, 2014 at 11:40:15AM -0700, Sean Bruno wrote: HV_KVP: open /dev/hv_kvp_dev failed; error: 2 No such file or directory I assume that there is missing error handling in or logic here somewhere as every one of my machines is spamming my consoles on startup with this new message.

Re: New spam on all my current machine consoles

2014-09-16 Thread Sean Bruno
On Tue, 2014-09-16 at 21:57 +0300, Konstantin Belousov wrote: On Tue, Sep 16, 2014 at 11:40:15AM -0700, Sean Bruno wrote: HV_KVP: open /dev/hv_kvp_dev failed; error: 2 No such file or directory I assume that there is missing error handling in or logic here somewhere as every one of my

Re: New spam on all my current machine consoles

2014-09-16 Thread Konstantin Belousov
On Tue, Sep 16, 2014 at 12:08:54PM -0700, Sean Bruno wrote: On Tue, 2014-09-16 at 21:57 +0300, Konstantin Belousov wrote: On Tue, Sep 16, 2014 at 11:40:15AM -0700, Sean Bruno wrote: HV_KVP: open /dev/hv_kvp_dev failed; error: 2 No such file or directory I assume that there is missing

Re: New spam on all my current machine consoles

2014-09-16 Thread Sean Bruno
On Tue, 2014-09-16 at 22:27 +0300, Konstantin Belousov wrote: On Tue, Sep 16, 2014 at 12:08:54PM -0700, Sean Bruno wrote: On Tue, 2014-09-16 at 21:57 +0300, Konstantin Belousov wrote: On Tue, Sep 16, 2014 at 11:40:15AM -0700, Sean Bruno wrote: HV_KVP: open /dev/hv_kvp_dev failed; error:

Re: Huawei E3272 tester needed

2014-09-16 Thread Maciej Milewski
On 16.09.2014 16:52, Milan Obuch wrote: On Tue, 16 Sep 2014 09:40:45 +0200 Nick Hibma n...@van-laarhoven.org wrote: Hi, Is there someone who is able to test support for the Huawei E3272 card with CURRENT after 269584? I have not been able to confirm that it works. Thanks in advance.

Re: Huawei E3272 tester needed

2014-09-16 Thread Milan Obuch
On Tue, 16 Sep 2014 21:55:50 +0200 Maciej Milewski m...@dat.pl wrote: On 16.09.2014 16:52, Milan Obuch wrote: On Tue, 16 Sep 2014 09:40:45 +0200 Nick Hibma n...@van-laarhoven.org wrote: Hi, Is there someone who is able to test support for the Huawei E3272 card with CURRENT after

Re: Huawei E3272 tester needed

2014-09-16 Thread Hans Petter Selasky
On 09/16/14 22:18, Milan Obuch wrote: On Tue, 16 Sep 2014 21:55:50 +0200 Maciej Milewski m...@dat.pl wrote: On 16.09.2014 16:52, Milan Obuch wrote: On Tue, 16 Sep 2014 09:40:45 +0200 Nick Hibma n...@van-laarhoven.org wrote: Hi, Is there someone who is able to test support for the Huawei

Re: Huawei E3272 tester needed

2014-09-16 Thread Maciej Milewski
On 16.09.2014 22:18, Milan Obuch wrote: On Tue, 16 Sep 2014 21:55:50 +0200 Maciej Milewski m...@dat.pl wrote: On 16.09.2014 16:52, Milan Obuch wrote: On Tue, 16 Sep 2014 09:40:45 +0200 Nick Hibma n...@van-laarhoven.org wrote: Hi, Is there someone who is able to test support for the

Re: Huawei E3272 tester needed

2014-09-16 Thread Milan Obuch
On Tue, 16 Sep 2014 22:35:19 +0200 Hans Petter Selasky h...@selasky.org wrote: On 09/16/14 22:18, Milan Obuch wrote: On Tue, 16 Sep 2014 21:55:50 +0200 Maciej Milewski m...@dat.pl wrote: On 16.09.2014 16:52, Milan Obuch wrote: On Tue, 16 Sep 2014 09:40:45 +0200 Nick Hibma

zpool: multiple IDs, CURRENT drops all pools after reboot

2014-09-16 Thread O. Hartmann
On of my backup drives dedicated to a ZPOOL is faulting and showing up multiple ID. The only working ID is id: 257822624560506537. FreeBSD CURRENT with three ZFS disks and only 4GB of RAM is very flaky regarding this issue: today, tow times the whole poolset vanishes after a reboot. Giving the

Re: CURRENT: EFI boot failure

2014-09-16 Thread O. Hartmann
Am Tue, 16 Sep 2014 00:09:01 -0700 Nathan Whitehorn nwhiteh...@freebsd.org schrieb: On 09/15/14 22:51, O. Hartmann wrote: Am Mon, 15 Sep 2014 17:39:26 -0700 Nathan Whitehorn nwhiteh...@freebsd.org schrieb: On 09/15/14 17:36, Allan Jude wrote: On 2014-09-15 20:05, O. Hartmann wrote:

Re: CURRENT: EFI boot failure

2014-09-16 Thread O. Hartmann
Am Mon, 15 Sep 2014 20:36:23 -0400 Allan Jude allanj...@freebsd.org schrieb: On 2014-09-15 20:05, O. Hartmann wrote: Installing FreeBSD-11.0-CURRENT-amd64-20140903-r270990 on a Laptop works for UEFI fine. After I updated the sources to r271649, recompiled world and kernel (as well

Re: zpool: multiple IDs, CURRENT drops all pools after reboot

2014-09-16 Thread Steven Hartland
On of my backup drives dedicated to a ZPOOL is faulting and showing up multiple ID. The only working ID is id: 257822624560506537. FreeBSD CURRENT with three ZFS disks and only 4GB of RAM is very flaky regarding this issue: today, tow times the whole poolset vanishes after a reboot. Giving the

Re: CURRENT: EFI boot failure

2014-09-16 Thread Ed Maste
On 16 September 2014 17:03, O. Hartmann ohart...@zedat.fu-berlin.de wrote: In that case, is it still /boot/boot1.efifat or is it /boot/boot1.efi? What is the difference? Is the efi partition FAT? An EFI system partition (ESP) is a FAT-formatted partition with a specific GPT or MBR identifier

Re: CURRENT: EFI boot failure

2014-09-16 Thread O. Hartmann
Am Tue, 16 Sep 2014 00:09:01 -0700 Nathan Whitehorn nwhiteh...@freebsd.org schrieb: On 09/15/14 22:51, O. Hartmann wrote: Am Mon, 15 Sep 2014 17:39:26 -0700 Nathan Whitehorn nwhiteh...@freebsd.org schrieb: On 09/15/14 17:36, Allan Jude wrote: On 2014-09-15 20:05, O. Hartmann wrote:

Re: 11.0-CURRENT and Lenovo ThinkPad E540: No LAN, no WiFI

2014-09-16 Thread O. Hartmann
Am Tue, 16 Sep 2014 08:40:25 -0700 Adrian Chadd adr...@freebsd.org schrieb: Ah, jumbo frames. Maybe you got lucky and some ethernet drivers default to accepting larger frames even if the MTU is 1500. -a It is not the jumbo frame that makes this specific NIC work, I have to set the mtu

Re: CURRENT: EFI boot failure

2014-09-16 Thread O. Hartmann
Am Tue, 16 Sep 2014 17:32:12 -0400 Ed Maste ema...@freebsd.org schrieb: On 16 September 2014 17:03, O. Hartmann ohart...@zedat.fu-berlin.de wrote: In that case, is it still /boot/boot1.efifat or is it /boot/boot1.efi? What is the difference? Is the efi partition FAT? An EFI system

Re: CURRENT: EFI boot failure

2014-09-16 Thread Andriy Gapon
On 17/09/2014 00:32, Ed Maste wrote: On 16 September 2014 17:03, O. Hartmann ohart...@zedat.fu-berlin.de wrote: In that case, is it still /boot/boot1.efifat or is it /boot/boot1.efi? What is the difference? Is the efi partition FAT? An EFI system partition (ESP) is a FAT-formatted

Re: CURRENT: EFI boot failure

2014-09-16 Thread O. Hartmann
Am Wed, 17 Sep 2014 01:25:07 +0300 Andriy Gapon a...@freebsd.org schrieb: On 17/09/2014 00:32, Ed Maste wrote: On 16 September 2014 17:03, O. Hartmann ohart...@zedat.fu-berlin.de wrote: In that case, is it still /boot/boot1.efifat or is it /boot/boot1.efi? What is the difference? Is

Re: zpool: multiple IDs, CURRENT drops all pools after reboot

2014-09-16 Thread O. Hartmann
Am Tue, 16 Sep 2014 22:06:36 +0100 Steven Hartland kill...@multiplay.co.uk schrieb: On of my backup drives dedicated to a ZPOOL is faulting and showing up multiple ID. The only working ID is id: 257822624560506537. FreeBSD CURRENT with three ZFS disks and only 4GB of RAM is very flaky

Re: zpool: multiple IDs, CURRENT drops all pools after reboot

2014-09-16 Thread Don Lewis
On 17 Sep, O. Hartmann wrote: Am Tue, 16 Sep 2014 22:06:36 +0100 Steven Hartland kill...@multiplay.co.uk schrieb: All that said you shouldnt end up with corrupt data no matter what. Are there any other symptoms? Has memory been checked for faults etc? Regards Steve The

Re: CURRENT: EFI boot failure

2014-09-16 Thread Nathan Whitehorn
On 09/16/14 14:50, O. Hartmann wrote: Am Tue, 16 Sep 2014 00:09:01 -0700 Nathan Whitehorn nwhiteh...@freebsd.org schrieb: On 09/15/14 22:51, O. Hartmann wrote: Am Mon, 15 Sep 2014 17:39:26 -0700 Nathan Whitehorn nwhiteh...@freebsd.org schrieb: On 09/15/14 17:36, Allan Jude wrote: On

Re: CURRENT: EFI boot failure

2014-09-16 Thread Ed Maste
On 16 September 2014 18:25, O. Hartmann ohart...@zedat.fu-berlin.de wrote: Besides, checking both boot1.efi and loader.efi with file() shows something like loader.efi: PE32+ executable (EFI application) x86-64 (stripped to external PDB), for MS Windows. So both are PECOFF format files?

Re: CURRENT: EFI boot failure

2014-09-16 Thread Ed Maste
On 16 September 2014 18:54, Nathan Whitehorn nwhiteh...@freebsd.org wrote: On 09/16/14 14:50, O. Hartmann wrote: When the system boots, I do not see a loader! Where is the loader I'm used to see when I have the chance to switch to single user mode, console or switch off ACPI? There is no

Cam panic on r271170

2014-09-16 Thread Bryan Drewery
I've been getting this quite frequently on head recently. I have dumps if anyone is interested in more information. Fatal trap 9: general protection fault while in kernel mode cpuid = 10; Memory modified after free 0xf8003e0b0800(2040) val= @ 0xf8003e0b0808 apanic: Most

Re: Huawei E3272 tester needed

2014-09-16 Thread Hans Petter Selasky
On 09/16/14 22:52, Milan Obuch wrote: On Tue, 16 Sep 2014 22:35:19 +0200 Hans Petter Selasky h...@selasky.org wrote: On 09/16/14 22:18, Milan Obuch wrote: On Tue, 16 Sep 2014 21:55:50 +0200 Maciej Milewski m...@dat.pl wrote: On 16.09.2014 16:52, Milan Obuch wrote: On Tue, 16 Sep 2014