bhyve with lagg failover doesn't work on wifi

2016-07-28 Thread Randy Westlund
I'm using bhyve on 11.0-BETA2, bridging tap0 to lagg0, a failover between wifi and ethernet. The bhyve VM's networking only works I'm using ethernet. > # Lagg config. > ifconfig_em0="up" > create_args_wlan0="wlanaddr 3c:97:0e:46:70:ca" > wlans_iwn0="wlan0" > ifconfig_wlan0="WPA" >

Re: wpa_supplicant doesn't work with lagg

2016-07-28 Thread Randy Westlund
On Fri, Jul 29, 2016 at 12:02:56AM +0200, Ronald Klop wrote: > I had the same problem a while ago. > For some reason you need to use this construction to set the MAC now. > > create_args_wlan0="wlanaddr 00:26:b9:12:34:56 country NL" > > I don't know why this changed. Thanks, that works. I've

freebsd-update and portsnap users still at risk of compromise

2016-07-28 Thread Martin Schroeder
On July 18, John Leyden, security editor at The Register, tweeted a link to a libarchive ticket that had been sitting without a response for almost a week. tweet: https://twitter.com/jleyden/status/755016810865582081 libarchive ticket: https://github.com/libarchive/libarchive/issues/743 The

Jenkins build is still unstable: FreeBSD_HEAD #494

2016-07-28 Thread jenkins-admin
See ___ freebsd-current@freebsd.org mailing list https://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Re: IWM(7260), no connect

2016-07-28 Thread Adrian Chadd
+imre, Hi! Larry is having issues with r303418. Would you be able to help him out? (If it's not too bad, can we back this out until you figure out what's going on?) Thanks! -a On 28 July 2016 at 18:05, Larry Rosenman wrote: > On 2016-07-28 20:02, Adrian Chadd wrote: >> >>

Re: IWM(7260), no connect

2016-07-28 Thread Larry Rosenman
On 2016-07-28 20:02, Adrian Chadd wrote: Hi, Which commit(s) did you revert? -a revert r303418 and now it connects again. -- Larry Rosenman http://www.lerctr.org/~ler Phone: +1 214-642-9640 E-Mail: l...@lerctr.org US Mail: 17716 Limpia Crk, Round Rock,

Re: IWM(7260), no connect

2016-07-28 Thread Adrian Chadd
Hi, Which commit(s) did you revert? -a ___ freebsd-current@freebsd.org mailing list https://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Jenkins build is unstable: FreeBSD_HEAD #493

2016-07-28 Thread jenkins-admin
See ___ freebsd-current@freebsd.org mailing list https://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Re: IWM(7260), no connect

2016-07-28 Thread Larry Rosenman
That seems to fix it, and I'm sorry I missed this in my Inbox earlier. On Thu, Jul 28, 2016 at 12:12:42PM +0300, Andriy Voskoboinyk wrote: > Thu, 28 Jul 2016 05:39:55 +0300 Larry Rosenman > : > > Try to revert r303418 (as I can see, r303416 and/or

Re: IWM(7260), no connect

2016-07-28 Thread Baptiste Daroussin
On Thu, Jul 28, 2016 at 06:10:26PM -0500, Larry Rosenman wrote: > negative. no reponse (except for this one) at all. > :( > He did reply: https://lists.freebsd.org/pipermail/freebsd-wireless/2016-July/006897.html Best regards, Bapt signature.asc Description: PGP signature

Re: IWM(7260), no connect

2016-07-28 Thread Larry Rosenman
negative. no reponse (except for this one) at all. :( On 2016-07-28 18:07, Adrian Chadd wrote: Hi, Andriy responded? -adrian On 28 July 2016 at 16:04, Larry Rosenman wrote: Anyone? On 2016-07-27 21:39, Larry Rosenman wrote: I'm running today's top of tree, and it

Re: IWM(7260), no connect

2016-07-28 Thread Adrian Chadd
Hi, Andriy responded? -adrian On 28 July 2016 at 16:04, Larry Rosenman wrote: > Anyone? > > > On 2016-07-27 21:39, Larry Rosenman wrote: >> >> I'm running today's top of tree, and it doesn't seem to want to connect: >> >> >> re0:

Re: IWM(7260), no connect

2016-07-28 Thread Larry Rosenman
Anyone? On 2016-07-27 21:39, Larry Rosenman wrote: I'm running today's top of tree, and it doesn't seem to want to connect: re0: flags=8843 metric 0 mtu 1500

Re: wpa_supplicant doesn't work with lagg

2016-07-28 Thread Ronald Klop
I had the same problem a while ago. For some reason you need to use this construction to set the MAC now. create_args_wlan0="wlanaddr 00:26:b9:12:34:56 country NL" I don't know why this changed. Regards, Ronald. On Thu, 28 Jul 2016 21:41:46 +0200, Randy Westlund wrote:

Re: Boot environments and zfs canmount=noauto

2016-07-28 Thread Ultima
Is this actually required? Instead of the extra steps, how about just moving/creating each dataset into each BE (or at least the ones desired) and setting them to mountpoint=inherit. With zfs_enable="YES" this should mount the dataset appropriately. Only the root BE should need canmount=noauto

Build failed in Jenkins: FreeBSD_HEAD #492

2016-07-28 Thread jenkins-admin
o_args -> passed [0.074s] [192.168.10.2] out: libexec/atf/atf-sh/integration_test:set_e -> passed [0.086s] [192.168.10.2] out: libexec/atf/atf-sh/normalize_test:main -> passed [0.088s] [192.168.10.2] out: libexec/atf/atf-sh/tc_test:default_status -> passed [0.154s] [192.168.10.2]

Call for testing on vagrant-bhyve

2016-07-28 Thread Tong Li
Hello Everyone, As part of this year's GSoC, we created a project named vagrant-bhyve which enables bhyve as a backend of Vagrant so that we can use Vagrant to manage bhyve VMs. Now most of fundamental functions are working, including booting up a box,

Re: Boot environments and zfs canmount=noauto

2016-07-28 Thread Randy Westlund
On Thu, Jul 28, 2016 at 01:34:03PM +0300, Andriy Gapon wrote: > Locally I have the following rc script to handle subordinate datasets of > a boot environment: http://dpaste.com/0Q0JPGN.txt > It is designed for exactly the scenario described above. > The script is automatically enabled when

wpa_supplicant doesn't work with lagg

2016-07-28 Thread Randy Westlund
I'm having trouble using the lagg driver with wpa_supplicant. When I boot with this standard configuration, my wifi works fine: > # Normal config. > wlans_iwn0="wlan0" > ifconfig_wlan0="WPA DHCP" > ifconfig_em0="DHCP" But when I boot with a lagg configuration, wpa_supplicant can't connect. > #

Jenkins build is still unstable: FreeBSD_HEAD #491

2016-07-28 Thread jenkins-admin
See ___ freebsd-current@freebsd.org mailing list https://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Jenkins build is still unstable: FreeBSD_HEAD #490

2016-07-28 Thread jenkins-admin
See ___ freebsd-current@freebsd.org mailing list https://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Re: EARLY_AP_STARTUP hangs during boot

2016-07-28 Thread John Baldwin
On Thursday, July 28, 2016 12:31:31 AM Gary Jennejohn wrote: > On Wed, 27 Jul 2016 14:43:36 -0700 > John Baldwin wrote: > > > On Tuesday, June 07, 2016 12:06:54 PM Gary Jennejohn wrote: > > > On Tue, 31 May 2016 13:10:06 -0700 > > > John Baldwin wrote: > > >

Jenkins build is still unstable: FreeBSD_HEAD #489

2016-07-28 Thread jenkins-admin
See ___ freebsd-current@freebsd.org mailing list https://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Re: Boot environments and zfs canmount=noauto

2016-07-28 Thread Miroslav Lachman
Andriy Gapon wrote on 07/28/2016 14:44: I also would like to add, just in case, that I never set a BE's mountpoint to '/'. I leave it at its default value like /pond/ROOT/foobar. When the BE is active it would be mounted at / anyway. And when it is not active and I want to access it for some

Re: Boot environments and zfs canmount=noauto

2016-07-28 Thread Andriy Gapon
I also would like to add, just in case, that I never set a BE's mountpoint to '/'. I leave it at its default value like /pond/ROOT/foobar. When the BE is active it would be mounted at / anyway. And when it is not active and I want to access it for some modifications, etc, then I can mount it

FreeBSD_HEAD_amd64_gcc - Build #1453 - Failure

2016-07-28 Thread jenkins-admin
FreeBSD_HEAD_amd64_gcc - Build #1453 - Failure: Build information: https://jenkins.FreeBSD.org/job/FreeBSD_HEAD_amd64_gcc/1453/ Full change log: https://jenkins.FreeBSD.org/job/FreeBSD_HEAD_amd64_gcc/1453/changes Full build log:

Re: Boot environments and zfs canmount=noauto

2016-07-28 Thread Andriy Gapon
On 28/07/2016 05:18, Allan Jude wrote: > On 2016-07-27 22:05, Randy Westlund wrote: >> I'm trying to follow Michael Dexter's post about using bhyve with boot >> environments. It involves moving all child datasets under >> zroot/ROOT/default, so that you can have entirely independent systems. >>

Jenkins build is unstable: FreeBSD_HEAD #488

2016-07-28 Thread jenkins-admin
See ___ freebsd-current@freebsd.org mailing list https://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Re: Fwd: Failed to boot -Current snapshot memstick img with EFI

2016-07-28 Thread Howard Su
It turns out a USB driver problem. the usb disk size is not correctly detected. But the disk works fine in BIOS. Here is dmesg information: ugen7.2: at usbus7 umass0: on usbus7 umass0: SCSI over Bulk-Only; quirks = 0x8100 umass0:6:0: Attached to scbus6 da0 at umass-sim0 bus 0 scbus6 target 0

Re: IWM(7260), no connect

2016-07-28 Thread Andriy Voskoboinyk
Thu, 28 Jul 2016 05:39:55 +0300 було написано Larry Rosenman : Try to revert r303418 (as I can see, r303416 and/or r303413 are not the reason of this). In case, if this will not help, you can try to add wlandebug_wlan0="state+scan+auth+assoc" into rc.conf to see where it

Re: SafeStack in base

2016-07-28 Thread Ed Schouten
Hi Conrad, 2016-07-28 2:02 GMT+02:00 Conrad Meyer : > The problem appears to be an upstream limitation of > -fsanitize=safe-stack: "Most programs, static libraries, or individual > files can be compiled with SafeStack as is. … Linking a DSO with > SafeStack is not currently

Re: SafeStack in base

2016-07-28 Thread David Chisnall
On 27 Jul 2016, at 23:55, Shawn Webb wrote: > > I'm interested in getting SafeStack working in FreeBSD base. Below is a > link to a simplistic (maybe too simplistic?) patch to enable SafeStack. > The patch applies against HardenedBSD's hardened/current/master branch.