Re: ATAng still problematic

2003-09-18 Thread Andrew Lankford
. Attached is my dmesg -a output for this bootup (includes results of atacontrol detach 1 ; atacontrol attach 1) Andrew Lankford Copyright (c) 1992-2003 The FreeBSD Project. Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994 The Regents

cvsup sites are all at capacity?

2003-09-16 Thread Andrew Lankford
, are the sites down for maintenance, or is something sinister going on? Just wonderin' Andrew Lankford ___ [EMAIL PROTECTED] mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail to [EMAIL

Re: cvsup sites are all at capacity?

2003-09-16 Thread Andrew Lankford
I spoke too soon. Suddenly it all works. It never got above 10 clients before today. How about a few people switch to my server for regular updates? Thanks. :) Regards, -- wca Oh, alright! Andrew Lankford ___ [EMAIL

Re: ATAng problems

2003-09-07 Thread Andrew Lankford
geæþele wæs from cneomægum,þæt hi æt campe oft wiþ laþra gehwæneland ealgodon, hord hamas ja baby! Andrew Lankford ___ [EMAIL PROTECTED] mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail

Re: ATAng probe updated please test

2003-09-01 Thread Andrew Lankford
I've gone over the probe code once again. I upgraded, and now my DVDROM (ata1-slave) is working again, but my Plextor 8/4/32A CDRW (ata1-master) still won't probe correctly. atacontrol list appears to send out the same message as before. dmesg atacontrol list output attached. Andrew Lankford

Re: ATAng probe updated please test (ERRATA)

2003-09-01 Thread Andrew Lankford
I upgraded, and now my DVDROM (ata1-slave) is working again, but my Plextor 8/4/32A CDRW (ata1-master) still won't probe correctly. atacontrol list appears to send out the same message as before. dmesg atacontrol list output attached. Andrew Lankford Crap, I attached the wrong file

Re: ATA-ng

2003-08-31 Thread Andrew Lankford
early revisions of ata-lowlevel.c allowed the DVDROM to probe correctly and mount file systems. But nowadays only my harddrive probes, works. I'll reboot and leave my latest verbose dmesg in another email. Andrew Lankford ___ [EMAIL PROTECTED

[no subject]

2003-08-28 Thread Andrew Lankford
OK, after checking out Soren's version 1.6 ata-lowlevel.c, rebuilding the kernel, and rebooting I got the following kernel boot message (attached). The output of atacontrol list is about the same as before as well. My last build (using 1.4 ata-lowlevel) booted up ok and at least my slave DVDROM

atang problem: my cdrw isn't detected

2003-08-24 Thread Andrew Lankford
After I rebooted from a make world, I found that my dvdrom device now occupies /dev/acd0 instead of /dev/acd1 and my plextor 8/4/32A is nowhere to be seen. Here's a snippet from my last good boot: ata0: at 0x1f0 irq 14 on atapci0 ata1: at 0x170 irq 15 on atapci0 ad0: 29314MB IBM-DTLA-307030

Re:cvs commit: src/contrib/smbfs/smbutil common.h

2003-08-23 Thread Andrew Lankford
Remove the # (stringify) operator from the printf() arguments in the iprintf macro. It was causing the actual format string and variable names to be written out, instead of substituting the values of the variables into the format string. I take it that gcc's preprocessor getting stricter

Re:cvs commit: src/contrib/smbfs/smbutil common.h

2003-08-23 Thread Andrew Lankford
Someone out there is just making a hash of things. No pun intended, right? :) -- Matt Emmerton On the contrary, I take my puns very seriously. You were supposed to reply with Ugh! Andrew Lankford ___ [EMAIL PROTECTED

Fun with 'fdisk -B -b /boot/boot0 ad0'

2003-07-24 Thread Andrew Lankford
this helps. Andrew Lankford ___ [EMAIL PROTECTED] mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail to [EMAIL PROTECTED]

putting /dev/lpt in polling mode in boot time.

2003-07-20 Thread Andrew Lankford
: FIFO with 16/16/9 bytes threshold ppbus0: Parallel port bus on ppc0 lpt0: Printer on ppbus0 lpt0: Interrupt-driven port Is there something that I overlooked? Thanks, Andrew Lankford PS Apart from some annoyances with ghostscript ps to pcl translation, nothing beats a vintage HP laser printer

Re: putting /dev/lpt in polling mode in boot time.

2003-07-20 Thread Andrew Lankford
Before anyone corrects me, yes, the man page says bit 5 controls polling, 0x20. My question stands. ___ [EMAIL PROTECTED] mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail to

Re: putting /dev/lpt in polling mode in boot time.

2003-07-20 Thread Andrew Lankford
Try to disable ACPI. Marc Ah yes. Just noticed that in the FAQ. I'll fiddle with that when I've got the time. Might as well disable acpi since it barely works on my machine anyway. Apart from the power button, that is. Thanks Andrew Lankford

Re: adsl/pppoe no longer connecting on 5.1

2003-06-11 Thread Andrew Lankford
one ':' Jun 11 22:00:14 bogushost2 ppp[222]: Phase: deflink: Enter pause (2) for redialing. Bloody irritating. Andrew Lankford ___ [EMAIL PROTECTED] mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail

CURRENT console setttings borked

2003-06-11 Thread Andrew Lankford
-parenb -hupcl erase2 status undef ^E Hope this helps unbreak whatever's broken Andrew Lankford ___ [EMAIL PROTECTED] mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail to [EMAIL PROTECTED]

Re: adsl/pppoe no longer connecting on 5.1

2003-06-11 Thread Andrew Lankford
is the same as last time. As a result, ppp's now up and running again. Thanks for the help. Andrew Lankford ___ [EMAIL PROTECTED] mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail

Re: adsl/pppoe no longer connecting on 5.1

2003-06-11 Thread Andrew Lankford
Thanks, that's actually more useful because it isolates the problem. It's probably something in ppp that is misbehaving with CSTD=c99. True. A simple rebuild of ppp (without libc, etc.) didn't change anything. Andrew Lankford

[no subject]

2003-03-14 Thread Andrew Lankford
Perhaps it would be a good idea to build a linker.hints file with kldxref(8) at boot time. At least, I can't think of any really good reasons why _not_ to do it. Your root and/or /boot partition is (normally) mounted read-only, perhaps? Just something to keep in mind, anyway. Andrew Lankford

Re: 80386 out of GENERIC

2002-12-15 Thread Andrew Lankford
Was sysinstall around when 386 was new? No, and neither was FreeBSD. To Unsubscribe: send mail to [EMAIL PROTECTED] with unsubscribe freebsd-current in the body of the message

getting rid of mknod? (was Re: getting rid of devfs...)

2002-11-09 Thread Andrew Lankford
You can still make device nodes so that the disk can be exported, but as, in -current the major and minor number will not exist ...Or use softlinks, perhaps? I can't seem to read mknod(8) disk device nodes anymore in -current. Andrew Lankford To Unsubscribe: send mail to [EMAIL PROTECTED

Re: What's the status of devfs(8)?

2002-11-05 Thread Andrew Lankford
, for that matter) could suggest a better way to communicate this requirement? My vote would be a direct error message like Must specify a default ruleset, or something closer to ipfw(8)'s behavior, like Mr. Nelson was saying. Andrew Lankford To Unsubscribe: send mail to [EMAIL PROTECTED] with unsubscribe

minor nit in /usr/src/usr.sbin/apm/apm.c

2002-11-04 Thread Andrew Lankford
Stupid question perhaps, but was the inclusion of sys/file.h and sys/ioctl.h twice in /usr/src/usr.sbin/apm/apm.c done intentionally? Thanks Andrew Lankford To Unsubscribe: send mail to [EMAIL PROTECTED] with unsubscribe freebsd-current in the body of the message

What's the status of devfs(8)?

2002-11-04 Thread Andrew Lankford
root@bogushost2:/usr/obj/usr/src/sys/ARL5KERNEL i386 Anyway I've tried a couple of buildworlds over the past week or two and still get the same behavior. How do I go about debugging this? Andrew Lankford To Unsubscribe: send mail to [EMAIL PROTECTED] with unsubscribe freebsd-current

suggested patch for small user ppp annoyance

2002-10-06 Thread Andrew Lankford
Once in a while, user ppp is killed rather abruptly and it leaves a diagnostic socket behind, which blocks the creation of a diagnostic socket after reboot. Anyway, I propose adding another variable to rc.conf, something along the lines of the three patches here. The default value for

Re: syscons in rcng ?

2002-09-08 Thread Andrew Lankford
don't know anything about problems with /etc/rc.d/syscons, but perhaps vidcontrol or the kernel is the culprit. Andrew Lankford Hello, With the latest changes (1.8, 5th of Sep) to /etc/rc.d/syscons, syscons doesn't get initialized on my 5.0-CURRENT. Have I missed some new configuration options

Re: ppp sig10's in current

2002-07-08 Thread Andrew Lankford
You were not, by any chance, using the -nat option with ppp? A Sure was. Thanks. Andrew Lankford To Unsubscribe: send mail to [EMAIL PROTECTED] with unsubscribe freebsd-current in the body of the message

ppp sig10's in current

2002-07-07 Thread Andrew Lankford
Just thought I'd throw in some more bad news :-). ppp in current core dumps on me. It starts up in ddial mode ok, does its job for a while, and then dies. I tried starting it again, and it just sat there instead of going into the background and returning the prompt, leaving me with no

Re: one or two errors in installworld

2002-06-10 Thread Andrew Lankford
/sendmail/Makefile?sortby=log or http://www.freebsd.org/cgi/cvsweb.cgi/src/usr.bin/xinstall/xinstall.c So, on to a new topic. Which is better, ^? or ^H ? Andrew Lankford To Unsubscribe: send mail to [EMAIL PROTECTED] with unsubscribe freebsd-current in the body of the message

one or two errors in installworld

2002-06-09 Thread Andrew Lankford
that INSTALL is defined as install -C, which I don't think is appropriate for use with the -d option either. I think I noticed a few install -C -C ... 's flash by before the last attempted installworld ground to a halt. Andrew Lankford To Unsubscribe: send mail to [EMAIL PROTECTED] with unsubscribe